Browse free open source Frameworks and projects below. Use the toggles on the left to filter open source Frameworks by OS, license, language, programming language, and project status.

  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 1
    Grassroots DICOM

    Grassroots DICOM

    Cross-platform DICOM implementation

    Grassroots DiCoM is a C++ library for DICOM medical files. It is accessible from Python, C#, Java and PHP. It supports RAW, JPEG, JPEG 2000, JPEG-LS, RLE and deflated transfer syntax. It comes with a super fast scanner implementation to quickly scan hundreds of DICOM files. It supports SCU network operations (C-ECHO, C-FIND, C-STORE, C-MOVE). PS 3.3 & 3.6 are distributed as XML files. It also provides PS 3.15 certificates and password based mecanism to anonymize and de-identify DICOM datasets.
    Leader badge
    Downloads: 280 This Week
    Last Update:
    See Project
  • 2
    Bootstrap

    Bootstrap

    HTML, CSS and JS framework for developing responsive websites and apps

    Bootstrap is an HTML, CSS, and JS framework designed for developing responsive, mobile first projects on the web. It's one of the most popular front-end frameworks and for good reason: it simply makes web development faster and easier. People of all skill levels can create projects of all sizes with Bootstrap, and for all types of devices too. With Bootstrap, you get a host of nifty features such as precompiled CSS, impressive scalability, dozens of custom HTML and CSS components and more.
    Downloads: 35 This Week
    Last Update:
    See Project
  • 3

    QuaZIP

    A C++/Qt ZIP library

    Moved to GitHub: https://github.com/stachenov/quazip
    Leader badge
    Downloads: 118 This Week
    Last Update:
    See Project
  • 4
    tabler

    tabler

    Tabler is free and open-source HTML Dashboard UI Kit

    Tabler is fully responsive and compatible with all modern browsers. Thanks to its modern, user-friendly design you can create a fully functional interface that users will love! Choose the layouts and components you need and customize them to make your design consistent and eye-catching. Every component has been created with attention to detail to make your interface beautiful! We've created this admin panel for everyone who wants to create templates based on our pre-made components. Our mission is to deliver a user-friendly, clear and easy administration panel that can be used by both simple websites and sophisticated systems. The only requirement is basic HTML and CSS (and some Liquid) knowledge, as a reward, you'll be able to manage and visualise different types of data in the easiest possible way! With the support for mobile, tablet and desktop displays, it doesn’t matter what device you’re using. Tabler is responsive in all major browsers.
    Downloads: 18 This Week
    Last Update:
    See Project
  • Build Securely on AWS with Proven Frameworks Icon
    Build Securely on AWS with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • 5
    Spring Data Redis

    Spring Data Redis

    Provides support to increase developer productivity in Java

    Provides support to increase developer productivity in Java when using Redis, a key-value store. Uses familiar Spring concepts such as a template class for core API usage and lightweight repository-style data access. The primary goal of the Spring Data project is to make it easier to build Spring-powered applications that use new data access technologies such as non-relational databases, map-reduce frameworks, and cloud-based data services. Connection package as low-level abstraction across multiple Redis drivers (Lettuce and Jedis). Exception translation to Spring’s portable Data Access exception hierarchy for Redis driver exceptions. RedisTemplate that provides a high level abstraction for performing various Redis operations, exception translation and serialization support. Pubsub support (such as a MessageListenerContainer for message-driven POJOs). Redis Sentinel and Redis Cluster support. Reactive API using the Lettuce driver. JDK, String, JSON and Spring Object/X.
    Downloads: 15 This Week
    Last Update:
    See Project
  • 6
    decimal

    decimal

    Arbitrary-precision fixed-point decimal numbers in go

    Arbitrary-precision fixed-point decimal numbers in go. Note: Decimal library can "only" represent numbers with a maximum of 2^31 digits after the decimal point. The zero-value is 0, and is safe to use without initialization. Addition, subtraction, and multiplication with no loss of precision. Division with specified precision. Database/sql serialization/deserialization. JSON and XML serialization/deserialization. big.Int's API is built to reduce the number of memory allocations for maximal performance. This makes sense for its use-case, but the trade-off is that the API is awkward and easy to misuse. In contrast, it's difficult to make such mistakes with decimal. Decimals behave like other go numbers types: even though a = b will not deep copy b into a, it is impossible to modify a Decimal, since all Decimal methods return new Decimals and do not modify the originals. The downside is that this causes extra allocations, so Decimal is less performant.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 7
    ServiceStack

    ServiceStack

    Simple, fast, versatile and full-featured services framework

    One framework to power them all. Write your HTTP APIs once and take advantage of end-to-end typed integrations for all popular web, mobile and desktop platforms. ServiceStack's primary goal is to enhance the value of System APIs which serve as the blueprint that most features centered around. By using simple & pure dependency-free DTO models decoupled from any implementation we're free to continue layering on features which now sees ServiceStack APIs as the most versatile in the world where the same high-performance APIs can be consumed from HTTP in any combination of Route, QueryString, FormData or a myriad of data formats, via popular resilient MQ Servers whilst simultaneously supporting legacy integrations like SOAP or adopting new technologies like gRPC without sacrificing any native HTTP integrations. To maximize the value of APIs we're focused beyond the API boundary by making it as simple as possible for API Consumers to call your APIs.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 8
    7.css

    7.css

    A JS-independent, tree-shakeable CSS framework

    7.css is a CSS framework for building interface components that look like Windows 7. It is built on top of the GUI backbone of XP.css, which is an extension of 98.css. This framework relies on the usage of semantic HTML. To make a button, you'll need to use a button. Input elements require labels. Tabs rely on the role="tab" attribute. This page will guide you through that process, but accessibility is a primary goal of this project. It does not ship with any JavaScript, so it is compatible with your frontend framework of choice.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 9
    Foundation for Emails

    Foundation for Emails

    Design responsive HTML emails that work on any device & email client

    Foundation for Emails is a framework that allows you to create responsive HTML emails that work on any device and on any email client, even Outlook. All of its HTML/CSS components have been tested, ensuring consistency across every major email client. Foundation for Emails consists of a solid set of customizable components, including a fully responsive grid, typography, alignment classes and more. It also has a new templating language, Inky, that makes it easier than ever to write HTML emails. Inky converts simple HTML into the complex tables required for email layout.
    Downloads: 6 This Week
    Last Update:
    See Project
  • Paessler: Easy to Use With Enterprise Power. Free Trial Icon
    Paessler: Easy to Use With Enterprise Power. Free Trial

    A low-code dashboard makes monitoring intuitive for any admin, while scripting and custom sensors give experts full control.

    You shouldn't have to choose between a monitoring tool that's easy to use and one that's powerful enough for a complex environment. PRTG's low-code interface lets any admin build dashboards, set alerts and monitor devices without scripting, while custom sensors and full API access are there when your team needs deeper control. One platform, no compromise. Download a free 30-day trial now.
    Get Free Download
  • 10
    RuoYi

    RuoYi

    The warehouse's SpringBoot-based rights management system

    The warehouse's SpringBoot-based rights management system is easy to read and understand, and the interface is simple and beautiful. The core technology uses Spring, MyBatis, and Shiro without any other heavy dependencies. I have always wanted to make a background management system, and I have seen many excellent open source projects but found no suitable ones. So I started to write a background system in my spare time. So there is Zoe. She can be used for all web applications, such as website management background, website member center, CMS, CRM, OA. All front-end and back-end codes are very compact and easy to use after encapsulation, and the probability of errors is low. Also supports mobile client access. The system will continue to update some useful functions. The user is the system operator, and this function mainly completes the system user configuration. Configure the system organization (company, department, group).
    Downloads: 4 This Week
    Last Update:
    See Project
  • 11
    express-openapi-validator

    express-openapi-validator

    Auto-validates api requests, responses, and securities using ExpressJS

    Auto-validates api requests, responses, and securities using ExpressJS and an OpenAPI 3.x specification. Express-openapi-validator is an unopinionated library that integrates with new and existing API applications. express-openapi-validator lets you write code the way you want; it does not impose any coding convention or project layout. Simply, install the validator onto your express app, point it to your OpenAPI 3 specification, then define and implement routes the way you prefer. An OpenApi validator for ExpressJS that automatically validates API requests and responses using an OpenAPI 3 specification. Ensure express is configured with all relevant body parsers. Body parser middleware functions must be specified prior to any validated routes.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 12
    WebHarvest - web data extraction tool
    Web data extraction (web data mining, web scraping) tool. It leverages well proved XML and text processing techologies in order to easely extract useful data from arbitrary web pages.
    Downloads: 16 This Week
    Last Update:
    See Project
  • 13
    ZK - Simply Ajax and Mobile
    ZK is an open-source Java framework for building modern web and mobile applications. It enables developers to create rich, interactive UIs using only Java — no JavaScript required. With 200+ Ajax-powered components, event-driven architecture, and support for popular technologies like Spring, Java EE, and JSP/JSF, ZK makes it simple to deliver powerful and user-friendly web applications.
    Downloads: 11 This Week
    Last Update:
    See Project
  • 14

    Okapi Framework (Old .NET version)

    See http://okapi.opentag.com/ for LATES VERSION of the Okapi Framework

    THIS VERSION ON SOURCEFORGE IS NO LONGER SUPPORTED and works only on Windows. The Okapi Framework is a set of components and tools for localization and translation tasks. THE NEWEST JAVA-BASED VERSION OF OKAPI IS AVAILABLE AT: http://okapi.opentag.com/ The new version runs on Windows, Mac, Linux, etc.
    Leader badge
    Downloads: 17 This Week
    Last Update:
    See Project
  • 15
    Bootstrap 5 UI KIT

    Bootstrap 5 UI KIT

    Bootstrap 5 & Material Design 2.0 UI KIT

    Trusted by 2 000 000+ developers & designers. Used by companies & institutions. Super simple, 1 minute installation. Detailed docs & practical examples. Lots of tutorials. Plain JavaScript (but works also with jQuery). Huge and active community. MIT license, free for personal & commercial use. Simplicity and ease of use are key features of MDB 5 UI Kit. You need only one minute to install and run it. A slideshow component for cycling through elements, images or slides of text, like a carousel. Use MDB custom button styles for actions in forms, dialogs, and more with support for multiple sizes, states, and more. Indicate the loading state of a component or page with MDB spinners, built entirely with HTML, CSS, and no JavaScript. A card is a flexible and extensible content container. It includes options for headers and footers, a wide variety of content, contextual background colors, and powerful display options.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 16
    Gatsby

    Gatsby

    Build blazing fast, modern apps and websites with React

    Gatsby is a free and open source web framework based on React that allows you to build blazing fast websites and apps. It offers the latest web technologies, such as React.js, Webpack, modern JavaScript, CSS and more to help you build really fast websites. A Progressive Web App generator, it’s fast in every way that matters.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 17
    jwx

    jwx

    Implementation of various JWx (Javascript Object Signing

    Go module implementing various JWx (JWA/JWE/JWK/JWS/JWT, otherwise known as JOSE) technologies. If you are using this module in your product or your company, please add your product and/or company name in the Wiki! It really helps keeping up our motivation. Complete coverage of JWA/JWE/JWK/JWS/JWT, not just JWT+minimum tool set. Supports JWS messages with multiple signatures, both compact and JSON serialization. Supports JWS with detached payload. Supports JWS with unencoded payload (RFC7797). Supports JWE messages with multiple recipients, both compact and JSON serialization. Most operations work with either JWK or raw keys e.g. *rsa.PrivateKey, *ecdsa.PrivateKey, etc). Opinionated, but very uniform API. Everything is symmetric, and follows a standard convention. Arguments are organized as explicit required paramters and optional WithXXXX() style options.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 18
    warp

    warp

    A super-easy, composable, web server framework for warp speeds

    The fundamental building block of warp is the Filter, they can be combined and composed to express rich requirements on requests. A Filter in warp is essentially a function that can operate on some input, either something from a request, or something from a previous Filter, and returns some output, which could be some app-specific type you wish to pass around, or can be some reply to send back as an HTTP response. That might sound simple, but the exciting part is the combinators that exist on the Filter trait. These allow composing smaller Filters into larger ones, allowing you to modularize, and reuse any part of your web server. As awesome as the Filter system is, if warp didn’t provide common web server features, it’d still be annoying to work with. Thus, warp provides a bunch of built-in Filters, allowing you to compose the functionality you need to describe each route or resource or sub-whatever.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 19
    Simple is an XML serialization framework for Java. Its goal is to provide an XML serialization framework that enables rapid development of XML configuration and XML communication applications.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 20
    This project develops an open source editor for Clavia Nord Modular and Micro Modular synthesizers.
    Leader badge
    Downloads: 38 This Week
    Last Update:
    See Project
  • 21
    POCO C++ Libraries

    POCO C++ Libraries

    Cross-platform C++ libraries with a network/internet focus.

    NOTE: Current source code as well as bugs/patches are on GitHub: https://github.com/pocoproject/poco/ C++ class libraries for network-centric, portable applications, integrated perfectly with the C++ Standard Library. Includes network protocols (Sockets, HTTP, FTP, SMTP, POP3, etc.), SQL database access and XML parsing. Licensed under Boost license.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 22
    Framework Benchmarks

    Framework Benchmarks

    Source for the TechEmpower Framework Benchmarks project

    If you're new to the project, welcome! Please feel free to ask questions here. We encourage new frameworks and contributors to ask questions. We're here to help! This project provides representative performance measures across a wide field of web application frameworks. With much help from the community, coverage is quite broad and we are happy to broaden it further with contributions. The project presently includes frameworks on many languages including Go, Python, Java, Ruby, PHP, C#, F#,Clojure, Groovy, Dart, JavaScript, Erlang, Haskell, Scala, Perl, Lua, C, and others. The current tests exercise plaintext responses, JSON serialization, database reads and writes via the object-relational mapper (ORM), collections, sorting, server-side templates, and XSS counter-measures. Future tests will exercise other components and greater computation.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 23
    Han

    Han

    The CSS typography framework optimised for Hanzi

    "Chinese Character Standard Format" is a Sass/Stylus and JavaScript typesetting framework that integrates the three concepts of "semantic style standardization", "text design" and "high-level typesetting functions". It provides a beautiful and standardized environment for Chinese character web pages, which not only conforms to traditional reading habits but also provides an established standard for screen reading, which can completely solve the typesetting needs of today's Chinese character web page design. "Hanji Standard Format" fully supports traditional Chinese, simplified Chinese and Japanese, three languages ​​using Chinese characters. "Chinese Character Standard Format" provides a number of customization functions, and can customize the exclusive style sheet through variable settings, module reference, etc. If no special customization is required, you can also directly use CDN external style sheets.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 24
    PHP JOSE Library

    PHP JOSE Library

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK, JWKSet and more)
    Downloads: 1 This Week
    Last Update:
    See Project
  • 25
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next