Browse free open source PHP Frameworks and projects below. Use the toggles on the left to filter open source PHP Frameworks by OS, license, language, programming language, and project status.

  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • 1
    PHP JOSE Library

    PHP JOSE Library

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK, JWKSet and more)
    Downloads: 1 This Week
    Last Update:
    See Project
  • 2
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 3
    JAMP (acronym Javascript Ajax Mysql Php) is powerful and fast framework, distributed with GNU licence, in it is enclosed a suit environment for the development WEB applications.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 4
    A drop-in framework for adding tagging (folksonomy) capabilities to existing applications
    Downloads: 0 This Week
    Last Update:
    See Project
  • Fully Managed MySQL, PostgreSQL, and SQL Server Icon
    Fully Managed MySQL, PostgreSQL, and SQL Server

    Automatic backups, patching, replication, and failover. Focus on your app, not your database.

    Cloud SQL handles your database ops end to end, so you can focus on your app.
    Start Free
  • 5
    Aura is a plug-and-play XML-RPC application framework in PHP5. It bundles an XML-RPC client and an XML-RPC server. It has simple and clean API and allows exposing already written functions and classes as web services for instant productivity.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 6
    Web 2.0 framework developed in PHP5 that allows you to develop interoperable, standards-compliant, scalable web applications without having to worry about the complexities of the underlying architecture for the most common of functionality.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 7
    The Bee Framework is a PHP 5 DI/IoC application framework based on the popular Spring Framework, bringing - among other features - XML-configured declarative Dependency Injection and a powerful MVC framework to PHP.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    BlooGee establishes semantic peer-to-peer networks, stores and forwards messages, based on HTTP communication between common CMSs. Access through AJAX based interfaces or HTTP-header. Works as add-on/editor for microcontent collections like weblogs. A pr
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    Read-in XML tags in an array format accessible via "paths". Modify existing XML. Create a proper XML string. All methods are used to programmatically read, modify, and/or create XML.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Host LLMs in Production With On-Demand GPUs Icon
    Host LLMs in Production With On-Demand GPUs

    NVIDIA L4 GPUs. 5-second cold starts. Scale to zero when idle.

    Deploy your model, get an endpoint, pay only for compute time. No GPU provisioning or infrastructure management required.
    Start Free
  • 10
    The purpose of the Control Framework for PHP (CFP) is to design and implement a completely OO based approach to HTML form generation, form state management and form handling in PHP. CFP supports reusable form components.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    The DUML project is 3 sub-projects: 1) Document Update Markup Language (DUML) which allows for updates of the DOM via server markup 2) Interpreted Application Markup Language (IAML) which provides markup based widgets. 3) A set of common libraries (JAS).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 12
    Dynamic Object Oriented Views -- absolute lightestweight PHP templating framework around. Inspired by PHPSavant but lower-footprint and contains built-in hooks to populate the headers of your XHTML documents.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    Module and theme file, providing minimal integration with the Postcode Anywhere and MailBuild mailing services for Drupal 5.x
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    Fat-Free Framework
    FAT-FREE is a powerful and lightweight PHP 5.3+ Web application framework designed to help you build dynamic and robust Web sites - fast! Unlike other PHP frameworks, Fat-Free aims to be usable - not usual.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    G-Framework Web3.0 ToolKit
    This is the most advanced and complete new generation tool for creating Web applications. You can create your own "Web Applications" once writing very few lines of code and make it simply accessible from anywhere in the world.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    The APIlity PHP Library provides an object-oriented way to easily access and manage the Google AdWords API from within PHP. This comes along with an abstraction from the SOAP and WSDL details.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    Guberno is a versatile framework that allows web based administration of any application you want.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    InstantSVC (pronounced as Instant Services) provides a set of tools to ease Web Services development with PHP5. You just need to document your PHP code with PHPDocumentor to generate Web Services from it - SOAP Services as well as RESTful Web Services.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Javascript/PHP framwork for running highly dynamic multi-user applications that actually do something which could be part of a business process on a web page.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20

    Interface Dialects Linker (XML)

    Write-Once, Deploy-Everywhere software framework

    The IDLX project aims to create a framework which leverages existing technologies and XML dialects to build user interfaces in a platform-independent way. The ultimate goal is a WODE (write once, deploy everywhere) framework which is flexible and powerful enough to support any development task long into the future.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Allowed browser to have live communication without designing a complicated database structure and yet provides flexibilities to the needs.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    Laravel Blade X

    Laravel Blade X

    Use custom HTML components in your Blade views

    Supercharged Blade Components. This package provides an easy way to render custom HTML components in your Blade views.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    Laravel Report Generators

    Laravel Report Generators

    Rapidly Generate Simple Pdf, CSV, & Excel Report Package on Laravel

    Rapidly generate simple PDF reports on Laravel or CSV/Excel reports. This package provides simple PDF, csv & excel report generators to speed up your workflow. It also allows you to stream(), download(), or store() the report seamlessly.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    LayManSys - Layout Management System - is a PHP framework, that helps you providing a consistent look&feel of your web pages. It stores the meta information about the documents in RDF files and uses them for generating the HTML frame (<head> and footer).
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    General-purpose modular web framework & forum system
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • Next