Browse free open source Frameworks and projects below. Use the toggles on the left to filter open source Frameworks by OS, license, language, programming language, and project status.

  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 1
    Grassroots DICOM

    Grassroots DICOM

    Cross-platform DICOM implementation

    Grassroots DiCoM is a C++ library for DICOM medical files. It is accessible from Python, C#, Java and PHP. It supports RAW, JPEG, JPEG 2000, JPEG-LS, RLE and deflated transfer syntax. It comes with a super fast scanner implementation to quickly scan hundreds of DICOM files. It supports SCU network operations (C-ECHO, C-FIND, C-STORE, C-MOVE). PS 3.3 & 3.6 are distributed as XML files. It also provides PS 3.15 certificates and password based mecanism to anonymize and de-identify DICOM datasets.
    Leader badge
    Downloads: 290 This Week
    Last Update:
    See Project
  • 2
    Bootstrap

    Bootstrap

    HTML, CSS and JS framework for developing responsive websites and apps

    Bootstrap is an HTML, CSS, and JS framework designed for developing responsive, mobile first projects on the web. It's one of the most popular front-end frameworks and for good reason: it simply makes web development faster and easier. People of all skill levels can create projects of all sizes with Bootstrap, and for all types of devices too. With Bootstrap, you get a host of nifty features such as precompiled CSS, impressive scalability, dozens of custom HTML and CSS components and more.
    Downloads: 32 This Week
    Last Update:
    See Project
  • 3
    tabler

    tabler

    Tabler is free and open-source HTML Dashboard UI Kit

    Tabler is fully responsive and compatible with all modern browsers. Thanks to its modern, user-friendly design you can create a fully functional interface that users will love! Choose the layouts and components you need and customize them to make your design consistent and eye-catching. Every component has been created with attention to detail to make your interface beautiful! We've created this admin panel for everyone who wants to create templates based on our pre-made components. Our mission is to deliver a user-friendly, clear and easy administration panel that can be used by both simple websites and sophisticated systems. The only requirement is basic HTML and CSS (and some Liquid) knowledge, as a reward, you'll be able to manage and visualise different types of data in the easiest possible way! With the support for mobile, tablet and desktop displays, it doesn’t matter what device you’re using. Tabler is responsive in all major browsers.
    Downloads: 12 This Week
    Last Update:
    See Project
  • 4

    QuaZIP

    A C++/Qt ZIP library

    Moved to GitHub: https://github.com/stachenov/quazip
    Leader badge
    Downloads: 46 This Week
    Last Update:
    See Project
  • Build Securely on AWS with Proven Frameworks Icon
    Build Securely on AWS with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • 5
    decimal

    decimal

    Arbitrary-precision fixed-point decimal numbers in go

    Arbitrary-precision fixed-point decimal numbers in go. Note: Decimal library can "only" represent numbers with a maximum of 2^31 digits after the decimal point. The zero-value is 0, and is safe to use without initialization. Addition, subtraction, and multiplication with no loss of precision. Division with specified precision. Database/sql serialization/deserialization. JSON and XML serialization/deserialization. big.Int's API is built to reduce the number of memory allocations for maximal performance. This makes sense for its use-case, but the trade-off is that the API is awkward and easy to misuse. In contrast, it's difficult to make such mistakes with decimal. Decimals behave like other go numbers types: even though a = b will not deep copy b into a, it is impossible to modify a Decimal, since all Decimal methods return new Decimals and do not modify the originals. The downside is that this causes extra allocations, so Decimal is less performant.
    Downloads: 7 This Week
    Last Update:
    See Project
  • 6
    Foundation for Emails

    Foundation for Emails

    Design responsive HTML emails that work on any device & email client

    Foundation for Emails is a framework that allows you to create responsive HTML emails that work on any device and on any email client, even Outlook. All of its HTML/CSS components have been tested, ensuring consistency across every major email client. Foundation for Emails consists of a solid set of customizable components, including a fully responsive grid, typography, alignment classes and more. It also has a new templating language, Inky, that makes it easier than ever to write HTML emails. Inky converts simple HTML into the complex tables required for email layout.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 7
    7.css

    7.css

    A JS-independent, tree-shakeable CSS framework

    7.css is a CSS framework for building interface components that look like Windows 7. It is built on top of the GUI backbone of XP.css, which is an extension of 98.css. This framework relies on the usage of semantic HTML. To make a button, you'll need to use a button. Input elements require labels. Tabs rely on the role="tab" attribute. This page will guide you through that process, but accessibility is a primary goal of this project. It does not ship with any JavaScript, so it is compatible with your frontend framework of choice.
    Downloads: 4 This Week
    Last Update:
    See Project
  • 8
    RuoYi

    RuoYi

    The warehouse's SpringBoot-based rights management system

    The warehouse's SpringBoot-based rights management system is easy to read and understand, and the interface is simple and beautiful. The core technology uses Spring, MyBatis, and Shiro without any other heavy dependencies. I have always wanted to make a background management system, and I have seen many excellent open source projects but found no suitable ones. So I started to write a background system in my spare time. So there is Zoe. She can be used for all web applications, such as website management background, website member center, CMS, CRM, OA. All front-end and back-end codes are very compact and easy to use after encapsulation, and the probability of errors is low. Also supports mobile client access. The system will continue to update some useful functions. The user is the system operator, and this function mainly completes the system user configuration. Configure the system organization (company, department, group).
    Downloads: 4 This Week
    Last Update:
    See Project
  • 9
    jwx

    jwx

    Implementation of various JWx (Javascript Object Signing

    Go module implementing various JWx (JWA/JWE/JWK/JWS/JWT, otherwise known as JOSE) technologies. If you are using this module in your product or your company, please add your product and/or company name in the Wiki! It really helps keeping up our motivation. Complete coverage of JWA/JWE/JWK/JWS/JWT, not just JWT+minimum tool set. Supports JWS messages with multiple signatures, both compact and JSON serialization. Supports JWS with detached payload. Supports JWS with unencoded payload (RFC7797). Supports JWE messages with multiple recipients, both compact and JSON serialization. Most operations work with either JWK or raw keys e.g. *rsa.PrivateKey, *ecdsa.PrivateKey, etc). Opinionated, but very uniform API. Everything is symmetric, and follows a standard convention. Arguments are organized as explicit required paramters and optional WithXXXX() style options.
    Downloads: 3 This Week
    Last Update:
    See Project
  • Paessler: Easy to Use With Enterprise Power. Free Trial Icon
    Paessler: Easy to Use With Enterprise Power. Free Trial

    A low-code dashboard makes monitoring intuitive for any admin, while scripting and custom sensors give experts full control.

    You shouldn't have to choose between a monitoring tool that's easy to use and one that's powerful enough for a complex environment. PRTG's low-code interface lets any admin build dashboards, set alerts and monitor devices without scripting, while custom sensors and full API access are there when your team needs deeper control. One platform, no compromise. Download a free 30-day trial now.
    Get Free Download
  • 10
    WebHarvest - web data extraction tool
    Web data extraction (web data mining, web scraping) tool. It leverages well proved XML and text processing techologies in order to easely extract useful data from arbitrary web pages.
    Downloads: 17 This Week
    Last Update:
    See Project
  • 11

    Okapi Framework (Old .NET version)

    See http://okapi.opentag.com/ for LATES VERSION of the Okapi Framework

    THIS VERSION ON SOURCEFORGE IS NO LONGER SUPPORTED and works only on Windows. The Okapi Framework is a set of components and tools for localization and translation tasks. THE NEWEST JAVA-BASED VERSION OF OKAPI IS AVAILABLE AT: http://okapi.opentag.com/ The new version runs on Windows, Mac, Linux, etc.
    Leader badge
    Downloads: 17 This Week
    Last Update:
    See Project
  • 12
    Bootstrap 5 UI KIT

    Bootstrap 5 UI KIT

    Bootstrap 5 & Material Design 2.0 UI KIT

    Trusted by 2 000 000+ developers & designers. Used by companies & institutions. Super simple, 1 minute installation. Detailed docs & practical examples. Lots of tutorials. Plain JavaScript (but works also with jQuery). Huge and active community. MIT license, free for personal & commercial use. Simplicity and ease of use are key features of MDB 5 UI Kit. You need only one minute to install and run it. A slideshow component for cycling through elements, images or slides of text, like a carousel. Use MDB custom button styles for actions in forms, dialogs, and more with support for multiple sizes, states, and more. Indicate the loading state of a component or page with MDB spinners, built entirely with HTML, CSS, and no JavaScript. A card is a flexible and extensible content container. It includes options for headers and footers, a wide variety of content, contextual background colors, and powerful display options.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 13
    Simple is an XML serialization framework for Java. Its goal is to provide an XML serialization framework that enables rapid development of XML configuration and XML communication applications.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 14
    POCO C++ Libraries

    POCO C++ Libraries

    Cross-platform C++ libraries with a network/internet focus.

    NOTE: Current source code as well as bugs/patches are on GitHub: https://github.com/pocoproject/poco/ C++ class libraries for network-centric, portable applications, integrated perfectly with the C++ Standard Library. Includes network protocols (Sockets, HTTP, FTP, SMTP, POP3, etc.), SQL database access and XML parsing. Licensed under Boost license.
    Downloads: 8 This Week
    Last Update:
    See Project
  • 15
    This project develops an open source editor for Clavia Nord Modular and Micro Modular synthesizers.
    Leader badge
    Downloads: 34 This Week
    Last Update:
    See Project
  • 16
    Connexion

    Connexion

    Swagger/OpenAPI First framework for Python on top of Flask

    Connexion is a framework on top of Flask that automagically handles HTTP requests defined using OpenAPI (formerly known as Swagger), supporting both v2.0 and v3.0 of the specification. Connexion allows you to write these specifications, then maps the endpoints to your Python functions. This is what makes it unique from other tools that generate the specification based on your Python code. You are free to describe your REST API with as much detail as you want and then Connexion guarantees that it will work as you specified. We built Connexion this way in order to simplify the development process. Reduce misinterpretation about what an API is going to look like. With Connexion, you write the spec first. Connexion then calls your Python code, handling the mapping from the specification to the code. This incentivizes you to write the specification so that all of your developers can understand what your API does, even before you write a single line of code.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 17
    Framework Benchmarks

    Framework Benchmarks

    Source for the TechEmpower Framework Benchmarks project

    If you're new to the project, welcome! Please feel free to ask questions here. We encourage new frameworks and contributors to ask questions. We're here to help! This project provides representative performance measures across a wide field of web application frameworks. With much help from the community, coverage is quite broad and we are happy to broaden it further with contributions. The project presently includes frameworks on many languages including Go, Python, Java, Ruby, PHP, C#, F#,Clojure, Groovy, Dart, JavaScript, Erlang, Haskell, Scala, Perl, Lua, C, and others. The current tests exercise plaintext responses, JSON serialization, database reads and writes via the object-relational mapper (ORM), collections, sorting, server-side templates, and XSS counter-measures. Future tests will exercise other components and greater computation.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 18
    Han

    Han

    The CSS typography framework optimised for Hanzi

    "Chinese Character Standard Format" is a Sass/Stylus and JavaScript typesetting framework that integrates the three concepts of "semantic style standardization", "text design" and "high-level typesetting functions". It provides a beautiful and standardized environment for Chinese character web pages, which not only conforms to traditional reading habits but also provides an established standard for screen reading, which can completely solve the typesetting needs of today's Chinese character web page design. "Hanji Standard Format" fully supports traditional Chinese, simplified Chinese and Japanese, three languages ​​using Chinese characters. "Chinese Character Standard Format" provides a number of customization functions, and can customize the exclusive style sheet through variable settings, module reference, etc. If no special customization is required, you can also directly use CDN external style sheets.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 19
    PHP JOSE Library

    PHP JOSE Library

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK

    JSON Object Signing and Encryption Framework (JWT, JWS, JWE, JWA, JWK, JWKSet and more)
    Downloads: 1 This Week
    Last Update:
    See Project
  • 20
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 1 This Week
    Last Update:
    See Project
  • 21
    Vanilla Framework

    Vanilla Framework

    From community websites to web applications, this CSS framework

    Backed by open-source code and written in Sass by the Canonical Web Team. Vanilla contains a responsive CSS grid, basic style for HTML elements and a selection of key useful patterns and utility classes that you can extend. Designed to be composable, you can include the whole framework to avail of all styles or you can use only what you need for your project. Anyone can contribute to Vanilla, improve it and extend it. All the code is available on GitHub and is licensed under LGPLv3 by Canonical.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 22
    Web Starter Kit

    Web Starter Kit

    Web Starter Kit - a workflow for multi-device websites

    Web Starter Kit is an opinionated boilerplate for web development. Tools for building a great experience across many devices and performance oriented. Helping you to stay productive following the best practices outlined in Google's Web Fundamentals. A solid starting point for both professionals and newcomers to the industry. A responsive boilerplate optimized for the multi-screen web. Powered by Material Design Lite. You're free to use either this or a completely clean-slate via basic.html. Minify and concatenate JavaScript, CSS, HTML and images to help keep your pages lean. JavaScript code linting is done using ESLint - a pluggable linter tool for identifying and reporting on patterns in JavaScript. Web Starter Kit uses ESLint with eslint-config-google, which tries to follow the Google JavaScript style guide. A built-in server for previewing your site locally while you develop and iterate. Reload the browser in real-time anytime an edit is made without the need for an extension.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 23
    A software toolkit for using the EPCglobal Low Level Reader Protocol (LLRP) to communicate with conforming RFID readers.
    Downloads: 9 This Week
    Last Update:
    See Project
  • 24
    Scrolling Game Development Kit 2
    All-in-one program for creating 2D scrolling games. Compile your games into stand-alone .NET executables or customizable C# source code. The IDE and framework are build on OpenTK, which wraps OpenGL, so generated games can be cross-platform.
    Leader badge
    Downloads: 3 This Week
    Last Update:
    See Project
  • 25
    The 4Ever framework provides a OO access layer to a single or a set of XML files. The framework offers a set of basic management services as loading/saving, change history, and consistency checking. It is realized in a component-oriented way.
    Downloads: 4 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next