收集 MicroStrategy 日志
本文档介绍了如何使用 Bindplane 将 MicroStrategy 日志注入到 Google Security Operations。
MicroStrategy 是一款商业智能和分析平台。它会针对报告执行、用户会话、数据访问权限和管理员操作生成审核日志。解析器会从 MicroStrategy 日志消息中提取字段,并将其映射到统一数据模型 (UDM),从而捕获用户身份、会话详细信息、服务器信息和安全元数据。
准备工作
请确保满足以下前提条件:
- Google SecOps 实例
- Windows Server 2016 或更高版本,或者具有
systemd的 Linux 主机 - Bindplane 代理与 MicroStrategy Intelligence Server 之间的网络连接
- 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
- 对 MicroStrategy Intelligence Server 的特权访问权限(管理员角色或服务器文件系统访问权限)
获取 Google SecOps 注入身份验证文件
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 收集代理。
下载数据注入身份验证文件。将文件安全地保存在将要安装 Bindplane 的系统上。
获取 Google SecOps 客户 ID
- 登录 Google SecOps 控制台。
- 依次前往 SIEM 设置 > 配置文件。
复制并保存组织详细信息部分中的客户 ID。
安装 Bindplane 代理
按照以下说明在 Windows 或 Linux 操作系统上安装 Bindplane 代理。
Windows 安装
- 以管理员身份打开命令提示符或 PowerShell。
运行以下命令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安装完成。
运行以下命令,验证安装是否成功:
sc query observiq-otel-collector
该服务应显示为 正在运行。
Linux 安装
- 打开具有 root 或 sudo 权限的终端。
运行以下命令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安装完成。
运行以下命令,验证安装是否成功:
sudo systemctl status observiq-otel-collector
该服务应显示为有效(正在运行)。
其他安装资源
如需了解其他安装选项和问题排查信息,请参阅 Bindplane 代理安装指南。
配置 Bindplane 代理以注入 syslog 并将其发送到 Google SecOps
找到配置文件
Linux:
sudo systemctl status observiq-otel-collectorWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
修改配置文件
将
config.yaml的全部内容替换为以下配置:receivers: tcplog: listen_address: "0.0.0.0:514" exporters: chronicle/microstrategy: compression: gzip creds_file_path: '/etc/bindplane-agent/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: MICROSTRATEGY raw_log_field: body service: pipelines: logs/microstrategy: receivers: - tcplog exporters: - chronicle/microstrategy
配置参数
替换以下占位符:
接收器配置:
tcplog:基于协议的接收器类型:udplog(适用于 UDP syslog)tcplog(适用于 TCP syslog)syslog(适用于 RFC 3164/5424 syslog)
0.0.0.0:要监听的 IP 地址:0.0.0.0侦听所有接口(推荐)- 在某个接口上监听的特定 IP 地址
514:要监听的端口号(例如514、1514、6514)
导出器配置:
<customer_id>:上一步中的客户 IDmalachiteingestion-pa.googleapis.com:区域端点网址:- 美国:
malachiteingestion-pa.googleapis.com - 欧洲:
europe-malachiteingestion-pa.googleapis.com - 亚洲:
asia-southeast1-malachiteingestion-pa.googleapis.com - 如需查看完整列表,请参阅区域级端点
- 美国:
- 根据平台调整
creds_file_path:- Linux:
/etc/bindplane-agent/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
保存配置文件
- 修改后,保存文件:
- Linux:依次按
Ctrl+O、Enter和Ctrl+X - Windows:依次点击文件 > 保存
- Linux:依次按
重启 Bindplane 代理以应用更改
如需在 Linux 中重启 Bindplane 代理,请执行以下操作:
运行以下命令:
sudo systemctl restart observiq-otel-collector验证服务是否正在运行:
sudo systemctl status observiq-otel-collector检查日志是否存在错误:
sudo journalctl -u observiq-otel-collector -f
如需在 Windows 中重启 Bindplane 代理,请执行以下操作:
请从下列选项中选择一项:
- 以管理员身份运行命令提示符或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector- 服务控制台:
- 按
Win+R,输入services.msc,然后按 Enter 键。 - 找到 observIQ OpenTelemetry 收集器。
- 右键点击并选择重新启动。
- 按
验证服务是否正在运行:
sc query observiq-otel-collector检查日志是否存在错误:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
配置 MicroStrategy syslog 转发
MicroStrategy Intelligence Server 会将日志文件本地写入文件系统。使用系统 syslog 守护程序配置 syslog 转发,以将这些日志发送到 Bindplane 代理。
找到 MicroStrategy 日志目录:
- Windows:
C:\Program Files\Common Files\MicroStrategy\Log\ - Linux:
/var/log/Strategy/
- Windows:
配置系统 syslog 守护程序,以监控 MicroStrategy 日志文件并将其转发到 Bindplane 代理。
在 Linux 上 (rsyslog):
创建新的 rsyslog 配置文件:
sudo nano /etc/rsyslog.d/microstrategy-forward.conf添加以下内容以转发 MicroStrategy 日志:
module(load="imfile") input(type="imfile" File="/var/log/Strategy/DSSErrors.log" Tag="microstrategy" Severity="info" Facility="local0") local0.* @BINDPLANE_AGENT_IP:514重启 rsyslog 服务:
sudo systemctl restart rsyslog
在 Windows 上:
使用日志转发器实用程序(例如 NXLog 或 Snare)监控 MicroStrategy 日志目录,并通过 syslog 将事件转发到 Bindplane 代理 IP 和端口。
UDM 映射表
| 日志字段 | UDM 映射 | 逻辑 |
|---|---|---|
| Account_Creation_Timestamp、Account_Modification_Timestamp、Timestamp | additional.fields | 如果非空,则与根据字段创建的标签合并 |
| Authentication_message | metadata.description | 直接复制值 |
| Event_start | metadata.event_timestamp | 使用日期过滤器转换,格式为“MMM dd HH:mm:ss” |
| metadata.event_type | 如果具有正文和目标,则设置为“USER_UNCATEGORIZED”;如果具有正文,则设置为“STATUS_UPDATE”;否则设置为“GENERIC_EVENT” | |
| 会话 | network.session_id | 直接复制值 |
| Source_server | principal.application | 直接复制值 |
| 主机名 | principal.asset.hostname | 直接复制值 |
| server_ip | principal.asset.ip | 直接复制值 |
| 主机名 | principal.hostname | 直接复制值 |
| server_ip | principal.ip | 直接复制值 |
| level | principal.platform_patch_level | 直接复制值 |
| User_Group_Name | principal.user.group_identifiers | 直接复制值 |
| Account_Name, User | principal.user.user_display_name | 如果 Account_Name 不为空,则使用该值;否则,使用“用户” |
| id、Account_Login、Account | principal.user.userid | 如果 ID 中的值不为空,则使用该值;否则,如果 Account_Login 不为空,则使用该值;否则,使用 Account |
| Log_level | security_result.detection_fields | 如果非空,则与从字段创建的标签合并 |
| Source_host | src.asset.hostname | 直接复制值 |
| Source_host | src.hostname | 直接复制值 |
| module | target.application | 直接复制值 |
| client_ip | target.asset.ip | 直接复制值 |
| client_ip | target.ip | 直接复制值 |
| PID | target.process.pid | 直接复制值 |
| Thread_ID、SID、方法、Account_Status_DESC | target.resource.attribute.labels | 如果非空,则与根据字段创建的标签合并 |
| OID | target.resource.id | 直接复制值 |
| Object_Owner_Name | target.resource.name | 直接复制值 |
| 用户 | target.user.user_display_name | 直接复制值 |
| UID | target.user.userid | 直接复制值 |
| metadata.product_name | 设置为“MICROSTRATEGY” | |
| metadata.vendor_name | 设置为“MICROSTRATEGY” | |
Hostname |
principal.hostname, principal.asset.hostname |
从变更日志映射 |
Source_host |
src.hostname, src.asset.hostname |
从变更日志映射 |
server_ip |
principal.ip, principal.asset.ip |
从变更日志映射 |
client_ip |
target.ip, target.asset.ip |
从变更日志映射 |
Account_Creation_Timestamp |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
Account_Modification_Timestamp |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |
Timestamp |
event.idm.read_only_udm.additional.fields |
从变更日志映射 |