收集 AIDE(高级入侵检测环境)日志

解析器版本:1.0

支持的平台:

本文档介绍了如何使用 Bindplane 将 AIDE(高级入侵检测环境)日志注入到 Google Security Operations。AIDE 是一款文件完整性监控工具,可检测 Linux/Unix 系统上文件的更改。

准备工作

请确保满足以下前提条件:

  • Google SecOps 实例
  • 运行 systemd 的 Linux 主机,且 AIDE 版本为 0.18 或更高版本(支持 JSON 格式)
  • 如果在代理后面运行,请确保防火墙端口已根据 Bindplane 代理要求打开
  • 对 AIDE 配置文件的特权访问权限

获取 Google SecOps 注入身份验证文件

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 收集代理
  3. 下载数据注入身份验证文件
  4. 将文件安全地保存在将要安装 Bindplane 的系统上。

获取 Google SecOps 客户 ID

  1. 登录 Google SecOps 控制台。
  2. 依次前往 SIEM 设置 > 配置文件
  3. 复制并保存组织详细信息部分中的客户 ID

安装 Bindplane 代理

按照以下说明在 Linux 操作系统上安装 Bindplane 代理。

Linux 安装

  1. 打开具有 root 或 sudo 权限的终端。
  2. 运行以下命令:

    sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh
    

其他安装资源

如需了解其他安装选项,请参阅此安装指南

配置 Bindplane 代理以注入 Syslog 并将其发送到 Google SecOps

  1. 访问配置文件:

    • 找到 config.yaml 文件。通常,它位于 Linux 上的 /etc/bindplane-agent/ 目录中。
    • 使用文本编辑器(例如 nanovi)打开该文件。
  2. 按如下方式修改 config.yaml 文件:

    receivers:
      udplog:
        # Replace the port and IP address as required
        listen_address: "0.0.0.0:514"
    
    exporters:
      chronicle/chronicle_w_labels:
        compression: gzip
        # Adjust the path to the credentials file you downloaded in Step 1
        creds_file_path: '/path/to/ingestion-authentication-file.json'
        # Replace with your actual customer ID from Step 2
        customer_id: <CUSTOMER_ID>
        endpoint: malachiteingestion-pa.googleapis.com
        # Add optional ingestion labels for better organization
        log_type: 'AIDE'
        raw_log_field: body
        ingestion_labels:
    
    service:
      pipelines:
        logs/source0__chronicle_w_labels-0:
          receivers:
            - udplog
          exporters:
            - chronicle/chronicle_w_labels
    
    • 根据基础架构的需要替换端口和 IP 地址。
    • <CUSTOMER_ID> 替换为实际的客户 ID。
    • /path/to/ingestion-authentication-file.json 更新为在第 1 步中保存身份验证文件的文件路径。

重启 Bindplane 代理以应用更改

  • 如需在 Linux 中重启 Bindplane 代理,请运行以下命令:

    sudo systemctl restart observiq-otel-collector
    

在 AIDE 上配置 Syslog 转发

  1. 打开 AIDE 配置文件:

    sudo vi /etc/aide/aide.conf
    
  2. 前往报告部分。

  3. 添加以下配置:

    • report_level:输入 list_entries
    • report_format:输入 json(适用于 AIDE 0.18 及更高版本)或 plain
    • report_url:输入 syslog:authpriv

    配置示例:

    ```ini
    report_level=list_entries
    report_format=json
    report_url=syslog:authpriv
    ```
    
  4. 保存配置。

  5. 配置 rsyslog 以将 AIDE 日志转发到 Bindplane 代理。打开 rsyslog 配置:

    sudo vi /etc/rsyslog.d/aide-forward.conf
    
  6. 添加以下配置,以将 authpriv 设备日志转发到 Bindplane 代理:

    authpriv.* @<BINDPLANE_AGENT_IP>:514
    
    • <BINDPLANE_AGENT_IP> 替换为 Bindplane 代理主机 IP 地址。
    • 使用 @ 进行 UDP 转发,或使用 @@ 进行 TCP 转发。
  7. 重启 rsyslog:

    sudo systemctl restart rsyslog
    
  8. 如果这是全新安装,请初始化 AIDE 数据库:

    sudo aide --init
    sudo mv /var/lib/aide/aide.db.new /var/lib/aide/aide.db
    
  9. 测试配置:

    sudo aide --check
    
  10. 使用 cron 设置自动化检查:

    sudo crontab -e
    
  11. 添加以下行,以便每天凌晨 4:05 运行 AIDE:

    05 4 * * * root /usr/sbin/aide --check
    

UDM 映射表

日志字段 UDM 映射 逻辑
added_label principal.asset.attribute.labels 已合并
changed_label principal.asset.attribute.labels 已合并
old_acl_label principal.asset.attribute.labels 已合并
old_md5_label principal.asset.attribute.labels 已合并
old_perms_label principal.asset.attribute.labels 已合并
old_sha256_label principal.asset.attribute.labels 已合并
old_ts_label principal.asset.attribute.labels 已合并
removed_label principal.asset.attribute.labels 已合并
total_label principal.asset.attribute.labels 已合并
file_path principal.file.full_path 直接映射
path principal.file.full_path 直接映射
old_size principal.file.size 直接映射
host principal.hostname 直接映射
sr security_result 已合并
new_acl_label target.asset.attribute.labels 已合并
new_md5_label target.asset.attribute.labels 已合并
new_perms_label target.asset.attribute.labels 已合并
new_sha256_label target.asset.attribute.labels 已合并
new_ts_label target.asset.attribute.labels 已合并
path target.file.full_path 直接映射
new_size target.file.size 直接映射
不适用 metadata.event_type 常量:GENERIC_EVENT
不适用 metadata.product_name 常量:AIDE
不适用 metadata.vendor_name 常量:AIDE
不适用 principal.application 常量:aide
不适用 principal.file.size 常量:sizedata
不适用 target.file.size 常量:sizedata_target
total_files", "added_files", "removed_files", "changed_files", "old_timestamp", "old_perms", "old_sha256", "old_md5", and "old_acl principal.asset.attribute.labels 从变更日志映射
new_timestamp", "new_perms", "new_sha256", "new_md5", and "new_acl target.asset.attribute.labels 从变更日志映射

更新日志

查看相应解析器的更改日志

需要更多帮助?获得社区成员和 Google SecOps 专业人士的解答。