Open Source ChromeOS File Transfer Protocol (FTP) Software

File Transfer Protocol (FTP) Software for ChromeOS

Browse free open source File Transfer Protocol (FTP) software and projects for ChromeOS below. Use the toggles on the left to filter open source File Transfer Protocol (FTP) software by OS, license, language, programming language, and project status.

  • Paessler: Easy to Use With Enterprise Power. Free Trial Icon
    Paessler: Easy to Use With Enterprise Power. Free Trial

    A low-code dashboard makes monitoring intuitive for any admin, while scripting and custom sensors give experts full control.

    You shouldn't have to choose between a monitoring tool that's easy to use and one that's powerful enough for a complex environment. PRTG's low-code interface lets any admin build dashboards, set alerts and monitor devices without scripting, while custom sensors and full API access are there when your team needs deeper control. One platform, no compromise. Download a free 30-day trial now.
    Get Free Download
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 1
    Double Commander
    Double Commander is a cross platform open source file manager with two panels side by side. It is inspired by Total Commander and features some new ideas.
    Leader badge
    Downloads: 9,040 This Week
    Last Update:
    See Project
  • 2
    Xtreme Download Manager

    Xtreme Download Manager

    Open source download manager

    The project has a new home now: https://xtremedownloadmanager.com/ For developers: https://github.com/subhra74/xdm Xtreme Download Manager is a powerful tool to increase download speed up-to 500%, resume broken/dead downloads and schedule downloads. XDM seamlessly integrates with Google Chrome, Mozilla Firefox Quantum, Opera, Vivaldi and many popular browsers, to take over downloads and saving streaming videos from web.
    Leader badge
    Downloads: 1,159 This Week
    Last Update:
    See Project
  • 3
    GDownloader is a download manager, that will allow to resume paused or aborted downloads, download from multiple locations, and manage multiples downloads (priorities, schedule, etc) among other features. It's developed in Java to provide portability
    Leader badge
    Downloads: 52 This Week
    Last Update:
    See Project
  • 4
    FullSync

    FullSync

    Easy file synchronization for everyone

    FullSync is a powerful tool that helps you keep multiple copies of various data in sync. I.e. it can update your Website using (S)Ftp, backup your data or refresh a working copy from a remote server. It offers flexible rules, a scheduler and more
    Downloads: 9 This Week
    Last Update:
    See Project
  • 99.99% Uptime for MySQL and PostgreSQL Databases Icon
    99.99% Uptime for MySQL and PostgreSQL Databases

    Sub-second maintenance. 2x read/write performance. Built-in vector search for AI apps.

    Cloud SQL Enterprise Plus delivers near-zero downtime with 35 days of point-in-time recovery. Supports MySQL, PostgreSQL, and SQL Server.
    Start Free
  • 5
    Open Upload is an open source extensible PHP application for fast file upload and download for big (and small) file sharing, like rapidshare and megaupload. Multiple authentication methods, database backends, multilanguage support.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 6
    Feature rich FTP Library using Java 1.4 / 5.0 (2 different builds) methods and java.nio. Code is now located at GitHub (https://github.com/arnold-maderthaner/ftp4che). For issues and patches please open this on GitHub too.
    Leader badge
    Downloads: 19 This Week
    Last Update:
    See Project
  • 7
    mendelson OFTP2

    mendelson OFTP2

    Implementation of the OFTP2 protocol (RFC 5024)

    The mendelson OFTP2 is a JAVA-based open source OFTP2 solution. It contains a logging- and configuration UI and supports encryption, digital signatures, message compression, TLS, certificate exchange, message routing, mail notification
    Leader badge
    Downloads: 33 This Week
    Last Update:
    See Project
  • 8
    JFtp is a graphical network browser. It supports various types of connections like FTP, SMB, SFTP, NFS, HTTP and local ones, has a nice Swing GUI, lots of features and can be started & (auto)updated using Java Web Start in any browser (link on homepage.)
    Downloads: 5 This Week
    Last Update:
    See Project
  • 9
    Hermes FTP Server is a free, cross-platform FTP server adhering to RFC 959, RFC 2228, and RFC 2389. It is being developed in Java with a strong focus on security and extensibility.
    Downloads: 7 This Week
    Last Update:
    See Project
  • Build Securely on Azure with Proven Frameworks Icon
    Build Securely on Azure with Proven Frameworks

    Lay a foundation for success with Tested Reference Architectures developed by Fortinet’s experts. Learn more in this white paper.

    Moving to the cloud brings new challenges. How can you manage a larger attack surface while ensuring great network performance? Turn to Fortinet’s Tested Reference Architectures, blueprints for designing and securing cloud environments built by cybersecurity experts. Learn more and explore use cases in this white paper.
    Download Now
  • 10
    Capivara is a graphical file transfer and file synchronization application. It supports network protocols such as SFTP and FTP.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 11
    The ftp4j library implements a Java full-featured FTP client. With ftp4j embedded in your application you can: transfer files (upload and download), browse the FTP site (directory listing), create, delete, rename and move directories and files.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 12
    Command line application written in Java useful for automation of downloading process and filtering contents of downloaded files. jDownloader uses simple script file to configure downloading and filtering processes.
    Downloads: 14 This Week
    Last Update:
    See Project
  • 13
    scponly is an alternative 'shell' (of sorts) for system administrators who would like to provide access to remote users to both read and write local files without providing any remote execution priviledges.
    Leader badge
    Downloads: 14 This Week
    Last Update:
    See Project
  • 14
    mendelson AS4

    mendelson AS4

    AS4 Solution for ENTSOG, e-SENS, ebMS, PEPPOL, ICS2, BDEW

    mendelson AS4 is a free JAVA-based open source AS4 solution. Contains a monitoring- and configuration GUI (SWING), supports PUSH and PULL messages, ENTSOG AS4, e-SENS AS4, ebMS AS4, BDEW AS4, PEPPOL AS4, ICS2 AS4, signatures (SOAP, payload), selectable profile per trading partner, encryption (SOAP, payload), UserNameToken, TLS, pluggable into any servlet container, trading partner management, compression, certificate management
    Downloads: 11 This Week
    Last Update:
    See Project
  • 15
    java ftp client library
    Downloads: 3 This Week
    Last Update:
    See Project
  • 16
    phpWebFTP enables connections to FTP servers, even behind a firewall not allowing traffic. phpWebFTP bypasses the firewall by making a FTP connection from your webserver to the FTP server and transfering the files to your webclient over the http protocol
    Downloads: 3 This Week
    Last Update:
    See Project
  • 17

    YADE (SOSFTP)

    A Batch and API oriented application for managed file transfer.

    YADE (former SOSFTP) is a batch file transfer solution for FTP, FTPS, SFTP, WebDAV and other protocols. It provides a configurable command line client, an API and a bridge to the SOS JobScheduler. YADE comes with advanced error handling and logging capabilities. YADE is able to create and maintain a transfer history in a central database. Product Knowledge Base at https://kb.sos-berlin.com Change Management System at https://change.sos-berlin.com
    Downloads: 2 This Week
    Last Update:
    See Project
  • 18
    webdavclient4j is a generic WebDAV client for Java. It is based on the retired Apache Jakarta Slide project's Java webdav client, and includes the VFS WebDAV provider. It is packaged with HttpClient 3.0.1.
    Leader badge
    Downloads: 4 This Week
    Last Update:
    See Project
  • 19
    Multi-connection command line tool to download Internet sites. Similar to wget and cURL, but it manages up to 50 parallel links. Main features are: recursive fetching, Metalink retrieving, segmented download and image filtering by width and height.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 20

    S3Feather

    An S3 browser that runs entirely in your browser.

    An S3 browser that runs entirely in your browser. No server, no install, no build step — one HTML file, open it and start browsing. Works on desktop and mobile, on any platform.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 21
    openbsd-iso is a set of _ scripts _ to download OpenBSD releases from ftp, and then create the CD/DVD iso images.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 22

    protobuf-delphi

    Protocol buffers for Delphi

    This project contains the implementation of Protocol Buffers for Delphi. From the project was implemented limited functionality necessary for a specific project. At that time, I do not see any sense to transfer the whole project code.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 23
    LeechCraft
    LeechCraft is a cross-platform modular "internet-client" application. It has plugins that allow one to browse the web, chat via instant messaging (like Jabber or IRC), read RSS/Atom feeds, download files via BitTorrent, Direct Connect and other protocols, play media files and much more.
    Leader badge
    Downloads: 1 This Week
    Last Update:
    See Project
  • 24

    Download machine

    Batch download manager

    Download Machine is pure Java daemon that watches queue files for changes. If a new entry is available, DM will download it. Queue files are just URL lists. DM supports resume for FTP, FSP and HTTP downloads.
    Leader badge
    Downloads: 2 This Week
    Last Update:
    See Project
  • 25
    Indexer of FTP sites so that the sites are searchable from a central location. Credentials of sites and the data are stored in an SQL database. No front-end is included at this time.
    Downloads: 2 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next