lab 08 final draft
lab 08 final draft
Lab Assignment - 08
Saba Haajira
1862496
3. Deliverables
3.1 Draw a network diagram illustrating interfaces with IP addresses, VLANs and other necessary
information. Mention the EVE-NG Server IP which was used to perform this exercise. (Do not
copy/capture the network/lab topology simply from EVE-NG Server)
Router Interface Net Are IPv4 subnet mask IPv6
a
G0/0 C 1 10.1.96.130/30 255.255.255.252 2023:DB9:1:96::41/122
3.2 Issue the following commands and copy the configurations from the following
devices in plain text after completing all tasks, and put the configured text in bold.
DELETE all default and not configured configuration lines, wherever applicable.
a) Cisco Routers: show running configuration
Cisco – R1
Haajira_Cisco-R1#sh run
!
hostname Haajira_Cisco-R1
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 1
ipv6 address 2023:DB9:1::1/128
ipv6 ospf 10 area 1
!
interface GigabitEthernet0/0
ip address 10.1.96.130 255.255.255.252
ip ospf 1 area 1
ipv6 address 2023:DB9:1:96::41/122
ipv6 ospf 10 area 1
!
interface GigabitEthernet0/1
ip address 10.0.96.1 255.255.255.252
ip ospf 1 area 0
ipv6 address 2023:DB9:0:96::1/126
ipv6 ospf 10 area 0
!
interface GigabitEthernet0/2
ip address 10.1.96.1 255.255.255.248
ip ospf 1 area 1
ipv6 address 2023:DB9:1:96::1/125
ipv6 ospf 10 area 1
!
!
router ospf 1
router-id 1.1.1.1
auto-cost reference-bandwidth 10000
area 1 virtual-link 4.4.4.4
passive-interface Loopback0
!
!
ipv6 router ospf 10
router-id 1.1.1.1
auto-cost reference-bandwidth 10000
area 1 virtual-link 4.4.4.4
passive-interface Loopback0
!
end
Cisco-R2
Haajira_Cisco-R2#sh run
hostname Haajira_Cisco-R2
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 1
ipv6 address 2023:DB9:1::2/128
ipv6 ospf 10 area 1
!
interface GigabitEthernet0/0
ip address 10.1.96.133 255.255.255.252
ip ospf 1 area 1
ipv6 address 2023:DB9:1:96::81/122
ipv6 ospf 10 area 1
!
interface GigabitEthernet0/1
ip address 10.1.96.2 255.255.255.248
ip ospf 1 area 1
ipv6 address 2023:DB9:1:96::2/125
ipv6 ospf 10 area 1
!
!
router ospf 1
router-id 2.2.2.2
auto-cost reference-bandwidth 10000
passive-interface Loopback0
!
ipv6 router ospf 10
router-id 2.2.2.2
auto-cost reference-bandwidth 10000
passive-interface Loopback0
!
End
Cisco-R4
Haajira_Cisco-R4#sh run
!
hostname Haajira_Cisco-R4
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf 1 area 1
ipv6 address 2023:DB9:1::4/128
ipv6 ospf 10 area 1
!
interface GigabitEthernet0/1
ip address 10.2.0.1 255.255.255.252
ip ospf mtu-ignore
ip ospf 1 area 2
ipv6 address 2023:DB9:2:96::1/126
ipv6 ospf 10 area 2
ipv6 ospf mtu-ignore
!
interface GigabitEthernet0/3
ip address 10.1.96.4 255.255.255.248
ip ospf 1 area 1
ipv6 address 2023:DB9:1:96::4/125
ipv6 ospf 10 area 1
!
router ospf 1
router-id 4.4.4.4
auto-cost reference-bandwidth 10000
area 1 virtual-link 1.1.1.1
area 2 nssa default-information-originate
redistribute static metric-type 1 subnets
passive-interface Loopback0
!
ip route 20.20.20.20 255.255.255.255 10.2.0.2
!
ipv6 route 2023:DB9:20::20/128 2023:DB9:2:96::2
ipv6 router ospf 10
router-id 4.4.4.4
auto-cost reference-bandwidth 10000
area 1 virtual-link 1.1.1.1
area 2 nssa default-information-originate
passive-interface Loopback0
redistribute static metric-type 1
!
End
Cisco-R5
Haajira_Cisco-R5#sh run
hostname Haajira_Cisco-R5
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip ospf 1 area 96
ipv6 address 2023:DB9:96::5/128
ipv6 ospf 10 area 96
!
interface GigabitEthernet0/2
ip address 10.96.96.1 255.255.255.252
ip ospf authentication message-digest
ip ospf message-digest-key 96 md5 Haajira
ip ospf dead-interval 80
ip ospf hello-interval 5
ip ospf 1 area 96
ipv6 address 2023:DB9:96:96::2/126
ipv6 ospf 10 area 96
!
router ospf 1
router-id 5.5.5.5
auto-cost reference-bandwidth 10000
area 96 stub no-summary
passive-interface Loopback0
!
ipv6 router ospf 10
router-id 5.5.5.5
auto-cost reference-bandwidth 10000
area 96 stub no-summary
passive-interface Loopback0
!
End
#--------------------------------------------------
echo "OSPFv2 Configuration"
#--------------------------------------------------
ospf 0
no shutdown
exit
#--------------------------------------------------
echo "OSPFv3 Configuration"
#--------------------------------------------------
ospf3 0
no shutdown
exit
#--------------------------------------------------
echo "Policy Configuration"
#--------------------------------------------------
policy-options
begin
policy-statement "OSPF"
entry 1
from
protocol direct
exit
action accept
type 1
exit
exit
exit
commit
exit
exit
3.3 Issue the following commands on all hosts and capture outputs
a) show ip int br
3.4 Issue the following commands on Cisco Routers (R1, R2, R4, R5) and capture outputs
a).show ip int br
b).
f. show ospf interface detail and highlight the new intervals and authentication of ge-0/0/2.
3.6 Issue the following commands on R6-Alcatel Router and capture outputs
a) show ip ospf interface g0/2 and highlight the new intervals and authentication.
3.8 Capture outputs of debugging on R5 when you configure 2.3.3 OSPFv2 the Advanced
Configuration
3.9 Issue both IPv4 and IPv6 ping with option source from the following devices and
capture outputs
a.Loopback 5 to Host A
b.Loopback 5 to Host B
c.Loopback 5 to Loopback 6
d.Loopback 5 to Loopback 20
e.Loopback 6 to Loopback 1
f.Loopback 6 to Loopback 2
g.Loopback 6 to Loopback 3
h.Loopback 6 to Loopback 4
i.Loopback 20 to Host A
j.Loopback 20 to Host B
3.10 Issue both IPv4 and IPv6 traceroute from the following devices and capture outputs
a) Host A to Host B
b) Host A to Loopback 1
c) Host A to Loopback 2
d) Host A to Loopback 3
e) Host A to Loopback 4
f) Host B to Loopback 5
g) Host B to Loopback 6
h) Host B to Loopback 20
3.11 Bonus 3 Points) Answer the following questions briefly:
a.The differences between Stub Area and NSSA and where we should use NSSA and Stub
Area.
**Stub Area: **
**When to Use: **
- Use Stub Areas when you want to reduce the size of routing tables and do not require external
routes.
- Use NSSAs when you need to import certain external routes but still want to limit LSA flooding.
Configuring the reference bandwidth in OSPF controls how link costs are calculated based on the
bandwidth of the links in your network. It ensures that OSPF properly handles and compares links
of all speeds, making routing decisions more accurate and efficient.
Reference Bandwidth
Link Cost =
Link Bandwidth
c. The reason why we should specifically define a router ID for OSPF? If the router ID is not
defined, what will become the router ID?
Reason:
Manually configuring the router ID ensures that the router consistently uses the same identifier in
the OSPF network, even after reboots or changes to interface.
If the router ID is not manually set, it may change unexpectedly when interface IP addresses are
modified or when interfaces go down.
The automatic selection process for router IDs can lead to unpredictability due to unexpected
changes caused by modifications in interface configurations, inconsistency from different routers
using various methods for selection, and potential conflicts in complex networks that may cause
OSPF adjacency issues.
END OF ASSIGNMENT