0% found this document useful (0 votes)
4 views

Lab-Report-5

Computer Network lab report. Title: OSPF

Uploaded by

rahman15-6410
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
4 views

Lab-Report-5

Computer Network lab report. Title: OSPF

Uploaded by

rahman15-6410
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 15

Computer Networks

Course Code: CSE314


Lab Assignment: OSPF

Submitted To
Mr. Husne Mubarak

Lecturer Department: CSE


Daffodil International University

Submitted By
A.K.M Obydur Rahman
ID: 222-15-6410
Section: 63_G1
Department: CSE
Fall-24
Introduction:
In this lab, we configured a network within Cisco Packet Tracer. The aim was to establish
reliable communication between multiple routers, switches and PCs by creating a fully or
partially meshed network where each device could communicate with any other device
through multiple paths. This Configuration ensures high availability and redundancy within
the network.

Equipment:
• Cisco Packet Tracer
✓ Cisco Routers
✓ Cisco Switches
✓ PCs (End Devices)
✓ Ethernet cables (Copper Straight-Through and Copper Crossover, available
within Cisco Packet Tracer)

Network Topology and Design:


The network is designed in a Mesh Topology, where multiple routers are interconnected to
ensure that each device has multiple paths to communicate with others. This setup
maximizes redundancy and enhances network reliability, making it highly resilient to single
points of failure. Routers are connected to switches and PCs, with various subnetworks
defined by distinct IP ranges. Each router has multiple connections to other routers, enabling
alternative paths for data transmission if one path fails. Unique IP ranges were assigned to
each router interface, allowing efficient routing between subnets.
Configuration Steps
Step 1: Establishing Physical Connections

• Connect each router's Ethernet interface to the appropriate network devices (e.g.,
other routers, switches, or PCs) using Ethernet cables.

• Connect the router's LAN interface to end devices (e.g., PCs) with Ethernet cables to
create local network segments.

Step 2: Accessing the Router Console

• Connect a PC to the router's console port using a dedicated console cable to access
and configure the router through the command-line interface.

Step 3: Assigning IP Addresses to PCs

• Configure IP addresses on all connected PCs to enable communication across the


network. Assign unique IP addresses within each respective subnet to ensure proper
connectivity.
Used Code for Configuration:

Router1:

en

conf t

int fa0/0

ip address 192.168.90.1 255.255.255.0

no shut
exit

router ospf 1

network 192.168.90.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

exit

int se2/0

ip address 192.168.70.1 255.255.255.252

no shut

exit

router ospf 1

network 192.168.90.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

exit

int se3/0

ip address 192.168.40.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.90.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2


exit

int fa1/0

ip address 192.168.45.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.90.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

exit

Router 2:

en

conf t

int fa0/0

ip address 192.168.95.1 255.255.255.0

no shut

exit

router ospf 1

network 192.168.95.0 0.0.0.255 area 2


network 192.168.70.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

int se2/0

ip address 192.168.70.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.95.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

int se3/0

ip address 192.168.75.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.95.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

int fa4/0

ip address 192.168.65.1 255.255.255.252


no shut

exit

router ospf 1

network 192.168.95.0 0.0.0.255 area 2

network 192.168.70.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

Router 3:

en

conf t

int fa0/0

ip address 192.168.80.1 255.255.255.0

no shut

exit

router ospf 1

network 192.168.80.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

exit
int se3/0

ip address 192.168.40.1 255.255.255.252

no shut

exit

router ospf 1

network 192.168.80.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

exit

int se2/0

ip address 192.168.55.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.80.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

exit

int fa4/0

ip address 192.168.50.2 255.255.255.252

no shut

exit

router ospf 1
network 192.168.80.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.40.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

exit

Router 4:

en

conf t

int fa1/0

ip address 192.168.85.1 255.255.255.0

no shut

exit

router ospf 1

network 192.168.85.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.60.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

int se3/0

ip address 192.168.55.1 255.255.255.252

no shut

exit

router ospf 1
network 192.168.85.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.60.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

int se2/0

ip address 192.168.75.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.85.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.60.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit

int fa0/0

ip address 192.168.60.1 255.255.255.252

no shut

exit

router ospf 1

network 192.168.85.0 0.0.0.255 area 2

network 192.168.55.0 0.0.0.3 area 2

network 192.168.60.0 0.0.0.3 area 2

network 192.168.75.0 0.0.0.3 area 2

exit
Router 5:

en

conf t

int fa1/0

ip address 192.168.60.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.60.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

exit

int fa4/0

ip address 192.168.65.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.60.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

exit
int fa5/0

ip address 192.168.50.2 255.255.255.252

no shut

exit

router ospf 1

network 192.168.60.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

exit

int fa0/0

ip address 192.168.45.1 255.255.255.252

no shut

exit

router ospf 1

network 192.168.60.0 0.0.0.3 area 2

network 192.168.50.0 0.0.0.3 area 2

network 192.168.65.0 0.0.0.3 area 2

network 192.168.45.0 0.0.0.3 area 2

exit
Step 4: Testing Network Connectivity
In Cisco Packet Tracer, ping tests were conducted between various endpoints (Pcs and
routers) to verify connectivity across the partial mesh network. Successful responses
confirmed that the IP and routing configuration were correct and that alternate paths were
functional.
Discussion:
The router configuration lab successfully set up a functional network, with the router acting
as the gateway to the internet and enabling communication within the LAN. Basic
configurations, including assigning IP addresses, setting the subnet mask, and configuring
routing, were performed to ensure smooth communication between devices.

This hands-on lab provided practical experience with router setup and network
troubleshooting, enhancing our understanding of how to configure networks and solve
connectivity issues. Overall, the lab helped solidify core networking concepts and gave us
the skills to manage and troubleshoot real-world networks effectively.

You might also like