0% found this document useful (0 votes)
16 views

Networking Design For Organization

The document discusses a campus network design project. It outlines the tools used including Packet Tracer, VMware, and GNS3 to simulate and test the network. It will cover concepts like multilayer switching, redundancy, load balancing, EtherChannel, and spanning tree protocol.

Uploaded by

outerbank007
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
16 views

Networking Design For Organization

The document discusses a campus network design project. It outlines the tools used including Packet Tracer, VMware, and GNS3 to simulate and test the network. It will cover concepts like multilayer switching, redundancy, load balancing, EtherChannel, and spanning tree protocol.

Uploaded by

outerbank007
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 92

See discussions, stats, and author profiles for this publication at: https://www.researchgate.

net/publication/348163172

CIE Program Project 2 - A Campus Network Design

Technical Report · January 2021

CITATIONS READS

0 4,050

1 author:

Mohamed Mahmoud Ashour


Mansoura University
30 PUBLICATIONS 19 CITATIONS

SEE PROFILE

All content following this page was uploaded by Mohamed Mahmoud Ashour on 17 May 2021.

The user has requested enhancement of the downloaded file.


‫هندسة االتصاالت و الحاسبات‬
‫كليـــة الهندســـة‬
‫جامعـــة المنصـــورة‬

Design of Campus
Communication Network
BSc Comm. & Computers Eng.

Assist Prof. Mohammed M. Ashour


Eng. Haitham Mahmoud Abd-Elghany

Team
Omar Mokhtar Mohamed Ahmed Mahmoud
Mohamed Mahmoud Hussien
Mahmoud Ahmed Gaber Akram Mohamed Aly
Thabet Attiya
Ahmed Wed Abdul-Azim Gamal Hussien Ebrahiem
Attiya Mohamed
Ahmed Khaled Mohamed Mohamed Aly Al-saied Aly
Esmaiel

29 March 2021
Design of Campus Communication Network

Abstract
In this project a computer network made up of an interconnection of local area
networks (LANs) within a limited geographical area.

Through a blend of theory and the VMware (TM) program, we develop the
backbone necessary for our project to work in high demand areas of network
support, user support, and security.

We use GNS3 to emulate, configure, test and troubleshoot our network.

A campus area network is larger than a local area network but smaller than a
metropolitan area network (MAN) or wide area network (WAN).

First, we use packet tracer to simulate an imaginary network design.

Then, we design a real Campus network and make it Suitable for our
capabilities to move to GNS3 to emulate, configure, test and troubleshoot the
network.

1|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Table of Contents
Abstract .................................................. 1

Table of Contents ............................................ 2

Chapter 1: Introduction ........................................ 4


About Project's Tools ........................................ 4
Packet Tracer ............................................ 5
VMware ............................................... 6
GNS3 ................................................. 7
First Topology in GNS3 & VMware ................................ 8
The final topology .......................................... 9

Chapter2: Multilayer Switching .................................. 10


What Is a Multilayer Switch? .................................. 10
Why Use a Multilayer Switch? ................................. 13
How to Use a Multilayer Switch? ................................ 14
Multilayer Switch Port Types .................................. 15
Conclusion .............................................. 17

Chapter3: Redundancy and Load Balancing .......................... 18


What Is Redundancy in Networking? ............................. 18
Forms of Network Redundancy ................................. 19
What Is Load balancing in Networking? ........................... 20
Benefits of Load Balancing .................................. 21
Gateway Load Balancing Protocol (GLBP) .......................... 22
Facts about GLBP ........................................ 23
Close view of the Topology.................................... 24
Configuration ............................................ 25
Testing ................................................. 29
Debugging .............................................. 36

2|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter4: EtherChannel....................................... 42
What is the EtherChannel?.................................... 42
Benefits of EtherChannel ..................................... 43
EtherChannel Requirements ................................... 45
EtherChannel Load-Balancing .................................. 46
Configuration ............................................ 47
EtherChannel – Manual Configuration .......................... 53
EtherChannel – Dynamic Configuration .......................... 54
EthernChannel - PAgP ....................................... 55
EtherChannel - LACP ........................................ 56
Troubleshooting EtherChannel ................................. 57

Chapter5: Spanning Tree protocol ................................ 65


Basic STP Configuration ...................................... 71
STP Port States ........................................... 73
Improving STP Convergence ................................... 77
Troubleshoot ............................................. 82
Troubleshoot a Failure ..................................... 82
Use the Diagram of the Network .............................. 82
Identify a Bridging Loop .................................... 83
Log STP Events on Devices That Host Blocked Ports .................. 83
Debug spanning-tree ...................................... 84
show spanning-tree ....................................... 85
show spanning-tree summary totals ............................ 86

Chapter6: Conclusion ........................................ 87


This is the final network ..................................... 88

Appendices ............................................... 89

References ............................................... 90

3|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter 1:
Introduction
The increasing demand for high performance network has challenged network
researchers to design network architectures capable of delivering a high
quality of service to end users.

The network infrastructure design becomes critical part for universities.

An important network design consideration for today's networks is creating the


potential to support future expansions; reliable and scalable networks. This
requires to define the client's unique situation, particularly the current
technology, application, and data architecture.

About Project's Tools

Many network design tools and methodologies in use today resemble the
connect-the-dots game that some of us played as children.

These tools let you place internetworking devices on a palette and connect
them with local-area network (LAN) or wide-area network (WAN) media.

The problem with this methodology is that it skips the steps of analyzing a
customer's requirements and selecting devices and media based on those
requirements.

Good network design must recognize that a customer's requirements embody


many business and technical goals including requirements for availability,
scalability, affordability, security, and manageability.

High-availability of the network has always been important in the


internetworking world.

4|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Packet Tracer

What is Packet Tracer? Packet Tracer is a cross-platform visual simulation


tool designed by Cisco Systems that allows users to create network
topologies and imitate modern computer networks. Packet Tracer (PT) is a
powerful and dynamic tool that displays the various protocols used in
networking, in either Real Time or Simulation mode. This includes layer 2
protocols such as Ethernet and PPP, layer 3 protocols such as IP, ICMP, and
ARP, and layer 4 protocols such as TCP and UDP. Routing protocols can also
be traced.

We use it to make a first design and configuration to our network

5|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

VMware

VMware Workstation 9 continues VMware’s tradition of delivering the virtual


hardware that technical professionals deserve and rely on every day. With
support for Windows 8, restricted VMs, Open GL support for Linux and a new
web interface to access virtual machines, it’s the perfect tool for getting work
done.

To help you and your organization evaluate Windows 8, master the Metro UI
and test your applications, VMware Workstation 9 is optimized for running
Windows 8 virtual machines and running on Windows 8 PCs. Easy Install
simplifies the task of creating Windows 8 virtual machines, Unity mode will
intelligently scale windows with Metro applications and multi-touch support
will ensure you get the true Windows 8 experience in a virtual machine.

Workstation’s new web interface allows you to access your virtual machines
running in Workstation or vSphere on a tablet, smart phone, PC or any device
with a modern browser. No plugins necessary. Now you can power on, off, or
suspend your virtual machines and interact with them from almost anywhere.

Create virtual machines that are encrypted, block USB devices, require a
runtime password, and another password to change virtual machine settings.
Once set, send the virtual machine

To anyone to run on their Mac, Windows, or Linux machines by using


VMware Fusion Professional. From PC to Datacenter and Back Again in
Workstation 8 we introduced the ability to upload a virtual machine from your
PC to vSphere. Workstation 9 takes the next step and allows you to drag and
drop a virtual machines form vSphere to your PC. It’s the easiest way to
move virtual machines between your PC and your internal cloud.

6|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

GNS3

GNS3 is used by hundreds of thousands of network engineers worldwide to


emulate, configure, test and troubleshoot virtual and real networks. GNS3
allows you to run a small topology consisting of only a few devices on your
laptop, to those that have many devices hosted on multiple servers or even
hosted in the cloud.

GNS3 consists of two software components:

 The GNS3-all-in-one software (GUI)

 The GNS3 virtual machine (VM)

When you create topologies in GNS3 using the all-in-one software GUI client,
the devices created need to be hosted and run by a server process. You have
a few options for the server part of the software:

1. Local GNS3 server


2. Local GNS3 VM
3. Remote GNS3 VM

The local GNS3 server runs locally on the same PC where you installed the
GNS3 all-in-one software. If for example you are using a Windows PC, both
the GNS3 GUI and the local GNS3 server are running as processes in
Windows.

GNS3 supports both emulated and simulated devices.

Emulation: GNS3 mimics or emulates the hardware of a device and you run
actual images on the virtual device. For example, you could copy the Cisco
IOS from a real, physical Cisco router and run that on a virtual, emulated
Cisco router in GNS3.

Simulation: GNS3 simulates the features and functionality of a device such


as a switch. You are not running actual operating systems (such as Cisco
IOS), but rather, a simulated device developed by GNS3, like the built-in layer
2 switch.

7|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

First Topology in GNS3 & VMware

We move to GNS3 & VMware to move to GNS3 to emulate, configure, test


and troubleshoot the network.

This is the First Topology in GNS3

8|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

The final topology

Then, we decrease the number of PCs and remove the Clouds because of
appropriate capabilities. And this is the final topology which is Configured and
tested.

9|P ag e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter2:
Multilayer Switching
With the increasing diversity of network applications and the implementation
of some converted networks, the multilayer switch is thriving in data centers
and networks. It is regarded as a technology to enhance the network routing
performance on LANs.

What Is a Multilayer Switch?

The multilayer switch (MLS) has 10gbe switch and Gigabit Ethernet switch. It is
a network device which enables operation at multiple layers of the OSI model.
By the way, the OSI model is a reference model for describing network
communications. It has seven layers, including the physical layer (layer 1), data
link layer (layer 2), network layer (layer 3) and so on. The multilayer switch
performs functions up to almost application Layer (layer 7). For instance, it can
do the context based access control, which is a feature of layer 7. Unlike the
traditional switches, multilayer switches also can bear the functions of routers
at incredibly fast speeds. In addition, the Layer 3 switch is one type of multilayer
switches and is very commonly used.

Figure 1: Seven layers in OSI model

10 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Multilayer Switch vs. Layer 2 Switch

The Layer 2 switch forwards data packets based on the Layer 2 information like
MAC addresses. As a traditional switch, it can inspect frames. While multilayer
switches not only can do all the job that Layer 2 switches do, it has routing
function as well, including static routing and dynamic routing. So multilayer
switches can inspect deeper into the protocol description unit.

Multilayer Switch vs. Router

Generally, multilayer switches and routers have three key differences. Firstly,
routers typically use software to route. While multilayer switches route packets
on ASCI (Application Specific Integrated Circuit) hardware. Another difference
is that multilayer switches route packets faster than routers. In addition, based
on IP addresses, routers can support numerous different WAN technologies.
However, multilayer switches lack some QoS (Quality of Service) features. It is
commonly used in LAN environment.

Routing Between VLANs

By default, a switch will forward both broadcasts and multicasts out every port
but the originating port. However, a switch can be logically segmented into
separate broadcast domains, using Virtual LANs (or VLANs).

Each VLAN represents a unique broadcast domain:

 Traffic between devices within the same VLAN is switched.


 Traffic between devices in different VLANs requires a Layer-3 device
to communicate.

11 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

There are three methods of routing between VLANs. The first method involves
using an external router with a separate physical interface in each VLAN. This
is the least scalable solution, and impractical for environments with a large
number of VLANs:

The second method involves using an external router with a single trunk link
to the switch, over which all VLANs can be routed. The router must support
either 802.1Q or ISL encapsulation. This method is known as router-on-a-
stick:

The final method involves using a multilayer switch, which supports both
Layer-2 and Layer-3 forwarding:

Multilayer switching is a generic term, encompassing any switch that can


forward traffic at layers higher than Layer-2.

12 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Why Use a Multilayer Switch?

As mentioned above, the multilayer switch plays an important role in network


setups. The following highlights some of the advantages.

 Easy for use – Multilayer switches are configured automatically and its Layer
3 flow cache is set up autonomously. And there is no need for you to learn
new IP switching technologies for its “plug-and-play” design.

 Faster connectivity – With multilayer switches, you gain the benefits of both
switching and routing on the same platform. Therefore, it can meet the
higher-performance need for the connectivity of intranets and multimedia
applications.

Figure 2: Multilayer switches

13 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

How to Use a Multilayer Switch?

Generally, there are three main steps for you to configure a multilayer switch.

Preparation

 Determine the number of VLANs that will be used, and the IP address range
(subnet) you’re going to use for each VLAN.
 Within each subnet, identify the addresses that will be used for the default
gateway and DNS server.
 Decide if you’re going to use DHCP or static addressing in each VLAN.

Configuration

You can start configuring the multilayer switch after making preparations.

 Enable routing on the switch with the IP routing command. (Note: some
multilayer switches may support the protocols like RIP and OSPF.)
 Log into multilayer switch management interface.
 Create the VLANs on the multilayer switch and assign ports to each VLAN.

Verification

After completing the second step, you still need to offer a snapshot of the
routing table entries and list a summary of an interface’s IP information and
status. Then, the multilayer switch configuration is finished.

14 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Multilayer Switch Port Types

Multilayer switches support both Layer-2 and Layer-3 forwarding.

Layer-2 forwarding, usually referred to as switching, involves decisions based


on frame or data-link headers. Switches will build hardware address tables to
intelligently forward frames.

Layer-3 forwarding, usually referred to as routing, involves decisions based


on packet or network headers. Routers build routing tables to forward packets
from one network to another.

A multilayer switch supports three port types:

 Layer-2 or switchports
 Layer-3 or routed ports
 Switched Virtual Interfaces (SVIs)

A switchport can either be an access or trunk port. By default on Cisco


switches, all interfaces are switchports. To manually configure an interface as
a switchport:

Switch(config)# interface gi1/10

Switch(config-if)# switchport

A routed port behaves exactly like a physical router interface, and is not
associated with a VLAN. The no switchport command configures an interface
as a routed port, allowing an IP address to be assigned:

Switch(config)# interface gi1/20

Switch(config-if)# no switchport

Switch(config-if)# ip address 10.101.101.1 255.255.255.0

15 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Multilayer switches support configuring a VLAN as a logical routed interface,


known as a Switched Virtual Interface (SVI). The SVI is referenced by the
VLAN number:

Switch(config)# interface vlan 101

Switch(config-if)# ip address 10.101.101.1 255.255.255.0

Switch(config-if)# no shut

SVIs are the most common method of configuring inter-VLAN routing. The
logical VLAN interface will not become online unless:

 The VLAN is created.


 At least one port is active in the VLAN.

Multilayer Switching – Route Once, Switch Many

Originally, multilayer switches consisted of two independent components:


 Routing engine
 Switching engine

The first packet in an IP traffic flow must be sent to the routing engine to
be routed. The switching engine could then cache this traffic flow.
Subsequent packets destined for that flow could then be switched instead
of routed. Thisgreatly reduced forwarding latency.

This concept is often referred to as route once, switch many.

Just like a router, a multilayer switch must update the following


header information

 Layer 2 destination address


 Layer 2 source address
 Layer 3 IP Time-to-Live (TTL)

16 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Additionally, the Layer-2 and Layer-3 check sums must be updated to


reflectthe changes in header information.

Cisco’s original implementation of multilayer switching was known as


NetFlow or route-cache switching. NetFlow incorporated separate
routingand switching engines.

NetFlow was eventually replaced with Cisco Express Forwarding (CEF),

Which addressed some of the disadvantages of NetFlow:


 CEF is less CPU intensive.
 CEF does not dynamically cache routes, eliminating the risk
ofstale routes in the cache if the routing topology changes.

Conclusion

The multilayer switch provides high functions in the networking. It is suitable for
VLAN segmentation and better network performance. When buying multilayer
switches, you’d better take multilayer switch price and using environment into
consideration.

17 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter3:
Redundancy and Load
Balancing
- What Is Redundancy in Networking?

Network redundancy is the process of adding additional instances of


network devices and lines of communication to help ensure network
availability and decrease the risk of failure along the critical data path.

The underlying premise that explains the importance of network redundancy


is simple. Without any backup systems in place, all it takes is one point of
failure in a network to disrupt or bring down an entire system. Redundancy in
networks helps to eliminate single points of failure to ensure better network
stability and uptime in the face of events that would otherwise take the
network offline. Consider the following example:

To reach other networks, HostA must utilize a single gateway – SwitchA.

The gateway represents a single point of failure on this network. If the


gateway fails, hosts will lose access to all resources beyond the
gateway.

18 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

- Forms of Network Redundancy:

Generally speaking, there are two forms of redundancy that data centers use
to ensure systems will stay up and running:

 Fault Tolerance: A fault-tolerant redundant system provides full


hardware redundancy, mirroring applications across two or more
identical systems that run in tandem. Should anything go wrong with the
primary system, the mirrored backup system will take over with no loss
of service. Ideal for any operations in which any amount of downtime is
unacceptable (such as industrial or healthcare applications), fault-
tolerance redundant systems are complex and often expensive to
implement.

 High Availability: A software-based redundant system, high availability


uses clusters of servers that monitor one another and have failover
protocols in place. If something goes wrong with one server, the backup
servers take over and restart applications that were running on the failed
server. This approach to network redundancy is less infrastructure
intensive, but it does tolerate a certain amount of downtime in that there
is a brief loss of service while the backup servers boot up applications.

19 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Using multiple routers or multilayer switches can provide Layer-3


redundancy for hosts:

However, the Layer-3 redundancy must be transparent to each host. Hosts


should not be configured with multiple default gateways.

- What Is Load balancing in Networking?

Load balancing is a standard functionality of the Cisco IOS® router software,


and is available across all router platforms. It is inherent to the forwarding
process in the router and is automatically activated if the routing table has
multiple paths to a destination. It is based on standard routing protocols, such
as Routing Information Protocol (RIP), RIPv2, Enhanced Interior Gateway
Routing Protocol (EIGRP), Open Shortest Path First (OSPF), and Interior
Gateway Routing Protocol (IGRP), or derived from statically configured routes
and packet forwarding mechanisms. It allows a router to use multiple paths to
a destination when forwarding packets.

20 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Benefits of Load Balancing

 Reduced Downtime
 Scalable
 Redundancy
 Flexibility
 Efficiency
 Global Server Load Balancing

Cisco supports three protocols to provide transparent Layer-3 redundancy:

 Hot Standby Router Protocol (HSRP)


 Virtual Router Redundancy Protocol (VRRP)
 Gateway Load Balancing Protocol (GLBP)

Why we will Use Gateway Load Balancing Protocol


(GLBP)?

- Because GLBP allows the load balancing of traffic among the master and
standby routers while in HSRP (and VRRP) the standby routers do not help
handle traffic. With GLBP, the single virtual IP address is associated with one
virtual MAC address per GLBP member. The master receives ARP requests
and sends replies that specify different virtual MAC addresses, taking turns
among the different virtual MAC addresses in order to distribute traffic among
them.

21 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Gateway Load Balancing Protocol (GLBP)

- To overcome the shortcomings in HSRP and VRRP, Cisco developed the


proprietary Gateway Load Balancing Protocol (GLBP).

- Routers are added to a GLBP group, numbered 0 to 1023. Unlike HSRP


and VRRP, multiple GLBP routers can be active, achieving both redundancy
and load balancing.

- A priority is assigned to each GLBP interface - 100 by default. The interface


with the highest priority becomes the Active Virtual Gateway (AVG). If
priorities are equal, the interface with the highest IP will become the AVG.

- Routers in the GLBP group are assigned a single virtual IP address. Hosts
will use this virtual address as their default gateway. The AVG will respond to
ARP requests for the virtual IP with the virtual MAC address of an Active
Virtual Forwarder (AVF).

- Up to three routers can be elected as AVFs. The AVG assigns a virtual MAC
address to each AVF, and to itself, for a maximum total of 4 virtual MAC
addresses. Only the AVG and AVFs can forward traffic for hosts.
Any router not elected as an AVF or AVG will become a Secondary Virtual
Forwarder (SVF), and will wait in standby until an AVF fails.

- GLBP supports three load balancing methods:


- Round Robin
- Weighted
- Host-dependent

22 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

- The default load balancing method is per-host round robin. Traffic from
hosts is distributed equally across all routers in the GLBP group. The AVG will
respond to the first host ARP request with the first virtual MAC address. The
second ARP request will receive the second virtual MAC address, etc.

- The weighted load balancing method will distribute traffic proportionally,


based on a router’s weight. Routers with a higher weight will receive a
proportionally higher percentage of traffic.

- Host-dependent load balancing will provide a host device with the same
Virtual MAC address every time it performs an ARP request.

- Hello packets are used to elect GLBP roles and to ensure all routers are
functional. If the current active router fails, the standby router will immediately
take over as active, and a new standby is elected. By default, hello packets
are sent every 3 seconds

- Facts about GLBP:

 Hello packets are sent every 3 seconds.


 Hello packets are sent to multicast address 224.0.0.102.
 The default hold down time is 10 seconds.
 The virtual MAC address is the reserved 0007.b4xx.xxyy, with xxxx

Representing the GLBP group number, and yy representing the AVF


Number.

23 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Close view of the Topology

 We used 4 multilayer switches and many access switches and


a lot of number of hosts.

 Assigned a single virtual IP address (10.16.8.1). Hosts will use


this virtual address as their default gateway.

 The AVG will respond to ARP requests for the virtual IP with
the virtual MAC address of an Active Virtual Forwarder (AVF).

 Assigned a priority to the multilayer switches to elect the AVG


and the AVF.

24 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Configuration

For Switch 1

- This Switch will be AVF.


- Using Load-Balancing method: Round-Robin.
- With Virtual GLBP Ip = 10.16.8.1
- Priority = 50

25 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

For Switch 2

- This Switch will be AVF.


- Using Load-Balancing method: Round-Robin.
- With Virtual GLBP Ip = 10.16.8.1
- Preempt: Enable
- Priority = 100 (default)

About Preempt: The preempt parameter will allow a router to forcibly


assume the role of AVG if it fails and return when its priority allow to give it a
role of AVG.

26 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

For Switch 3

- This Switch will be AVF.


- Using Load-Balancing method: Round-Robin.
- With Virtual GLBP Ip = 10.16.8.1
- Preempt: Enable
- Priority = 150

27 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

For Switch 4

- This Switch will be AVG.


- Using Load-Balancing method: Round-Robin.
- With Virtual GLBP Ip = 10.16.8.1
- Preempt: Enable
- Priority = 200

28 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Testing

Show Glbp

Let’s dissect this output piece by piece and talk about what it means.

The top portion of the output talks about who the AVG is, as well as the
general state of the group.

Vlan8 – Group 1
State is Active

The first line tells about the group we are looking at as well as the interface
that GLBP is running on. The second line tells us that this router in the Active
AVG.

29 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

The next chunk of output gives us some general information about the local
GLBP host as well as the group in general. We can see the virtual IP that the
group is responsible for which was configured on all of the hosts to star the
GLBP process. We can also see the local priority of this GLBP host. As the
output, states this is the default value. The priority is used to determine who
the active AVG is. The router with the highest AVG will always be the AVG,
and the second highest will always be the SVG.

30 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Glbp brief

- Switch 1

-Switch 2

- Switch 3

- Switch 4

31 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

So all the other switches know who the AVG is as well as who the SVG
is. Switch3 is the SVG so he marks himself as ‘local’ under the Standby
router field…

Now let’s take a look at the output of the ‘show glbp brief’ command on
Swittch4…

As you can see, Switch4 is now the active AVG with Switch3 (with the second
highest priority) being the SVG.

- Let’s take a second to talk about the output from this command.

- Show glbp brief…

32 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

- The First line in the output talks about the group in general. It tells you the
priority of the AVG, the GLBP group IP, the AVG and the SVG. In this case,
the priority of the AVG is 200, the group IP is 10.16.8.1, the AVG is local, and
the SVG is switch3.

- The Second line talks about the first virtual forwarder. The state is shown
as active here since the third AVF is the local router itself. This shows that a
switch can own both the AVG as well as the AVF roles. We see the virtual
MAC as well as ‘local’ to indicate that this router has this role

- The Third line talks about the second AVF in the group. The meaning of
the ‘state’ column changes here slightly. As far as switch4 is concerned, it is
listening to this AVF to make sure that it is still online. This does NOT imply
that this AVF is not active. This is just the view point from switch4. The rest
of the line shows the virtual MAC that this AVF is responsible for as well as
the router’s IP address.

- The Fourth line talks about the third virtual forwarder. Again, from switch4’s
perspective it is listening to this AVF. We see the virtual MAC that this AVF is
using and responsible for as well as its IP address.

- The Fifth line shows the fourth AVF, its virtual MAC and IP address.

33 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

- In Command ( Show Glbp )..

GLBP supports three load balancing methods:

• Round Robin

• Weighted

• Host-dependent

The default load balancing method is per-host round robin. Traffic from
hosts is distributed equally across all routers in the GLBP group. The AVG will
respond to the first host ARP request with the first virtual MAC address. The
second ARP request will receive the second virtual MAC address, etc.

34 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

The default weight is 100.

 If the weight falls below the lower threshold, the router must stop
functioning as an AVF. The router will become an AVF again once its
weight reaches the upper threshold, as long as preempt is configured.

 Hello packets are sent every 3 seconds.

 Hello packets are sent to multicast address 224.0.0.102.

 The default hold down time is 10 seconds.

35 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Debugging

Debug Glbp

-Debug Glbp Errors

To display debugging messages about Gateway Load Balancing Protocol


(GLBP) error conditions, use the debug glbp errors command in privileged
EXEC mode. To disable debugging output, use the no form of this command.

- Debug glbp errors

- No debug glbp errors

Examples

The following is sample output from the debug glbp errors command:

Router# debug glbp errors

GLBP Errors debugging is on


1d19h: GLBP: Fa0/0 API active virtual address 10.21.8.32 not found
1d19h: GLBP: Fa0/0 API active virtual address 10.21.8.32 not found
1d19h: GLBP: Fa0/0 API active virtual address 10.21.8.32 not found

36 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Debug glbp Events

To display debugging messages about Gateway Load Balancing Protocol


(GLBP) events that are occurring, use the debug glbp events command in
privileged EXEC mode. To disable debugging output, use the no form of this
command.

- debug glbp events [all | detail | terse]

- no debug glbp events [all | detail | terse]

Examples

The following is sample output from the debug glbp


events command when the terse keyword is specified:

Router# debug glbp events terse

GLBP Events debugging is on


(Protocol, redundancy, track)

37 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Debug glbp Packets

To display summary information about Gateway Load Balancing Protocol


(GLBP) packets being sent or received, use the debug glbp
packets command in privileged EXEC mode. To disable debugging output,
use the no form of this command.

- debug glbp packets [all | detail | hello | reply | request | terse]

- no debug glbp packets [all | detail | hello | reply | request | terse]

38 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Examples

The following is sample output from the debug glbp packets command:

Router# debug glbp packets hello

GLBP Packets debugging is on


(Hello)
1d19h: GLBP: Fa0/0 Grp 10 Hello out 10.21.8.32 VG Active pri 254 vIP
10.21.8.10 1

1d19h: GLBP: Fa0/0 Grp 10 Hello out 10.21.8.32 VG Active pri 254 vIP
10.21.8.10 1

1d19h: GLBP: Fa0/0 Grp 10 Hello out 10.21.8.32 VG Active pri 254 vIP
10.21.8.10 1

1d19h: GLBP: Fa0/0 Grp 10 Hello out 10.21.8.32 VG Active pri 254 vIP
10.21.8.10 1

39 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Debug glbp Terse

To display a limited range of debug messages about Gateway Load Balancing


Protocol (GLBP) errors, events, and packets, use the debug glbp
terse command in privileged EXEC mode. To disable debugging output, use
the no form of this command.

- debug glbp terse

- no debug glbp terse

Examples

The following is sample output from the debug glbp terse command:

Router# debug glbp terse

GLBP:
GLBP Errors debugging is on

GLBP Events debugging is on


(protocol, redundancy, track)

GLBP Packets debugging is on


(Request, Reply)

40 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

41 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter4:
EtherChannel

-What is the EtherChannel?

EtherChannel is a port link aggregation technology or port-channel


architecture used primarily on Cisco switches.

It allows grouping of several physical Ethernet links to create one logical


Ethernet link for the purpose of providing fault-tolerance and high-speed links
between switches, routers and servers.

An EtherChannel can be created from between two and eight active Fast,
Gigabit or 10-Gigabit Ethernet ports, with an additional one to eight inactive
(failover) ports which become active as the other active ports fail.

EtherChannel is primarily used in the backbone network, but can also be used
to connect end user machines.

EtherChannel technology was invented by Kalpana and conceptualized by


Kalpana employee Scott Childs in the early 1990s. It was later acquired
by Cisco Systems in 1994. In 2000 the IEEE passed 802.3ad which is
an open standard version of EtherChannel.

42 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

-Benefits of EtherChannel:

Using an EtherChannel has numerous advantages, and probably the most


desirable aspect is the bandwidth.

Using the maximum of 8 active ports a total bandwidth of 800 Mbit/s,


8 Gbit/s or 80 Gbit/s is possible depending on port speed.

This assumes there is a traffic mixture, as those speeds do not apply to a


single application only. It can be used with Ethernet running on twisted pair
wiring, single-mode and multimode fiber.

Because EtherChannel takes advantage of existing wiring it makes it very


scalable. It can be used at all levels of the network to create higher bandwidth
links as the traffic needs of the network increase. All Cisco switches have the
ability to support EtherChannel.

-What is the port aggregation?

A network will often span across multiple switches. Trunk ports are usually
Used to connect switches together.
There are two issues with using only a single physical port for the trunk
Connection:-

• The port represents a single point of failure. If the port goes down,
the trunk connection is lost.
• The port represents a traffic bottleneck.
All other ports on the switch will use that one port to communicate across the
trunk connection.

Thus, the obvious benefits of adding redundancy to the trunk connection are
fault tolerance and increased bandwidth, via load balancing.
However, simply trunking two or more ports between the switches will not
Work, as this creates a switching loop.

43 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

One of two things will occur:-

• Spanning Tree Protocol (STP) will disable one or more ports to eliminate the
loop.
• If STP is disabled, the switching loop will result in an almost.

Port aggregation allows multiple physical ports to be bundled together to


Form a single logical port.
The switch and STP will treat the bundled ports as a single interface,
eliminating the possibility of a switching loop.

Cisco’s implementation of port aggregation is called EtherChannel.


EtherChannel supports Fast, Gigabit, and 10 Gigabit Ethernet ports.
A maximum of 8 active ports are supported in a single EtherChannel.

If the ports are operating in full duplex, the maximum theoretical bandwidth
Supported is as follows:-

Fast Ethernet / Gigabit Ethernet / 10 Gigabit Ethernet


The maximum number of supported EtherChannel on a single switch is
Platform-dependent, though most support up to 64 or 128 EtherChannel.

44 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

EtherChannel Requirements:

The previous section described the benefits of port aggregation for a trunk
Connection. However, EtherChannel can be formed with either access or
trunk ports.

EtherChannel are also supported on Layer-3 interfaces.


Implementing an EtherChannel for access ports provides increased
bandwidth and redundancy to a host device, such as a server.
However, the host device must support a port aggregation protocol, such as
LACP.
Port aggregation protocols are covered in great detail later in this guide.
Similarly, implementing EtherChannel for trunk connections provides
increased bandwidth and redundancy to other switches.

If a port in an EtherChannel bundle fails, traffic will be redistributed across the


remaining ports in the bundle. This happens nearly instantaneously.

For an EtherChannel to become active, all ports in the bundle must be


configured identically, regardless if the EtherChannel is being used with
access or trunk ports. Port settings that must be identical include the
Following:-
• Speed settings.
• Duplex settings.
• STP settings.
• VLAN membership (for access ports).
• Native VLAN (for trunk ports).
• Allowed VLANs (for trunk ports).
• Trucking encapsulation protocol (for trunk ports).

45 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

EtherChannel Load-Balancing:

Traffic sent across an EtherChannel is not evenly distributed across all ports
in the bundle.
Instead, EtherChannel utilizes a load-balancing algorithm to determine the
port to send the traffic out, based on one of several criteria:-

• Source IP address - src-ip.


• Destination IP address - dst-ip.
• Source and destination IP address - src-dst-ip.
• Source MAC address - src-mac.
• Destination MAC address - dst-mac.
• Source and Destination MAC address - src-dst-mac.
• Source TCP/UDP port number - src-port.
• Destination TCP/UDP port number - dst-port.
• Source and destination port number - src-dst-port.

Using a deterministic algorithm prevents perfect load-balancing.


However, a particular traffic flow is forced to always use the same port in the
bundle, preventing out-of-order delivery.

The default load-balancing method for a Layer-2 EtherChannel is either


srcmac or src-dst-mac, depending on the platform.
The default method for a Layer-3 EtherChannel is src-dst-ip.

46 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Configuration

Switch 1 with switch 2


Switch1(config-if)#int range GigaEthernet 1/1-2

Switch1(config-if)#channel-group 5 mode desirable

Switch1(config-if)#interface port-channel 5

Switch1(config-if)#switchport mode access

Switch1(config-if)#switchport access VLAN 8

47 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Switch 2 with Switch 1

Switch2(config-if)#int range GigaEthernet 0/2-3

Switch2(config-if)#channel-group 5 mode desirable

Switch2(config-if)#interface port-channel 5

Switch2(config-if)#switchport mode access

Switch2(config-if)#switchport access VLAN 8

Switch 2 with switch 3

Switch2(config-if)#int range GigaEthernet 1/0-1

Switch2(config-if)#channel-group 6 mode desirable

Switch2(config-if)#interface port-channel 6

Switch2(config-if)#switchport mode access

Switch2(config-if)#switchport access VLAN 8

48 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

49 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

For Switch 3 with switch 2

Switch3(config-if)#int range GigaEthernet 0/2-3

Switch3(config-if)#channel-group 6 mode desirable

Switch3(config-if)#interface port-channel 6

Switch3(config-if)#switchport mode access

Switch3(config-if)#switchport access VLAN 8

For Switch 3 with switch 4

Switch3(config-if)#int range GigaEthernet 1/0-1

Switch3(config-if)#channel-group 5 mode desirable

Switch3(config-if)#interface port-channel 5

Switch3(config-if)#switchport mode access

Switch3(config-if)#switchport access VLAN 8

50 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

51 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

For Switch 4 with switch 3

Switch4(config-if)#int range GigaEthernet 1/1-2

Switch4(config-if)#channel-group 5 mode desirable

Switch4(config-if)#interface port-channel 5

Switch4(config-if)#switchport mode access

Switch4(config-if)#switchport access VLAN 8

52 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

EtherChannel – Manual Configuration

There are two methods of configuring an EtherChannel:


• Manually
• Dynamically, using an aggregation protocol

To manually configure two ports to join an EtherChannel:


` Switch(config)# interface range gi2/23 - 24
Switch(config-if)# channel-group 1 mode on

The remote switch must also have the EtherChannel manually configured as
on. Remember that speed, duplex, VLAN, and STP configuration must be
configured identically across all participating ports on both switches.

The channel-group number identifies the EtherChannel on the local switch. This
number does not need to match on both switches, though for documentation
purposes it should.

Adding switch ports to a channel-group creates a logical port-channel interface.


This interface can be configured by referencing the channelgroup number:
Switch(config)# interface port-channel 1

Changes made to the logical port-channel interface are applied to all physical
switch ports in the channel-group:
Switch(config)# interface port-channel 1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan 50-100

To configure a port-channel as a Layer-3 interface:


Switch(config)# interface port-channel 1
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.168.10.1 255.255.255.0

53 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

By default, a port-channel interface is administratively shutdown. To bring


the port-channel online:
Switch(config)# interface port-channel 1
Switch(config-if)# no shut

Physical port properties, such as speed and duplex, must be configured on


the physical interface, and not on the port-channel interface.

EtherChannel – Dynamic Configuration

Cisco switches support two dynamic aggregation protocols:


• PAgP (Port Aggregation Protocol) – Cisco proprietary aggregating
protocol.
• LACP (Link Aggregation Control Protocol) – IEEE standardized
aggregation protocol, originally defined in 802.3ad.

Both PAgP and LACP exchange negotiation packets to form the EtherChannel.
When an EtherChannel is configured manually, no negotiation packets are
exchanged.

Thus, an EtherChannel will never form if one switch manually configured the
EtherChannel, and the other switch is using a dynamic aggregation protocol.

PAgP and LACP are not compatible – both sides of an EtherChannel must use
the same aggregation protocol.

54 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

EthernChannel - PAgP

PAgP is a Cisco-proprietary aggregation protocol, and supports two modes:


• Desirable – actively attempts to form a channel
• Auto – waits for the remote switch to initiate the channel

A PAgP channel will form in the following configurations:


• desirable ‫ـــــــــــ‬desirable
• desirable ‫ـــــــــــ‬auto

A channel will not form if both sides are set to auto. Also, PAgP will not form a
channel if the remote side is running LACP, or manually configured.

To create an EtherChannel using PAgP negotiation:


Switch(config)# interface range gi2/23 – 24
Switch(config-if)# channel-protocol pagp
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# channel-group 1 mode auto

PAgP requires that speed, duplex, VLAN, and STP configuration be configured
identically across all participating ports.

55 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

EtherChannel - LACP

LACP is an IEEE standard aggregation protocol, and supports two modes: •


Active – actively attempts to form a channel
• Passive – waits for the remote switch to initiate the channel

An LACP channel will form in the following configurations:


• active‫ ـــــــــــــ‬active
• active‫ ــــــــــــ‬passive

A channel will not form if both sides are set to passive. Also, LACP will not form
a channel if the remote side is running PAgP, or manually configured.

To create an EtherChannel using LACP negotiation:


Switch(config)# interface range gi2/23 – 24
Switch(config-if)# channel-protocol lacp
Switch(config-if)# channel-group 1 mode active
Switch(config-if)# channel-group 1 mode passive

LACP requires that speed, duplex, VLAN, and STP configuration be configured
identically across all participating ports.

Recall that a maximum of 8 active ports are supported in a single EtherChannel.


LACP supports adding an additional 8 ports into the bundle in a standby state,
to replace an active port if it goes down.

LACP assigns a numerical port-priority to each port, to determine which ports


become active in the EtherChannel. By default, the priority is set to 32768, and
a lower priority is preferred. If there is a tie in port-priority, the lowest port
number is preferred.

56 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

To change the LACP port-priority to something other than default:


Switch(config)# interface range gi2/23 – 24
Switch(config-if)# lacp port-priority 100

LACP also assigns a system-priority to each switch, dictated which switch


becomes the decision-maker if there is a conflict about active ports. The default
system-priority is 32768, and a lower priority is again preferred. If there is a tie
in system-priority, the lowest switch MAC address is preferred.

To globally change the system-priority on a switch:


Switch(config)# lacp system-priority 500

Troubleshooting EtherChannel

To view status information on all configured EtherChannels:


Switch# show etherchannel summary

Flags:
D - Down
P - in port-channel
I - stand-alone
s - Suspended
R - Layer3
S - Layer2
U - port-channel in use

Group Port-channel Ports


---------- --------------- ---------------
1 Po1(SU) Gi2/23(P) Gi2/24(P)

Note that both ports have a status of P, which indicates that they are up and
active in the EtherChannel.

57 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

On Cisco Nexus switches, the syntax for this command is slightly different:
NexusSwitch# show port-channel summary

58 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

59 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

60 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

61 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

62 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

63 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

64 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter5:
Spanning Tree protocol
Switching loops:
When a switching loop is introduced into the network, a destructive broadcast
storm will develop within seconds. A storm occurs when broadcasts are
endlessly forwarded through the loop.
Consider the following example:

65 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

If HostA sends out a broadcast, SwitchD will forward the broadcast out all
ports in the same VLAN. The broadcast will loop around the switches infinitely
and there will be a broadcast storm.

Spanning Tree Protocol (STP) was developed to prevent the broadcast


storms caused by switching loops. STP was originally defined in IEEE
802.1D.
Switches running STP will build a map or topology of the entire switching
network. STP will identify if there are any loops, and then disable or block as
many ports as necessary to eliminate all loops in the topology.
STP switches exchange Bridge Protocol Data Units (BPDU’s) to build the
topology database. BPDU’s are forwarded out all ports every two seconds, to
a dedicated MAC multicast address of 0180.c200.0000.

Building the STP topology is a multistep convergence process:


• A Root Bridge is elected
• Root ports are identified
• Designated ports are identified
• Ports are placed in a blocking state as required, to eliminate loops.

Root Bridge:
which is the central reference point for the STP topology is elected based on
its Bridge ID, comprised of two components in the original 802.1D standard:
• 16-bit Bridge priority
• 48-bit MAC address

the lowest priority wins. If there is a tie in priority, the lowest MAC address is
used as the tie-breaker.

66 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Consider the following example:

 SwitchB, SwitchC, and SwitchE have the default priority of 32,768.

 SwitchA and SwitchD are tied with a lower priority of 100.

 SwitchA has the lowest MAC address, and will be elected the Root
Bridge.

By default, a switch will always believe it is the Root Bridge, until it


receives a BPDU from a switch with a lower Bridge ID. This is referred
to as a superior BPDU.

The second step in the STP convergence process is to identify root


ports. The root port of each switch has the lowest root path cost to get
to the Root Bridge.

67 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Consider the following example:

 SwitchA has a cumulative path cost of 0, because it is the Root Bridge.

 SwitchB has two paths to the Root Bridge:


- A direct connection to SwitchA, with a path cost of 4.
- Another path through SwitchD, with a path cost of 16.

 SwitchD also has two paths to the Root Bridge:


- A path through SwitchB, with a path cost of 8.
- A path through SwitchE, with a path cost of 12

the port to switch is preferred and will become the root port .

68 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

The third step in the STP convergence process is to identify designated


ports. A single designated port is identified for each network segment.
Similar to a root port, the designated port is determined by the lowest
cumulative path cost leading the Root Bridge.

If two ports are eligible to become the designated port, then there is a
loop. One of the ports will be placed in a blocking state to eliminate the
loop.
Note: A port can never be both a designated port and a root port.
Consider the following example:

69 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Port ID:

When electing root and designated ports, it is possible to have a tie in both
path cost and Bridge ID. Consider the following example: The bandwidth of
both links is equal, thus both ports on SwitchB have an equal path cost to the
Root Bridge. Which port will become the root port then? Normally, the lowest
Bridge ID is used as the tiebreaker, but that is not possible in this
circumstance.
Port ID is used as the final tiebreaker, and consists of two components:
• 4-bit port priority
• 12-bit port number, derived from the physical port number

Versions of STP
There are three flavors of the original 802.1D version of STP:
• Common Spanning Tree (CST)
• Per-VLAN Spanning Tree (PVST)
• Per-VLAN Spanning Tree Plus (PVST+)

CST utilizes a single STP instance for all VLANs, and is sometimes referred
to as mono spanning tree. All CST BPDU’s are sent over the native VLAN on
a trunk port, and thus are untagged. PVST employs a separate STP instance
for each VLAN, improving flexibility and performance. PVST requires trunk
ports to use ISL encapsulation. PVST and CST are not compatible. The
enhanced PVST+ is compatible with both CST and PVST, and supports both
ISL and 802.1Q encapsulation. PVST+ is the default mode on many Cisco
platforms.

STP has continued to evolve over time. Modern extensions of STP will be
covered later in this guide:
• Rapid Spanning Tree Protocol (RSTP)

• Multiple Spanning Tree (MST)

70 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Basic STP Configuration

STP is enabled by default on all Cisco switches, for all VLANs and ports.
PVST+ is the default STP mode on most modern Cisco platforms, allowing
each VLAN to run a separate STP instance.
STP can be disabled. This should be done with caution - any switching loop
will result in a broadcast storm.

To disable STP for an entire VLAN:


Switch(config)# no spanning-tree vlan 101

A range of VLANs can be specified:


Switch(config)# no spanning-tree vlan 1 – 4094

STP can also be disabled on a per-port basis, for a specific VLAN:


Switch(config)# interface gi2/23
Switch(config-if)# no spanning-tree vlan 101

The switch with the lowest Bridge ID is elected as the Root Bridge. The
priority can be adjusted from its default of 32,768, to increase the likelihood
that a switch is elected as the Root Bridge.
Priority can be configured on a per-VLAN basis. Remember that the priority
must be in multiples of 4,096 when extended system IDs are enabled:
SwitchA(config)# spanning-tree vlan 101 priority 8192

A switch can be indirectly forced to become the Root Bridge for a specific
VLAN:
SwitchA(config)# spanning-tree vlan 101 root primary

The root primary parameter automatically lowers the priority to 24,576. If


another switch has a priority lower than 24,576, the priority will be lowered
to 4,096 less than the current Root Bridge.

71 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

STP does not technically support a backup Root Bridge. However, the root
secondary command can increase the likelihood that a specified switch will
succeed as the new Root Bridge in the event of a failure:
SwitchB(config)# spanning-tree vlan 101 root secondary

-tree vlan 101 root secondary

72 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

STP Port States

As STP converges the switching topology, a switch port will progress


through a series of states:

 Blocking

 Listening

 Learning

 Forwarding

Initially, a switch port will start in a blocking state:


-A blocking port will not forward frames or learn MAC addresses.
-A blocking port will still listen for BPDUs from other switches, to
learn about changes to the switching topology.

A port will then transition from a blocking to a listening state:


-The switch must believe that the port will not be shut down to
eliminate a loop. In other words, the port may become a root or
designated port.
-A listening port will not forward frames or learn MAC addresses.
-A listening port will send and listen for BPDUs, to participate in the
election of the Root Bridge, root ports, and designated ports.
-If a listening port is not elected as a root or a designated Port, it will
transition back to a blocking state.

73 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

If a listening port is elected as a root or designated port, it will transition to a


learning state:
-A port must wait a brief period of time, referred to as the forward
delay, before transitioning from a listening to learning state.
-A learning port will continue to send and listen for BPDUs.
-A learning port will begin to add MAC addresses to the CAM table.
-However, a learning port cannot forward frames quite yet.

Finally, a learning port will transition to a forwarding state:


-A port must wait another forward delay before transitioning from
learning to forwarding.
-A forwarding port is fully functional – it will send and listen for
BPDUs, learn MAC addresses, and forward frames.
-Root and designated ports will eventually transition to a forwarding
state.

Technically, there is a fifth port state – disabled. A port in a disabled state


has been administratively shutdown. A disabled port does not forward
frames or participate in STP convergence.
Why does a port start in a blocking state? STP must initially assume that a
loop exists. A broadcast storm can form in seconds, and requires physical
intervention to stop.

Thus, STP will always take a proactive approach. Starting in a blocking state
allows STP to complete its convergence process before any traffic is
forwarded. In perfect STP operation, a broadcast storm should never occur.

74 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

- To view the current state of a port:

STP Timers

Switches running STP exchange BPDUs to build and converge the topology
database. There are three timers that are crucial to the STP process:

-Hello timer

-Forward delay timer

-Max Age timer

75 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

The hello timer determines how often switches send BPDUs.

By default, BPDUs are sent every 2 seconds.

The forward delay timer determines how long a port must spend in both a
learning and listening state:
-Introducing this delay period ensures that STP will have enough time
to detect and eliminate loops.
-By default, the forward delay is 15 seconds.
-Because a port must transition through two forward delays, the total
delay time is 30 seconds.

The max age timer indicates how long a switch will retain BPDU
information from a neighbor switch, before discarding it:
-Remember that BPDUs are sent every two seconds.
-If a switch fails to receive a BPDU from a neighboring switch for the
max age period, it will assume there was a change in the switching
topology.
-STP will then purge that neighbor’s BPDU information.
-By default, the max age timer is 20 seconds.

Timer values can be adjusted. However, this is rarely necessary, and can
negatively impact STP performance and reliability.
Timers must be changed on the Root Bridge. The Root Bridge will
propagate the new timer values to all switches using BPDUs. Non-root
switches will ignore their locally configured timer values.

To manually adjust the three STP timers for a specific VLAN:


Switch(config)# spanning-tree vlan 101 hello-time 10
Switch(config)# spanning-tree vlan 101 forward-time 20
Switch(config)# spanning-tree vlan 101 max-age 40
The timer values are measured in seconds, and the above represents the
maximum possible value for each timer.

76 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

- Improving STP Convergence

In many environments, a 30 second outage for every topology change is


unacceptable. Cisco developed three proprietary features that improve STP
convergence time:

 PortFast

 UplinkFast

 BackboneFast
Each feature will be covered in detail in the following sections.

- PortFast

By default, all ports on a switch participate in the STP topology. This


includes any port that connects to a host, such as a workstation. In most
circumstances, a host represents no risk of a loop.

The host port will transition through the normal STP states, including
waiting two forward delay times. Thus, a host will be without network
connectivity for a minimum of 30 seconds when first powered on.

This is not ideal for a couple reasons:

 Users will be annoyed by the brief outage.

 A host will often request an IP address through DHCP during bootup.


If the switch port is not forwarding quickly enough, the DHCP
request may fail.

 Devices that boot from network may fail as well.

PortFast allows a switch port to bypass the usual progression of STP


states.

77 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

The port will instead transition from a blocking to a forwarding state


immediately, eliminating the typical 30 second delay.
PortFast should only be enabled on ports connected to a host. If
enabled on a port connecting to a switch or hub, any loop may result in
a broadcast storm.

Note: PortFast does not disable STP on a port - it merely accelerates


STP convergence. If a PortFast-enabled port receives a BPDU, it will
transition through the normal process of STP states.

PortFast provides an additional benefit. Remember that a switch will


generate a TCN if a port transitions to a forwarding or blocked state.
This is true even if the port connects to a host device, such as a
workstation.
Thus, powering on or off a workstation will cause TCNs to reach the
Root Bridge, which will send out configuration BPDUs in response.
Because the switching topology did not technically change, no
outage will occur.

78 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

However, all switches will reduce the CAM aging timer to 15


seconds, thus purging MAC addresses from the table very quickly.
This will increase frame flooding and reduce the efficiency and
performance. PortFast eliminates this unnecessary BPDU traffic
and frame flooding. A TCN will not be generated for state changes
on a Port Fast-enabled port. Portfast is disabled by default.

To enable PortFast on a switch port:


SwitchD(config)# int gi1/14
SwitchD(config-if)# spanning-tree portfast

PortFast can also be globally enabled for all interfaces:


SwitchD(config)# spanning-tree portfast default

- UplinkFast
Often, a switch will have multiple uplinks to another upstream switch:

If the links are not bundled using an EtherChannel, at least one of the ports
will transition to a blocking state to eliminate the loop.

In the above example, port gi2/24 was placed into a blocking state on
SwitchB.
Normally, if the root port fails on the local switch, STP will need to perform
a recalculation to transition the other port out of a blocking state. At a
minimum, this process will take 30 seconds.

79 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

UplinkFast allows a blocking port to be held in a standby state. If the root


port fails, the blocking port can immediately transition to a forwarding state.
Thus, UplinkFast improves convergence time for direct failures in the STP
topology.
If multiple ports are in a blocking state, whichever port has the lowest root
path cost will transition to forwarding.

UplinkFast is disabled by default, and must be enabled globally for all


VLANs on the switch:
Switch(config)# spanning-tree uplinkfast

UplinkFast functions by tracking all possible links to the Root Bridge. Thus,
UplinkFast is not supported on the Root Bridge. In fact, enabling this
feature will automatically increase a switch’s bridge priority to 49,152.
UplinkFast is intended for the furthest downstream switches in the STP
topology.

- BackboneFast
UplinkFast provides faster convergence if a directly-connected port fails. In
contrast, BackboneFast provides improved convergence if there is an
indirect failure in the STP topology.

80 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

If the link between SwitchB and SwitchA fails, SwitchD will eventually
recalculate a path through SwitchE to reach the Root Bridge. However,
SwitchD must wait the max age timer before purging SwitchB’s superior
BPDU information. By default, this is 20 seconds.

BackboneFast allows a switch to bypass the max age timer. The switch will
accept SwitchE’s inferior BPDU’s immediately. The blocked port on
SwitchE must still transition to a forwarding state. Thus, BackboneFast
essentially reduces total convergence time from 50 seconds to 30 seconds for
an indirect failure.

This is accomplished by sending out Root Link Queries (RLQs). The Root
Bridge will respond to these queries with a RLQ Reply:

 If a RLQ Reply is received on a root port, the switch knows that the
root path is stable.

 If a RLQ Reply is received on a non-root port, the switch knows that


the root path has failed. The max age timer is immediately expired to
allow a new root port to be elected.

BackboneFast is a global command, and should be enabled on every


switch:
Switch(config)# spanning-tree backbonefast

81 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Troubleshoot

Troubleshoot a Failure

Unfortunately, there is no systematic procedure to troubleshoot an STP issue.


However, this section sums up some of the actions that are available. Most of
the steps in this section apply to the troubleshooting of bridging loops in
general. We can use a more conventional approach to identify other failures
of the STP that lead to a loss of connectivity. For example, we can explore the
path that the traffic that experiences a problem takes.

Note: Most of these troubleshooting steps assume connectivity to the different


devices of the bridge network. This connectivity means you having a console
access.

Use the Diagram of the Network

Before we troubleshoot a bridging loop, we need to know these items, at


minimum:

 The topology of the bridge network

 The location of the root bridge

 The location of the blocked ports and the redundant links

This knowledge is essential for at least these two reasons:

 In order to know what to fix in the network, we need to know how the
network looks when it works correctly.

 Most of the troubleshooting steps simply use show commands to try


to identify error conditions. Knowledge of the network helps us focus
on the critical ports on the key devices.

82 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Identify a Bridging Loop

It used to be that a broadcast storm could have a disastrous effect on the


network. Today, with high-speed links and devices that provide switching at
the hardware level, it is not likely that a single host, for example, a server,
brings down a network through broadcasts. The best way to identify a bridging
loop is to capture the traffic on a saturated link and check that you see similar
packets multiple times. Realistically, however, if all users in a certain bridge
domain have connectivity issues at the same time, we can already suspect a
bridging loop.

On the Catalyst switches that run CatOS, we can easily check the overall
backplane usage with the show system command. The command provides
the current usage of the switch backplane and also specifies the peak usage
and date of peak usage. An unusual peak utilization shows us whether there
has ever been a bridging loop on this device.

Log STP Events on Devices That Host Blocked Ports

If we cannot precisely identify the source of the problem, or if the problem is


transient, enable the logging of STP events on the bridges and switches of the
network that experiences the failure. If we want to limit the number of devices
to configure, at least enable this logging on devices that host blocked ports;
the transition of a blocked port is what creates a loop.

83 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Debug spanning-tree

 Cisco IOS Software-Issue the exec command debug spanning-tree


events to enable STP debug information. Issue the general config
mode command logging buffered to capture this debug information in
the device buffers.

84 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Show spanning-tree

 Cisco IOS Software-In Cisco IOS Software Release 12.0 or later,


output of the show spanning-tree bridge-group # command has
a BPDU field. The field shows you the number of BPDUs received for
each interface. Issue the command an additional one or two times to
determine if the device receives BPDUs.

85 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Show spanning-tree summary totals

 Issue the show spanning-tree summary totals command for


switches that run Cisco IOS Software. These commands display the
number of logical ports or interfaces per VLAN in the STP
Active column.

86 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Chapter6:
Conclusion
Finally we made the network and we can divide the network to 4 main
sections:

1- We decided that we will use packet tracer then transfer the design to

GNS3 & VMware to emulate and test the network.

2- EtherChannel: we designed and used it then configured it after that we


tested it to make sure that all configurations work.

3- Load-Balancing & redundancy: we designed the network and setup GLBP


protocol to make the campus network load-balanced and available all time
then we tested it to be sure that the network working correctly.

4- STP: Finally we use this protocol to ensure that we do not create loops
when we have redundant paths in our network. Loops are deadly to a
network.

87 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

This is the final network

88 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

Appendices
Value Description

IP Internet Protocol version 4

STP Spanning Tree protocol

BPDU Bridge Protocol Data Unit

PAgP Port Aggregation Protocol

LACP Link Aggregation Control


Protocol

BPDU Bridge Protocol Data Units

RSTP Rapid Spanning Tree Protocol

MST Multiple Spanning Tree

GLBP Gateway Load Balancing Protocol

VRRP Virtual Router Redundancy


Protocol

HSRP Hot Standby Router Protocol

VLAN virtual LAN

MAC address Media Access Control address

ISL Inter-Switch Link

89 | P a g e
Comm. & Computer Engineering Program, 29 March 2021
Design of Campus Communication Network

References
 https://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/
ft_glbp.html#wp1048594

 https://www.cisco.com/c/en/us/support/docs/lan-
switching/spanning-tree-protocol/5234-5.html

 https://www.cisco.com/en/US/docs/ios/12_2/switch/configuration/g
uide/xcfmsc_external_docbase_0900e4b180753c28_4container_ext
ernal_docbase_0900e4b18088695e.html

 https://www.cisco.com/c/en/us/support/docs/lan-
switching/etherchannel/12023-4.html

 Books About : -Redundancy and Load Balancing

- Spanning Tree Protocol

- EtherChannel

-Multilayer Switching

From: http://www.routeralley.com. By Aaron Balchunas.

90 | P a g e
Comm. & Computer Engineering Program, 29 March 2021

View publication stats

You might also like