Access Control Lists: Security
Access Control Lists: Security
Security
● The original use of ACLs was as a security feature to decide if traffic should
be allowed to pass through the router
● By default a router will allow all traffic to pass between its interfaces
● When ACLs are applied the router identifies traffic and then decides if it will be
allowed or not
● ACL’s are also used in other software policies when traffic has to be identified,
for example:
○ Identify traffic to give better service to in a QoS Quality of Service
policy
○ Identify traffic to translate to a different IP address in a NAT Network
Address Translation policy
● Access Control Lists are made up of Access Control Entries which are a
series of permit or deny rules
● Each ACE is written in a separate line
Extended
R1(config)# access-list 100 deny tcp 10.10.10.10 0.0.0.0
gt 49151 10.10.50.10 0.0.0.0 eq 23
R1(config)# access-list 100 permit tcp 10.10.10.0
0.0.0.255 gt 49151 10.10.50.10 0.0.0.0 eq telnet
Named ACLs
● You can now reference ACLs by number or by a name
● Named ACLs begin with the command ‘ip access-list’ instead of ‘access-list
R1(config)#ip access-list standard Flackbox-Demo
R1(config-std-nacl)#deny 10.10.10.10 0.0.0.0
R1(config-std-nacl)#permit 10.10.10.0 0.0.0.255
ACL Syntax
ACL Operations/Groups
● ACLs are applied at the interface level with the Access-Group command
● ACLs can be applied in the inbound or outbound direction
● You can have a maximum of one ACL per interface per direction
● You can have both an inbound and an outbound ACL on the same interface,
but not 2 inbound or outbound ACLs
● An interface can have no ACL applied, an inbound ACL only, an outbound
ACL only, or ACLs in both directions
Access-Group Configuration
R1(config)# interface GigabitEthernet0/1
R1(config-if)# ip access-group 100 out
R1(config-if)# ip access-group 101 in
This will deny 10.10.10.10 but permit the rest of the 10.10.10.0/24 subnet
R1(config)# access-list 1 deny host 10.10.10.10
R1(config)# access-list 1 permit 10.10.10.0 0.0.0.255
This will permit all of the 10.10.10.0/24 subnet including 10.10.10.10
R1(config)# access-list 1 permit 10.10.10.0 0.0.0.255
R1(config)# access-list 1 deny host 10.10.10.10
Support for injecting ACEs in an existing ACL started in Named ACLs but is
also supported in Numbered ACLs now