MP LDP Sessn Prot
MP LDP Sessn Prot
The MPLS LDP Session Protection feature provides faster Label Distribution Protocol (LDP) convergence
when a link recovers following an outage. MPLS LDP Session Protection protects an LDP session between
directly connected neighbors or an LDP session established for a traffic engineering (TE) tunnel.
issue the duration keyword to specify the number of seconds that the LDP Targeted Hello Adjacency is
retained after the loss of the LDP Link Hello Adjacency. When the link is lost, a timer starts. If the timer
expires, the LDP Targeted Hello Adjacency is removed.
1. enable
2. configure terminal
3. ip cef [distributed]
4. interface loopback number
5. ip address prefix mask
6. exit
7. interface type number
8. mpls ip
9. mpls label protocol [ldp | tdp | both]
10. exit
11. mpls ldp session protection [vrf vpn-name] [for acl] [duration {infinite | seconds}]
12. exit
DETAILED STEPS
Example:
Device# configure terminal
Step 3 ip cef [distributed] Configures distributed Cisco Express Forwarding or Cisco Express
Forwarding.
Example:
Device(config)# ip cef distributed
Step 4 interface loopback number Configures a loopback interface and enters interface configuration
mode.
Example:
Device(config)# interface Loopback 0
Example:
Device(config-if)# ip address
10.25.0.11 255.255.255.255
Example:
Device(config-if) exit
Step 7 interface type number Specifies the interface to configure and enters interface configuration
mode.
Example:
Device(config)# interface POS 0/3/0
Step 8 mpls ip Configures MPLS hop-by-hop forwarding for the specified interface.
Example:
Device(config-if)# mpls ip
Step 9 mpls label protocol [ldp | tdp | both] Configures the use of LDP on a specific interface or on all interfaces.
Example:
Device(config-if)# exit
Step 11 mpls ldp session protection [vrf vpn-name] Enables MPLS LDP session protection.
[for acl] [duration {infinite | seconds}]
• The vrf vpn-name keyword and argument protects Label
Distribution Protocol (LDP) sessions for a specified virtual routing
Example: and forwarding (VRF) interface.
Device(config)# mpls ldp session
protection • The for acl keyword and argument specifies a standard IP access
control list (ACL) of prefixes to be protected.
• The duration keyword specifies how long the device should
retain the LDP Targeted Hello Adjacency following the loss of
the LDP Link Hello Adjacency.
• The infinite keyword specifies that the LDP Targeted Hello
Adjacency should be retained forever after a link is lost.
• The seconds argument specifies the time in seconds that the LDP
Targeted Hello Adjacency should be retained after a link is lost.
The range is 30 to 2,147,483 seconds.
Example:
Device(config)# exit
Troubleshooting Tips
Use the clear mpls ldp neighbor command if you need to terminate a Label Distribution Protocol (LDP)
session after a link goes down. This is useful for situations where the link needs to be taken out of service or
needs to be connected to a different neighbor.
To enable the display of events related to MPLS LDP Session Protection, use the debug mpls ldp session
protection command.
1. enable
2. show mpls ldp discovery
3. show mpls ldp neighbor
4. show mpls ldp neighbor detail
5. exit
DETAILED STEPS
Step 1 enable
Enables privileged EXEC mode. Enter your password, if prompted.
Example:
Device> enable
Device#
Example:
Device# show mpls ldp discovery
Example:
Device# show mpls ldp neighbor
Verifies that the MPLS LDP Session Protection state is Ready or Protecting. If the second last line of the output shows
Incomplete, the Targeted Hello Adjacency is not up yet.
Example:
Device# show mpls ldp neighbor detail
Step 5 exit
Returns to user EXEC mode.
Example:
Device# exit
Device>
The following configuration examples for R1, R2, and R3 are based on the figure above.
R1
redundancy
no keepalive-enable
mode hsa
!
ip cef distributed
no ip domain-lookup
multilink bundle-name both
mpls label protocol ldp
mpls ldp session protection
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Multilink4
no ip address
no ip directed-broadcast
no ip mroute-cache
load-interval 30
ppp multilink
multilink-group 4
!
interface FastEthernet1/0/0
ip address 10.3.123.1 255.255.0.0
no ip directed-broadcast
!
interface FastEthernet2/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet2/0/1
description -- ip address 10.0.0.2 255.255.255.0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet2/0/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/1/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/2/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
redistribute connected
network 10.0.0.1 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
ip classless
R2
redundancy
no keepalive-enable
mode hsa
!
ip subnet-zero
ip cef distributed
mpls label protocol ldp
mpls ldp session protection
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
no ip directed-broadcast
!
interface FastEthernet0/1/0
no ip address
no ip directed-broadcast
shutdown
full-duplex
!
interface FastEthernet0/1/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
full-duplex
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1/1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
ip load-sharing per-packet
full-duplex
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/2/0
ip address 10.3.123.112 255.255.0.0
no ip directed-broadcast
!
router ospf 100
log-adjacency-changes
redistribute connected
network 10.0.0.3 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
ip classless
R3
ip cef distributed
no ip domain-lookup
mpls label range 200 100000 static 16 199
mpls label protocol ldp
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 10.0.0.5 255.255.255.255
no ip directed-broadcast
!
interface FastEthernet1/0/0
no ip address
no ip directed-broadcast
shutdown
half-duplex
!
interface FastEthernet1/2/0
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
full-duplex
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/3/0
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
full-duplex
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
redistribute connected
network 10.0.0.5 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
ip classless
Additional References
Related Documents
MPLS LDP IGP synchronization “MPLS LDP IGP Synchronization” module in the
MPLS Label Distribution Protocol Configuration
Guide
MIBs
RFCs
RFCs Title
RFC 3036 LDP Specification
Technical Assistance
Description Link
The Cisco Support and Documentation website http://www.cisco.com/cisco/web/support/index.html
provides online resources to download documentation,
software, and tools. Use these resources to install and
configure the software and to troubleshoot and resolve
technical issues with Cisco products and technologies.
Access to most tools on the Cisco Support and
Documentation website requires a Cisco.com user ID
and password.