Programs Input Class9
Programs Input Class9
CLASS IX
SOLVED PROGRAMS
CHAPTER-INPUT
Program 1. A shopkeeper offers 30% discount on purchasing articles whereas the other
shopkeeper offers two successive discounts 20% and 10% for purchasing the same
articles. Write a program in Java to compute and display the discounts.
Take the price of an article as the input.
import java.util.*;
import java.util.*;
import java.util.*;
public class Pendulum_scan
{
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
System.out.print("Enter length: ");
double l = in.nextDouble();
System.out.print("Enter g ");
double g = in.nextDouble();
double t = 2 * (22.0 / 7.0) * Math.sqrt(l/g);
System.out.println("T = " + t); }}
Program 4. Write a program by using class 'Employee' to accept Basic Pay of an
employee.
Calculate the allowances/deductions as given below.
import java.util.*;
public class Compound_Interest{
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
System.out.print("Enter sum of money: ");
double p = in.nextDouble();
double interest = p * 5 * 1 / 100.0;
System.out.println("Interest for the first year = " + interest);
p =p+ interest;
interest = p * 5 * 1 / 100.0;
System.out.println("Interest for the second year = " + interest);
p =p+ interest;
interest = p * 5 * 1 / 100.0;
System.out.println("Interest for the third year = " + interest);
}
}
Program 6. A businessman wishes to accumulate 3000 shares of a company. However,
he already has some shares of that company valuing ₹10 (nominal value) which yield
10% dividend per annum and receive ₹2000 as dividend at the end of the year. Write a
program in Java to calculate the number of shares he has and how many more shares
to be purchased to make his target.
Hint: No. of share = (Annual dividend * 100) / (Nominal value * div %)
public class Shares_Divident
{
public static void main(String args[]) {
int s_held = (2000 * 100)/(10 * 10);
System.out.println("No. of shares held currently = " + s_held);
int s_required = 3000 - s_held;
System.out.println("No. of shares to purchase = " + s_required);
}
}
Program 7. Write a program to input the time in seconds. Display the time after
converting them into hours, minutes and seconds.
Sample Input: Time in seconds 5420
Sample Output: 1 Hour 30 Minutes 20 Seconds
Program 8. A shopkeeper sells two calculators for the same price. He earns 20% profit
on one and suffers a loss of 20% on the other. Write a program to find his total cost
price of the calculators by taking selling price as input.
Hint: CP = (SP / (1 + (profit / 100))) (when profit)
CP = (SP / (1 - (loss / 100))) (when loss)
import java.util.*;
Program 9. A certain amount is invested at the rate 10% per annum for 3 years.
Find the difference between Compound Interest (CI) and Simple Interest (SI).
Write a program to take amount as an input.
Hint: SI = (P * R * T) / 100
A = P * (1 + (R/100))T
CI = A - P
import java.util.*;
public class SI_CI
{
public static void main(String args[])
{
Scanner in = new Scanner(System.in);
System.out.print("Enter Amount: ");
double p = in.nextDouble();
double si = p * 10 * 3 / 100;
double ciAmt = p * Math.pow(1 + (10/100.0), 3);
System.out.print("Difference between CI & SI: " +ciAmt);
double ci = ciAmt - p;
System.out.print("Difference between CI & SI: " + (ci - si));
}
}
Program 10. Write a program to input two unequal numbers. Display the numbers
after swapping their values in the variables without using a third variable.
Sample Input: a = 23, b = 56
Sample Output: a = 56, b = 23
class Swap
{
public static void main(String args[])
{
int a=23,b=56;
a =a+ b;
b = a - b;
a =a- b;
System.out.println("a = " + a + ", b = " + b);
}
}
Program 11. Write a program to input two unequal numbers. Display the numbers
after swapping their values in the variables using a third variable.
Sample Input: a = 23, b = 56
Sample Output: a = 56, b = 23
class Swap1
{
public static void main(String args[])
{
int a=23,b=56,t=0;
t=a;
a=b;
b=t;
System.out.println("a = " + a + ", b = " + b);
}
}