Cellular Interface Modules
Cellular Interface Modules
This chapter provides configuration details for the cellular interface modules used in the IR807 routers.
Cellular Interface
The IR807 routers use the Sierra Wireless WP7601 and WP750X series modems supporting Single Input Multiple Output
(SIMO) on LTE.
SIMO is an antenna technology for wireless communications in which multiple antennas are used at the destination
(receiver). The antennas are combined to minimize errors and optimize data speed. The source (transmitter) has only
one antenna. SIMO is one of several forms of smart antenna technology, the others being MIMO (multiple input, multiple
output) and MISO (multiple input, single output)
Installation of the SIM card(s) and antennas is covered in the IR807 Hardware Installation Guide under the Cisco 800
Series Industrial Integrated Services Routers page:
http://www.cisco.com/c/en/us/support/routers/800-series-industrial-routers/tsd-products-support-series-home.html
https://software.cisco.com/download/navigator.html?mdfid=286288566&flowid=76082
The Firmware Upgrade Guide for Cellular Modems can be found here:
http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/firmware/Firmware_Upgrade.html
http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/software/feature/guide/EHWIC-4G-LTESW.html
After installing the SIM card(s) and antennas, check the cellular hardware, radio, network and SIM (Unlock SIM card if
necessary).
27
Cellular Interface Modules
Cellular Interface
A fail over mechanism in the event the primary SIM loses connectivity to one of the Mobile Service Provider networks.
There is no automatic fall-back to the primary SIM, since a change only occurs when there is no signal from the
carrier in use. A script is needed to reverse back to the primary. Both mobile provider networks must be supported
by the given IR807 SKU, and it must be in an applicable region.
— By default, SIM slot 0 is the primary, and SIM slot1 is the backup. Behavior may be changed using the lte sim
primary command.
— Profiles for each SIM are assigned by using the lte sim profile command. Each SIM has an associated Internet
profile and an IMS profile in the CLI.
— The fail-overs happen when there is no signal from the current carrier, and generally happen depending on the
fail-over timer value that is set. The default value is 2 minutes. The range is from 0-7 minutes.
Radio Configuration
The following examples are of an IR807 cellular configuration:
IR807> enable
IR807# show ip int brief
Interface IP-Address OK? Method Status Protocol
Async0 unassigned YES unset up down
Async1 unassigned YES unset up down
Cellular0 166.140.43.237 YES IPCP up up Single APN
Cellular1 10.61.25.231 YES IPCP up up Multi APN
FastEthernet0 10.65.217.109 YES TFTP administratively down down
FastEthernet1 unassigned YES unset administratively down down
The output of this running configuration example has been edited for brevity:
28
Cellular Interface Modules
Cellular Interface
29
Cellular Interface Modules
Cellular Interface
30
Cellular Interface Modules
Cellular Interface
no logging trap
logging facility local2
dialer watch-list 1 ip 8.8.8.8 0.0.0.0
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
!
access-list 1 permit 0.0.0.0 252.255.255.255
!
!
!
control-plane
!
!
!
no vstack
banner login
==============================================================================
Test
==============================================================================
!
line con 0
exec-timeout 5 0
logging synchronous
login authentication local_auth
transport output telnet
line 2
exec-timeout 5 0
privilege level 0
no activation-character
no exec
transport preferred none
transport input all
transport output none
stopbits 1
line 3
exec-timeout 5 0
script dialer lte
modem InOut
no exec
rxspeed 100000000
txspeed 50000000
line 4
exec-timeout 5 0
privilege level 0
no exec
transport output none
line 5
exec-timeout 5 0
privilege level 0
no exec
transport output none
stopbits 1
line 8
exec-timeout 5 0
privilege level 0
no exec
transport output none
rxspeed 100000000
txspeed 50000000
31
Cellular Interface Modules
Cellular Interface
line vty 0 4
exec-timeout 15 0
login authentication local_auth
transport input telnet ssh
transport output none
!
exception memory ignore overflow processor
exception memory ignore overflow io
scheduler allocate 20000 1000
!
end
Verizon Profile
IR807# show cellular 0 profile
Profile 1 = INACTIVE **
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwims
Authentication = None
Profile 2 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwadmin
Authentication = None
Profile 4 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwapp
Authentication = None
Profile 5 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzw800
Authentication = None
Profile 6 = INACTIVE
32
Cellular Interface Modules
Cellular Interface
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwenterprise
Authentication = None
* - Default profile
** - LTE attach profile
AT&T Profile
IR807# show cellular 0 profile
Profile 1 = ACTIVE* **
--------
PDP Type = IPv4
PDP address = 192.168.1.51
Access Point Name (APN) = keysight
Authentication = None
Primary DNS address = 0.0.0.0
Secondary DNS address = 0.0.0.0
* - Default profile
** - LTE attach profile
* - Default profile
** - LTE attach profile
Sprint Profile
IR807#show cellular 0 profile
Profile 1 = INACTIVE* **
--------
PDP Type = IPv4v6
Access Point Name (APN) = otasn
Authentication = None
Profile 9 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = cinet.spcs
Authentication = None
Profile 16 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = otasn
Authentication = None
* - Default profile
** - LTE attach profile
Generic Profile
Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = keysight
Authentication = None
* - Default profile
** - LTE attach profile
Use the show cellular hardware command to view information about your device.
33
Cellular Interface Modules
Cellular Interface
IR807#conf
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
IR807(config)#controller cellular 0
IR807(config-controller)#
IR807(config-controller)#lte sim data-profile 1 attach-profile 1 slot 0
IR807#sh cellular 0 profile
Profile 1 = ACTIVE* **
--------
PDP Type = IPv4
PDP address = 192.168.1.51
Access Point Name (APN) = keysight
Authentication = None
Primary DNS address = 0.0.0.0
Secondary DNS address = 0.0.0.0
Profile 2 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = keysight2
Authentication = None
Profile 3 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = keysight
Authentication = None
* - Default profile
** - LTE attach profile
34
Cellular Interface Modules
Cellular Interface
Profile 3 already exists with above parameters. Do you want to overwrite? [confirm] <return>
IR807# conf t
Enter configuration commands, one per line. End with CNTL/Z.
IR807(config)# controller cellular 0
IR807(config-controller)# lte sim data-profile 3 attach-profile 1
IR807(config-controller)# end
IR807#
IR807# show
*Oct 24 19:43:44.841: %SYS-5-CONFIG_I: Configured from console by consolecell
IR807# show cellular 1/0 profile
Profile 1 = ACTIVE* **
--------
PDP Type = IPv4
PDP address = 10.61.185.213
Access Point Name (APN) = m2m.com.attz
Authentication = None
Primary DNS address = 8.8.8.8
Secondary DNS address = 8.8.4.4
* - Default profile
** - LTE attach profile
Profile 1 already exists with above parameters. Do you want to overwrite? [confirm] <return>
35
Cellular Interface Modules
Cellular Interface
IR807# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Note: Please issue a modem reset for the modified attach-profile to take effect.
IR807(config-controller)# end
IR807#
If the SIM in slot #1 must be used as primary, it is done under controller cellular 0
2. If the cellular interface obtains an IPv4 private address, NAT should be configured.
IR807#conf term
Enter configuration commands, one per line. End with CNTL/Z.
IR807(config)#inter cellular 0
IR807(config-if)#ip nat outside
IR807(config-if)interface fastethernet 0
IR807(config-if)ip nat inside
IR807(config-if) ip virtual-reassembly in
IR807(config)#access-list 10 permit 10.20.20.0 0.0.0.255! IPv4 subnet to be NATed
IR807(config)#ip nat inside source list 10 interface Cellular0 overload !NAT interface association
3. Once the Cellular configuration is done, ping a well-known IP address to test the connectivity.
IR807#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 340/472/740 ms
IR807#
36
Cellular Interface Modules
Cellular Interface
4. Attached Cellular 0 profile must become “active” and “connection” shows IP address and traffic.
What to do Next
Use the show interface cellular 0 command to display the negotiated IP address if operational.
37
Cellular Interface Modules
Cellular Interface
38
Cellular Interface Modules
Cellular Interface
Cell ID = 222094374
IR807#
Profile Information
====================
Profile 1 = ACTIVE* **
--------
PDP Type = IPv4
PDP address = 192.168.1.51
Access Point Name (APN) = keysight
Authentication = None
Primary DNS address = 0.0.0.0
Secondary DNS address = 0.0.0.0
Profile 2 = ACTIVE
--------
PDP Type = IPv4
PDP address = 192.168.1.54
39
Cellular Interface Modules
Cellular Interface
Profile 3 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = keysight
Authentication = None
* - Default profile
** - LTE attach profile
Network Information
===================
Current System Time = Mon Apr 3 23:39:5 2000
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Network = Test PLMN 1-1
Mobile Country Code (MCC) = 1
Mobile Network Code (MNC) = 1
Packet switch doma Attached
Registration state(EMM) = Registered
EMM Sub State = Normal Service
Tracking Area Code (TAC) = 1
Cell ID = 1
Negotiated network MTU is 1430
Radio Information
=================
40
Cellular Interface Modules
Cellular Interface
GPS Information
==========================
GPS Info
-------------
GPS Feature: enabled
GPS Port Sated GPS port
GPS Status: GPS mode or nmea not enabled
GPS auto tracking status: disabled (Mode is not set)
GPS auto tracking config: disabled
GPS Mode Configured: not configured/unknown
SMS Information
===============
Incoming Message Information
----------------------------
SMS stored in modem = 0
SMS archived since booting up = 0
Total SMS deleted since booting up = 0
Storage records allocated = 25
Storage records used = 0
Number of callbacks triggered by SMS = 0
Number of successful archive since booting up = 0
Number of failed archive since booting up = 0
41
Cellular Interface Modules
Cellular Interface
Error Information
=================
Profile Information
====================
Profile password Encryption level: 7
Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = sl2sfr
Authentication = None
* - Default profile
** - LTE attach profile
42
Cellular Interface Modules
Cellular Interface
Network Information
===================
Current System Time = Wed Oct 11 8:24:34 2017
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Network = F SFR
Mobile Country Code (MCC) = 208
Mobile Network Code (MNC) = 10
Packet switch domain(PS) state = Attached
Registration state(EMM) = Registered
EMM Sub State = Normal Service
Tracking Area Code (TAC) = 46506
Cell ID = 604934
Network MTU is not Available
Radio Information
=================
Radio power mode = online
LTE Rx Channel Number = 1501
LTE Tx Channel Number = 19501
LTE Band = 3
LTE Bandwidth = 20 MHz
Current RSSI = -84 dBm
Current RSRP = -114 dBm
Current RSRQ = -13 dB
Current SNR = -1.0 dB
Physical Cell Id = 0x102
Number of nearby cells = 1
Idx PCI (Physical Cell Id)
--------------------------------
1 258
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = LTE
GPS Information
==========================
GPS Info
-------------
GPS Feature: enabled
GPS Port Selected: Dedicated GPS port
43
Cellular Interface Modules
Cellular Interface
SMS Information
===============
Incoming Message Information
----------------------------
SMS stored in modem = 6
SMS archived since booting up = 0
Total SMS deleted since booting up = 0
Storage records allocated = 25
Storage records used = 6
Number of callbacks triggered by SMS = 0
Number of successful archive since booting up = 0
Number of failed archive since booting up = 0
Error Information
=================
44
Cellular Interface Modules
Cellular Interface
IR807#show line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
A 3 TTY - inout - - - 0 0 611/0 Ce0 – Single APN
I 8 TTY - inout - - - 0 0 0/0 Ce1 – Multi APN
Use one of the IR807 IP addresses along with 2000 + line number (2003)
at!gstatus?
Current Time: 1418Temperature: 37
Bootup Time: 5Mode: ONLINE
System mode: LTE PS state: Attached
LTE band: B5 LTE bw: 10 MHz
LTE Rx chan: 2525LTE Tx chan: 20525
EMM state: Registered Normal Service
EMM connection:RRC Connected RSSI (dBm): -60Tx Power: 1
RSRP (dBm): -86TAC: 0001 (1)
RSRQ (dB): -10Cell ID: 00000001 (1)
SINR (dB): 30.0
IMS Reg State: UNKNOWN IMS Mode: Not Support
IMS Srv State: UNKNOWN SMS,UNKNOWN VoIP
IR807#disc
Closing connection to 1.1.1.1 [confirm]enter
IR807#
45
Cellular Interface Modules
46
Cellular Interface Modules
lte LTE
GA modem WP7502
IR807# cellular 0 lte technology ?
auto Automatic Radio Access Technology(RAT) Selection
gsm GSM
lte LTE
umts UMTS
Note: The default technology type selection is auto and it is recommended to be used at all times. Although gsm & umts
as part of the selection, the modem firmware does not support them on gsm/umts network. They will be used as lte
selection on Verizon network.
47
Cellular Interface Modules
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
license udi pid IR807G-LTE-NA-K9 sn FCW211700HD
license boot module ir800l level advipservices
!
!
!
redundancy
notification-timer 120000
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte modem link-recovery disable
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer string multimode
dialer-group 1
no peer default ip address
ipv6 address autoconfig
async mode interactive
routing dynamic
!
interface Cellular1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer string multimode
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface FastEthernet0
ip address 10.65.217.109 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface Async0
no ip address
encapsulation slip
hold-queue 10 out
!
interface Async1
no ip address
48
Cellular Interface Modules
encapsulation scada
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 10.0.0.0 255.0.0.0 FastEthernet0
ip route 192.168.1.51 255.255.255.255 Cellular0
ip route 192.168.1.52 255.255.255.255 Cellular1
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
dialer watch-list 1 ip 8.8.8.8 255.255.255.255
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
access-list 1 permit any
access-list 101 permit ip any any
!
control-plane
line con 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
script dialer lte
modem InOut
no exec
monitor
transport input all
transport output all
rxspeed 100000000
txspeed 50000000
line 4
line 5
stopbits 1
line 8
script dialer lte
modem InOut
no exec
monitor
transport input all
transport output all
line vty 0 3
password lab
login
transport input all
transport output all
line vty 4
password lab
login local
transport input all
transport output all
!
scheduler allocate 20000 1000
49
Cellular Interface Modules
!
end
There are three file types that will be upgraded on the WP75xx and WP76xx modems:
WP7504_1103235_07.12.09.00_00_Cisco_001.001_000.nvu
WP75xx_07.12.09.00_Legato_Yocto_MCU.spk
IR807G-LTE-GA-K9 WP7502 WP7502_1103234_07.12.09.00_00_Cisco_001.001_000.nvu
WP75xx_07.12.09.00_00_GENERIC_001.033_000.spk
WP75xx_07.12.09.00_Legato_Yocto_MCU.spk
Each of the files need to be upgraded separately. You cannot place them together in the same folder and perform
a simultaneous upgrade.
When switching from one carrier to another, only the Firmware file corresponding to the carrier needs to be
upgraded. You do not need to re-upgrade with the OEM PRI and Legato-Yocto files. For example: If using an
IR807G-LTE-NA-K9 with the ATT SIM in one slot and Sprint SIM in the other slot, simply upgrade with the firmware
corresponding to the active SIM.
https://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/firmware/Firmware_Upgrade.html#pgfId-1023076
50
Cellular Interface Modules
1. Go to the Cisco web page to download the latest certified firmware for your carrier by going to the following location:
Products -> Cisco Interfaces and Modules -> LTE Wireless WAN Interfaces.
2. Create a directory in flash to host the firmware, which will be downloaded in step 3.
4. Verify that the firmware is available on the newly created directory inside router flash by using the following
command:
5. Initiate a modem firmware upgrade using the microcode reload command. Ex : IR807# microcode reload cellular
0 lte modem-provision flash:<directory>?
*****************************************************
The interface will be Shut Down for Firmware Upgrade
This will terminate any active data connections.
*****************************************************
*Sep 4 05:55:01.570: %LINK-5-CHANGED: Interface Cellular0, changed state to reset
*Sep 4 05:55:02.570: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to
down
*Sep 4 05:55:06.570: %LINK-5-CHANGED: Interface Cellular0, changed state to administratively down
*Sep 4 05:55:11.586: %LINK-5-CHANGED: Interface Cellular1, changed state to reset
*Sep 4 05:55:12.586: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular1, changed state to
down
*Sep 4 05:55:16.586: %LINK-5-CHANGED: Interface Cellular1, changed state to administratively down
*****************************************************
Modem will be upgraded!
Upgrade process will take up to 15 minutes. During
this time the modem will be unusable.
Please do not remove power or reload the router during
the upgrade process.
51
Cellular Interface Modules
*****************************************************
Sending F/W[WP75xx_07.12.09.00_Legato_Yacto_MCU.spk] to the card [24444106 bytes]:
Firmware file: WP75xx_07.12.09.00_Legato_Yacto_MCU.spk sent to the card
Modem Device ID: WP7502 MODEM F/W Boot Version: SWI9X15Y_07.12.09.00 r34123 CARMD-EV-FRMWR1
2017/04/26 23:34:19
Modem F/W App Version: SWI9X15Y_07.12.09.00 r34123 CARMD-EV-FRMWR1 2017/04/26 23:34:19 Modem SKU
ID: 1103234
Modem Package Identifier: 1103234_9906721_WP7502_07.11.22.00_00_Cisco_001.000_000 Modem Carrier
String: 1
Modem PRI Ver: 01.00 Modem Carrier Name: GENERIC
Modem Carrier Revision: 001.033_000
IR807#
Auto-SIM is supported in Sierra wireless WP7504 modem on the IR807. The WP7502 and WP7601 modems do not
support this feature. A CLI is available in the cellular controller to enable/disable Auto-SIM. The modem in Auto-SIM
mode selects the right carrier firmware after a SIM slot switch and an automatic modem reset. During bootup, if the
Auto-SIM configuration on the modem doesn’t match to the IOS configuration, the corresponding Auto-SIM or manual
mode is pushed to the modem.
After an Auto-SIM configuration change, the modem is automatically reset; the default is “auto-sim” enabled:
controller cellular 0
[no] lte firmware auto-sim
If Auto-SIM is disabled and the modem is in manual mode, select a carrier with a new exec CLI:
Enable/Disable Auto-SIM:
52
Cellular Interface Modules
(config)#controller cellular 0
(config)# [no] lte firmware auto-sim default is auto-sim enabled
Manual mode:
controller cellular 0
no lte firmware auto-sim
The following CLI shows the firmware-index of the carrier in the modem:
Cisco 4G LTE and Cisco 4G LTE-Advanced Network Interface Module Software Configuration Guide
In Exec mode:
— The user executes the command and if the AVMS server has firmware available, then the firmware will be
download to the modem and the modem will be upgraded.
In Config mode:
— The user can configure the poll timer. Based on the poll timer value the modem will communicate with the AVMS
server. If any firmware is available to download, then that firmware will be downloaded to the modem and
upgraded. The modem will attempt to connect to the AVMS server 3 times, After 3 attempts, the modem will
not communicate to the AVMS server again, but the IOS configuration will be preserved.
53
Cellular Interface Modules
FOTA Information
==============
FOTA server poll timer (mins = Disable
FOTA server connection retry value = 0
FOTA status = Firmware downloading
Firmware size to download = 64437120 bytes
Firmware bytes downloaded = 21264384 bytes
Firmware download progress = 33 % complete
Note: In the above show cellular <interface number> radio output, the Radio power mode shows OFF because the user
has turned the radio off by choice. In all other cases, when the radio goes to Low Power mode, you will see the display
Radio power mode = low power.
The following examples show the new functionality of the configuration CLI:
Router(config-controller)#lte modem crash-action ?
boot-and-hold Remain in crash state
reset Reset the modem on crash
54
Cellular Interface Modules
This CLI will set the flag to either 1 or 0 for reset and boot and hold respectively. This is the same as AT command
at!eroption= 0 / 1
The following examples show the new functionality of the exec CLI:
router#show cellular <your interface> logs modem-crash-action
Current modem crash action: Reset
This CLI will show the current state the modem is set to. This is the same as AT command at!eroption=?.
55
Cellular Interface Modules
56