0% found this document useful (0 votes)
2K views

Case Study 3 Report

Uploaded by

Yichuan Fan
Copyright
© Attribution Non-Commercial (BY-NC)
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
2K views

Case Study 3 Report

Uploaded by

Yichuan Fan
Copyright
© Attribution Non-Commercial (BY-NC)
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 66

UTS

Case Study 3 Report


[32011]

TABLE OF CONTENTS
GROUP3: CASE STUDY 3

TOPOLOGY DIAGRAM............................................................................................................................................3

1. SCENARIO..............................................................................................................................................................3

2. REQUIREMENTS AND CONFIGURATIONS....................................................................................................4

2.1. General Tasks................................................................................................................................................4

2.1.1. Basic configuration............................................................................................................................4

2.1.2. Trunking and EtherChannels..........................................................................................................5

2.2. VLANs and VTP...........................................................................................................................................9

2.3. Spanning-Tree.............................................................................................................................................14

2.4. Inter-VLAN Routing and HSRP...............................................................................................................17

2.4.1. Inter-VLAN Routing.......................................................................................................................18

2.4.2. HSRP and IP Addressing...............................................................................................................19

2.5. Additional Requirements...........................................................................................................................24

3. VERIFICATION...................................................................................................................................................30

3.1. Ping...............................................................................................................................................................30

4. FINAL CONFIGURATION..................................................................................................................................32

4.1. ISP................................................................................................................................................................32

4.2. BACKUP......................................................................................................................................................34

4.3. DLS1.............................................................................................................................................................36

4.4. DLS2.............................................................................................................................................................43

4.5. ALS1.............................................................................................................................................................50

4.6. ALS2.............................................................................................................................................................57

5. REFERENCES........................................................................................................................................................66

CCNP3: Building Multilayer Switched Networks PAGE 2 OF 66


GROUP3: CASE STUDY 3

TOPOLOGY DIAGRAM

1. SCENARIO
Digital Technologies Inc (DTI) has a new city office. The design requires main trunks as
EtherChannels, with back up links, trunk ports and access ports using Catalyst 2960 (or 2950)
and 3560 (or 3550) switches, and 2811 series routers. Fault tolerant links are required so all
links, even those to ISP, require backup.

Staff, at the city office, are in the following subnets:

1. Corporate (Manager, Accounts, Secretaries) VLAN 10


2. Sales (Marketing, Sales, Delivery) VLAN 20
3. Servers (attached to DLS2) VLAN 30
4. Telephony VLAN 150
5. Management (For all switches) VLAN 217

Multiple Instance Spanning Tree (MST) will be used, in combination with PortFast and BPDU
guard. For load balancing, DLS1 will be root for Corporate VLAN, Sales VLAN and
Management VLAN, and DLS2 will be root for Telephony VLAN and Servers VLAN. Multiple
HSRP groups will be implemented so that DLS1 is active for VLAN 10, 20 & 217, and DLS2 is
active for VLAN 30 & 150. Backup Router will provide standby links for all VLANs.

CCNP3: Building Multilayer Switched Networks PAGE 3 OF 66


GROUP3: CASE STUDY 3

2. REQUIREMENTS AND CONFIGURATIONS


2.1. General Tasks
2.1.1. Basic configuration

Basic configuration includes the following requirements described in the case study and also
contains the command ‘logging synchronous’ on console port configuration for better
readability.

 vty support with password cisco


Routers:
Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login
Switches:
Switch(config)#line vty 0 15
Switch(config-line)#password cisco
Switch(config-line)#login

 console password cisco


Both routers and switches:
Router/Switch(config)#line console 0
Router/Switch(config-line)#password cisco
Router/Switch(config-line)#logging synchronous

 privileged EXEC mode secret cisco


Both routers and switches:
Router/Switch(config)#enable secret cisco

 All hostnames
Both routers and switches:
Router/Switch(config)#hostname ****

 Prevent bystanders from reading passwords by configuring all networks devices to


encrypt the clear text passwords.
Both routers and switches:
Router/Switch(config)#service password-encryption

CCNP3: Building Multilayer Switched Networks PAGE 4 OF 66


GROUP3: CASE STUDY 3

2.1.2. Trunking and EtherChannels

This section covers the following requirements:

 Connect all the network devices according to the network diagram. (Note: No IP
Telephones will be connected at this stage, although all configurations will assume their
presence.)

 On DL & AL Switches use ports 3 & 4 for the EtherChannels (DLS1 to ALS1 & DLS2 to
ALS2).

DLS1(config)#interface range fastEthernet 0/3 - 4


DLS1(config-if-range)#switchport trunk encapsulation dot1q
DLS1(config-if-range)#switchport mode trunk
DLS1(config-if-range)#channel-group 1 mode desirable

ALS1(config)#interface range fastEthernet 0/3 - 4


ALS1(config-if-range)#switchport trunk encapsulation dot1q (by default)
ALS1(config-if-range)#switchport mode trunk
ALS1(config-if-range)#channel-group 1 mode desirable

DLS2(config)#interface range fastEthernet 0/3 - 4


DLS2(config-if-range)#switchport trunk encapsulation dot1q
DLS2(config-if-range)#switchport mode trunk
DLS2(config-if-range)#channel-group 4 mode desirable

ALS2(config)#interface range fastEthernet 0/3 - 4


ALS2(config-if-range)#switchport trunk encapsulation dot1q (by default)
ALS2(config-if-range)#switchport mode trunk
ALS2(config-if-range)#channel-group 1 mode desirable

DLS1#show etherchannel summary


Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

CCNP3: Building Multilayer Switched Networks PAGE 5 OF 66


GROUP3: CASE STUDY 3

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------

1 Po1(SU) PAgP Fa0/3(P) Fa0/4(P)

DLS2# show etherchannel summary


Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------

1 Po1(SU) PAgP Fa0/3(P) Fa0/4(P)

ALS1#show etherchannel summary


Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1

CCNP3: Building Multilayer Switched Networks PAGE 6 OF 66


GROUP3: CASE STUDY 3

Number of aggregators: 1

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/3(P) Fa0/4(P)

ALS2# show etherchannel summary


Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel s
------+-------------+-----------+-----------------------------------------------
1 Po1(P Fa0/3(P) Fa0/4(P)

 On DL & AL Switches use ports 5 & 6 as trunk ports between them (DLS1 to ALS2 &
DLS2 to ALS1).

DLS1(config)#interface range fastEthernet 0/5 - 6


DLS1(config-if-range)#switchport trunk encapsulation dot1q
DLS1(config-if-range)#switchport mode trunk

ALS2(config)#interface range fastEthernet 0/5 - 6


ALS2(config-if-range)#switchport trunk encapsulation dot1q (by default)
ALS2(config-if-range)#switchport mode trunk

DLS2(config)#interface range fastEthernet 0/5 - 6


DLS2(config-if-range)#switchport trunk encapsulation dot1q
DLS2(config-if-range)#switchport mode trunk

ALS1(config)#interface range fastEthernet 0/5 - 6


ALS1(config-if-range)#switchport trunk encapsulation dot1q (by default)
ALS1(config-if-range)#switchport mode trunk

CCNP3: Building Multilayer Switched Networks PAGE 7 OF 66


GROUP3: CASE STUDY 3

 Use ports 7 & 8 for the trunk ports between ALS1 & ALS2.

ALS1(config)#interface range fastEthernet 0/7 - 8


ALS1(config-if-range)#switchport trunk encapsulation dot1q (by default)
ALS1(config-if-range)#switchport mode trunk

ALS2(config)#interface range fastEthernet 0/7 - 8


ALS2(config-if-range)#switchport trunk encapsulation dot1q (by default)
ALS2(config-if-range)#switchport mode trunk

 Use port 7 for the trunk links to ISP (DLS1 to ISP & DLS2 to ISP).

DLS1(config)#interface fastEthernet 0/7


DLS1(config-if)#no switchport
DLS1(config-if)#ip address 192.168.1.5 255.255.255.252
DLS1(config-if)#no shutdown

DLS2(config)#interface fastEthernet 0/7


DLS2(config-if)#no switchport
DLS2(config-if)#ip address 192.168.1.9 255.255.255.252
DLS2(config-if)#no shutdown

ISP(config)#interface fastEthernet 0/0


ISP(config-if)#ip address 192.168.1.6 255.255.255.252
ISP(config-if)#no shutdown

ISP(config)#interface fastEthernet 0/1


ISP(config-if)#ip address 192.168.1.10 255.255.255.252
ISP(config-if)#no shutdown

 ALS1 has the only link to BACKUP Router on port 24.

ALS1(config)#interface fastEthernet 0/24


ALS1(config-if)#switchport trunk encapsulation dot1q (by default)
ALS1(config-if)#switchport mode trunk

DLS1#show int trunk


Port Mode Encapsulation Status Native vlan
Fa0/5 on 802.1q trunking 1
Fa0/6 on 802.1q trunking 1
Po1 on 802.1q trunking 1

DLS2#show int trunk


Port Mode Encapsulation Status Native vlan
Fa0/5 on 802.1q trunking 1

CCNP3: Building Multilayer Switched Networks PAGE 8 OF 66


GROUP3: CASE STUDY 3

Fa0/6 on 802.1q trunking 1


Po1 on 802.1q trunking 1

ALS2#show interfaces trunk


Port Mode Encapsulation Status Native vlan
Fa0/5 on 802.1q trunking 1
Fa0/6 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Po1 on 802.1q trunking 1

ALS2#show interfaces trunk


Port Mode Encapsulation Status Native vlan
Fa0/5 on 802.1q trunking 1
Fa0/6 on 802.1q trunking 1
Fa0/7 on 802.1q trunking 1
Fa0/8 on 802.1q trunking 1
Po1 on 802.1q trunking 1

2.2. VLANs and VTP


Digital Technologies Inc (DTI) requires VLANs and VTP to be configured within the switched
network. The following details are the requirements of DTI VLANs and VTP.

 VTP
o Domain DTCORP
o Password cisco
o DLS1 Server
o All other switches CLIENT

DLS1(config)#vtp domain DTCORP


DLS1(config)#vtp password cisco
DLS1(config)#vtp mode server

DLS2(config)#vtp domain DTCORP


DLS2(config)#vtp password cisco
DLS2(config)#vtp mode client

ALS1(config)#vtp domain DTCORP


ALS1(config)#vtp password cisco
ALS1(config)#vtp mode client

CCNP3: Building Multilayer Switched Networks PAGE 9 OF 66


GROUP3: CASE STUDY 3

ALS2(config)#vtp domain DTCORP


ALS2(config)#vtp password cisco
ALS2(config)#vtp mode client

 Fast EtherChannel is between ALS1 & DLS1, and ALS2 & DLS2
Fast EtherChannel is done in the previous section.

 Create all required VLANs in the VTP Domain

DLS1(config)#vlan 10
DLS1(config-vlan)#name Corporate

DLS1(config)#vlan 20
DLS1(config-vlan)#name Sales

DLS1(config)#vlan 30
DLS1(config-vlan)#name Servers

DLS1(config)#vlan 150
DLS1(config-vlan)#name Telephony

DLS1(config)#vlan 217
DLS1(config-vlan)#name Management

DLS1(config)#vlan 539
DLS1(config-vlan)#name Unused

 Configure Access Ports as follows:

VLAN10 VLAN20 VLAN30 VLAN150


DLS1 Nil Nil nil n/a
DLS2 Nil Nil Fa0/22-24 n/a
ALS1 Fa0/10-13 Fa0/14-20 Nil All access ports
ALS2 Fa0/10-13 Fa0/14-22 Nil All access ports

DLS2(config)#interface range fastEthernet 0/22 – 24


DLS2(config-if-range)#switchport access vlan 30
DLS2(config-if-range)#switchport mode access

ALS1(config)#interface range fastEthernet 0/10 – 13


ALS1(config-if-range)#switchport access vlan 10
ALS1(config-if-range)#switchport mode access

ALS1(config)#interface range fastEthernet 0/14 – 22

CCNP3: Building Multilayer Switched Networks PAGE 10 OF 66


GROUP3: CASE STUDY 3

ALS1(config-if-range)#switchport access vlan 20


ALS1(config-if-range)#switchport mode access

ALS2(config)#interface range fastEthernet 0/10 – 13


ALS2(config-if-range)#switchport access vlan 10
ALS2(config-if-range)#switchport mode access

ALS2(config)#interface range fastEthernet 0/14 – 20


ALS2(config-if-range)#switchport access vlan 20
ALS2(config-if-range)#switchport mode access

 All unused ports are to be shutdown and placed into VLAN539. This VLAN is to then be
deleted.

DLS1(config)#interface range fastEthernet 0/1 – 2, fastEthernet 0/8 – 24


DLS1(config-if-range)#switchport access vlan 539
DLS1(config-if-range)#shutdown

DLS1(config)#interface range gigabitEthernet 0/1 – 2


DLS1(config-if-range)#switchport access vlan 539
DLS1(config-if-range)#shutdown

DLS2(config)#interface range fastEthernet 0/1 – 2, fastEthernet 0/8 – 21


DLS2(config-if-range)#switchport access vlan 539
DLS2(config-if-range)#shutdown

DLS2(config)#interface range gigabitEthernet 0/1 – 2


DLS2(config-if-range)#switchport access vlan 539
DLS2(config-if-range)#shutdown

ALS1(config)#interface range fastEthernet 0/1 – 2, fastEthernet 0/9


ALS1(config-if-range)#switchport access vlan 539
ALS1(config-if-range)#shutdown

ALS1(config)#interface range fastEthernet 0/21 – 23, gigabitEthernet 0/1 – 2


ALS1(config-if-range)#switchport access vlan 539
ALS1(config-if-range)#shutdown

ALS2(config)#interface range fastEthernet 0/1 – 2, fastEthernet 0/9


ALS2(config-if-range)#switchport access vlan 539
ALS2(config-if-range)#shutdown

ALS2(config)#interface range fastEthernet 0/23 – 24, gigabitEthernet 0/1 – 2


ALS2(config-if-range)#switchport access vlan 539
ALS2(config-if-range)#shutdown

CCNP3: Building Multilayer Switched Networks PAGE 11 OF 66


GROUP3: CASE STUDY 3

*Deleting VLAN539

DLS1(config)#no vlan 539

DLS1#show vtp status


VTP Version :2
Configuration Revision : 10
Maximum VLANs supported locally : 1005
Number of existing VLANs : 10
VTP Operating Mode : Server
VTP Domain Name : DTCORP
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x88 0xE3 0xB1 0x89 0x9A 0x6B 0x9F 0xCA
Configuration last modified by 10.1.10.10 at 3-1-93 01:22:14
Local updater ID is 10.1.10.10 on interface Vl10 (lowest numbered VLAN interface
found)
DLS1#show vtp password
VTP Password: cisco
DLS1#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active
10 Corporate active
20 Sales active
30 Servers active
217 Management active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

LS2#show vtp status


VTP Version :2
Configuration Revision : 10
Maximum VLANs supported locally : 1005
Number of existing VLANs : 10
VTP Operating Mode : Client
VTP Domain Name : DTCORP
VTP Pruning Mode : Disabled

CCNP3: Building Multilayer Switched Networks PAGE 12 OF 66


GROUP3: CASE STUDY 3

VTP V2 Mode : Disabled


VTP Traps Generation : Disabled
MD5 digest : 0x88 0xE3 0xB1 0x89 0x9A 0x6B 0x9F 0xCA
Configuration last modified by 10.1.10.10 at 3-1-93 01:22:14
DLS2#show vtp password
VTP Password: cisco
DLS2#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active
10 Corporate active
20 Sales active
30 Servers active Fa0/22, Fa0/23,Fa0/24
150 Telephony active
217 Management active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

ALS1#show vtp stat


VTP Version :2
Configuration Revision : 10
Maximum VLANs supported locally : 255
Number of existing VLANs : 10
VTP Operating Mode : Client
VTP Domain Name : DTCORP
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x88 0xE3 0xB1 0x89 0x9A 0x6B 0x9F 0xCA
Configuration last modified by 10.1.10.10 at 3-1-93 01:22:14
ALS1#show vtp pass
VTP Password: cisco
ALS1#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active
10 Corporate active Fa0/10, Fa0/11, Fa0/12, Fa0/13
20 Sales active Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20
30 Servers active
150 Telephony active
217 Management active

CCNP3: Building Multilayer Switched Networks PAGE 13 OF 66


GROUP3: CASE STUDY 3

1002 fddi-default act/unsup


1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

ALS2#show vtp status

VTP Version :2
Configuration Revision : 10
Maximum VLANs supported locally : 255
Number of existing VLANs : 10
VTP Operating Mode : Client
VTP Domain Name : DTCORP
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x88 0xE3 0xB1 0x89 0x9A 0x6B 0x9F 0xCA
Configuration last modified by 10.1.10.10 at 3-1-93 01:22:14

ALS2#show vtp pass


VTP Password: cisco

ALS2#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active
10 Corporate active Fa0/10, Fa0/11, Fa0/12, Fa0/13
20 Sales active Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22
30 Servers active
150 Telephony active
217 Management active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

2.3. Spanning-Tree
 Configure instance 1 for VLANs 10, 20 & 217 with DLS1 as Root Bridge, with all other
VLANs being in instance 2 with DLS2 as Root Bridge.

CCNP3: Building Multilayer Switched Networks PAGE 14 OF 66


GROUP3: CASE STUDY 3

DLS1(config)#spanning-tree mode mst


DLS1(config)#spanning-tree mst configuration
DLS1(config-mst)#name CS3
DLS1(config-mst)#revision 1
DLS1(config-mst)#instance 1 vlan 10, 20, 217
DLS1(config-mst)#instance 2 vlan 1, 30, 150 ,1002-1005
DLS1(config)#spanning-tree mst 1 root primary
DLS1(config)#spanning-tree mst 2 root secondary

DLS2(config)#spanning-tree mode mst


DLS2(config)#spanning-tree mst configuration
DLS2(config-mst)#name CS3
DLS2(config-mst)#revision 1
DLS2(config-mst)#instance 1 vlan 10, 20, 217
DLS2(config-mst)#instance 2 vlan 1, 30, 150 ,1002-1005
DLS2(config)#spanning-tree mst 2 root primary
DLS2(config)#spanning-tree mst 1 root secondary

ALS1(config)#spanning-tree mode mst


ALS1(config)#spanning-tree mst configuration
ALS1(config-mst)#name CS3
ALS1(config-mst)#revision 1
ALS1(config-mst)#instance 1 vlan 10, 20, 217
ALS1(config-mst)#instance 2 vlan 1, 30, 150 ,1002-1005

ALS2(config)#spanning-tree mode mst


ALS2(config)#spanning-tree mst configuration
ALS2(config-mst)#name CS3
ALS2(config-mst)#revision 1
ALS2(config-mst)#instance 1 vlan 10,20,217
ALS2(config-mst)#instance 2 vlan 1, 30, 150 ,1002-1005

DLS1#show spanning-tree mst configuration


Name [CS3]
Revision 1 Instances configured 3

Instance Vlans mapped


-------- ---------------------------------------------------------------------
0 2-9,11-19,21-29,31-149,151-216,218-1001,1006-4094
1 10,20,217
2 1,30,150,1002-1005
-------------------------------------------------------------------------------
DLS2# show spanning-tree mst configuration
Name [CS3]
Revision 1 Instances configured 3

CCNP3: Building Multilayer Switched Networks PAGE 15 OF 66


GROUP3: CASE STUDY 3

Instance Vlans mapped


-------- ---------------------------------------------------------------------
0 2-9,11-19,21-29,31-149,151-216,218-1001,1006-4094
1 10,20,217
2 1,30,150,1002-1005
----------------------------------------------------------------

ALS1#show spanning-tree mst config


Name [CS3]
Revision 1 Instances configured 3

Instance Vlans mapped


-------- ---------------------------------------------------------------------
0 2-9,11-19,21-29,31-149,151-216,218-1001,1006-4094
1 10,20,217
2 1,30,150,1002-1005
-------------------------------

ALS2#show spanning-tree mst configuration


Name [CS3]
Revision 1 Instances configured 3

Instance Vlans mapped


-------- ---------------------------------------------------------------------
0 2-9,11-19,21-29,31-149,151-216,218-1001,1006-4094
1 10,20,217
2 1,30,150,1002-1005
------------------------------

DLS1#show spanning-tree
MST1
Spanning tree enabled protocol mstp
Root ID Priority 24577
Address 0024.9897.9780
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24577 (priority 24576 sys-id-ext 1)


Address 0024.9897.9780
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
MST2
Spanning tree enabled protocol mstp
Root ID Priority 24578
Address 0026.caa6.e200
Cost 300000
Port 7 (FastEthernet0/5)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

CCNP3: Building Multilayer Switched Networks PAGE 16 OF 66


GROUP3: CASE STUDY 3

Bridge ID Priority 28674 (priority 28672 sys-id-ext 2)


Address 0024.9897.9780
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

DLS2#show spanning-tree
MST1
Spanning tree enabled protocol mstp
Root ID Priority 24577
Address 0024.9897.9780
Cost 300000
Port 56 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 28673 (priority 28672 sys-id-ext 1)


Address 0026.caa6.e200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

MST2
Spanning tree enabled protocol mstp
Root ID Priority 24578
Address 0026.caa6.e200
This bridge is the root
me 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24578 (priority 24576 sys-id-ext 2)


Address 0026.caa6.e200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

 Configure PortFast on all non trunk ports.

DLS1(config)#spanning-tree portfast default


DLS2(config)#spanning-tree portfast default
ALS1(config)#spanning-tree portfast default
ALS2(config)#spanning-tree portfast default

2.4. Inter-VLAN Routing and HSRP


Enable InterVLAN routing. Configure Backup as a router-on-a-stick. Configure HSRP on
DLS1, DLS2 and Backup Router

Configure HSRP on DLS1, DLS2 and Backup Router so that DLS1 is the active router for
VLANs 10, 20 & 217 and DLS 2 is the active router for VLANs 30 & 150, with standby for all
VLANs being Backup Router. Include the preempt option in all configuration.

CCNP3: Building Multilayer Switched Networks PAGE 17 OF 66


GROUP3: CASE STUDY 3

Configure HSRP interface tracking so that Backup becomes the active router if the FastEthernet
links between DLS1 and ISP or DLS2 and ISP fails.

Use the following Addresses:

 VLAN10 - 10.1.10.0/24
 VLAN20 - 10.1.20.0/24
 VLAN30 - 10.1.30.0/24
 VLAN150 - 10.1.150.0/24
 VLAN217 - 10.1.217.0/24
 Interface S0/0/0 (facing ISP) on Backup - 192.168.1.0/30
 Interface fa0/7 on DLS1 – 192.168.1.4/30
 Interface fa0/7 on DLS2 – 192.168.1.8/30
 Configure valid addresses for the host on ALS1 (port 15) and the host on ALS2 (port20),
and server in VLAN 30.
 Configure tracking on all links to ISP.

2.4.1. Inter-VLAN Routing

DLS1(config)#ip routing
DLS1(config)#interface vlan 10
DLS1(config-if)#ip address 10.1.10.10 255.255.255.0
DLS1(config-if)#interface vlan 20
DLS1(config-if)#ip address 10.1.20.10 255.255.255.0
DLS1(config-if)#interface vlan 30
DLS1(config-if)#ip address 10.1.30.10 255.255.255.0
DLS1(config-if)#interface vlan 150
DLS1(config-if)#ip address 10.1.150.10 255.255.255.0
DLS1(config-if)#interface vlan 217
DLS1(config-if)#ip address 10.1.217.10 255.255.255.0

DLS2(config)#ip routing
DLS2(config)#interface vlan 10
DLS2(config-if)#ip address 10.1.10.20 255.255.255.0
DLS2(config)#interface vlan 20                 
DLS2(config-if)#ip address 10.1.20.20 255.255.255.0
            DLS2(config)#interface vlan 30                 
DLS2(config-if)#ip address 10.1.30.20 255.255.255.0
DLS2(config)#interface vlan 150                
DLS2(config-if)#ip address 10.1.150.20 255.255.255.0
DLS2(config)#interface vlan 217
DLS2(config-if)#ip address 10.1.217.20 255.255.255.0

CCNP3: Building Multilayer Switched Networks PAGE 18 OF 66


GROUP3: CASE STUDY 3

* Router-on-a-stick

Backup(config)#interface fastEthernet 0/0


Backup(config-if)#no shutdown

Backup(config)#interface fastEthernet 0/0.10


Backup(config-subif)#encapsulation dot1Q 10
Backup(config-subif)#ip address 10.1.10.100 255.255.255.0

Backup(config)#interface fastEthernet 0/0.20         


Backup(config-subif)#encapsulation dot1Q 20            
Backup(config-subif)#ip address 10.1.20.100 255.255.255.0

Backup(config)#interface fastEthernet 0/0.30         


Backup(config-subif)#encapsulation dot1Q 30            
Backup(config-subif)#ip address 10.1.30.100 255.255.255.0

Backup(config)#interface fastEthernet 0/0.150        


Backup(config-subif)#encapsulation dot1Q 150           
Backup(config-subif)#ip address 10.1.150.100 255.255.255.0

Backup(config)#interface fastEthernet 0/0.217         


Backup(config-subif)#encapsulation dot1Q 217            
Backup(config-subif)#ip address 10.1.217.100 255.255.255.0

2.4.2. HSRP and IP Addressing

* HSRP Configuration

DLS1(config)#interface vlan10
DLS1(config-if)#standby 10 ip 10.1.10.1
DLS1(config-if)#standby 10 priority 110
DLS1(config-if)#standby 10 preempt
DLS1(config-if)#standby 10 track fastEthernet0/7

DLS1(config-if)#interface vlan20
DLS1(config-if)#standby 20 ip 10.1.20.1
DLS1(config-if)#standby 20 priority 110
DLS1(config-if)#standby 20 preempt
DLS1(config-if)#standby 20 track fastEthernet0/7

DLS1(config-if)#interface vlan217
DLS1(config-if)#standby 217 ip 10.1.217.1

CCNP3: Building Multilayer Switched Networks PAGE 19 OF 66


GROUP3: CASE STUDY 3

DLS1(config-if)#standby 217 priority 110


DLS1(config-if)#standby 217 preempt
DLS1(config-if)#standby 217 track fastEthernet0/7

DLS2(config)#interface vlan30
DLS2(config-if)# standby 30 ip 10.1.30.1
DLS2(config-if)# standby 30 priority 110
DLS2(config-if)# standby 30 preempt
DLS2(config-if)# standby 30 track fastEthernet0/7

DLS2(config-if)#interface vlan150
DLS2(config-if)# standby 150 ip 10.1.150.1
DLS2(config-if)# standby 150 priority 110
DLS2(config-if)# standby 150 preempt
DLS2(config-if)# standby 150 track fastEthernet0/7

Backup(config)#interface fastEthernet0/0.10
Backup(config-subif)#standby 10 ip 10.1.10.1
Backup(config-subif)#standby 10 preempt
Backup(config-subif)#standby 10 priority 105
Backup(config-subif)#standby 10 track Serial0/0/0

Backup(config)#interface fastEthernet 0/0.20


Backup(config-subif)#standby 20 ip 10.1.20.1
Backup(config-subif)#standby 20 preempt
Backup(config-subif)#standby 20 priority 105
Backup(config-subif)#standby 20 track Serial 0/0/0

Backup(config)#interface fastEthernet 0/0.30


Backup(config-subif)#standby 30 ip 10.1.30.1
Backup(config-subif)#standby 30 preempt
Backup(config-subif)#standby 30 priority 105
Backup(config-subif)#standby 30 track Serial 0/0/0

Backup(config)#interface fastEthernet 0/0.150


Backup(config-subif)#standby 150 ip 10.1.150.1
Backup(config-subif)#standby 150 preempt
Backup(config-subif)#standby 150 priority 105
Backup(config-subif)#standby 150 track Serial 0/0/0

Backup(config)#interface fastEthernet 0/0.217


Backup(config-subif)#standby 217 ip 10.1.217.1
Backup(config-subif)#standby 217 preempt
Backup(config-subif)#standby 217 priority 105
Backup(config-subif)#standby 217 track Serial 0/0/0

CCNP3: Building Multilayer Switched Networks PAGE 20 OF 66


GROUP3: CASE STUDY 3

* HSRP Configuration on Subinterfaces

“HSRP groups on subinterfaces must have a group number unique among all other
groups on all subinterfaces on the same main interface. This is because subinterfaces do
not receive a unique SNMP interface index. If you had two groups with the number N on
different subinterfaces, then in the MIB, group N on sub-interface 1 and group N on sub-
interface 2 would appear to be the same group (Cisco Systems 2010)”.

* IP Addressing

ISP(config)#interface serial 0/0/0


ISP(config-if)#ip address 192.168.1.2 255.255.255.252
ISP(config-if)#clock rate 64000
ISP(config-if)#no shutdown

BACKUP(config)#interface serial 0/0/0


BACKUP(config-if)#ip address 192.168.1.1 255.255.255.252
BACKUP(config-if)#no shutdown

ALS1(config)#interface vlan 217


ALS1(config-if)#ip address 10.1.217.30 255.255.255.0
ALS1(config-if)#no shutdown
ALS1(config)#ip default-gateway 10.1.217.1

ALS2(config)#interface vlan 217


ALS2(config-if)#ip address 10.1.217.40 255.255.255.0
ALS2(config-if)#no shutdown
ALS2(config)#ip default-gateway 10.1.217.1

DLS1#show standby
Vlan10 - Group 10
State is Active
7 state changes, last state change 00:32:31
Virtual IP address is 10.1.10.1
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.859 secs
Preemption enabled
Active router is local
Standby router is 10.1.10.100, priority 95 (expires in 9.153 sec)
Priority 110 (configured 110)

CCNP3: Building Multilayer Switched Networks PAGE 21 OF 66


GROUP3: CASE STUDY 3

Track interface FastEthernet0/7 state Up decrement 10


IP redundancy name is "hsrp-Vl10-10" (default)
Vlan20 - Group 20
State is Active
5 state changes, last state change 00:32:34
Virtual IP address is 10.1.20.1
Active virtual MAC address is 0000.0c07.ac14
Local virtual MAC address is 0000.0c07.ac14 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.062 secs
Preemption enabled
Active router is local
Standby router is 10.1.20.100, priority 95 (expires in 7.626 sec)
Priority 110 (configured 110)
Track interface FastEthernet0/7 state Up decrement 10
IP redundancy name is "hsrp-Vl20-20" (default)
Vlan217 - Group 217
State is Active
5 state changes, last state change 00:32:35
Virtual IP address is 10.1.217.1
Active virtual MAC address is 0000.0c07.acd9
Local virtual MAC address is 0000.0c07.acd9 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.069 secs
Preemption enabled
Active router is local
Standby router is 10.1.217.100, priority 95 (expires in 8.045 sec)
Priority 110 (configured 110)
Track interface FastEthernet0/7 state Up decrement 10
IP redundancy name is "hsrp-Vl217-217" (default)

DLS2#show standby
Vlan30 - Group 30
State is Active
4 state changes, last state change 01:52:13
Virtual IP address is 10.1.30.1
Active virtual MAC address is 0000.0c07.ac1e
Local virtual MAC address is 0000.0c07.ac1e (v1 default)
Hello time 3 sec, ho
Next hello sent in 2.865 secs
Preemption enabled
Active router is local
Standby router is 10.1.30.100, priority 95 (expires in 9.916 sec)
Priority 110 (configured 110)
Track interface FastEthernet0/7 state Up decrement 10
IP redunsrp-Vl30-30" (default)
Vlan150 - Group 150

CCNP3: Building Multilayer Switched Networks PAGE 22 OF 66


GROUP3: CASE STUDY 3

State is Active
4 state changes, last state change 01:50:52
Virtual IP address is 10.1.150.1
Active virtual MAC address is 0000.0c07.ac96
Local virtual MAC address is 0000.0c07.ac96 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.278 secs
Preemption enabled
Active router is local
Standby router is 10.1.150.100, priority 95 (expir in 9.773 sec)
Priority 110 (configured 110)
Track interface FastEthernet0/7 state Up decrement 10
IP redundancy name is "hsrp-Vl150-150" (default)

BACKUP#show standby
FastEthernet0/0.10 - Group 10
State is Standby
12 state changes, last state change 00:23:04
Virtual IP address is 10.1.10.1
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.912 secs
Preemption enabled
Active router is 10.1.10.10, priority 110 (expires in 9.648 sec)
Standby router is local
Priority 105 (configured 105)
Track interface Serial0/0/0 state Up decrement 10
Group name is "hsrp-Fa0/0.10-10" (default)
FastEthernet0/0.20 - Group 20
State is Standby
9 state changes, last state change 00:23:07
Virtual IP address is 10.1.20.1
Active virtual MAC address is 0000.0c07.ac14
Local virtual MAC address is 0000.0c07.ac14 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.352 secs
Preemption enabled
Active router is 10.1.20.10, priority 110 (expires in 10.400 sec)
Standby router is local
Priority 105 (configured 105)
Track interface Serial0/0/0 state Up decrement 10
Group name is "hsrp-Fa0/0.20-20" (default)
FastEthernet0/0.30 - Group 30
State is Standby
9 state changes, last state change 01:36:38
Virtual IP address is 10.1.30.1

CCNP3: Building Multilayer Switched Networks PAGE 23 OF 66


GROUP3: CASE STUDY 3

Active virtual MAC address is 0000.0c07.ac1e


Local virtual MAC address is 0000.0c07.ac1e (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.816 secs
Preemption enabled
Active router is 10.1.30.20, priority 110 (expires in 8.272 sec)
Standby router is local
Priority 105 (configured 105)
Track interface Serial0/0/0 state Up decrement 10
Group name is "hsrp-Fa0/0.30-30" (default)
FastEthernet0/0.150 - Group 150
State is Standby
9 state changes, last state change 01:35:17
Virtual IP address is 10.1.150.1
Active virtual MAC address is 0000.0c07.ac96
Local virtual MAC address is 0000.0c07.ac96 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.408 secs
Preemption enabled
Active router is 10.1.150.20, priority 110 (expires in 9.872 sec)
Standby router is local
Priority 105 (configured 105)
Track interface Serial0/0/0 state Up decrement 10
Group name is "hsrp-Fa0/0.150-150" (default)
FastEthernet0/0.217 - Group 217
State is Standby
9 state changes, last state change 00:23:09
Virtual IP address is 10.1.217.1
Active virtual MAC address is 0000.0c07.acd9
Local virtual MAC address is 0000.0c07.acd9 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.464 secs
Preemption enabled
Active router is 10.1.217.10, priority 110 (expires in 8.144 sec)
Standby router is local
Priority 105 (configured 105)
Track interface Serial0/0/0 state Up decrement 10
Group name is "hsrp-Fa0/0.217-217" (default)

2.5. Additional Requirements


 Configure Port sticky on all access ports, allowing only a single user, and shut down if
violated.

DLS2(config)#interface range fastEthernet 0/22 - 24


DLS2(config-if-range)#switchport port-security mac-address sticky

CCNP3: Building Multilayer Switched Networks PAGE 24 OF 66


GROUP3: CASE STUDY 3

DLS2(config-if-range)#switchport port-security maximum 1


DLS2(config-if-range)#switchport port-security violation shutdown

ALS1(config)#interface range fastEthernet 0/10 - 20


ALS1(config-if-range)#switchport port-security mac-address sticky
ALS1(config-if-range)#switchport port-security maximum 2
ALS1(config-if-range)#switchport port-security violation shutdown

ALS2(config)#interface range fastEthernet 0/10 - 22


ALS2(config-if-range)#switchport port-security mac-address sticky
ALS2(config-if-range)#switchport port-security maximum 2
ALS2(config-if-range)#switchport port-security violation shutdown

Both Access layer switches ALS1 and ALS2 are configured the port-security maximum
value as 2 because all access ports in ALS1 and ALS2 can be attached IP phones with
PCs.

 Enable BPDU guard on all appropriate interfaces

DLS1(config)#spanning-tree portfast bpduguard default


DLS2(config)#spanning-tree portfast bpduguard default
ALS1(config)#spanning-tree portfast bpduguard default
ALS2(config)#spanning-tree portfast bpduguard default

 Configure Portfast an all appropriate ports.

DLS1(config)#spanning-tree portfast default


DLS2(config)#spanning-tree portfast default
ALS1(config)#spanning-tree portfast default
ALS2(config)#spanning-tree portfast default

 Place any ports not attached to a VLAN into VLAN 539, place these interfaces in
shutdown mode and the delete this vlan.

* This is done in the previous VLAN section.

 Configure IP routing on DLS1 and DLS2, and use EIGRP, with automatic summarization
disabled.

DLS1(config)#router eigrp 1
DLS1(config-router)#no auto-summary
DLS1(config-router)#network 10.0.0.0

CCNP3: Building Multilayer Switched Networks PAGE 25 OF 66


GROUP3: CASE STUDY 3

DLS1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.6

DLS2(config)#router eigrp 1
DLS2(config-router)#no auto-summary
DLS2(config-router)#network 10.0.0.0
DLS2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.10

BACKUP(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

In order to communicate between ISP and DTI, static route configurations with different
administrative distance value are required.

ISP(config)#ip route 10.0.0.0 255.0.0.0 192.168.1.5


ISP(config)#ip route 10.0.0.0 255.0.0.0 192.168.1.9 5
ISP(config)#ip route 10.0.0.0 255.0.0.0 192.168.1.1 10

DLS1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.6 to network 0.0.0.0

10.0.0.0/24 is subnetted, 5 subnets


C 10.1.10.0 is directly connected, Vlan10
C 10.1.30.0 is directly connected, Vlan30
C 10.1.20.0 is directly connected, Vlan20
C 10.1.150.0 is directly connected, Vlan150
C 10.1.217.0 is directly connected, Vlan217
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, FastEthernet0/7
S* 0.0.0.0/0 [1/0] via 192.168.1.6

DLS2# show ip route


Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, candidate default, U - per-user static route

CCNP3: Building Multilayer Switched Networks PAGE 26 OF 66


GROUP3: CASE STUDY 3

o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.10 to network 0.0.0.0

10.0.0.0/24 is subnetted, 5 subnets


C 10.1.10.0 is directly connected, Vlan10
C 10.1.30.0 is directly connected, Vlan30
C 10.1.20.0 is directly connected, Vlan20
C 10.1.150.0 is directly connected, Vlan150
C 10.1.217.0 is directly connected, Vlan217
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.8 is directly connected, FastEthernet0/7
S* 0.0.0.0/0 [1/0] via 192.168.1.10

ISP#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

S 10.0.0.0/8 [1/0] via 192.168.1.5


192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.8 is directly connected, FastEthernet0/1
C 192.168.1.4 is directly connected, FastEthernet0/0

 Enable QoS globally on all switches.

DLS1(config)#mls qos
DLS1(config)#interface rage fastEthernet 0/3 – 6
DLS1(config-if-range)#auto qos voip trust

DLS2(config)#mls qos
DLS2(config)#interface rage fastEthernet 0/3 – 6
DLS2(config-if-range)#auto qos voip trust

DLS1#show mls qos


QoS is enabled
QoS ip packet dscp rewrite is enabled

CCNP3: Building Multilayer Switched Networks PAGE 27 OF 66


GROUP3: CASE STUDY 3

DLS1#
DLS1#show auto qos int
FastEthernet0/3
auto qos voip trust

FastEthernet0/4
auto qos voip trust

FastEthernet0/5
auto qos voip trust

FastEthernet0/6
auto qos voip trust

DLS2#show mls qos


QoS is enabled
QoS ip packet dscp rewrite is enabled

DLS2#show auto qos interface


FastEthernet0/3
auto qos voip trust

FastEthernet0/4
auto qos voip trust

FastEthernet0/5
auto qos voip trust

FastEthernet0/6
auto qos voip trust

 On ALS1 and ALS2, configure access ports to trust Cisco IP Phones for QoS. Use
VLAN150 as the voice VLAN.

ALS1(config)#interface range fastEthernet 0/10 - 20


ALS1(config-if-range)#switchport voice vlan 150
ALS1(config-if-range)#auto qos voip cisco-phone

ALS2(config)#interface range fastEthernet 0/10 - 22


ALS2(config-if-range)#switchport voice vlan 150
ALS2(config-if-range)#auto qos voip cisco-phone

ALS1#show mls qos


QoS is enabled
QoS ip packet dscp rewrite is enabled

CCNP3: Building Multilayer Switched Networks PAGE 28 OF 66


GROUP3: CASE STUDY 3

ALS1#show auto qos interface


FastEthernet0/10
auto qos voip cisco-phone

FastEthernet0/11
auto qos voip cisco-phone

FastEthernet0/12
auto qos voip cisco-phone

FastEthes voip cisco-phone

FastEthernet0/14
auto qos voip cisco-phone

FastEthernet0/15
auto qos voip cisco-phone

FastEthernet0/16
auto qos voip cisco-phone

FastEthernet0/17
auto qos voip cisco-phone

FastEthernet0/18
auto qos voip cisco-phone

FastEthernet0/19
auto qos voip cisco-phone

FastEthernet0/20
auto qos voip cisco-phone

ALS2#show mls qos


QoS is enabled
QoS ip packet dscp rewrite is enabled

ALS2#show auto qos interface


FastEthernet0/10
auto qos voip cisco-phone

FastEthernet0/11
auto qos voip cisco-phone

FastEthernet0/12

CCNP3: Building Multilayer Switched Networks PAGE 29 OF 66


GROUP3: CASE STUDY 3

auto qos voip cisco-phone

FastEthes voip cisco-phone

FastEthernet0/14
auto qos voip cisco-phone

FastEthernet0/15
auto qos voip cisco-phone

FastEthernet0/16
auto qos voip cisco-phone

FastEthernet0/17
auto qos voip cisco-phone

FastEthernet0/18
auto qos voip cisco-phone

FastEthernet0/19
auto qos voip cisco-phone

FastEthernet0/20
auto qos voip cisco-phone

FastEthernet0/21
auto qos voip cisco-phone

FastEthernet0/22
auto qos voip cisco-phone

3. VERIFICATION
3.1. Ping
Allocate host and sever with the following IP addresses:
ALS1 Host 1 IP (10.1.150.50)
ALS2 Host 2 IP (10.1.150.60)
Server in VLAN 30 (10.1.30.50)

Host1>ping 10.1.150.60
Sending 5, 100-byte ICMP Echos to 10.1.150.60, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5)

CCNP3: Building Multilayer Switched Networks PAGE 30 OF 66


GROUP3: CASE STUDY 3

Host1>ping 10.1.30.50
Sending 5, 100-byte ICMP Echos to 10.1.30.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5)

Host1>ping 192.168.1.6
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5)

CCNP3: Building Multilayer Switched Networks PAGE 31 OF 66


GROUP3: CASE STUDY 3

4. FINAL CONFIGURATION
4.1. ISP
Building configuration...
Current configuration : 1297 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$gJAQ$m11fVIgt7tnM4omRShA650
!
no aaa new-model
memory-size iomem 5
!
dot11 syslog
ip source-route
!
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
archive
log config
hidekeys
!
interface FastEthernet0/0
ip address 192.168.1.6 255.255.255.252

CCNP3: Building Multilayer Switched Networks PAGE 32 OF 66


GROUP3: CASE STUDY 3

duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.10 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.1.2 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
ip route 10.0.0.0 255.0.0.0 192.168.1.5
ip route 10.0.0.0 255.0.0.0 192.168.1.9 5
ip route 10.0.0.0 255.0.0.0 192.168.1.1 10
no ip http server
no ip http secure-server
!
control-plane
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
line con 0
password 7 13061E010803
logging synchronous
login
line aux 0
line vty 0 4
password 7 01100F175804
login
!
scheduler allocate 20000 1000
end

CCNP3: Building Multilayer Switched Networks PAGE 33 OF 66


GROUP3: CASE STUDY 3

4.2. BACKUP
Building configuration...

Current configuration : 2130 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname BACKUP
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$D2Mw$deBMqS473wBBR1DVRCe7F.
!
no aaa new-model
memory-size iomem 15
!
dot11 syslog
ip source-route
!
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
archive
log config
hidekeys
!
interface FastEthernet0/0
no ip address
duplex auto

CCNP3: Building Multilayer Switched Networks PAGE 34 OF 66


GROUP3: CASE STUDY 3

speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.1.10.100 255.255.255.0
standby 10 ip 10.1.10.1
standby 10 priority 105
standby 10 preempt
standby 10 track Serial0/0/0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.1.20.100 255.255.255.0
standby 20 ip 10.1.20.1
standby 20 priority 105
standby 20 preempt
standby 20 track Serial0/0/0
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.1.30.100 255.255.255.0
standby 30 ip 10.1.30.1
standby 30 priority 105
standby 30 preempt
standby 30 track Serial0/0/0
!
interface FastEthernet0/0.150
encapsulation dot1Q 150
ip address 10.1.150.100 255.255.255.0
standby 150 ip 10.1.150.1
standby 150 priority 105
standby 150 preempt
standby 150 track Serial0/0/0
!
interface FastEthernet0/0.217
encapsulation dot1Q 217
ip address 10.1.217.100 255.255.255.0
standby 217 ip 10.1.217.1
standby 217 priority 105
standby 217 preempt

CCNP3: Building Multilayer Switched Networks PAGE 35 OF 66


GROUP3: CASE STUDY 3

standby 217 track Serial0/0/0


!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.1.1 255.255.255.252
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.2
no ip http server
no ip http secure-server
!
control-plane
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
line con 0
password 7 02050D480809
logging synchronous
line aux 0
line vty 0 4
password 7 1511021F0725
login
!
scheduler allocate 20000 1000
end

4.3. DLS1

Building configuration...

CCNP3: Building Multilayer Switched Networks PAGE 36 OF 66


GROUP3: CASE STUDY 3

Current configuration : 7612 bytes


!
version 12.2
no service pad
service timestamps debug e timestamps log uptime
service password-encryption
!
hostname DLS1
!
enable secret 5 $1$CqlE$MlF9/Zr4z82i2lpza2H46.
!
no aaa new-model
system mtu routi subnet-zero
ip routing
!
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0

CCNP3: Building Multilayer Switched Networks PAGE 37 OF 66


GROUP3: CASE STUDY 3

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47


mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
!
spanning-tree mode mst
spanning-tree portfast default
spanning-tree portfast bpduguard default
spanning-tree extend system-id
!
spanning-tree mstname CS3
revisnce 1 vlan 10, 20, 217
instance 2 vlan 1, 30, 150, 1002-1005
!
spanning-tree mst 1 priority 24576
spanning-tree mst 2 priority 28672
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q

CCNP3: Building Multilayer Switched Networks PAGE 38 OF 66


GROUP3: CASE STUDY 3

switchport mode trunk


!
interface FastEthernet0/1
switchport access vlan 539
shutdown
!
interface FastEthernet0/2
switchport access vlan 539
shutdown
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust cos
auto qos voip trust
channel-group 1 mode desirable
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls s
auto qos voip trust
channel-group 1 mode desirable
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust cos
auto qos voip trust
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20

CCNP3: Building Multilayer Switched Networks PAGE 39 OF 66


GROUP3: CASE STUDY 3

srr-queue bandwidth shape 10 0 0 0


mls qos trust cos
auto qos voip trust
!
interface FastEthernet0/7
192.168.1.5 255.255.255.252
!
interface FastEthernet0/8
switchport access vlan 539
shutdown
!
interface FastEthernet0/9
switchport access vlan 539
shutdown
!
interface FastEthernet0/10
switchport access vlan 539
shutdown
!
interface FastEthernet0/11
switchport access vlan 539
shutdown
!
interface FastEthernet0/12
switchport access vlan 539
shutdown
!
interface FastEthernet0/13
switchport access vlan 539
shutdown
!
interface FastEthernet0/14
switchport access vlan 539
shutdown
!
interface FastEthernet0/15
switchport access vlan 539
shutdown
!
interface FastEthernet0/16

CCNP3: Building Multilayer Switched Networks PAGE 40 OF 66


GROUP3: CASE STUDY 3

switchport access vlan 539


shutdown
!
interface FastEthernet0/17
switchport access vlan 539
shutdown
!
interface FastEthernet0/18
switchport access vlan 539
shutdown
!
interface FastEthernet0/19
switchport access vlan 539
shutdown
!
interface FastEthernet0/20
switchport access vlan 539
shutdown
!
interface FastEthernet0/21
switchport access vlan 539
shutdown
!
interface FastEthernet0/22
switchport access vlan 539
shutdown
!
interface FastEthernet0/23
switchport access vlan 539
shutdown
!
interface FastEthernet0/24
switchport access vlan 539
shutdown
!
interface GigabitEthernet0/1
switchport access vlan 539
shutdown
!
interface GigabitEthernet0/2

CCNP3: Building Multilayer Switched Networks PAGE 41 OF 66


GROUP3: CASE STUDY 3

switchport access vlan 539


shutdown
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.1.10.10 255.255.255.0
standby 10 ip 10.1.10.1
standby 10 priority 110
standby 10 preempt
standby 10 track FastEthernet0/7
!
interface Vlan20
ip address 10.1.20.10 255.255.255.0
standby 20 ip 10.1.20.1
standby 20 priority 110
standby 20 preempt
standby 20 track FastEthernet0/7
!
interface Vlan30
ip address 10.1.30.10 255.255.255.0
!
interface Vlan150
ip address 10.1.150.10 255.255.255.0
!
interface Vlan217
ip address 10.1.217.10 255.255.255.0
standby 217 ip 10.1.217.1
standby 217 priority 110
standby 217 preempt
standby 217 track FastEthernet0/7
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.6
ip http server

CCNP3: Building Multilayer Switched Networks PAGE 42 OF 66


GROUP3: CASE STUDY 3

!
control-plane
!
line con 0
password 7 045802150C2E
logging synchronous
line vty 0 4
password 7 045802150C2E
login
length 0
line vty 5 15
password 7 045802150C2E
login
length 0
!
end

4.4. DLS2
Building configuration...

Current configuration : 7609 bytes


!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname DLS2
!
enable secret 5 $1$iNH/$GxKpd/6db2HfdivyY3WS81
!
no aaa new-model
system mtu routing 1500
!
ip subnet-zero
ip routing
!
!

CCNP3: Building Multilayer Switched Networks PAGE 43 OF 66


GROUP3: CASE STUDY 3

mls qos map cos-dscp 0 8 16 26 32 46 48 56


mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-mathreshold 2 1
ueue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
-mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63


mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 queue output dscp-map que
ue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272

CCNP3: Building Multilayer Switched Networks PAGE 44 OF 66


GROUP3: CASE STUDY 3

mls qos queue-set output 2 threshold 4 42 72 100 242


mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
!
spanning-tree mode mst
spanning-tree portfast default
spanning-tree portfast bpduguard default
spanning-tree extend system-id
!
spanning-tree mst configuration
name CS3
revision 1
instance 1 vlan 10, 20, 217
instance 2 vlan 1, 30, 150, 1002-1005
!
spanning-tree mst 1 priority 28672
spanning-tree mst 2 priority 24576
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport access vlan 539
shutdown
!
interface FastEthernet0/2
switchport access vlan 539
shutdown
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20

CCNP3: Building Multilayer Switched Networks PAGE 45 OF 66


GROUP3: CASE STUDY 3

srr-queue bandwidth shape 10 0 0 0


mls qos trust cos
auto qos voip trust
channel-group 1 mode desirable
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust cos
auto qos voip trust
channel-group 1 mode desirable
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust cos
autoos voip trust
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust cos
auto qos voip trust
!
interface FastEthernet0/7
no switchport
ip address 192.168.1.9 255.255.255.252
!
interface FastEthernet0/8
switchport access vlan 539
shutdown
!
interface FastEthernet0/9
switchport access vlan 539

CCNP3: Building Multilayer Switched Networks PAGE 46 OF 66


GROUP3: CASE STUDY 3

shutdown
!
interface FastEthernet0/10
switchport access vlan 539
shutdown
!
interface FastEthernet0/11
switchport access vlan 539
shutdown
!
interface FastEthernet0/12
switchport access vlan 539
shutdown
!
interface FastEthernet0/13
switchport access vlan 539
shutown
!
interface FastEthernet0/14
switchport access vlan 539
shutdown
!
interface FastEthernet0/15
switchport access vlan 539
shutdown
!
interface FastEthernet0/16
switchport access vlan 539
shutdown
!
interface FastEthernet0/17
switchport access vlan 539
shutdown
!
interface FastEthernet0/18
switchport access vlan 539
shutdown
!
interface FastEthernet0/19
switchport access vlan 539

CCNP3: Building Multilayer Switched Networks PAGE 47 OF 66


GROUP3: CASE STUDY 3

shutdown
!
interface FastEthernet0/20
switchport access vlan 539
shutdown
!
interface FastEthernet0/21
switchport access vlan 539
shutdown
!
interface FastEthernet0/22
switchport access vlan 30
switchport mode access
switchport port-security mac-address sticky
switchport access vlaitchport port-security maximum 1
!
interface FastEthernet0/23
switchport access vlan 30
switchport mode access
switchport port-security mac-address sticky
switchport access vlaitchport port-security maximum 1
!
interface FastEthernet0/24
switchport access vlan 30
switchport mode access
switchport port-security mac-address sticky
switchport access vlaitchport port-security maximum 1
!
interface GigabitEthernet0/1
switchport access vlan 539
shutdown
interface GigabitEthernet0/2
switchport access vlan 539
shutdown
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.1.10.20 255.255.255.0

CCNP3: Building Multilayer Switched Networks PAGE 48 OF 66


GROUP3: CASE STUDY 3

!
interface Vlan20
ip address 10.1.20.20 255.255.255.0
!
interface Vlan30
ip address 10.1.30.20 255.255.255.0
standby 30 ip 10.1.30.1
standby 30 priority 110
standby 30 preempt
standby 30 track FastEthernet0/7
!
interface Vlan150
ip address 10.1.150.20 255.255.255.0
standby 150 ip 10.1.150.1
standby 150 priority 110
standby 150 preempt
standby 150 track FastEthernet0/7
!
interface Vlan217
ip address 10.1.217.20 255.255.255.0
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.10
ip http server
!
control-plane
!
line con 0
password 7 13061E010803
logging synchronous
line vty 0 4
password 7 login
length 0
line vty 5 15
password 7 13061E010803
login

CCNP3: Building Multilayer Switched Networks PAGE 49 OF 66


GROUP3: CASE STUDY 3

length 0
!
end

4.5. ALS1
hostname ALS1
!
enable secret 5 $1$zQiP$.u.F09z8vMld1csf9Hfmb.
!
no aaa new-model
ip subnet-zero
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srs-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 52 53 54 55

CCNP3: Building Multilayer Switched Networks PAGE 50 OF 66


GROUP3: CASE STUDY 3

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63


mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
no file verify auto
!
spanning-tree mode mst
spanning-tree portfast default
spanning-tree portfast bpduguard default
spanning-tree extend system-id
!
spanning-tree mst configuration
name CS3
revision 1
instance 1 vlan 10, 20, 217
instance 2 vlan 1, 30, 150, 1002-1005
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport mode trunk
!
interface FastEthernet0/1
switchport access vlan 539
shutdown
!
interface FastEthernet0/2

CCNP3: Building Multilayer Switched Networks PAGE 51 OF 66


GROUP3: CASE STUDY 3

switchport access vlan 539


shutdown
shutdown
!
interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/4
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/5
switchport mode trunk
!
intet0/6
switchport mode trunk
!
interface FastEthernet0/7
switchport mode trunk
!
interface FastEthernet0/8
switchport mode trunk
!
interface FastEthernet0/9
switchport access vlan 539
shutdown
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
switchport access vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast

CCNP3: Building Multilayer Switched Networks PAGE 52 OF 66


GROUP3: CASE STUDY 3

!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!

CCNP3: Building Multilayer Switched Networks PAGE 53 OF 66


GROUP3: CASE STUDY 3

interface FastEthernet0/14
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
switchport voice vlan 150
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access

CCNP3: Building Multilayer Switched Networks PAGE 54 OF 66


GROUP3: CASE STUDY 3

switchport voice vlan 150


switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls uto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwi shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2

CCNP3: Building Multilayer Switched Networks PAGE 55 OF 66


GROUP3: CASE STUDY 3

switchport port-security mac-address sticky


srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 539
shutdown
!
interface FastEthernet0/22
switchport access vlan 539
shutdown
!
interface FastEthernet0/23
switchport access vlan 539
shutdown
!
interface FastEthernet0/24
switchport mode trunk
!
interface GigabitEthernet0/1
switchport access vlan 539
shutdown
!
interface GigabitEthernet0/2
switchport access vlan 539
shutdown
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan217
ip address 10.1.217.30 255.255.255.0
no ip route-cache
!
ip default-gateway 10.1.217.1

CCNP3: Building Multilayer Switched Networks PAGE 56 OF 66


GROUP3: CASE STUDY 3

ip http server
!
control-plane
!
line con 0
password 7 02050D480809
logging synchronous
login
line vty 0 4
password 7 02050D480809
login
length 0
line vty 0 15
password 7 02050D480809
login
length 0
!
end

4.6. ALS2
hostname ALS2
!
enable secret 5 $1$2TtX$T/gr4Imf.jp5YOBg21MXP1
!
no aaa new-model
ip subnet-zero
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7

CCNP3: Building Multilayer Switched Networks PAGE 57 OF 66


GROUP3: CASE STUDY 3

mls qos srr-queue input dscp-map queue 1 threshold 3 32


mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39 21 22 23
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
!
spanning-tree mode mst
spanning-tree extend systeg-tree mst configuration
name CS3
revision 1
instance 1 vlan 10, 20, 217

CCNP3: Building Multilayer Switched Networks PAGE 58 OF 66


GROUP3: CASE STUDY 3

instance 2 vlan 1, 30, 150, 100vlan internal allocation policy ascending


!
interface Port-channel1
switchport mode trunk
!

interface FastEthernet0/1
switchport access vlan 539
shutdown
!
interface FastEthernet0/2
switchport access vlan 539
shutdown
!
interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/4
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/5
switchport mode trunk
!
interface FastEthernet0/6
switchport mode trunk
!
interface FastEthernet0/7
switchport mode trunk
!
interface FastEthernet0/8
switchport mode trunk
!
interface FastEthernet0/9
switchport access vlan 539
shutdown
!
interface FastEthernet0/10
switchport access vlan 10

CCNP3: Building Multilayer Switched Networks PAGE 59 OF 66


GROUP3: CASE STUDY 3

switchport mode access


switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls q auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2

CCNP3: Building Multilayer Switched Networks PAGE 60 OF 66


GROUP3: CASE STUDY 3

switchport port-security mac-address sticky


srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20

CCNP3: Building Multilayer Switched Networks PAGE 61 OF 66


GROUP3: CASE STUDY 3

srr-queue bandwidth shape 10 0 0 0


mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0

CCNP3: Building Multilayer Switched Networks PAGE 62 OF 66


GROUP3: CASE STUDY 3

mls qos trust device cisco-phone


mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
switchport voice vlan 150
switchport port-security maximum 2
switchport port-security mac-address sticky
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone

CCNP3: Building Multilayer Switched Networks PAGE 63 OF 66


GROUP3: CASE STUDY 3

mls qos trust cos


auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 539
shutdown
!
interface FastEthernet0/24
switchport access vlan 539
shutdown
!
interface GigabitEthernet0/1
switchport access vlan 539
shutdown
!
interface GigabitEthernet0/2
switchport access vlan 539
shutdown
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan217
ip address 10.1.217.40 255.255.255.0
no ip route-cache
!
ip default-gateway 10.1.217.1
ip http server
!
control-plane
!
line con 0
password 7 121A0C041104
logging synchronous
login
line vty 0 4
password 7 070C285F4D06
login

CCNP3: Building Multilayer Switched Networks PAGE 64 OF 66


GROUP3: CASE STUDY 3

length 0
line vty 5 15
password 7 070C285F4D06
login
length 0
!
end

CCNP3: Building Multilayer Switched Networks PAGE 65 OF 66


GROUP3: CASE STUDY 3

5. REFERENCES
Cisco Systems, Inc. 2010, Hot Standby Router Protocol Features and Functionality, viewed 8
May 2010,
<http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094a91.sht
ml#subinterfaces>.

CCNP3: Building Multilayer Switched Networks PAGE 66 OF 66

You might also like