7.1.2 Lab - Implement Multi-Area OSPFv2
7.1.2 Lab - Implement Multi-Area OSPFv2
Topology
Addressing Table
Device Interface IPv4 Address
R1 G0/0/0 172.16.0.2/30
R1
G0/0/1 10.10.0.1/30
R2 Lo0 209.165.200.225/27
R2
G0/0/0 172.16.0.1/30
R2
G0/0/1 172.16.1.1/30
R3 G0/0/0 172.16.1.2/30
R3
G0/0/1 10.10.4.1/30
D1 G1/0/11 10.10.0.2/30
D1
G1/0/23 10.10.1.1/24
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
D2 G1/0/11 10.10.4.2/30
D2
G1/0/23 10.10.5.1/24
PC1 NIC 10.10.1.10/24
PC2 NIC 10.10.5.10/24
Objectives
Part 1: Build the Network and Configure Basic Device Settings and Interface Addressing
Part 2: Configure and Verify Multiarea OSPF for IPv4 on R1, D1, and D2
Part 3: Exploring Link State Announcements
Background / Scenario
To make OSPF more efficient and scalable, OSPF supports hierarchical routing using the areas. An OSPF
area is a group of routers that share the same link-state information in their link-state databases (LSDBs).
When a large OSPF area is divided into smaller areas, it is called multiarea OSPF. Multi-area OSPF is useful
in larger network deployments to reduce processing and memory overhead.
In this lab you will configure multiarea OSPF version 2 for IPv4. This lab was specifically designed to use
three routers and two Layer 3 switches.
Note: This lab is an exercise in developing, deploying, and verifying how multiarea OSPF operates and does
not reflect networking best practices.
Note: The routers used with this CCNP hands-on lab is a Cisco 4221and the two Layer 3 switches are
Catalyst 3560 switches. Other routers and Layer 3 switches and Cisco IOS versions can be used. Depending
on the model and Cisco IOS version, the commands available and the output produced might vary from what
is shown in the labs.
Note: Ensure that the routers and switches have been erased and have no startup configurations. If you are
unsure contact your instructor.
Required Resources
3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
2 Switches (Cisco 3650 with Cisco IOS XE Release 16.9.4 universal image or comparable)
2 PCs (Windows with terminal emulation program, such as Tera Term)
Console cables to configure the Cisco IOS devices via the console ports
Ethernet cables as shown in the topology
Instructions
Part 1: Build the Network and Configure Basic Device Settings and Interface
Addressing
In Part 1, you will set up the network topology and configure basic settings and interface addressing on the
routers and Layer 3 switches.
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
Router R1
hostname R1
no ip domain lookup
line con 0
logging sync
exec-time 0 0
exit
banner motd # This is R1, Implement Multi-Area OSPFv2 Lab #
interface g0/0/0
ip add 172.16.0.2 255.255.255.252
no shut
exit
interface GigabitEthernet0/0/1
ip address 10.10.0.1 255.255.255.252
no shut
exit
Router R2
hostname R2
no ip domain lookup
line con 0
logging sync
exec-time 0 0
exit
banner motd # This is R2, Implement Multi-Area OSPFv2 Lab #
interface g0/0/0
ip add 172.16.0.1 255.255.255.252
no shut
exit
interface GigabitEthernet0/0/1
ip address 172.16.1.1 255.255.255.252
no shut
exit
interface lo0
ip add 209.165.200.225 255.255.255.224
exit
Router R3
hostname R3
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
no ip domain lookup
line con 0
logging sync
exec-time 0 0
exit
banner motd # This is R3, Implement Multi-Area OSPFv2 Lab #
interface g0/0/0
ip add 172.16.1.2 255.255.255.252
no shut
exit
interface GigabitEthernet0/0/1
ip address 10.10.4.1 255.255.255.252
no shut
exit
Switch D1
hostname D1
no ip domain lookup
line con 0
exec-timeout 0 0
logging synchronous
exit
banner motd # This is D1, Implement Multi-Area OSPFv2 Lab #
interface g1/0/11
no switchport
ip address 10.10.0.2 255.255.255.252
no shut
exit
interface g1/0/23
no switchport
ip address 10.10.1.1 255.255.255.0
no shut
exit
Switch D2
hostname D2
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
no ip domain lookup
line con 0
logging sync
exec-time 0 0
exit
banner motd # This is D2, Implement Multi-Area OSPFv2 Lab #
interface g1/0/11
no switchport
ip address 10.10.4.2 255.255.255.252
no shut
exit
interface g1/0/23
no switchport
ip address 10.10.5.1 255.255.255.0
no shut
exit
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
All five devices should be able to reach the other directly connected networks. Troubleshoot if necessary.
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
D1(config)# ip routing
b. Next, enter the OSPF router configuration mode using process ID 123, assign D1 the router ID 1.1.1.2.
You will also set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet
interfaces. Changing the reference bandwidth to a higher value allows for a differentiation of cost between
higher-speed interfaces.
D1(config)# router ospf 123
D1(config-router)# router-id 1.1.1.2
D1(config-router)# auto-cost reference-bandwidth 1000
% OSPF: Reference bandwidth is changed.
Please ensure reference bandwidth is consistent across all routers.
Note: Setting the reference cost value too high may cause issues with low-bandwidth interfaces.
c. Configure D1 to advertise the FastEthernet 0/5 interface 10.10.0.0/30 network in OSPF Area 1. The
wildcard mask can be calculated by deducting the subnet mask (i.e., /30 = 255.255.255.252) from
255.255.255.255, resulting in a wildcard mask of 0.0.0.3.
D1(config-router)# network 10.10.0.0 0.0.0.3 area 1
d. Next, configure D1 to advertise its Fa0/23 interface 10.10.1.0/24 network in OSPF Area 1 and return to
privileged EXEC mode.
D1(config-router)# network 10.10.1.0 0.0.0.255 area 1
D1(config-router)# end
e. Verify the OSPF configuration on D1 using the show ip protocols command.
D1# show ip protocols
*** IP Routing is NSF aware ***
The output confirms the router ID, and the number of areas, and the networks advertised. Notice there
are no Routing Information Sources because there are no OSPF neighbors.
f. Verify the OSPF interfaces using the show ip ospf interface brief command.
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output confirms that both G1/0/11 and G1/0/23 interfaces were correctly assigned to Area 1.
g. Finally, verify the OSPF routes in the routing table using the show ip route ospf command.
D1# show ip route ospf
Close configuration window
Notice that no routes are displayed. This is because D1 does not yet have an OSPF neighbor.
Notice the informational message stating that a neighbor adjacency has been established with D1 (i.e.,
1.1.1.2).
d. Verify the OSPF configuration on R1 using the show ip protocols command.
R1# show ip protocols | begin ospf
Routing Protocol is "ospf 123"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 1.1.1.1
It is an area border router
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.10.0.0 0.0.0.3 area 1
172.16.0.0 0.0.0.3 area 0
Routing Information Sources:
Gateway Distance Last Update
1.1.1.2 110 00:07:55
Distance: (default is 110)
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 8 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
Like the previous output of D1, this output confirms the router ID, and the networks advertised. However,
notice that it also explicitly states that R1 is an area border router (ABR), that it is in two areas, and that it
has established an adjacency and exchanged routing information with D2 (i.e., 1.1.1.2).
e. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command.
R1# show ip ospf | begin Ref
Reference bandwidth unit is 1000 mbps
Area BACKBONE(0) (Inactive)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:14:41.606 ago
SPF algorithm executed 2 times
Area ranges are
Number of LSA 3. Checksum Sum 0x01ABED
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 1
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:15:07.141 ago
SPF algorithm executed 5 times
Area ranges are
Number of LSA 4. Checksum Sum 0x0292B8
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
The output confirms that the reference bandwidth has been changed to distinguish GigabitEthernet
interfaces. The output also confirms that R1 is in two areas and has two link-state databases (LSDBs).
Note: Area 0 is currently inactive because there are no other peers configured yet.
f. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.
R1# show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Gi0/0/0 123 0 172.16.0.2/30 1 DR 0/0
Gi0/0/1 123 1 10.10.0.1/30 1 BDR 1/1
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 9 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output confirms that R1 has one neighbor (i.e., 1.1.1.2 = D1), they have a full adjacency established,
the IP address of D1 is 10.10.0.2, and R1 can reach D1 using its G0/0/1 interface.
h. Use the show ip ospf neighbor detail command to get additional information about neighbor
adjacencies.
R1# show ip ospf neighbor detail
Neighbor 1.1.1.2, interface address 10.10.0.2, interface-id 38
In the area 1 via interface GigabitEthernet0/0/1
Neighbor priority is 1, State is FULL, 6 state changes
DR is 10.10.0.2 BDR is 10.10.0.1
Options is 0x12 in Hello (E-bit, L-bit)
Options is 0x52 in DBD (E-bit, L-bit, O-bit)
LLS Options is 0x1 (LR)
Dead timer due in 00:00:34
Neighbor is up for 00:19:09
Index 1/1/1, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0)/0x0(0) Next 0x0(0)/0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
As shown, the output confirms various information about the OSPF neighbor including DR and BDR
status.
i. Verify the OSPF routes in the routing table using the show ip route ospf command.
R1# show ip route ospf | begin Gateway
Gateway of last resort is not set
The output displays an entry for the D1 LAN. The O designation identifies this as an OSPF internal route.
Network routes learned from other OSPF routers in the same area are known as intra-area routes and are
identified in the IP routing table with an O.
j. Finally, get detailed information on how R1 learned about the OSPF entry using the show ip route ospf
10.10.1.0 command.
R1# show ip route 10.10.1.0
Routing entry for 10.10.1.0/24
Known via "ospf 123", distance 110, metric 11, type intra area
Last update from 10.10.0.2 on GigabitEthernet0/0/1, 00:25:25 ago
Routing Descriptor Blocks:
* 10.10.0.2, from 1.1.1.2, 00:25:25 ago, via GigabitEthernet0/0/1
Route metric is 11, traffic share count is 1
The output confirms that R1 learned about the intra-area route 10.10.1.0 from 10.10.0.2 with a router ID
of 1.1.1.2 in OSPF 123.
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 10 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output confirms that an adjacency has been established with R1 (i.e., 1.1.1.1).
Note: Alternatively, the two network statements could be combined using network 17.16.0.0 0.0.1.3
area 0.
c. Configure R2 to propagate a default route to the internet. In our lab, the internet is represented as a
loopback interface.
R2(config-router)# default-information originate
R2(config-router)# exit
R2(config)# ip route 0.0.0.0 0.0.0.0 lo0
%Default route without gateway, if not a point-to-point interface, may impact
performance
R2(config)# exit
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 11 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
Again, this output confirms the router ID chosen, number of areas R2 is in (i.e., 1), networks advertised,
and that it has established an adjacency and exchanged routing information with R1 (i.e., 1.1.1.1). R2
does not have an adjacency with D1 because it is in another area.
Notice as well, that it explicitly states that R2 is an autonomous system boundary router (ASBR). This is
because it is now propagating a default route to all other routers in the OSPF domain.
e. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command as
shown.
R2# show ip ospf | begin Ref
Reference bandwidth unit is 1000 mbps
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:02:27.531 ago
SPF algorithm executed 5 times
Area ranges are
Number of LSA 5. Checksum Sum 0x01C25B
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
The output confirms that the reference bandwidth has been changed and also confirms that R2 has two
interfaces in its link-state database (LSDB).
f. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.
R2# show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Gi0/0/1 123 0 172.16.1.1/30 1 DR 0/0
Gi0/0/0 123 0 172.16.0.1/30 1 BDR 1/1
The output confirms that the two interfaces are in Area 0, their IP addresses, state, and neighbors.
g. Verify which OSPF neighbors R2 has established an adjacency using the show ip ospf neighbor
command.
R2# show ip ospf neighbor
The output confirms that R2 has one neighbor (i.e., 1.1.1.1 = R1) and they have a full adjacency
established.
h. Use the show ip ospf neighbor detail command to get additional information about neighbor
adjacencies.
R2# show ip ospf neigh detail
Neighbor 1.1.1.1, interface address 172.16.0.2, interface-id 5
In the area 0 via interface GigabitEthernet0/0/0
Neighbor priority is 1, State is FULL, 6 state changes
DR is 172.16.0.2 BDR is 172.16.0.1
Options is 0x12 in Hello (E-bit, L-bit)
Options is 0x52 in DBD (E-bit, L-bit, O-bit)
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 12 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
As shown, the output confirms various information about the OSPF neighbor including DR and BDR
status.
i. Verify the OSPF routes in the routing table using the show ip route ospf command.
R2# show ip route ospf | begin Gateway
The output displays that there is now a default gateway and two entries for the OSPF Area 1 networks.
Notice how these routes are identified as O IA which means they are routes from another area. Network
routes learned from OSPF routers in another area using an ABR are known as interarea routes as
opposed to intra-area routes.
j. Verify the static route entry in the routing table.
R2# show ip route static | begin Gateway
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
k. Finally, get detailed information on how R2 learned about the OSPF entry using the show ip route ospf
10.10.1.0 command.
R2# show ip route 10.10.1.0
Routing entry for 10.10.1.0/24
Known via "ospf 123", distance 110, metric 12, type inter area
Last update from 172.16.0.2 on GigabitEthernet0/0/0, 00:31:08 ago
Routing Descriptor Blocks:
* 172.16.0.2, from 1.1.1.1, 00:31:08 ago, via GigabitEthernet0/0/0
Route metric is 12, traffic share count is 1
The output confirms that R2 learned about the interarea route 10.10.1.0 from OSPF 123 and specifically
from R1, based on the router ID of 1.1.1.1.
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 13 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output confirms the router ID, and that R3 is an ABR, it has interfaces in two areas, the networks it is
advertising, and that R3 has R1 (i.e., 1.1.1.1) and R2 (i.e., 2.2.2.1) as sources of routing information.
d. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command as
shown.
R3# show ip ospf | begin Ref
Reference bandwidth unit is 1000 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:10:38.256 ago
SPF algorithm executed 4 times
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 14 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output confirms that the reference bandwidth has been changed and also confirms that R2 has area
information for Area 0 and Area 2.
e. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.
R3# show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Gi0/0/0 123 0 172.16.1.2/30 1 BDR 1/1
Gi0/0/1 123 2 10.10.4.1/30 1 DR 0/0
The output confirms the interfaces, process ID, areas, IP addresses, cost, state, and neighbors.
f. Verify which OSPF neighbors R2 has established an adjacency with using the show ip ospf neighbor
command.
R3# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.1 1 FULL/DR 00:00:31 172.16.1.1 GigabitEthernet0/0/0
The output confirms that R3 has one neighbor (i.e., 2.2.2.1= R2) and they have a full adjacency
established.
g. Use the show ip ospf neighbor detail command to get additional information about neighbor
adjacencies.
R3# show ip ospf neighbor detail
Neighbor 2.2.2.1, interface address 172.16.1.1, interface-id 6
In the area 0 via interface GigabitEthernet0/0/0
Neighbor priority is 1, State is FULL, 6 state changes
DR is 172.16.1.1 BDR is 172.16.1.2
Options is 0x12 in Hello (E-bit, L-bit)
Options is 0x52 in DBD (E-bit, L-bit, O-bit)
LLS Options is 0x1 (LR)
Dead timer due in 00:00:37
Neighbor is up for 00:21:50
Index 1/1/1, retransmission queue length 0, number of retransmission 0
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 15 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
As shown, the output confirms various information about the OSPF neighbor including DR and BDR
status.
h. Verify the OSPF routes in the routing table using the show ip route ospf command.
R3# show ip route ospf | begin Gateway
Gateway of last resort is 172.16.1.1 to network 0.0.0.0
The output verifies that R3 has received a default route from R2, two interarea routes (i.e., O IA routes)
and one intra-area OSPF route (i.e., O routes). The O*E2 route indicates that this is an external route that
did not originate in OSPF. The asterisk identifies this as a candidate default route.
i. Now get detailed information on how R3 learned about the O E2 and O IA routes.
R3# show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "ospf 123", distance 110, metric 1, candidate default path
Tag 123, type extern 2, forward metric 1
Last update from 172.16.1.1 on GigabitEthernet0/0/0, 00:28:41 ago
Routing Descriptor Blocks:
* 172.16.1.1, from 2.2.2.1, 00:28:41 ago, via GigabitEthernet0/0/0
Route metric is 1, traffic share count is 1
Route tag 123
The output confirms that R3 learned about the default route from R2 (2.2.2.1) and interarea routes from
R1 (1.1.1.1) via OSPF.
Close configuration window
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 16 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
D2(config)# ip routing
b. Next, enter the OSPF router configuration mode using process ID 123, assign the D2 the router ID
3.3.3.2, and set the reference bandwidth to distinguish between Gigabit Ethernet and FastEthernet
interfaces.
D2(config)# router ospf 123
D2(config-router)# router-id 3.3.3.2
D2(config-router)# auto-cost reference-bandwidth 1000
% OSPF: Reference bandwidth is changed.
Please ensure reference bandwidth is consistent across all routers.
c. Configure D2 to advertise its interfaces in OSPF Area 2 and return to privileged EXEC mode.
D2(config-router)# network 10.10.4.0 0.0.0.3 area 2
D2(config-router)# network 10.10.5.0 0.0.0.255 area 2
D2(config-router)# end
D2#
*Mar 1 01:52:03.888: %OSPF-5-ADJCHG: Process 123, Nbr 3.3.3.1 on
GigabitEthernet1/0/11 from LOADING to FULL, Loading Done
As expected, we can verify the router ID, number of areas, networks being advertised, and routing
sources. It may be surprising that R2 (i.e., 2.2.2.1) is displayed as a routing source. The reason is
because it is the source of the default route.
e. Verify that the reference bandwidth has been changed using the show ip ospf | begin Ref command as
shown.
D2# show ip ospf | begin Ref
Reference bandwidth unit is 1000 mbps
Area 2
Number of interfaces in this area is 2
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 17 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
f. Verify the active OSPF interfaces and assigned areas using the show ip ospf interface brief command.
D2# show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Gi1/0/23 123 2 10.10.5.1/24 10 DR 0/0
G11/0/11 123 2 10.10.4.2/30 1 BDR 1/1
The output confirms that the two interfaces are in Area 2 and their IP addresses are correct.
g. Verify which OSPF neighbors D2 has established an adjacency with using the show ip ospf neighbor
command.
D2# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.1 1 FULL/BDR 00:00:33 10.10.4.1 GigabitEthernet1/0/11
The output confirms that D2 has one neighbor (i.e., 3.3.3.1= R3) and they have a full adjacency
established.
h. Verify the OSPF routes in the routing table using the show ip route ospf | begin Gateway command.
D2# show ip route ospf | begin Gateway
Gateway of last resort is 10.10.4.1 to network 0.0.0.0
The output displays four interarea routes (i.e., O IA routes) and the OSPF external route from 2.2.2.1(R2).
D2# show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "ospf 123", distance 110, metric 1, candidate default path
Tag 123, type extern 2, forward metric 2
Last update from 10.10.4.1 on GigabitEthernet1/0/11, 00:18:31 ago
Routing Descriptor Blocks:
* 10.10.4.1, from 2.2.2.1, 00:18:31 ago, via GigabitEthernet1/0/11
Route metric is 1, traffic share count is 1
Route tag 123
As we can see, the routing source for the default route is R2 (i.e., 2.2.2.1).
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 18 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
C:\Users\Student> ipconfig
1 1 ms 1 ms 1 ms 10.10.1.1
2 <1 ms <1 ms <1 ms 10.10.0.1
3 1 ms <1 ms <1 ms 172.16.0.1
4 1 ms 1 ms <1 ms 172.16.1.2
5 1 ms 2 ms 2 ms 10.10.4.2
6 1 ms <1 ms <1 ms DESKTOP-3RF7RKA [10.10.5.10]
Trace complete.
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 19 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 20 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output confirms that R1 (i.e., 1.1.1.1) is a neighbor and is the BDR on the link. Therefore, D1 must be
the DR.
b. Verify the OSPF routing table using the show ip router ospf | begin Gateway command.
D1# show ip route ospf | begin Gateway
The routing table lists the four interarea networks and one external OSPF network.
c. D1 learned about these networks from LSAs. A router maintains a LSDB for each area it has interfaces in.
Because D1 is an internal OSPF router, it will only have entries for Area 1. To display the contents of the
LSDB of D1, use the show ip ospf database command.
D1# show ip ospf database
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 21 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
Notice how the command output is divided into the following five sections:
o Router Link States – These are the type 1 LSAs received by D1 and they identify the routers
(i.e., 1.1.1.1 = R1, 1.1.1.2 = D1) in Area 1 that sent them, and the number of links that the routers
have in the area. Therefore, R1 only has one interface in Area 1 and D1 has 2 interfaces in Area 1.
o Net Link States – These are the type 2 LSAs generated by the DR. In our example, the DR is
1.1.1.2 (i.e., D1) on the link 10.10.0.2.
o Summary Net Link States – These are the type 3 LSAs describing remote networks (i.e., our O
IA networks or interarea routes) and the router that advertised them to D1.
o Summary ASB Link States – This is a type 4 LSA sent by the ABR (i.e., 1.1.1.1 = R1)
advertising that there is an ASBR in the network (i.e., 2.2.2.1).
o Type-5 AS External Link States – This is a type 5 LSA advertising a default route (i.e., 0.0.0.0)
and the router that is advertising it (i.e., 2.2.2.1).
d. Additional information about the Router Link States type 1 LSA can be gathered using the show ip ospf
database router command.
D1# show ip ospf database router
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 22 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
LS age: 1196
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 1.1.1.2
Advertising Router: 1.1.1.2
LS Seq Number: 80000006
Checksum: 0x18A7
Length: 48
Number of Links: 2
The output provides more information about the type 1 LSAs. The first router link (i.e., type 1) LSA is from
R1 (i.e., 1.1.1.1). It is an ABR with only 1 link in Area 1 which is the transit network connecting to D1. The
second router link portion identifies the transit network connecting to R1 and the stub network of D1 (i.e.,
10.10.1.0/24).
An OSPF link can be connected to a stub, to another router (point-to-point), or to a transit network. The
transit network usually describes an Ethernet segment which can include two or more routers. If the link is
connected to a transit network, the LSA also includes the IP address of the DR.
e. To learn more about type 2 network LSAs, use show ip ospf database network command.
D1# show ip ospf database network
LS age: 845
Options: (No TOS-capability, DC)
LS Type: Network Links
Link State ID: 10.10.0.2 (address of Designated Router)
Advertising Router: 1.1.1.2
LS Seq Number: 80000005
Checksum: 0xB064
Length: 32
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 23 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
LS age: 987
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 10.10.4.0 (summary Network Number)
Advertising Router: 1.1.1.1
LS Seq Number: 80000005
Checksum: 0xA271
Length: 28
Network Mask: /30
MTID: 0 Metric: 3
LS age: 987
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 10.10.5.0 (summary Network Number)
Advertising Router: 1.1.1.1
LS Seq Number: 80000005
Checksum: 0xEF7
Length: 28
Network Mask: /24
MTID: 0 Metric: 13
LS age: 988
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(Network)
Link State ID: 172.16.0.0 (summary Network Number)
Advertising Router: 1.1.1.1
LS Seq Number: 80000005
Checksum: 0xD5A4
Length: 28
Network Mask: /30
MTID: 0 Metric: 1
LS age: 989
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 24 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output lists four type 3 LSAs. The LSAs identify the interarea networks, which ABR advertised, and
the network mask using CIDR notation.
g. To learn more about type 4 summary LSAs, use show ip ospf database asbr-summary command.
D1# show ip ospf database asbr-summary
LS age: 591
Options: (No TOS-capability, DC, Upward)
LS Type: Summary Links(AS Boundary Router)
Link State ID: 2.2.2.1 (AS Boundary Router address)
Advertising Router: 1.1.1.1
LS Seq Number: 80000006
Checksum: 0xB20
Length: 28
Network Mask: /0
MTID: 0 Metric: 1
The output lists one type 4 LSA advertised by R1 identifying 2.2.2.1 as an ASBR.
h. Finally, to learn more about type 5 AS external link LSAs, use show ip ospf database external
command.
D1# show ip ospf database external
LS age: 1024
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 0.0.0.0 (External Network Number )
Advertising Router: 2.2.2.1
LS Seq Number: 80000006
Checksum: 0x9794
Length: 36
Network Mask: /0
Metric Type: 2 (Larger than any link state path)
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 25 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
TOS: 0
Metric: 1
Forward Address: 0.0.0.0
External Route Tag: 123
The output lists one type 5 LSA identifying that 0.0.0.0/0 is available from 2.2.2.1 (i.e., R2).
Open configuration window
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 26 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output displays the type 1, 2, and 3 LSAs in Area 0, and then lists the type 1, 2, 3, and 4 LSAs in
Area 1. The last section displays the type 5 LSAs.
To learn more about each LSA type, use the following commands:
o show ip ospf database router
o show ip ospf database network
o show ip ospf database summary
o show ip ospf database asbr-summary
o show ip ospf database external
Close configuration window
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 27 of 28 www.netacad.com
Lab - Implement Multi-Area OSPFv2
The output displays the type 1, 2, 3 and 5 LSAs in Area 0. Notice that there is no type 4 LSA because R2
is the ASBR and only an ABR can generate an LSA4.
Close configuration window
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many
interfaces the router has. There is no way to effectively list all the combinations of configurations for each router
class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.
The table does not include any other type of interface, even though a specific router may contain one. An example
of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in
Cisco IOS commands to represent the interface.
End of document
2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 28 of 28 www.netacad.com