Practical No.4: Routing Information Protocol - RIP
Practical No.4: Routing Information Protocol - RIP
4
Q4) Configure IP routing using RIP.
For example, all routers are running RIP and network 10.0.0.0 goes down.
After hold timer expires, that network will be advertised by metric 16 and everyone will know that
the network is down and that network will be seen in routing table as possibly down.
4.Both RIPv1 and RIPv2 send routing updates or complete routing table or broadcast every 30
seconds. i.e. The default routing update period for both version of RIP is 30 seconds. i.e. Both have
the same timers.
5.Both RIPv1 and RIPv2 use split horizon to prevent routing loops.
7.network command tells both RIPv1 and RIPv2 to send hellos, out an interface, to find neighbors
and to advertise routes.
R1(config-router)#network ?
A.B.C.D Network number
R1(config-router)#network 172.16.0.0 ?
<cr>
R1(config-router)#^Z
R1#
The first number in the brackets is the administrative distance of the information source.
The second number is the metric for the route.
In this case, the administrative distance is 120, default AD for RIP routes, and the 3 represents the
metric, which is the number of router hops in RIP.
Difference
1. RIPv1 used broadcast. RIPv2 used multicast(224.0.0.9).
2. RIPv1 is a classful.(Classful: all subnet mask must be the same in the network.) RIPv2 is a classless.
3. RIPv1 does not support VLSM. RIPv2 supports VLSM. subnet mask field was added to the RIPv2
message header by RFC 1723 to add support for VLSM and CIDR.
5. RIP enabled interfaces send version 1(RIPv1) updates.Do not send version 2(RIPv2) updates.
RIP enabled interfaces receive any version(RIPv1 and RIPv2).
6. RIPv2 sends the subnet mask in updates and RIPv1 does not. i.e. Subnet mask information is
included in RIPv2 routing updates that is not included in RIPv1.
4. RIPv2 is classless routing protocol means that it sends subnet mask information when updates.
By sending the subnet mask information with the updates, RIPv2 can support Variable Length
Subnet Mask(VLSMs) as well as the summarization of network boundaries.
3.RIPv1 and RIPv2 work only on hop count(not consider the bandwith).
1.The command show ip route followed by the protocol will show that protocol's route from the
entire routing table.
2.The command show protocols is used to view the RIP routing protocol settings and configuration.
3.The command show ip rip database will display RIP routing updates or RIP routing information as
they are sent and received. But to see the updates in real time, we need command Debug not Show.
But don't do debug ip rip, don't do debug all. It may crash your router.Because all possible debugs
will start and consume router's whole processing and memory.
4.If The command Router(config-router)# version 2 is entered on the routers, only version 2 updates
are sent to 224.0.0.9.
5.If The command Router(config-router)# no version 2 is entered on the routers, version 1 and 2
updates will be received and the version 2 updates will not be sent.
6.The command debug ip rip shows the routes being advertised in RIP updates and the metrics of
these routes. i.e. debug ip rip will display RIP activity as it occurs on a router.
R1#debug ip rip
7.The command clear ip route * should apply after the command debug ip rip to clear the routing
table of its dynamic routes.
R1#clear ip route *
R1#undebug all
9.To turn off specific debugs, run the command no debug followed by the type of debug you want to
turn off.
Putting three IP addresses, subnet mask and default gateway to three PCs.
Click PC1/ Desktop/IP Configuration /Static
Click PC2/ Desktop/IP Configuration /Static
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R1
R1(config)#int fa 0/1
R1(config-if)#ip address 172.16.0.1 255.255.0.0
R1(config-if)#no shut
R1(config-if)#int fa 1/0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shut
R1(config)#int fa 0/0
R1(config-if)#ip address 100.0.0.1 255.255.255.252
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#
Configure Router R2
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host R2
R2(config)#int fa 0/0
R2(config-if)#ip address 100.0.0.2 255.255.255.252
R2(config-if)#no shut
R2(config)#int fa 0/1
R2(config-if)#ip address 10.0.0.1 255.0.0.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#
Configure RIPv1 to router R1Here we put all three network those are connected to R1 router.
A numeric value is required for EIGRP, OSPF. With EIGRP, AS number, with OSPF, the process
number, but RIP, there is no number.
R1(config)#router rip
R1(config-router)#network ?
A.B.C.D Network number
R1(config-router)#network 172.16.0.0 ?
<cr>
R1(config-router)#network 172.16.0.0
R1(config-router)#network 192.168.0.0
R1(config-router)#network 100.0.0.0
R1(config-router)#^Z
R1#
R2(config)#router rip
R2(config-router)#network ?
A.B.C.D Network number
R2(config-router)#network 100.0.0.0
R2(config-router)#network 10.0.0.0
R2(config-router)#^Z
R2#
R1#show ip route
R2#show ip route
PC>ping 10.0.0.2
PC>
PC>
PC>
PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
PC>