0% found this document useful (0 votes)
77 views

Lab Experiment 1 One Router 2 Switches and 4 PCS: Pc0 Ip Configuration

The document describes a lab experiment involving 3 routers, 3 computers, and dynamic routing protocols. Router 0 is connected to network 10.0.0.0 and router 1 via a serial link. Router 1 is connected to networks 20.0.0.0 and router 2 via separate serial links. Router 2 is connected to network 30.0.0.0. The CLI configurations set IP addresses for each router interface and enable a dynamic routing protocol to establish connectivity between all networks.

Uploaded by

RabiulAlam
Copyright
© © All Rights Reserved
Available Formats
Download as DOC, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
77 views

Lab Experiment 1 One Router 2 Switches and 4 PCS: Pc0 Ip Configuration

The document describes a lab experiment involving 3 routers, 3 computers, and dynamic routing protocols. Router 0 is connected to network 10.0.0.0 and router 1 via a serial link. Router 1 is connected to networks 20.0.0.0 and router 2 via separate serial links. Router 2 is connected to network 30.0.0.0. The CLI configurations set IP addresses for each router interface and enable a dynamic routing protocol to establish connectivity between all networks.

Uploaded by

RabiulAlam
Copyright
© © All Rights Reserved
Available Formats
Download as DOC, PDF, TXT or read online on Scribd
You are on page 1/ 24

Lab Experiment 1

One Router 2 Switches and 4 PCs

PC0 IP Configuration

1
PC1 IP Configuration

2
PC2 IP Configuration

3
PC3 IP Configuration

4
 Now Click on Router Router0, and then click on CLI (Command Line Interface).
 You will see like this, “Continue with configuration dialog?[yes/no]:”, Give “no” and
press Enter. Now you will go to user mode.
 Now give “enable” and press Enter. Now you get into the Privileged Mode.
 Now type “configure terminal” and press Enter to get into global configuration mode.
 Now configure router interface with ip address and subnet mask then give no shutdown to
make this interface and line protocol up.

Complete CLI Command

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

5
Router(config-if)#exit
Router(config)#interface fastethernet 0/1
Router(config-if)#ip address 172.16.0.1 255.255.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#

interface fastEthernet 0/0 command is used to enter in interface mode.

ip address 172.16.0.1 255.255.0.0 command will assign IP address to interface.

no shutdown command will bring the interface up.

exit command is used to return in global configuration mode .

Lab Experiment 2

Two Routers 2 Switches and 4 PCs (Dynamic routing)

6
PC0 IP Configuration

7
PC1 IP Configuration

8
PC2 IP Configuration

9
Complete CLI command for Router0

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface fastethernet 0/0

Router(config-if)#ip address 192.168.0.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface fastethernet 0/1

Router(config-if)#ip address 172.16.0.1 255.255.0.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#network 192.168.0.0

Router(config-router)#network 172.16.0.0

Router(config-router)#exit

Router(config)#

Complete CLI command for Router1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

10
Router(config)#interface fastethernet 0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface fastethernet 0/1

Router(config-if)#ip address 172.16.0.2 255.255.0.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#network 172.16.0.0

Router(config-router)#network 192.168.1.0

Router(config-router)#exit

Router(config)#

11
Lab Experiment 3: Static Routing (2 routers 2 computers)

Two interfaces FastEthernet0/0 and Serial0/0/0 of Router0 are used in this topology. By
default interfaces on router are remain administratively down during the start up. We need to
configure IP address and other parameters on interfaces before we could actually use them for
routing.
PC0 IP Configuration

12
PC1 IP Configuration

13
14
Complete CLI command for router0

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface fastethernet 0/0

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface serial 0/0/0

Router(config-if)#ip address 192.168.0.253 255.255.255.252

Router(config-if)#clock rate 64000

Router(config-if)#bandwidth 64

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#

Router(config)#ip route 20.0.0.0 255.0.0.0 192.168.0.254

Router(config)#

Complete CLI command for router 1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

15
Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 20.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface serial 0/0/0

Router(config-if)#ip address 192.168.0.254 255.255.255.252

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#

Router(config)#ip route 10.0.0.0 255.0.0.0 192.168.0.253

Router(config)#

interface fastEthernet 0/0 command is used to enter in interface mode.

ip address 10.0.0.2 255.0.0.0 command will assign IP address to interface.

no shutdown command will bring the interface up.

exit command is used to return in global configuration mode.

Router#configure terminal Command is used to enter in global configuration mode.

Router(config)#interface serial 0/0/0 Command is used to enter in interface mode.

Router(config-if)#ip address 192.168.0.253 255.255.255.252 Command assigns IP


address to interface. For serial link we usually use IP address from /30 subnet.
16
Router(config-if)#clock rate 64000

Router(config-if)#bandwidth 64 In real life environment these parameters control the data


flow between serial links and need to be set at service providers end. In lab environment we need
not to worry about these values. We can use these values.

Router(config-if)#no shutdown Command brings interface up.

Router(config-if)#exit Command is used to return in global configuration mode.

We will use same commands to assign IP addresses on interfaces of Router1. Since we have
provided clock rate and bandwidth on serial interface of Router0 we need not to assign them on
serial interface of Router1.

Configure Static Route

Now we know that how IP route command is used to configure the static route. Let's implement
it in our example topology. Run following command from global configuration mode in routers.

Router0

Router(config)#ip route 20.0.0.0 255.0.0.0 192.168.0.254


Router1

Router(config)#ip route 10.0.0.0 255.0.0.0 192.168.0.253

Lab Experiment 4: Dynamic Routing (3 routers 3 computers) (Serial Port)

17
18
Router 0

--- System Configuration Dialog ---

19
Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface serial 2/0
Router(config-if)#ip address 40.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#exit
Router(config)#

Router 1

20
--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: n


Press RETURN to get started!
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface serial 2/0
Router(config-if)#ip address 40.0.0.2
% Incomplete command.
Router(config-if)#ip address 40.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
This command applies only to DCE interfaces
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#interface serial 3/0
Router(config-if)#ip address 50.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 64
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down


Router(config-if)#exit
Router(config)#

Router 2
21
--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 30.0.0.1 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface serial 3/0


Router(config-if)#ip address 50.0.0.2 255.0.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 40.0.0.0
Router(config-router)#exit
Router(config)#

Router(config)#router rip
Router(config-router)#network 20.0.0.0
Router(config-router)#network 40.0.0.0
22
Router(config-router)#network 50.0.0.0
Router(config-router)#exit
Router(config)#

Router(config)#router rip
Router(config-router)#network 30.0.0.0
Router(config-router)#network 50.0.0.0
Router(config-router)#exit

Lab Experiment 5: Static Routing (3 routers 3 computers) (Serial Port)

Router 0

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 20.0.0.0 255.0.0.0 40.0.0.2
Router(config)#ip route 30.0.0.0 255.0.0.0 40.0.0.2
Router(config)

Router 1

Router#enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 10.0.0.0 255.0.0.0 40.0.0.1
Router(config)#ip route 30.0.0.0 255.0.0.0 50.0.0.2
Router(config)#exit
Router#

Router 2

23
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 10.0.0.0 255.0.0.0 50.0.0.1
Router(config)#ip route 20.0.0.0 255.0.0.0 50.0.0.1

Lab Experiment 5: Dynamic Routing (3 routers 3 computers) (Serial Port)

24

You might also like