0% found this document useful (0 votes)
183 views

Configuring Ip Sla PBR Object Tracking PDF

This document discusses configuring IP SLA PBR object tracking on Cisco Nexus devices. It allows routing to use alternate paths if the next hop is unreachable. The tracking process monitors objects like interfaces, routes, or IP SLA operations and notifies clients like PBR of any state changes. The document provides steps to configure IP SLA operations with ICMP echo probes, schedule the operations, track the operations with PBR, and configure route maps to match tracked objects and control packet routing.

Uploaded by

Aamir Raza
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
183 views

Configuring Ip Sla PBR Object Tracking PDF

This document discusses configuring IP SLA PBR object tracking on Cisco Nexus devices. It allows routing to use alternate paths if the next hop is unreachable. The tracking process monitors objects like interfaces, routes, or IP SLA operations and notifies clients like PBR of any state changes. The document provides steps to configure IP SLA operations with ICMP echo probes, schedule the operations, track the operations with PBR, and configure route maps to match tracked objects and control packet routing.

Uploaded by

Aamir Raza
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 8

Configuring IP SLA PBR Object Tracking

This chapter describes the PBR object tracking capabilities of IP Service Level Agreements (SLAs).
This chapter includes the following sections:

• IP SLA PBR Object Tracking, page 1


• Configuring IP SLA PBR Object Tracking, page 2
• Example: Configuring IP SLA PBR Object Tracking, page 6
• Feature History for IP SLA PBR Object Tracking, page 6

IP SLA PBR Object Tracking


This feature allows you to make sure that the next hop is reachable before that route is used. If the next hop
is not reachable, another route is used as defined in the policy-based routing (PBR) configuration. If no other
route is present in the route map, the routing table is used.

Object Tracking
Object tracking monitors objects such as the following:
• State of the line protocol of an interface
• Existence of an entry in the routing table

Clients, such as PBR, can register their interest in specific, tracked objects and then take action when the state
of the objects changes.

IP SLA PBR Object Tracking Overview


The PBR Object Tracking feature gives policy-based routing (PBR) access to all the objects that are available
through the tracking process. The tracking process enables you to track individual objects—such as ICMP
ping reachability, routing adjacency, an application running on a remote device, a route in the Routing
Information Base (RIB)—or to track the state of an interface line protocol.

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
OL-27603-02 1
Configuring IP SLA PBR Object Tracking
Configuring IP SLA PBR Object Tracking

Object tracking functions in the following manner: PBR informs the tracking process that a certain object
should be tracked, and the tracking process then notifies PBR when the state of that object changes.

Configuring IP SLA PBR Object Tracking


Procedure

Command or Action Purpose


Step 1 configure terminal Enters global configuration mode.

Example:
switch# configure terminal

Step 2 ip sla operation-number Starts a Cisco IOS IP Service Level Agreement


(SLA) operation configuration and enters IP SLA
Example: configuration mode.

switch(config)# ip sla 1

Step 3 icmp-echo destination-ip-address Configures an IP SLA Internet Control Message


Protocol (ICMP) echo probe operation.
Example:
switch(config-ip-sla)# icmp-echo
10.3.3.2

Step 4 exit Exits IP SLA configuration mode and returns the


router to global configuration mode.
Example:
switch(config-ip-sla)# exit

Step 5 ip sla schedule operation-number life Configures the scheduling parameters for a single
forever start-time now Cisco IOS IP SLA operation.
• In this example, the time parameters for the
Example: IP SLA operation are configured.
switch(config)# ip sla schedule 1 life
forever start-time now Note Repeat Steps 2 to 5 to configure and
schedule other IP SLA operations.
Step 6 track object-number ip sla entry-number Tracks the reachability of an object and enters
reachability tracking configuration mode.
Note Repeat this step to track other
Example: operations.
switch(config)# track 1 ip sla 1
reachability

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
2 OL-27603-02
Configuring IP SLA PBR Object Tracking
Configuring IP SLA PBR Object Tracking

Command or Action Purpose


Step 7 exit Exits tracking configuration mode and returns
the router to global configuration mode.
Example:
switch(config-track)# exit

Step 8 ip access-list standard access-list-name Defines an IP access list access control list (ACL)
in order to enable filtering for packets.
Example:
switch(config)# ip access-list standard
ACL

Step 9 permit ip source destination Creates an access control list (ACL) rule that
permits traffic matching its conditions.
Example:

switch(config-acl)# permit ip
192.0.2.0/24 198.51.100.0/24

Step 10 ipv6 access-list access-list-name Defines an IPv6 access list ACL in order to
enable filtering for packets.
Example:
switch(config)# ipv6 access-list
IPv6ACL

Step 11 permit ipv6 source destination Creates an access control list (ACL) rule that
permits traffic matching its conditions.
Example:

switch(config-ipv6-acl)# permit ipv6


2001:DB8::/32 2001:DB8::/48

Step 12 exit Exits ACL configuration mode and returns the


router to global configuration mode.
Example:
switch(config-ipv6-acl)# exit

Step 13 route-map map-tag Specifies a route map and enters route-map


configuration mode.
Example:
switch(config)# route-map PBR

Step 14 match ip address access-list-name Distributes any routes that have a destination
IPv4 network number address that is permitted
Example: by a standard access list.

switch(config-route-map)# match ip
address ACL

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
OL-27603-02 3
Configuring IP SLA PBR Object Tracking
Configuring IP SLA PBR Object Tracking

Command or Action Purpose


Step 15 match ipv6 address access-list-name Distributes any routes that have a destination
IPv6 network number address that is permitted
Example: by a standard access list.

switch(config-route-map)# match ipv6


address IPv6ACL

Step 16 set ip next-hop verify-availability Configures the route map to verify the
next-hop-address track object reachability of the tracked object.
Note Repeat this step to configure the route
Example: map to verify the reachability of other
switch(config-route-map)# set ip tracked objects.
next-hop verify-availability
198.51.100.2 track 1

Step 17 set ipv6 next-hop verify-availability Configures the route map to verify the
next-hop-address track object reachability of the tracked object.
Note Repeat this step to configure the route
Example: map to verify the reachability of other
switch(config-route-map)# set ipv6 tracked objects.
next-hop verify-availability
2001:DB8:1::1 track 1

Step 18 set ip default next-hop verify-availability Configures the route map to verify the
next-hop-address track object reachability of the default next hop.

Example:
switch(config-route-map)# set ip
default next-hop verify-availability
192.0.2.2 track 1

Step 19 set ipv6 default next-hop verify-availability Configures the route map to verify the
next-hop-address track object reachability of the default next hop.

Example:
switch(config-route-map)# set ipv6
default next-hop verify-availability
2001:DB8:0:ABCD::1 track 1

Step 20 exit Exits route-map configuration mode and returns


the router to global configuration mode.
Example:
switch(config-route-map)# exit

Step 21 interface type number Specifies an interface type and number and enters
interface configuration mode.
Example:
switch(config)# interface ethernet 0/0

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
4 OL-27603-02
Configuring IP SLA PBR Object Tracking
Configuring IP SLA PBR Object Tracking

Command or Action Purpose


Step 22 ip address ip-address mask Specifies a primary IP address for an interface.

Example:
switch(config-if)# ip address 10.2.2.1
255.255.255.0

Step 23 ipv6 address ip-address mask Specifies a primary IPv6 address for an interface.

Example:
switch(config-if)# ipv6 address
2001:DB8::/48

Step 24 ip policy route-map map-tag Enables policy routing and identifies a route map
to be used for policy routing.
Example:
switch(config-if)# ip policy route-map
PBR

Step 25 ipv6 policy route-map map-tag Enables IPv6 policy routing and identifies a route
map to be used for policy routing.
Example:
switch(config-if)# ipv6 policy
route-map PBR

Step 26 end Exits interface configuration mode and returns


the router to privileged EXEC mode.
Example:
switch(config-if)# end

Step 27 show track object-number (Optional) Displays tracking information.


Use this command to verify the configuration.
Example:
switch# show track 1

Step 28 show route-map map-name (Optional) Displays route map information.

Example:
switch# show route-map PBR

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
OL-27603-02 5
Configuring IP SLA PBR Object Tracking
Example: Configuring IP SLA PBR Object Tracking

Example: Configuring IP SLA PBR Object Tracking


This example shows that object tracking is configured for PBR:

! Configure and schedule IP SLA operations


ip sla 1
icmp-echo 10.3.3.2
ip sla schedule 1 life forever start-time now
!
ip sla 2
udp-echo 10.4.4.2
ip sla schedule 2 life forever start-time now
!
ip sla 3
icmp-echo 10.5.5.2
ip sla schedule 3 life forever start-time now
!
ip sla 4
icmp-echo 10.6.6.2
ip sla schedule 4 life forever start-time now
!
ip sla 5
icmp-echo 10.7.7.2
ip sla schedule 5 life forever start-time now
!
! Configure Object Tracking to track the operations
!
track 1 ip sla 1 reachability
track 2 ip sla 2 reachability
track 3 ip sla 3 reachability
track 4 ip sla 4 reachability
track 5 ip sla 5 reachability
!
! Configure ACL
ip access-list standard ACL
permit ip 10.2.2.0/24 10.1.1.1/32
!
! Configure PBR policing on the router
route-map PBR
match ip address ACL
set ip next-hop verify-availability 10.3.3.2 track 1
set ip next-hop verify-availability 10.4.4.2 track 2
set ip next-hop verify-availability 10.5.5.2 track 3
!
! Apply PBR policy on the incoming interface of the router.
interface ethernet 0/0
ip address 10.2.2.1 255.255.255.0
ip policy route-map PBR
!
! Display PBR related information
show route-map
show track brief
show ip sla stat
show ip sla application
!

Feature History for IP SLA PBR Object Tracking


This table includes only the updates for those releases that have resulted in additions or changes to the feature.

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
6 OL-27603-02
Configuring IP SLA PBR Object Tracking
Feature History for IP SLA PBR Object Tracking

Table 1: Feature History for IP SLA PBR Object Tracking

Feature Name Release Feature Information


IP SLA PBR Object Tracking 6.2(2) This feature was introduced.

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
OL-27603-02 7
Configuring IP SLA PBR Object Tracking
Feature History for IP SLA PBR Object Tracking

Cisco Nexus 7000 Series NX-OS IP SLAs Configuration Guide, Release 6.x
8 OL-27603-02

You might also like