0% found this document useful (0 votes)
38 views

Router Commands

This document provides instructions for basic router operations, viewing router information, Cisco Discovery Protocol commands, managing configuration files, setting passwords, router identification, configuring serial interfaces, TCP/IP commands, and configuring routing protocols like RIP and IGRP on Cisco routers. Some key commands include show version, show running-config, copy running-config startup-config, interface serial 0, ip address, router rip, and debug ip rip.

Uploaded by

Patrick Sulk
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
38 views

Router Commands

This document provides instructions for basic router operations, viewing router information, Cisco Discovery Protocol commands, managing configuration files, setting passwords, router identification, configuring serial interfaces, TCP/IP commands, and configuring routing protocols like RIP and IGRP on Cisco routers. Some key commands include show version, show running-config, copy running-config startup-config, interface serial 0, ip address, router rip, and debug ip rip.

Uploaded by

Patrick Sulk
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 3

Cisco Routers commands

Basic Router Operations


To get to User Mode Press ENTER and a password if required.
To get to Privileged Mode Router>enable
To get back to User Mode Router# disable
To Exit the Router Router>exit or logoff
Break Key <shift>+<ctrl>+6 ‘x’

To move to the beginning of the command line Ctrl+A


To move to the end of the command line Ctrl+E
To move forward one character Ctrl+F [or right arrow key]
To move back one character Ctrl+B [or left arrow key]
To repeat the previous command Ctrl+P [or up arrow key]
To repeat the most recent (last) command Ctrl+N [or down arrow key]
To move back one word Esc+B
To move forward one word Esc+F
To erase a word Ctrl+W
To erase a line Ctrl+U
To redisplay a line Ctrl+R

Ends configuration mode and returns to privileged mode Router# Ctrl+Z


To auto complete a command <tab>

To show the command buffer Router>show history


To set the command buffer size Router>terminal history size
To disable advanced editing features Router>terminal no editing
To re-enable advanced editing features Router>terminal editing
Viewing Router Information
View IOS version Router# show version
View current configuration file (RAM) Router# show running-config
View saved configuration file (NVRAM) Router# show startup-config
View IOS version, size of IOS, and free space in FLASH Router# show flash
View CPU utilization Router# show processes cpu
View info about programs in RAM Router# show processes
Display interfaces on router and their status Router# show interface
Display the ip interfaces on router and their status Router# show ip interface
Display which protocols are configured on the router Router# show protocol
Display ip protocol info Router# show ip protocol

Cisco Discovery Protocol


View info of neighboring Cisco devices (routers, switches,etc) Router# show cdp neighbors [ show cdp neighbor detail]
View interface info, default encap, cdp update and holdtime freq Router# show cdp interface
View a neighbors details Router# show cdp entry RouterB
View cdp update and holdtime frequency Router# show cdp
Change update frequency Router# cdp timer 90 [60 sec is default]
Change how long to hold a CDP entry of a neighbor for Router# cdp holdtime 240
Turn off CDP on an interface Router(config-if)# no cdp enable
CDP is enabled globally [CDP is enabled by default] Router(config)# cdp run
Managing Configuration Files
Run the initial configuration dialog Router# setup
Reboot the router and reload the startup config from NVRAM Router# reload
Enter global configuration mode Router# config terminal
Copy configuration file in RAM to NVRAM Router# copy running- config startup-config
Copy configuration file in NVRAM to RAM Router# copy startup- config running-config
Erase the configuration file in NVRAM [run initial config dialog] Router# erase startup-config
Copy startup config file from TFTP to NVRAM Router# copy tftp startup- config
Copy startup config file from NVRAM to TFTP Router# copy startup- config tftp
Copy startup config file from TFTP to RAM Router# copy tftp running-config
Copy running config file from RAM to TFTP Router# copy running- config tftp
Backup IOS to file server Router# copy flash tftp
Upgrade the IOS from the file server Router# copy tftp flash

Password
Set the enable secret password [to enter privileged mode] Router(config)#enable secret Rimmer
Set the enable password Router(config)#enable Rimmer
Set the password for Telnet Router(config)#line vty 0 4 ;0 4 specifies num of telnet sessions
Router(config-line)# login
Router(config-line)# password Holly
Set the console port password Router(config)#line con 0
Router(config-line)# login
Router(config-line)# password Holly
Set the auxiliary password Router(config)#line aux 0
Router(config-line)# login
Router(config-line)# password Holly
Passwords can be encrypted Routerconfig)# service password-encryption
To de-encrypt the passwords Routerconfig)# no service password-encryption
Router Identification
Message of the day Router(config)# banner motd # You are in… #
Give the router a hostname Router(config)#hostname RouterC
Configuring a Serial Interface
Is it DCE or DTE? Router# show controller serial 1
Enter sub interface mode Router(config)# interface serial 1
Set clock rate on DCE Router(config-if)# clock rate 64000 [or clockrate 64000]
Set the bandwidth Router(config-if)# bandwidth 64
Enable the interface Router(config-if)# no shutdown
Check interface status Router# show interface serial 1
Router# show ip interface brief
TCP/IP
Disable IP routing on a router (enabled by default) Router(config)#no ip routing
Put an IP address on an interface Router(config)#interface serial 0
Router(config-if)# ip address 172.16.1.3 255.255.0.0
Router(config-if )#exit
Router(config)#interface ethernet 0
Router(config-if)# ip address 208.10.10.3 255.255.255.0
Configure RIP Router(config)# router rip
Router(config-router)# network 157.2.0.0
Router(config-router)# network 177.2.0.0
Disable RIP routing Router(config)# no router rip
Configure IGRP Router(config)# router igrp 300
Router(config-router)# network 157.2.0.0
Router(config-router)# network 177.2.0.0
Disable IGRP routing Router(config)#no router igrp 300
View the IP routing table Router# show ip route
View RIP Debug Router# debug ip rip
View IGRP Debug Router# debug ip igrp events
Router# debug ip igrp transactions

Config-Reg
ROM Monitor Mode [prompt will be either: > or rommon>] Router(config)# Config-reg 0x0000
Boot from ROM and enter RXBOOT mode Router(config)# Config-reg 0x0001
[prompt will be: Router_Name(boot)> ]
Boot from ROM & check NVRAM for startup [boot] commands Router(config)# Config-reg 0x0002 [through to 0x000F]
RXBOOT (diagnostics mode, use ‘b’ to continue boot) Router(config)# Config-reg 0x2000
Boot from ROM, use NVRAM (upgrade flash in run-from-flash ) Router(config)# Config-reg 0x2101
Boot from ROM, skip NVRAM (disaster recovery) Router(config)# Config-reg 0x2141
Boot from FLASH, use NVRAM (normal operation) Router(config)# Config-reg 0x2102
Boot from FLASH, skip NVRAM (password recovery) Router(config)# Config-reg 0x2142
Access-Lists
<1-99> IP standard access list
<100-199> IP extended access-list
<200-299> Protocol type-code access list

View all access lists on the router and list each line of the list Router# show access-lists
View i p access lists only Router# show ip access-lists

IP Standard Access-Lists [1-99] filter on Source Address Template


Deny the subnet 200.10.10.0/24 from entering port E0 Router(config)# access-list 1 deny 200.10.10.0 0.0.0.255
Permit all others [any =0.0.0.0 255.255.255.255] Router(config)# access-list 1 permit any
Implicit deny all at the end of the access list  Router(config)#access-list 1 deny any any
The access list is not operational until bound to an interface Router(config)#interface e0
Router(config-if)# ip access-group 1 in
Deny the host 200.10.10.2/24 from entering port E0 Router(config)# access-list 88 deny host 200.10.10.2
Permit all others [host =200.10.10.2 0.0.0.0] Router(config)# access-list 88 permit any
An implicit deny all other traffic is the default line of an access list Router(config)#access-list 88 deny any any
The access list is not operational until bound to an interface Router(config)#interface e0
Router(config-if)# ip access-group 88 in
IP Extended Access-Lists [100-199] filter on Srce+Dest Address Template, Port, Protocol
Stop all hosts on network 4.4.4.0 from accessing the web (www) Router(config)# access-list 101 deny tcp 4.4.4.0 0.0.0.255 any eq 80
Stop host 2.2.2.2 from telneting to host 3.3.3.3 out E0 Router(config)# access-list 101 deny tcp host 2.2.2.2 host 3.3.3.3 eq 23
Permit all others to have access Router(config)# access-list 101 permit any any
An implicit deny all other traffic is the default line of an access list Router(config)#access-list 101 deny any any
The access list is not operational until bound to an interface Router(config)#interface e0
Router(config-if)# ip access-group 101 out

You might also like