CCNPv7 ROUTE Lab5-2 IP SLA Tracking and Path Control Student
CCNPv7 ROUTE Lab5-2 IP SLA Tracking and Path Control Student
Topology.
Objectives
Configure and verify the IP SLA feature.
Test the IP SLA tracking feature.
Verify the configuration and operation using show and debug commands.
Background
You want to experiment with the Cisco IP Service Level Agreement (SLA) feature to study how it could be of
value to your organization.
At times, a link to an ISP could be operational, yet users cannot connect to any other outside Internet
resources. The problem might be with the ISP or downstream from them. Although policy-based routing (PBR)
can be implemented to alter path control, you will implement the Cisco IOS SLA feature to monitor this
behavior and intervene by injecting another default route to a backup ISP.
To test this, you have set up a three-router topology in a lab environment. Router R1 represents a branch
office connected to two different ISPs. ISP1 is the preferred connection to the Internet, while ISP2 provides a
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
backup link. ISP1 and ISP2 can also interconnect, and both can reach the web server. To monitor ISP1 for
failure, you will configure IP SLA probes to track the reachability to the ISP1 DNS server. If connectivity to the
ISP1 server fails, the SLA probes detect the failure and alter the default static route to point to the ISP2
server.
Note: This lab uses Cisco 1941 routers with Cisco IOS Release 15.2 with IP Base. Depending on the router
or switch model and Cisco IOS Software version, the commands available and output produced might vary
from what is shown in this lab.
Required Resources
3 routers (Cisco IOS Release 15.2 or comparable)
Serial and Ethernet cables
interface Loopback 0
description R1 LAN
ip address 192.168.1.1 255.255.255.0
interface Serial0/0/0
description R1 --> ISP1
ip address 209.165.201.2 255.255.255.252
clock rate 128000
bandwidth 128
no shutdown
interface Serial0/0/1
description R1 --> ISP2
ip address 209.165.202.130 255.255.255.252
bandwidth 128
no shutdown
Router ISP1 (R2)
hostname ISP1
interface Loopback0
description Simulated Internet Web Server
ip address 209.165.200.254 255.255.255.255
interface Loopback1
description ISP1 DNS Server
ip address 209.165.201.30 255.255.255.255
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
interface Serial0/0/0
description ISP1 --> R1
ip address 209.165.201.1 255.255.255.252
bandwidth 128
no shutdown
interface Serial0/0/1
description ISP1 --> ISP2
ip address 209.165.200.225 255.255.255.252
clock rate 128000
bandwidth 128
no shutdown
Router ISP2 (R3)
hostname ISP2
interface Loopback0
description Simulated Internet Web Server
ip address 209.165.200.254 255.255.255.255
interface Loopback1
description ISP2 DNS Server
ip address 209.165.202.158 255.255.255.255
interface Serial0/0/0
description ISP2 --> R1
ip address 209.165.202.129 255.255.255.252
clock rate 128000
bandwidth 128
no shutdown
interface Serial0/0/1
description ISP2 --> ISP1
ip address 209.165.200.226 255.255.255.252
bandwidth 128
no shutdown
b. Verify the configuration by using the show interfaces description command. The output from router R1
is shown here as an example.
R1# show interfaces description | include up
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 4 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
EIGRP neighbor relationship messages on ISP1 and ISP2 should be generated. Troubleshoot if
necessary.
b. The Cisco IOS IP SLA feature enables an administrator to monitor network performance between Cisco
devices (switches or routers) or from a Cisco device to a remote IP device. IP SLA probes continuously
check the reachability of a specific destination, such as a provider edge router interface, the DNS server
of the ISP, or any other specific destination, and can conditionally announce a default route only if the
connectivity is verified.
Before implementing the Cisco IOS SLA feature, you must verify reachability to the Internet servers. From
router R1, ping the web server, ISP1 DNS server, and ISP2 DNS server to verify connectivity. You can
copy the following Tcl script and paste it into R1.
foreach address {
209.165.200.254
209.165.201.30
209.165.202.158
} {
ping $address source 192.168.1.1
}
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 6 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 7 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
Tag:
Operation timeout (milliseconds): 5000
Type of operation to perform: icmp-echo
Target address/Source address: 209.165.201.30/0.0.0.0
Type Of Service parameter: 0x0
Request size (ARR data portion): 28
Verify data: No
Vrf Name:
Schedule:
Operation frequency (seconds): 10 (not considered if randomly scheduled)
Next Scheduled Start Time: Start Time already passed
Group Scheduled : FALSE
Randomly Scheduled : FALSE
Life (seconds): Forever
Entry Ageout (seconds): never
Recurring (Starting Everyday): FALSE
Status of entry (SNMP RowStatus): Active
Threshold (milliseconds): 5000
Distribution Statistics:
Number of statistic hours kept: 2
Number of statistic distribution buckets kept: 1
Statistic distribution interval (milliseconds): 20
Enhanced History:
History Statistics:
Number of history Lives kept: 0
Number of history Buckets kept: 15
History Filter Type: None
R1#
The output lists the details of the configuration of operation 11. The operation is an ICMP echo to
209.165.201.30, with a frequency of 10 seconds, and it has already started (the start time has already
passed).
c. Issue the show ip sla statistics command to display the number of successes, failures, and results of
the latest operations.
R1# show ip sla statistics
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 8 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1#
You can see that operation 11 has already succeeded five times, has had no failures, and the last
operation returned an OK result.
d. Although not actually required because IP SLA session 11 alone could provide the desired fault tolerance,
create a second probe, 22, to test connectivity to the second DNS server located on router ISP2.
R1(config)# ip sla 22
R1(config-ip-sla)# icmp-echo 209.165.202.158
R1(config-ip-sla-echo)# frequency 10
R1(config-ip-sla-echo)# exit
R1(config)#
R1(config)# ip sla schedule 22 life forever start-time now
R1(config)# end
R1#
e. Verify the new probe using the show ip sla configuration and show ip sla statistics commands.
R1# show ip sla configuration 22
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 10 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1#
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 11 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1#
R1# show ip sla statistics 22
R1#
The output lists the details of the configuration of operation 22. The operation is an ICMP echo to
209.165.202.158, with a frequency of 10 seconds, and it has already started (the start time has already
passed). The statistics also prove that operation 22 is active.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 12 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1(config)# exit
b. Verify the routing table.
R1# show ip route | begin Gateway
Notice that the default static route is now using the route with the administrative distance of 5. The first
tracking object is tied to IP SLA object 11.
c. From global configuration mode on R1, use the track 1 ip sla 11 reachability command to enter the
config-track subconfiguration mode.
R1(config)# track 1 ip sla 11 reachability
R1(config-track)#
d. Specify the level of sensitivity to changes of tracked objects to 10 seconds of down delay and 1 second of
up delay using the delay down 10 up 1 command. The delay helps to alleviate the effect of flapping
objects—objects that are going down and up rapidly. In this situation, if the DNS server fails momentarily
and comes back up within 10 seconds, there is no impact.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 13 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
f. Configure the floating static route that will be implemented when tracking object 1 is active. Use the ip
route 0.0.0.0 0.0.0.0 209.165.201.1 2 track 1 command to create a floating static default route via
209.165.201.1 (ISP1). Notice that this command references the tracking object number 1, which in turn
references IP SLA operation number 11.
R1(config)# ip route 0.0.0.0 0.0.0.0 209.165.201.1 2 track 1
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 14 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1(config)#
Jan 10 10:45:39.119: RT: updating static 0.0.0.0/0 (0x0) :
via 209.165.201.1 0 1048578
Jan 10 10:45:39.119: RT: closer admin distance for 0.0.0.0, flushing 1 routes
Jan 10 10:45:39.119: RT: add 0.0.0.0/0 via 209.165.201.1, static metric [2/0]
Jan 10 10:45:39.119: RT: updating static 0.0.0.0/0 (0x0) :
via 209.165.201.1 0 1048578
Notice that the default route with an administrative distance of 5 has been immediately flushed because of
a route with a better admin distance. It then adds the new default route with the admin distance of 2.
g. Repeat the steps for operation 22, track number 2, and assign the static route an admin distance higher
than track 1 and lower than 5. On R1, copy the following configuration, which sets an admin distance of 3.
R1(config)# track 2 ip sla 22 reachability
R1(config-track)# delay down 10 up 1
R1(config-track)# exit
R1(config)#
R1(config)# ip route 0.0.0.0 0.0.0.0 209.165.202.129 3 track 2
R1(config)#
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 15 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 16 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
ISP1(config-if)#
Jan 10 10:53:25.091: %LINK-5-CHANGED: Interface Loopback1, changed state to
administratively down
Jan 10 10:53:26.091: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback1, changed state to down
ISP1(config-if)#
b. On R1, observe the debug output being generated. Recall that R1 will wait up to 10 seconds before
initiating action therefore several seconds will elapse before the output is generated.
R1#
Jan 10 10:53:59.551: %TRACK-6-STATE: 1 ip sla 11 reachability Up -> Down
Jan 10 10:53:59.551: RT: del 0.0.0.0 via 209.165.201.1, static metric [2/0]
Jan 10 10:53:59.551: RT: delete network route to 0.0.0.0/0
Jan 10 10:53:59.551: RT: default path has been cleared
Jan 10 10:53:59.551: RT: updating static 0.0.0.0/0 (0x0) :
via 209.165.202.129 0 1048578
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 17 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
The tracking state of track 1 changes from up to down. This is the object that tracked reachability for IP
SLA object 11, with an ICMP echo to the ISP1 DNS server at 209.165.201.30.
R1 then proceeds to delete the default route with the administrative distance of 2 and installs the next
highest default route to ISP2 with the administrative distance of 3.
c. On R1, verify the routing table.
R1# show ip route | begin Gateway
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 18 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1#
Notice that the latest return code is Timeout and there have been 45 failures on IP SLA object 11.
e. On R1, initiate a trace to the web server from the internal LAN IP address.
R1# trace 209.165.200.254 source 192.168.1.1
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 19 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
Jan 10 11:06:20.551: RT: closer admin distance for 0.0.0.0, flushing 1 routes
Jan 10 11:06:20.551: RT: add 0.0.0.0/0 via 209.165.201.1, static metric [2/0]
Jan 10 11:06:20.551: RT: updating static 0.0.0.0/0 (0x0) :
via 209.165.202.129 0 1048578
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 20 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
Now the IP SLA 11 operation transitions back to an up state and reestablishes the default static route to
ISP1 with an administrative distance of 2.
g. Again examine the IP SLA statistics.
R1# show ip sla statistics
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 21 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
R1#
The IP SLA 11 operation is active again, as indicated by the OK return code, and the number of
successes is incrementing.
h. Verify the routing table.
R1# show ip route | begin Gateway
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 22 of 23
CCNPv7 ROUTE Lab 5-2, Configure IP SLA Tracking and Path Control
Before deploying a Cisco IOS IP SLA solution, the impact of the additional probe traffic being generated
should be considered, including how that traffic affects bandwidth utilization, and congestion levels. Tuning
the configuration (for example, with the delay and frequency commands) is critical to mitigate possible
issues related to excessive transitions and route changes in the presence of flapping tracked objects.
The benefits of running IP SLAs should be carefully evaluated. The IP SLA is an additional task that must be
performed by the router’s CPU. A large number of intensive SLAs could be a significant burden on the CPU,
possibly interfering with other router functions and having detrimental impact on the overall router
performance. The CPU load should be monitored after the SLAs are deployed to verify that they do not cause
excessive utilization of the router CPU.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 23 of 23