Cisco IOS Firewall Design Guide
Cisco IOS Firewall Design Guide
®
Cisco IOS Firewall is a stateful security software component of Cisco IOS Software. Firewall integration in Cisco IOS routers
augments a router’s inherent capabilities: multitopology interfaces, industry-standard routing protocols, and a broad range
of services, as well as an expanding group of other security features such as virtual private network (VPN) and intrusion
prevention system (IPS) features. Cisco IOS Firewall interoperates with other Cisco IOS Software technologies, including
Network Address Translation (NAT), quality of service (QoS), and IP Security (IPsec) and Secure Sockets Layer (SSL) VPN,
to become a vital component of an end-to-end network security infrastructure.
• Cisco IOS Firewall stateful packet inspection provides true firewall capabilities to protect networks against unauthorized traffic and control
legitimate business-critical data.
• Authentication proxy controls access to hosts or networks based on user credentials stored in an authentication, authorization, and accounting
(AAA) server.
• Multi-VRF firewall offers firewall services on virtual routers with virtual routing and forwarding (VRF), accommodating overlapping address
space to provide multiple isolated private route spaces with a full range of security services.
• Transparent firewall adds stateful inspection without time-consuming, disruptive IP addressing modifications.
• Application inspection controls application activity to provide granular policy enforcement of application usage, protecting legitimate application
protocols from rogue applications and malicious activity.
Cisco IOS Firewall is primarily supported in Cisco IOS Software mainline and technology release trains. The service provider release train
incorporates limited firewall feature set capabilities, and is not as current as the mainline and technology releases for integration of new features.
This document offers technical discussion of most Cisco IOS Firewall features and provides deployment scenarios in typical network infrastructures,
using features supported up to Cisco IOS Software Release 12.4(2)T. The scenarios can act as a guide for the deployment of features that are useful
when securing a range of home, small business, branch office, extranet, and enterprise networks.
Cisco IOS Firewall offers stateful inspection capability on par with competing firewall products, and several benefits when compared to dedicated
firewall appliances. A Cisco IOS router with the Firewall Feature set offers additional functions and benefits integrated with the firewall’s
capabilities:
• Integrated Routing Capabilities—Cisco IOS Firewall provides integrated, inline security services. These enhance current Cisco IOS Software
capabilities: secure IP routing, multitopology interfaces, industry-standard routing protocols, NAT, and voice and video services.
• Industry-Leading VPN—Cisco IOS Software offers secure VPN capabilities to address almost any secure network requirement. EasyVPN,
DMVPN, traditional IPsec site-to-site, and Web-based SSL VPN support capabilities to securely connect remote-access users and remote
sites over the public Internet, or to offer added security to existing private-network connections.
All contents are Copyright © 1992–2005 Cisco Systems, Inc. All rights reserved. Important Notices and Privacy Statement.
Page 1 of 58
• Full-Featured Firewall—Stateful Packet Inspection provides stateful security and control for both common and user-defined network services,
and configurable protection from denial of service (DoS) attacks.
• Authentication Proxy—The Authentication Proxy (Auth Proxy) offers per-user authenticated access control to network resources. Users’
authorization policy may be provided to the Auth Proxy device by an AAA server.
• Scalability—Available on a wide variety of Cisco IOS platforms, Cisco IOS Firewall scales to meet any network’s bandwidth and performance
requirements.
• Security in the Infrastructure—Enables sophisticated security and policy enforcement for connections within an organization (intranet), from
central sites to remote offices and telecommuters in the home, between an organization and its partner networks, and between the organization
and the Internet.
• Integrates with Existing Investment in Cisco—IT managers can enhance security without additional cost and complexity of adding standalone
security appliances.
TECHNICAL HIGHLIGHTS
Cisco IOS Firewall consists of several major subsystems:
Enhancements to these features extend these capabilities to VRF instances to support multiple virtual routers per device, and to Cisco Integrated
Route-Bridging features to allow greater deployment flexibility, reduce implementation timelines, and ease requirements to add security to existing
networks.
This portion of the document introduces the individual subsystems and discusses their benefits.
Cisco IOS Firewall SPI protects against packet-injection attacks by checking several components of TCP and UDP sessions. Source and destination
IP address and port numbers must match, as well as TCP sequence number. Other attributes are checked as well, such as TCP window size, reducing
the likelihood of buffer overrun attacks.
Real-time alerts send syslog error messages to central management consoles upon detecting suspicious activity. Using the firewall engine inspection
rules, alerts and audit trail information can be configured on a per-application protocol basis. These configurable real-time alerts, audit trail, and
logging events allow administrators to track potential security breaches and other nonstandard activities in real time.
Authentication Proxy
Network administrators can create specific security policies for each user with the Cisco IOS Firewall per-user authentication and authorization.
Previously, user identity and related authorized access was determined by a user’s fixed IP address, or a single security policy had to be applied to an
entire user group or subnet. Now, per-user policy can be downloaded dynamically to the router from a TACACS+ or RADIUS authentication server.
Users log into the network resources or onto the Internet via HTTP, HTTPS, FTP, and Telnet authentication interfaces, and their specific access
profiles are downloaded to Cisco IOS Firewall routers with Authentication Proxy upon successful authentication. Authentication and authorization
can be applied for inbound and/or outbound traffic, which means that auth proxy can support Internet, intranet, and extranet configurations.
Application Inspection
Cisco IOS Firewall offers deeper, more detailed inspection of certain application protocols to prevent abuse and malicious activity that may be
transmitted over service ports generally used for more desirable traffic, such as HTTP, Simple Mail Transfer Protocol (SMTP)/Extended SMTP
(ESMTP), Post Office Protocol (POP), and Internet Mail Access Protocol (IMAP). Application Inspection capabilities vary by service, from
checking authentication to ensure login credentials are encrypted, to performing granular control over types and quantities of content that may
be carried over a controlled service.
SPI was introduced as a feature called Context-Based Access Control (CBAC). Prior to CBAC, Cisco IOS Software’s only packet-filtering
mechanism was the access control list (ACL). CBAC greatly enhanced the packet filtering capability of ACLs by introducing stateful filtering
capability. The early Cisco IOS Firewall capability was occasionally perceived as a “glorified” ACL. This misconception is partly due to the fact
that ACL monitoring commands were used to monitor CBAC activity, as well as the fact that inspection used (and still uses) ACLs to filter traffic,
permitting desired traffic, while blocking unwanted, potentially harmful traffic. However, CBAC substantially augments an ACL’s capability for
restricting traffic. CBAC monitors several attributes in TCP connections, UDP sessions, and Internet Control Message Protocol (ICMP) dialogue to
ensure that the only traffic allowed through a firewall ACL is the return traffic for dialogue that was originated on the private side of the firewall.
Many changes have been made to CBAC to enhance its capability and increase performance. Inspection of some protocols has been enhanced to
ensure protocol compliance or offer application-level service filtering. Cisco IOS Software Release 12.3(4)T’s ACL Bypass feature introduced
substantial improvements in performance and significant changes to the stateful inspection architecture. CBAC had outgrown its original, basic
function and was renamed Cisco IOS Stateful Packet Inspection to more accurately reflect the feature’s capability. CBAC is frequently still used
synonymously with Stateful Packet Inspection, but the CBAC name does not reflect the full feature set offered by Cisco IOS SPI.
SPI inspects the packet after it passes the inbound ACL of an input interface if ip inspect in is applied, or after the outbound ACL of output
interface if ip inspect out is used. Thus, outbound traffic must be permitted by input ACLs facing the source, and outbound ACLs facing the
destination.
SPI monitors connections from a secured network to an unsecured network, and anticipates the traffic returning to the secure host from the unsecure
network. The mechanism for anticipating and allowing the return traffic changed slightly as Cisco IOS Firewall changed from CBAC to SPI. Prior
to Cisco IOS Software Release 12.3(4)T, CBAC placed dynamic access control entries (ACEs) in ACLs in the return path for internally originated
connections, as indicated in “show access-list” for a simple “deny all” ACL:
sdp-ezvpn#show access-lists
Extended IP access list 111
permit tcp host 172.16.105.1 eq telnet host 172.16.105.10 eq
1176 (30 matches)
10 deny ip any any (708 matches)
ACL Bypass improves firewall performance for two reasons. SPI is able to maintain a more efficient list to track active sessions, reducing the time
required for session setup and verification. Also, return traffic is not subjected to ACLs on the return path, so when return traffic finds a matching
entry in the session table, it is shunted past the ACLs in the packet path, reducing the CPU overhead the packet incurs as it moves through the
router’s processing.
Configure and apply the “deny any” ACL on the public-facing interface, fastethernet 0/0, to block requests from the unsecure network.
access-list 101 deny ip any any
interface fastethernet 0/0
ip access-group 101 in
Configure a basic inspection policy. Most Internet traffic can be inspected by “inspect tcp”, “inspect udp”, and “inspect icmp”. This permits the
most common Internet traffic, including Web browsing, e-mail applications, file transfer, remote-console and remote-desktop applications, instant
messaging, and peer-to-peer file transfer applications. Certain applications that use a secondary data channel, such as voice applications or streaming
media applications, may require that you configure the protocol-specific inspection for that particular service, such as “inspect ftp”, “inspect skinny”,
or “inspect h.323”. If you set up Cisco IOS Stateful Inspection and find that one of your network applications that must traverse the firewall stops
working, you should consult the product’s documentation or knowledgebase and determine if the software vendor offers documentation specific to
setting up a Cisco IOS Firewall.
This completes the configuration of the least complex Cisco IOS SPI.
The Stateful Inspection engine only needs to see the initiating connection for these complex services. Subsequent connections for the session are
dynamically opened for the session, based on SPI’s scrutiny of the connection setup. This is usually known as “fixup”. If an outbound ACL is
configured on an interface to restrict network access policy, it must only account for the initiating port. The task of accommodating the media
channels will be handled by Stateful iInspection’s fixup. The following command lists the complex services and their initiating ports that Cisco
IOS Stateful Inspection can handle:
FWRouter# sh ip port-map
Granular Inspection
Granular Protocol Inspection (GPI), introduced in Cisco IOS Software Release 12.3(14)T, offered complete integration with PAM. Prior to GPI,
a firewall policy was defined by configuring inspection for outbound TCP, UDP, and ICMP traffic. Inspection was explicitly configured for
specific protocols, such as FTP, H.323, Skinny, Session Initiation Protocol (SIP) and others that required fixup to watch for and allow protocol-
specific media channels. Common single-connection services such as POP, Telnet, Microsoft RPC, and other simple protocols were inspected by
the generic capability of TCP, UDP, and ICMP inspection. Using these generic inspection capabilities is simple to configure, but it limits Stateful
Packet Inspection’s granularity—any traffic that was allowed to leave through a firewall was allowed to return because inspection created an ACL
Bypass entry for that traffic.
GPI allows creation of specific ACL Bypass for only the desired traffic, as defined by an inspection list consisting of only the protocols that are
explicitly permitted by an organization’s Internet/security access policy.
A complete list of the default services that GPI can inspect is contained in the appendix at the enof the Stateful Inspection section.
GPI allows the user to specify PAM-defined services for firewall permission. Prior to GPI, if you wished to restrict your firewall policy, you simply
used “inspect tcp/udp/icmp” as in the least complex firewall example, but you placed an ACL in the outbound packet path to block access to specific
services, or to restrict the list to a specific few. If you use GPI, you must explicitly state the list of protocols, but you will be able to use the user-
configurable PAM names for the allowed services, instead of using specific port numbers or ACL service names, which cannot be modified to reflect
network requirements.
Network policy in this example allows users to access these Internet services:
Apply the “deny any” ACL on the public-facing interface to block requests from the unsecure network:
access-list 101 deny ip any any
interface fastethernet 0/0
ip access-group 101 in
”Inspect http” adds capability to inspect returned content for java applets, offering the option to block potentially malicious java content. However,
java filtering incurs a substantial performance penalty. To configure an http inspection policy that does not inspect for embedded java content, define
an ACL exempting network address ranges from java inspection and associate the ACL with “inspect http”:
access-list 102 permit ip any any
ip inspect name myfw http java-list 102
This completes the configuration of the most secure Cisco IOS Stateful Packet Inspection. Cisco.com’s reference for Granular Protocol Inspection
is available at: http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a008040afd7.html
Note: In general, network administrators should account for their specific local topology (which interfaces are considered protected and
unprotected). Additional time should be allowed for testing and access considerations for ongoing management of the routers before configuring
the firewall. To prevent traffic via the firewall, it is critical to understand how extended access lists function.
Denial of Service
Cisco IOS Stateful Packet Inspection maintains counters of the number of “half-open” TCP connections, as well as the total connection rate through
the firewall and IPS software. These half-open connections are TCP connections that have not completed the SYN—SYN/ACK—ACK handshake
that is always used by TCP peers to negotiate the parameters of their mutual connection. Cisco IOS Firewall also regards UDP sessions with traffic
in only one direction as “half-open”, as nearly all applications that use UDP for transport will acknowledge reception of data. UDP sessions without
Cisco IOS Stateful Packet Inspection provides protection from DoS attack as a default when an inspection rule is applied. The DoS protection is
enabled on the interface, in the direction in which the firewall is applied, for the protocols that the firewall policy is configured to inspect. DoS
protection is only enabled on network traffic if the traffic enters or leaves an interface with inspection applied in the same direction of the traffic’s
initial movement. Cisco IOS Firewall inspection provides several adjustable values to protect against DoS attacks. These settings have default
values that may interfere with proper network operation if they are not configured for the appropriate level of network activity in networks
where connection rates will exceed the defaults:
These parameters allow you to configure the points at which your firewall router’s DoS protection begins to take effect. When your router’s
DoS counters exceed the default or configured values, the router will reset one old half-open connection for every new connection that exceeds the
configured max-incomplete or one-minute high values, until the number of half-open sessions drops below the max-incomplete low values. The
router will send a syslog message if logging is enabled, and if Intrusion Protection System (IPS) is configured on the router, the firewall router will
send a DoS signature message via SDEE. If the DoS parameters are not adjusted to your network’s normal behavior, normal network activity may
trigger the DoS protection mechanism, causing application failures, poor network performance, and high CPU utilization on the Cisco IOS Firewall
router.
While you cannot “disable” your firewall’s DoS protection, you can adjust the DoS protection so that it will not take effect unless a very large
number of half-open connections are present in your firewall router’s Stateful Inspection session table.
Follow this procedure to tune your firewall’s DoS Protection to your network’s activity:
Step 1. Be sure your network is not infected with viruses or worms that could lead to erroneously large half-open connection values and
attempted connection rates. If your network is not a “clean slate”, there is no way to properly adjust your firewall’s DoS protection.
This will prevent the router from providing DoS protection for the time being while you observe your network’s connection patterns.
If you wish to leave DoS protection disabled, stop following this procedure now.
Step 3. Clear the IOS Firewall statistics, using the following command:
show ip inspect statistics reset
Step 5. After waiting for some observation period, check the DoS counters with the following command. The parameters you must observe to
tune your DoS protection are highlighted in bold:
router#show ip inspect statistics
Packet inspection statistics [process switch:fast switch]
tcp packets: [528:22519]
udp packets: [318:0]
Interfaces configured for inspection 1
Session creations since subsystem startup or last reset 766
Current session counts (estab/half-open/terminating) [1:0:0]
Maxever session counts (estab/half-open/terminating) [48:12:5]
Last session created 00:12:21
Last statistic reset never
Last session creation rate 0
Last half-open session total 0
Step 6. Configure “ip inspect max-incomplete high” to a value twenty-five percent higher than your router’s indicated maxever session count
half-open value.
For example:
Maxever session counts (estab/half-open/terminating) [48:12:5]
Step 7. Configure “ip inspect max-incomplete low” to the value your router displayed for its maxever session count half-open value.
For example:
Maxever session counts (estab/half-open/terminating) [48:12:5]
Thus, configure:
router(config)#ip inspect max-incomplete low 65
Step 8. The counter for “ip inspect one-minute high” and “one-minute low” maintains a sum of all TCP, UDP, and ICMP connection attempts
during the preceding minute of the router’s operation, whether the connections have been successful or not. A rising connection rate
could be indicative of a worm infection on a private network, or an attempted DoS against a server. IOS does not maintain a value of
the maxever one-minute connection rate, so you must calculate the value you will apply based on observed maxever values. While the
maximum indicated values for established, half-open, and terminating sessions are unlikely to occur in the same instant, the calculated
values used for the one-minute settings have been observed to be reasonably accurate. To calculate the ip inspect one-minute low value,
add the indicated established, half-open, and terminating values, then multiply the sum by three.
Step 9. Calculate and configure “ip inspect max-incomplete high.” The ip inspect one-minute high value should be twenty-five percent greater
than the calculated one-minute low value.
For example:
Step 10. You will need to define a value for “ip inspect tcp max-incomplete host” according to your understanding of your servers’ capability.
Step 11. Monitor your network’s DoS protection activity. Ideally, you should use a syslog server and record occurrences of DoS attack detection.
If detection happens very frequently, you may need to monitor and adjust your DoS protection parameters.
For more information about TCP SYN DoS attacks, please visit:
http://www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a00800f67d5.shtml
Audit-trail can be enabled or disabled per protocol in the firewall rules to control the amount of audit-trail messages.
Cisco IOS Firewall inspects packets after input and output ACL checks. When inspecting, the advanced firewall engine may insert or remove the
ACL items associated with a session, depending upon its state and context. The following explains the process that the packet undertakes for many
of the components within the router.
cisco-net-mgmt cisco-net-mgmt
cisco-svcs Cisco license/perf/GDP/X.25/ident svcs
fcip-port FCIP
finger Finger
fragment IP fragment inspection
ftp File Transfer Protocol (FTP)
ftps FTP over Transport Layer Security/Secure Sockets Layer (TLS/SSL)
igmpv3lite Internet Group Management Protocol (IGMP) over UDP for SSM
imap IMAP
ipx IPX
irc-serv IRC-SERV
ircs IRC over TLS/SSL
ircu IRCU
isakmp ISAKMP
iscsi iSCSI
kazaa KAZAA
kerberos Kerberos
kermit kermit
l2tp Layer 2 Tunneling Protocol (L2TP)/Layer 2 Forwarding (L2F)
ldap Lightweight Directory Access Protocol (LDAP)
microsoft-ds Microsoft-DS
oracle Oracle
pcanywheredata pcANYWHEREdata
pcanywherestat pcANYWHEREstat
pop3 POP3
pop3s POP3 over TLS/SSL
pptp Point-to-Point Tunneling Protocol (PPTP)
pwdgen Password Generator Protocol
qmtp-tcp Quick Mail Transfer Protocol
r-winsock remote-winsock
radius RADIUS and accounting
rcmd R commands (r-exec, r-login, r-sh)
send-tcp SEND
shell Remote command
sip-tls SIP-TLS
skinny Skinny Client Control Protocol (SCCP)
socks Socks
sql-net SQL-NET
sshell SSLshell
vqp VQP
This section describes two applications for Cisco IOS Transparent Firewall.
Background
Most firewall applications require TCP/IP Layer 3 routing, where the network that a firewall protects must be in a completely separate subnet
from the potentially hostile network. The firewall must forward the packets from one subnet to the other, inspecting the traffic for firewall policy
compliance during the routing operation. This is impractical for some applications, where networking or operational requirements do not allow
sufficient address space or downtime flexibility to reconfigure a network to accommodate a traditional “routing” firewall.
Cisco IOS Transparent Firewall uses Layer 2 bridging to apply Cisco IOS Firewall capabilities within a single IP subnet. Cisco IOS Firewall
inspection is applied as the router bridges the traffic from one segment to the other, according to the policy. Cisco IOS Transparent Firewall only
inspects the traffic moving between the segments of the bridge group. Traffic to other subnets requires inspection as it traverses Layer 3 interfaces.
Appendix A provides links to more Cisco IOS bridging information.
The Transparent Firewall feature was introduced in Cisco IOS Software Release 12.3(7)T. Table 1 indicates which releases added support for
particular platforms.
12.3(11)T Added ISR Support for Transparent Firewall 85x/87x, 1800, 2800, 3800
12.4(1) First mainline release to support Transparent Firewall All current platforms with IOS Firewall Support
The simplest application of Cisco IOS Transparent Firewall involves bridges between two Ethernet ports on a router, while inspecting all traffic
in one direction (client HTTP traffic sending requests to the server, and denying all connections from the server toward the client, for example),
shown in Figure 5.
Practical Applications
This document explores two different practical applications of Cisco IOS Transparent Firewall. The first example is a scenario where two physical
network segments in the same subnet are offered similar policies to the public Internet, but one segment is firewalled from the other. The second
example is a configuration for limiting public access to a DMZ, and blocking all outbound DMZ access except Extended Simple Mail Transport
Protocol (ESMTP) traffic.
Both segments will use Port Address Translation (PAT) to access the public Internet, to conserve IP addresses.
Figure 6. Cisco IOS Transparent Firewall Applying Dissimilar Policy to Two LAN Segments in One Subnet
Interfaces assigned to a bridge group do not have an IP address. The interfaces share the address on the bridge virtual interface (BVI), as mentioned
in the Transparent Firewall background.
Configure the BVI. The BVI will act as the PAT inside interface:
interface BVI 1
ip add 192.168.1.254 255.255.255.0
ip nat inside
Configure the outside interface. This instance will use a static IP address for Ethernet WAN connectivity through a DSL or cable modem:
interface FastEthernet 4
ip address 171.71.58.67 255.255.255.0
ip nat outside
Set up PAT:
ip nat inside source list 101 interface FastEthernet 4 overload
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
Apply the ACL to the wireless interface and assign the interface to the bridge group:
interface Dot11Radio0
no ip address
ip access-group 102 in
bridge-group 1
Define the firewall policy for access from the Ethernet segment to the Wi-Fi segment:
ip inspect name transparent tcp
ip inspect name transparent udp
ip inspect name transparent icmp
Assign the VLAN 1 interface for the Ethernet LAN to the bridge group and apply the inspection policy. This inspection policy will only inspect
traffic moving between interfaces in the bridge group:
interface VLAN 1
no ip address
ip inspect transparent in
bridge-group 1
Define the firewall policy for access from the Ethernet and Wi-Fi segments to the public Internet:
ip inspect name internet tcp
ip inspect name internet udp
ip inspect name internet icmp
Apply the Internet access policy to the BVI. This inspection policy only inspects traffic leaving the bridge group:
interface BVI 1
ip inspect internet in
This completes the Cisco IOS Transparent Firewall configuration for separating two network segments. The complete configuration is available
in Appendix B.
Exposing a service to the Internet opens a vulnerability to compromise by worms and malicious activity. If the exposed host is compromised,
a firewall between the infected host and other hosts is desired to contain as much of the infection as possible. A traditional routing-type firewall
would cause segmentation of the available address space and waste IP addresses. A transparent firewall minimizes address loss, improving
efficiency of address use. This example could also be viewed as an enterprise assigning a small subnet to a remote location, and needing to
restrict headquarters’ access to a portion of the subnet.
Figure 7. Cisco IOS Firewall Separating DMZ and Protected Private LAN
This network’s configuration does not differ appreciably from the previous example, except for the omission of the NAT policy and addition of
some ACL entries to minimize service accessibility between network segments. A common practice in use with most Internet service DMZs is
to disallow any connections from the DMZ to any host, so that a compromised host will not act as an attack “zombie” or offer a stepping-stone
to attack other hosts and mask the true source of an attack.
Configure the BVI. The BVI will act as the PAT inside interface:
interface BVI 1
ip add 192.168.1.254 255.255.255.0
Configure the outside interface. This instance will use a static IP address for Ethernet WAN connectivity through a DSL or cable modem:
interface FastEthernet 0/0
ip address 171.71.58.67 255.255.255.0
Apply the ACL to the wireless interface and assign the interface to the bridge group:
interface Dot11Radio0
no ip address
ip access-group 102 in
bridge-group 1
Define the firewall policy for access from the Ethernet segment to the Wi-Fi segment:
ip inspect name transparent tcp
ip inspect name transparent udp
ip inspect name transparent icmp
Assign the VLAN 1 interface for the Ethernet LAN to the bridge group and apply the inspection policy:
interface VLAN 1
no ip address
ip inspect transparent in
bridge-group 1
Define the firewall policy for access from the private and DMZ segments to the public Internet. The ACL will block all connections from the
DMZ except ESMTP, which will be checked for protocol conformance by “inspect ESMTP”. The mail protocol must be allowed to pass so
that the Internet server can send outbound mail:
ip inspect name internet tcp
ip inspect name internet udp
ip inspect name internet icmp
ip inspect name internet esmtp
Define the ACL to block traffic from the Internet, but to allow access to services on hosts in the DMZ. For this example, we will permit requests
for Web (HTTP), secure Web (HTTPS), mail (SMTP), Internet name resolution (DNS), and file transfer (FTP) to reach the Internet server. We
will permit ICMP echo requests to the entire subnet:
access-list 103 permit tcp any host 198.133.219.1 eq 80
access-list 103 permit tcp any host 198.133.219.1 eq 443
access-list 103 permit tcp any host 198.133.219.1 eq 25
access-list 103 permit tcp any host 198.133.219.1 eq 53
access-list 103 permit udp any host 198.133.219.1 eq 53
Authentication Proxy
Authentication Proxy (Auth Proxy) offers a mechanism to authenticate and authorize users’ access to network resources. Two common applications
for Auth Proxy are authenticating users’ access from a secure network to the public Internet to avoid network resource abuse, and authenticating user
access to sensitive network resources, such as network management resources or human resources and payroll servers. Authentication proxy requires
that users provide a valid user name and password before they can access these resources. The user names and passwords may be stored locally on
the router, or held on a authentication, accounting, and authorization (AAA) server. AAA servers offer the benefits of offering service to multiple
routers, so every router that uses Auth Proxy or other authenticated services does not need to be configured with a new user name any time a user is
added on the network. AAA also provides authorization policy information when users provide their credentials, so the users’ access to authenticated
resources can be filtered on a granular, user-specific basis. Auth Proxy provides HTTP, HTTPS, Telnet, and FTP interfaces to authenticate user
access. HTTP and HTTPS provide the benefits of launching a separate browser window for the users’ credentials when they try to access HTTP
or HTTPS resources protected by the Auth Proxy-enabled router.
Auth Proxy is configured on an interface without direction, as access authentication is always inbound, intercepting the packet before it reaches
the inbound ACL. Therefore, an inbound ACL can be configured to block all traffic (deny ip any any). Once a user is authenticated by Auth
Proxy, ACL Bypass is applied to shunt legitimate traffic around the inbound ACL.
This document does not include AAA server configurations. For more information, please visit:
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804ad9bc.html
This document describes use cases and application backgrounds for Web (HTTP), mail client (POP3 and IMAP), and mail server (SMTP and
ESMTP) application inspection services.
Background
Cisco IOS Software Release 12.3(14)T introduced new application inspection engines for three protocols, augmenting the existing ESMTP RFC
conformance capability. Most well-known Internet services, such as HTTP, POP3, IMAP, and SMTP/ESMTP are described by RFCs, a step in
the Internet Engineering Task Force (IETF) standardization process. RFCs define how Internet services must conduct their activities to ensure
compatibility and interoperability in the multivendor environment of the public Internet.
The HTTP application inspection engine offers the greatest range of capabilities by offering the capability to inspect packets for RFC conformance
as well as checking various parameters within the content to detect malicious or unauthorized network traffic.
POP and IMAP inspection monitors connection setup to help ensure a secure connection and block unwanted traffic on mail-client ports.
ESMTP inspection has been available since Cisco IOS Software Release 12.3(7)T, augmenting existing SMTP inspection support. ESMTP/SMTP
inspection offers protocol compliance checking to block various malicious activities directed at e-mail servers.
The Cisco IOS Software HTTP application inspection engine offers flexible application-layer inspection to examine network traffic to detect and
take action against malicious or unwanted HTTP traffic. The HTTP application inspection engine offers three fundamental capabilities: protecting
servers from malicious clients, protecting clients from malicious or compromised content, and enforcing organizational information systems policies.
This document examines three respective examples of some of the capabilities available with HTTP application inspection: HTTP method control,
HTTP content verification, and IM and P2P blocking.
All of the HTTP application inspection engine functions offer the option to allow or reset the offending traffic. Furthermore, syslog can send an
alarm concerning the violation to a monitoring station. Thus, application inspection can monitor traffic if allow is used with a rule, or it can filter
out unwanted traffic using the reset option.
RFC conformance checking plays an important role in the capability of the HTTP application inspection engine. HTTP was originally defined in
RFC 2068, which was superseded by RFC 2616. These RFCs describe the methodology for establishing HTTP sessions and transferring hypertext
content. A Web browser and Web server employ a somewhat limited set of requests and responses to carry out their communications over the course
of the session.
The HTTP application inspection engine offers several options (Table 2).
The following examples combine several of these options to illustrate application-specific HTTP policy enforcement.
Web browsers use a standardized group of requests to request and transmit data to and from Web servers. This request is carried in the HTTP header
inside the TCP packet, inside the IP packet. By examining the contents of the Web browser’s request to the Web server, application inspection can
permit or allow specific types of requests, based on the perceived threat of the different types of requests.
Many attacks against Web servers use specific requests that are fairly uncommon for ordinary Web transactions. An HTTP inspection engine can
restrict the particular HTTP methods that Web clients use to communicate with Web servers by checking the HTTP request type field in the HTTP
header of the IP packet.
To apply the server protection just discussed to this simple network, configure an HTTP application inspection policy:
appfw policy-name method-control
application http
strict-http action reset alarm
request-method rfc put action reset alarm
This application inspection policy must then be applied to an inspection policy, either an existing inspection set or a minimal set that will only
employ application inspection:
ip inspect name my-fw appfw method-control
Finally, the policy must be applied in the direction that the inspection occurs:
interface fastethernet 1/0
ip inspect my-fw out
To see the HTTP application inspection engine configuration, issue this command at the privileged EXEC prompt:
sh ip inspect config
An appropriate use of the HTTP application inspection engine for client protection applies the content-type-verification feature. Several documented
Web browser vulnerabilities involve a browser’s susceptibility to intentionally mislabeled content. When a Web browser requests content from a
Web server, the Web server indicates to the Web browser the type of embedded content in its reply. The Web browser usually passes the content
to an application on the workstation that is associated with the type of content that the Web server indicated in its reply. However, if the content
is mislabeled, the application that opens the content might try to implement the content according to the content’s file header information or the
file name extension. As an example, consider an attack that takes advantage of this weakness to distribute a Microsoft Visual Basic script file
with an .mpg or .avi extension on the file name (for instance, an attacker applies the name “attack.mpg” to the attack.vbs file). This causes a
default installation of Microsoft Internet Explorer to pass the file to Microsoft Windows Media Player. Media Player receives the file from
Internet Explorer and recognizes that the content does not have the appropriate attributes to be a genuine .mpg or .avi file, but it makes its best
The content-type-verification feature of the HTTP application engine checks Web content replies to protected browsers to verify that the embedded
content matches the content type indicated by the Web server. Like most HTTP application inspection features, content-type-verification can be
configured to allow or reset traffic that doesn’t pass the content-type check. Obviously, the only appropriate action for invalid traffic is to reset the
Web client connection so that the invalid traffic is not allowed to pass through to the Web client.
Once again, this exercise assumes a simple network consisting of a Web server separated from the Web client by a Cisco IOS router (Figure 9).
To apply the server protection just discussed to this simple network, configure an HTTP application inspection policy:
appfw policy-name chk-content
application http
strict-http action reset alarm
request-method rfc put action reset alarm
This application inspection policy must then be applied to an inspection policy, either an existing inspection set or a minimal set that will only
employ application inspection:
ip inspect name my-fw appfw chk-content
Finally, the policy must be applied in the direction that connection was initiated:
interface fastethernet 1/0
ip inspect chk-content in
To see the HTTP application inspection engine configuration, issue this command at the privileged EXEC prompt:
sh ip inspect config
This exercise assumes a simple network consisting of a Web browser accessing the Web using a Cisco IOS router (Figure 10).
To apply instant messaging and P2P blocking on this simple network, configure an HTTP application inspection policy:
appfw policy-name no-abuse
application http
strict-http action reset alarm
port-misuse default action reset alarm
This application inspection policy must then be applied to an inspection policy, either an existing inspection set or a minimal set that will only
employ application inspection:
ip inspect name my-fw appfw no-abuse
Finally, the policy must be applied in the direction that the inspection occurs:
interface fastethernet 0/1
ip inspect my-fw in
To see the HTTP application inspection engine configuration, issue this command at the privileged EXEC prompt:
sh ip inspect config
The second concern regarding remote e-mail client access is when users have configured their e-mail client to secure their authentication credential
exchange. Most POP3 and IMAP client applications default to passing the user’s user name and password to the server as “cleartext,” meaning this
information is not encrypted to conceal its credentials. If an attacker intercepts a user name and password being transmitted as cleartext, the attacker
could read the user name and password and could masquerade as the authorized user. Such a situation is especially problematic if the credentials are
used for multiple services.
To help ensure security on POP3 and IMAP ports and maximize connection security between mail clients and servers, e-mail client traffic inspection
monitors the clients’ negotiations with servers to help ensure that the session setup follows the requirements of the respective RFCs. RFC 1939
defines the POP3 client negotiation, and RFC 3501 defines the IMAP client negotiation (Figure 15).
E-mail client inspection can be configured to log and/or reset client negotiations that violate the RFC requirements. If neither log nor reset is
specified, e-mail client application inspection not be useful. Furthermore, if secure login is required, the secure-login switch will require that
clients ask for a secure negotiation. If the client does not ask for a secure login, the client will be logged out or reset according to the configuration.
Table 3 shows the options that are available in e-mail application inspection configuration.
Option Description
inspection-name Names the set of inspection rules. To add a protocol to an existing set of rules, use the same inspection-name
as the existing set of rules.
Protocol Indicates which protocol (POP or IMAP) the inspection engine will monitor.
alert {on | off} For each inspected protocol, the generation of alert messages can be set be to on or off. If no option is selected,
alerts are generated based on the setting of the ipv6 inspect alert-off command. (Optional)
audit-trail {on | off} For each inspected protocol, audit-trail can be set to on or off. If no option is selected, audit-trail messages are
generated based on the setting of the ipv6 inspect audit-trail command. (Optional)
timeout seconds To override the global TCP or UDP idle timeouts for the specified protocol, specify the number of seconds for a
different idle timeout. This timeout overrides the global TCP and UDP timeouts but will not override the global
DNS timeout. (Optional)
Reset Specifies that the TCP connection will be reset if the client enters a nonprotocol command before authentication
is complete.
secure-login Forces client to authorize using a secure method for login. Firewall will not allow plain text login (password in the
clear) using this option.
This example assumes a simple network consisting of an e-mail client accessing an e-mail server using a Cisco IOS router (Figure 11).
To apply the e-mail client traffic protection just discussed to this simple network, define an IP inspection statement in an existing inspection policy
or add the statement to an existing inspection set:
ip inspect name mail-clients pop3 log reset secure-login
ip inspect name mail-clients imap log reset secure-login
Finally, the policy must be applied in the direction that the inspection occurs:
interface fastethernet 0/1
ip inspect mail-client in
To show the e-mail client application inspection configuration, issue the following show command:
show ip inspect config
To see e-mail client application inspection engine messages for individual events, enable debug for the appropriate protocol:
debug ip inspect pop3
debug ip inspect imap
This example assumes a simple network consisting of an e-mail server connecting to the public Internet using a Cisco IOS router (Figure 12).
To apply the e-mail server traffic protection to this simple network, define an SMTP or ESMTP inspection statement for use by itself or add the
statement to an existing inspection set:
ip inspect name mail-server [ smtp | esmtp ]
SMTP traffic inspection configuration and ESMTP traffic inspection configuration in any given inspection set contain mutually exclusive
commands. ESMTP inspection is a superset of SMTP inspection. SMTP inspection should only be applied if the mail server is to be limited
to supporting only SMTP. Otherwise, ESMTP inspection should be applied.
To show SMTP and ESMTP application inspection configuration, issue the following show command:
show ip inspect config
References
ESMTP inspection engine: http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801ed6ee.html
Blocking Instant Messaging and Peer-to-Peer File Sharing Applications with Cisco IOS Software Release 12.3(14)T
Most organizations view IM and P2P applications as frivolous consumers of expensive resources—employee time and network bandwidth.
Furthermore, some P2P networks can act as a conduit for malicious software such as worms, offering an easy path around firewalls into an
organization to compromise desktop computing resources.
Cisco IOS Software Release 12.3(14)T introduced application inspection engines and granular inspection, two critical new features that allow Cisco
IOS Firewall to control IM and P2P applications on networks. This document offers some sample configurations to use these features to monitor and
block IM and P2P file sharing traffic.
Background
P2P and IM traffic generally offer two modes of operation—a native mode, where the application runs on a uniquely defined set of TCP or UDP
ports, and “HTTP cloaked” mode, in which the application masquerades as HTTP (TCP port 80) traffic in order to gain passage through firewalls
Prior to Release 12.3(14)T, Cisco IOS Software was bound by two major restrictions in the control of P2P and IM applications—a limited list of
applications that were supported in Cisco IOS Firewall Stateful Inspection (formerly known as Context-Based Access Control [CBAC]), and lack
of application inspection capability.
Cisco IOS Firewall Stateful Inspection is the basis of the Cisco IOS Firewall feature set. If a specific application was not built into Cisco IOS
Firewall (see the list of original supported protocols in Appendix 1), the inspect tcp or inspect udp commands were used to watch for any outbound
connection activity through a firewall, and anticipated return traffic was subsequently allowed through firewall blocking policies with ACL bypass
capability. Unfortunately, these commands allow all traffic that is not specifically filtered out to make a connection with the appropriate server
through a firewall, and return traffic is allowed back in. This mode of operation offers little control in allowing or disallowing specific protocols.
From an application inspection standpoint, HTTP inspection was one of the more thorough protocol inspections that Cisco IOS Firewall offered.
However, even if an extremely restrictive Cisco IOS Firewall policy allowing only “HTTP out” was applied, users might still be able to use P2P
and IM applications that offered HTTP cloaking.
Cisco IOS Software Release 12.3(14)T introduced application inspection and granular inspection capabilities to address both of these shortcomings.
Example Network
We can examine a simple network to build an example of an effective inspection policy that will prohibit P2P and IM traffic, and that will offer
control over cloaked applications that try to exploit TCP port 80 to gain access though the firewall (Figure 13). This network consists of one or
more client PCs in a private network, connected to the public Internet through a Cisco IOS router running Cisco IOS Software Release 12.3(14)T.
This sample network needs standard services, such as Web access (HTTP and Secure HTTP [HTTPS]), Internet e-mail (SMTP, POP3, and IMAP),
packet voice (H.323), DNS lookup, FTP, Network Time Protocol (NTP), and ICMP. Furthermore, the network users employ Virtual Network
Computing (VNC), an open-source remote console application that runs by default on TCP port 5900, and they need HTTP access on atypical ports
(TCP port 81 and 8080) for connectivity to vendor or customer e-commerce Webpages.
Background
Cisco IOS Firewall uses Cisco IOS Firewall Stateful Inspection to restrict a public network’s access to protected networks, while maintaining the
private network’s ability to access resources located in the public network (Figure 14).
Cisco IOS Firewall Stateful Inspection protects networks with two basic components. ACLs restrict inbound connections, and stateful inspection
examines activity traversing the Cisco IOS Firewall from the protected network to the public network and anticipates the return traffic. Stateful
inspection is a mechanism that observes the initiation, maintenance, and closure of network data connections.
Cisco IOS Firewall Stateful Inspection with granular inspection supports several of the specific application protocols listed in Appendix 1. Some
of these protocols are common, simple protocols such as HTTP and Telnet, which only use one connection between client and server (or peers) to
request and return application data. More complex supported protocols, such as FTP and H.323, employ a control channel to establish
communications and a secondary data channel to transmit application data.
Some common protocols are not specifically predefined in IP inspection. Prior to Cisco IOS Software Release 12.3(14)T, ip inspect tcp and ip
inspect udp were used as universal options for any services not covered by specific inspection services to inspect outgoing traffic and allow return
traffic through a Cisco IOS Firewall’s inbound permission ACL. Unfortunately, the inspect tcp option’s capability to allow any return traffic is
problematic in circumstances where specific protocols must be disallowed, particularly when a complex application such as IM or P2P employs
unpredictable port numbers and other mechanisms that make the traffic difficult to detect and block as it leaves the network. Undesired complex
applications can be blocked by denying all return traffic except the traffic allowed by specific inspection services.
Granular inspection is an effective solution for blocking applications using port-hopping techniques that defy ACLs attempting to block the traffic,
because the only traffic that is allowed to return through the firewall is running on the specific desired ports that the user allows with existing,
predefined inspection capabilities, as well as user-specific, PAM-defined granular inspection policies. inspect tcp does not offer this application-
specific mechanism to permit traffic—it simply anticipates all traffic running over TCP.
Application Inspection
Granular inspection leaves some openings that advanced P2P and IM applications may exploit. Most networks allow HTTP traffic through
their firewalls, as it is the standard transport of many business applications, including ordinary Web traffic. Many IM and P2P applications have
developed mechanisms to disguise their traffic within TCP port 80 (HTTP) traffic, thus offering their application an additional mechanism to work
By combining granular inspection with the HTTP Application Inspection Engine, network engineers can allow desired protocols’ traffic to return to
their networks through access lists that protect the private network from unwanted public Internet traffic. Application inspection can control specific
unwanted application traffic that has been concealed inside legitimate HTTP traffic.
The first configuration step restricts hosts on the public Internet from reaching the protected network with an ACL blocking all traffic from the
public Internet, and applying the list to an interface:
access-list 101 deny ip any any
In the next step, specific inspection statements are configured based on the acceptable traffic that the router will allow out through the firewall, and
on the expected return traffic:
ip inspect name my-ios-fw http
ip inspect name my-ios-fw https
ip inspect name my-ios-fw esmtp
ip inspect name my-ios-fw pop3
ip inspect name my-ios-fw imap3
ip inspect name my-ios-fw dns
ip inspect name my-ios-fw ftp
ip inspect name my-ios-fw ntp
ip inspect name my-ios-fw icmp
Cisco IOS Software supports the most popular Internet protocols, as well as several protocols that require additional effort to accommodate
secondary data connections (Appendix 1). This example requires support for VNC, which is not supported by default IP inspection capability;
Now that the IP inspection set is complete, apply the inspection policy to the outbound traffic. Since this example protects traffic sourced on the
private side of the router, ip inspect in is applied to the private interface. The router will inspect traffic passing from the private network to the
public Internet, and the appropriate ACL bypass entries will be entered on the public side of the router to allow desired return traffic from the
public Internet to pass back to the private network.
interface fastethernet 0/1
ip inspect my-ios-fw in
The Cisco IOS Firewall Stateful Inspection configuration that you have defined blocks unwanted connections from the public Internet and allows
return traffic for desired applications. Some P2P and IM applications may be able to carry their traffic over TCP port 80, so we’ll use the HTTP
Application Inspection Engine to inspect further into TCP port 80 packets, and look for indications of the unwanted P2P and IM traffic.
First, define the application inspection policy name, then configure HTTP inspection. Next, set up the policy. This policy will only inspect TCP port
80 traffic for misuse by non-HTTP traffic; you may wish to define other application inspection features. Check the configuration reference list at the
end of this document for details on using other HTTP application inspection features:
appfw policy-name abuse-control
application http
port-misuse default action reset alarm
This completes the configuration for Cisco IOS Firewall with granular inspection and application inspection.
References
Configuring Cisco IOS Firewall Stateful Inspection:
http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca7c5.html
Configuring PAM:
http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800d981c.html
CAVEATS
• This document does not illustrate a security policy that must be followed; rather, it explains how to initiate such a policy.
• Separate documentation outlines IDS design.
• Cisco IOS Firewall does not currently protect ICMP and it is not covered. For the purposes of troubleshooting, ICMP can be allowed. However,
as a security measure, it is not advisable to permit ICMP to pass. It is advisable to use ACLs to control the various types of ICMP packets.
• ACLs can be used for IP Spoofing Defense, so that traffic is denied if it comes from outside and has spoofed the inside IP address.
• All firewall states are internal to a single router; therefore, there is currently no provisioning available for redundant firewall routers.
Configurations with asymmetric routing (only one direction of each session passes through the router) cause limitations for dynamic
modification of ACLs.
• Due to the connectionless nature of UDP traffic, the advanced firewall engine relies on idle timers for closing client-server channels. These
timers are not specifically covered in this document, but can be configured for certain types of UDP traffic (i.e. DNS), which can limit very
large numbers of open UDP channels.
• A separate document explains Advanced Firewall Inspection/Authentication Proxy with IPSec VPN. Although IPSec VPNs can affect a
security policy, Cisco IOS Firewall addresses IPSec type packets directly in the packet flow process.
DEPLOYMENT SCENARIOS
Corporations today can implement the Cisco IOS Firewall to secure the following perimeters (Figure 21):
Figure 16 details several key components of a typical enterprise network. Each component is broken down into sections to better understand the
configuration tasks and security implications for each segment within the network. Security policies and intruder concerns vary widely in each
scenario. These implications often involve “political” relationships among departments and/or partners, which affects the technical implementation
of the defined security policies for the firewall. Each policy should be reviewed periodically to best address access and security concerns.
Internet Perimeter
Cisco IOS Firewall used as corporate Internet firewall is shown in Figure 17.
The company assigns everyone a user ID and password for authentication. The protocols the company wants to secure are SMTP, FTP, H.323,
DNS, Telnet, SQLnet, and RealAudio. The protocols—HTTP, SSL, FTP, VDOlive, NetShow, and H.323—are allowed for outside to access the
Web server in DMZ. As a policy, no one is allowed to initiate any connection from DMZ.
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname FWRouter
!
! Enable authentication proxy globally.
!
boot system flash
aaa new-model
aaa authentication login default group tacacs+
aaa authentication login console_line line none
• Each interface can be configured so that each subnet has its own policy
• Sub-interfaces of WAN protocols are supported (i.e. ATM and Frame Relay)
The administrative network has Web servers that need to be accessed by all of the company and permit only HTTP in. Marketing maintains servers
and needs to allow the Telnet, FTP, SMTP, UDP, and HTTP inbound protocols. Similar to the Internet perimeter scenario, only specific protocols
that are necessary for each department are allowed. This approach not only limits the number of resources that can be attacked at any one time, but
also layers security into administrative areas. The server subnet has only servers that will require Telnet, FTP, and UDP.
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname FWRouter
!
boot system flash
enable secret 5 $1$VZGK$Els0ipcmt8Pe0R98RMEds0
enable password 7 0822455D0A16544541
!
username cisco password 7 121A0C041104
!
!
no ip source-route
no ip finger
!
! inspection is configured per interface. Traffic traversing interfaces depends on
! the configuration of the outbound ACLs.
!
ip inspect audit-trail
! inspection for the admin, eng and mktng subnets. This traffic can go anywhere and
! is applied to traffic heading into the interface. Note: tcp inspection will
! account for TELNET traffic and HTTP which are single channel protocols. UDP
! inspection takes care of DNS.
ip inspect name CorpFIREin tcp
ip inspect name CorpFIREin udp
ip inspect name CorpFIREin ftp
ip inspect name CorpFIREin smtp
ip inspect name CorpFIREin realaudio
ip inspect name CorpFIREin h323
ip audit notify log
ip audit po max-events 100
• Only the subnet 200.2.4.0/24 is permitted for Telnet, FTP, and HTTP into inside.
• Inside has Telnet, FTP, and HTTP access to the branch office.
The branch office policy limited not only protocols, but also the source address of the network. This limit also restricts the types of attacks that can
be generated.
Note the placement of this router relative to the corporate intranet perimeter. This placement, along with the security policy defined per department,
helps to limit liabilities throughout the whole network. This builds a layered security approach.
Current configuration:
!
Extranet Perimeter
Cisco IOS Firewall used as a corporate extranet firewall is shown in Figure 20.
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname FWRouter
!
boot system flash
!
! Enable authentication proxy globally.
!
aaa new-model
aaa authentication login default group tacacs+
aaa authentication login console_line line none
aaa authentication login vty_line line none
aaa authorization exec vty_line none
aaa authorization auth-proxy default group tacacs+
enable secret 5 $1$VZGK$Els0ipcmt8Pe0R98RMEds0
enable password 7 0822455D0A16544541
!
username cisco password 7 121A0C041104
!
!
!
!
no ip source-route
no ip finger
!
ip inspect name CorpFire ftp
ip inspect name CorpFire tcp
ip auth-proxy name PROXY http
ip audit notify log
Like the Internet Firewall policy, HTTP need not be specified, as Java blocking is not necessary. Specifying TCP inspection allows for single-
channel protocols like Telnet and HTTP. UDP is specified for DNS.
Access
• Keep the firewall in a secured (locked) room.
• Think about access control before connecting a console port to the network in any way, including attaching a modem to the port. Be aware that
a break character on the console port might give total control of the firewall, even with access control configured.
Services
Any enabled service could present a potential security risk. A determined, hostile party might be able to find creative ways to misuse the enabled
services to access the firewall or the network. Do not enable any local service (such as SNMP or NTP) that will not be used.
• Cisco Discovery Protocol (CDP) is enabled by default. To turn off CDP, enter the no cdp run global configuration command, or apply no cdp
enable on public or vulnerable interfaces if CDP is required for specific interfaces.
• For local services that are enabled, protect against misuse by configuring the services to communicate only with specific peers, and protect by
configuring access lists to deny packets for the services at specific interfaces.
• Disable minor services. For IP, enter the no service tcp-small-servers and no service udp-small-servers global configuration commands.
• If NTP is essential, configure it only on required interfaces to listen only to certain peers, and use authenticated NTP if NTP poisoning is a
concern. To disable the NTP server on specific interfaces, enter the ntp disable interface configuration command on each interface where NTP
will not be served.
• Disable all HTTP services except those required for network function. Service restriction is configured with “ip http active-session-modules”
command, as documented on Cisco.com:
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080455929.html
Cisco IOS offers two different options to “lock down” routers. AutoSecure is available at the command line by typing “auto secure” at the router’s
enable prompt, and Cisco Router and Security Device Manager (SDM) offers the Router Security Audit tool in a GUI format. Both of these tools
can lead the network engineer through a dialogue to disable services that may increase the router’s vulnerability profile, set up stronger
authentication, and configure other settings to improve router security.
• Protect against spoofing: protect the networks on both sides of the firewall from being spoofed from the other side. You could protect against
spoofing by configuring input access lists at all interfaces to pass only traffic from expected source addresses, and to deny all other traffic.
Many network attacks (SYN attacks in particular) use a “bogus” source address, originating from one of the reserved address ranges. The
reserved address space list is somewhat dynamic, as the Internet Assigned Numbers Authority grants and revokes address space to Internet
network service providers. The list of reserved or unassigned IP addresses is known as the “bogon” list. A current bogon list is available at:
http://www.cymru.org
• IP Source Routing allows a traffic source to specify that a packet must pass through certain hosts on the Internet on the way to its
destination. Source routing rarely has legitimate use on the public Internet, and is more frequently used for network attack or abuse.
Under most circumstances, all routers in a network should have source routing disabled. Disable source routing. For IP, enter the no ip
source-route global configuration command.
Configuration
Most small to medium-sized networks can employ element-based configuration and management, where a network engineer/administrator
individually configures and monitors devices on the network. Element-based configuration and monitoring/management is accomplished with
the router’s CLI, or with Cisco SDM if an easier-to-use graphical interface is desired. The CLI and Cisco SDM can only configure one device
at a time, and do not provide any multiple-device correlation to compile networkwide rules’ impact on traffic.
As the number of devices on the network increases, determination of the network’s policy for a given traffic flow becomes more complex. Larger
networks usually benefit from application of network-based configuration and management systems, such as Cisco Security Manager to integrate
networkwide provisioning, configuration, and management into one system, and Cisco Security Monitoring, Analysis, and Response System
(MARS) for network monitoring and security event correlation.
REFERENCES
• Cisco IOS Firewall Overview
• Security Command Reference
• Cisco IOS Firewall Command Reference
• Implementing Authentication
• SDM 2.2 User’s Guide , including several pages for configuring IOS Firewall with SDM
Cisco Systems has more than 200 offices in the following countries and regions. Addresses, phone numbers, and fax numbers are listed on
the Cisco Website at www.cisco.com/go/offices.
Argentina • Australia • Austria • Belgium • Brazil • Bulgaria • Canada • Chile • China PRC • Colombia • Costa Rica • Croatia • Cyprus
Czech Republic • Denmark • Dubai, UAE • Finland • France • Germany • Greece • Hong Kong SAR • Hungary • India • Indonesia • Ireland • Israel
Italy • Japan • Korea • Luxembourg • Malaysia • Mexico • The Netherlands • New Zealand • Norway • Peru • Philippines • Poland • Portugal
Puerto Rico • Romania • Russia • Saudi Arabia • Scotland • Singapore • Slovakia • Slovenia • South Africa • Spain • Sweden • Switzerland • Taiwan
Thailand • Turkey • Ukraine • United Kingdom • United States • Venezuela • Vietnam • Zimbabwe
Copyright 2005 Cisco Systems, Inc. All rights reserved. CCSP, CCVP, the Cisco Square Bridge logo, Follow Me Browsing, and StackWise are trademarks of Cisco Systems, Inc.;
Changing the Way We Work, Live, Play, and Learn, and iQuick Study are service marks of Cisco Systems, Inc.; and Access Registrar, Aironet, ASIST, BPX, Catalyst, CCDA, CCDP,
CCIE, CCIP, CCNA, CCNP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity,
Empowering the Internet Generation, Enterprise/Solver, EtherChannel, EtherFast, EtherSwitch, Fast Step, FormShare, GigaDrive, GigaStack, HomeLink, Internet Quotient, IOS, IP/TV, iQ
Expertise, the iQ logo, iQ Net Readiness Scorecard, LightStream, Linksys, MeetingPlace, MGX, the Networkers logo, Networking Academy, Network Registrar, Packet, PIX, Post-
Routing, Pre-Routing, ProConnect, RateMUX, ScriptShare, SlideCast, SMARTnet, StrataView Plus, TeleRouter, The Fastest Way to Increase Your Internet Quotient, and TransPath are
registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.