AIX Performance Cmds
AIX Performance Cmds
close window
Resources
Editor’s note: This article is the second in a two-part series. The first article can be found
here on the IBM Systems Magazine, Power Systems — AIX edition Web site.
As you know, AIX has a vast array of commands that enable you to do a multitude of tasks.
Depending on your needs, you use only a certain subset of these commands. These subsets
differ from user to user and from need to need. However, there are a few core commands
every user will commonly use.
In the first part of the series, I discussed commands that help you answer questions related to
your OS hardware, version of AIX and kernels. In this article, I’ll outline information related
to volume groups and logical volumes, networks, workload partitions and other performance
monitoring tools. The intent is to provide a list you can use as a ready reference. While the
behavior of these commands should be identical in all releases of AIX, they have been only
tested in AIX 5.3.
How do I create a volume group? Use the following command, where s partition_size sets
the number of megabytes (MB) in each physical partition where the partition_size is
expressed in units of MB from one through 1,024. (It's one through 131,072 for AIX 5.3.)
mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
The partition_size variable must be equal to a power of two (for example: one, two, four or
eight). The default value for standard and big volume groups is the lowest value to remain
http://www.ibmsystemsmag.com/print/print.aspx?print_page=/aix/enewsletterexclusive/24... 9/20/2010
IBM Systems Magazine Page 2 of 4
within the limitation of 1,016 physical partitions per physical volume. The default value for
scalable volume groups is the lowest value to accommodate 2,040 physical partitions per
physical volume.
How can I change the characteristics of a volume group? You use the chvg command to
change the characteristics of a volume group.
How do I increase the size of a logical volume? To increase the size of the logical volume
represented by the lv05 directory by three logical partitions, for example, type extendlv
lv05 3.
How do I display all logical volumes that are part of a volume group (e,g, rootvg)? You
can display all logical volumes that are part of rootvg by typing the following command:
lsvg -l rootvg/
How do I list information about logical volumes? Run the following command to display
information about the logical volume lv1: lslv lv1.
How do I remove a logical volume? You can remove the logical volume lv7 by running the
following command: rmlv lv7. The rmlv command removes only the logical volume, but
does not remove other entities, such as file systems or paging spaces that were using the
logical volume.
How do I remove a copy of a logical volume? You can use the rmlvcopy command to
remove copies of logical partitions of a logical volume. To reduce the number of copies of
each logical partition belonging to logical volume testlv, ente: rmlvcopy testlv 2. Each
logical partition in the logical volume now has at most two physical partitions.
Queries about volume groups: To show volume groups in the system, type lsvg. To show
all the characteristics of rootvg, type lsvg rootvg. To show disks used by rootvg, type lsvg -
p rootvg.
http://www.ibmsystemsmag.com/print/print.aspx?print_page=/aix/enewsletterexclusive/24... 9/20/2010
IBM Systems Magazine Page 3 of 4
How can I clone the rootvg? You can run the alt_disk_copy command to copy the current
rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1:
alt_disk_copy -d hdisk1.
Network
How can I display or set values for network parameters? The no command sets or
displays current or next boot values for network tuning parameters.
How do I get the IP address of my machine? Type one of the following: ifconfig -a or
host Fully_Qualified_Host_Name. For example, host cyclop.austin.ibm.com.
How do I identify the network interfaces on my server? Either of the following two
commands will display the network interfaces: lsdev -Cc if or ifconfig -a. To get
information about one specific network interface, for eaxample tr0, run the command
ifconfig tr0.
How do I activate a network interface? To activate the network interface tr0, run the
command ifconfig tr0 up.
How do I deactivate a network interface? For example, to deactivate the network interface
tr0, run the command: ifconfig tr0 down.
How do I display routing table, interface and protocol information? To display routing
table information for an Internet interface, type netstat -r -f inet. To display interface
information for an Internet interface, type netstat -i -f inet. To display statistics for
each protocol, type netstat -s -f inet.
Workload Partitions
Workload Partitions (WPARs), a set of completely new software-based system virtualization
features, were introduced in IBM AIX Version 6.1.
How do I create a workload partition? To create a workload partition named temp with IP
Address xxx.yyy.zzz.nnn, type
mkwpar -n temp -N address= xxx.yyy.zzz.nnn
How do I start a workload partition? To start the workload partition called temp, type
startwpar temp.
http://www.ibmsystemsmag.com/print/print.aspx?print_page=/aix/enewsletterexclusive/24... 9/20/2010
IBM Systems Magazine Page 4 of 4
foo D S foo.austin.ibm.com /wpars/foo
trigger A A trigger /
How do I remove a workload partition? To remove the workload partition called temp,
type rmwpar temp. To stop and remove the workload partition called temp preserving data
on its file system, type rmwpar -p -s temp.
How do I display statistics for all TTY commands, CPUs and disks? To display a single
set of statistics for all TTY, CPU, and Disks since boot, type iostat.
How do I display a detailed local and remote system statistics? Type the following
command:
topas
topas -P displays process
topas -L displays logical partition
topas -D displays disk metric
topas -F displays file system
How do I report system unit activity? Type the sar command. To report processor activity for
the first two processors, enter sar -u -P 0,1. This produces output similar to the following:
cpu %usr %sys %wio %idle
0 45 45 5 5
1 27 65 3 5
Admittedly, a list such as this can be helpful in quickly answering some of your own
questions. However, it doesn’t cover everything that you might need. You can extend the
usefulness of such a list by adding other commands that answer additional questions not
addressed here.
This article was based in part upon the IBM developerWorks article “AIX commands you
should not leave home without,” first published on the IBM developerWorks AIX and UNIX
zone. All rights retained by IBM.
http://www.ibmsystemsmag.com/print/print.aspx?print_page=/aix/enewsletterexclusive/24... 9/20/2010