50% found this document useful (2 votes)
8K views

VIOS Commands

This document provides instructions for managing virtual devices and network configuration on a VIOS. It includes commands for checking virtual devices and mappings, hardware configuration, IP addressing, logical volumes, virtual device creation and removal, storage array emulation configuration, and more. Key steps are to list virtual devices and mappings, check hardware configuration and IP addresses, create logical volumes for virtual disks, establish mappings between logical volumes and virtual devices, and configure network interfaces for storage array emulation.

Uploaded by

selvaraj1950
Copyright
© Attribution Non-Commercial (BY-NC)
Available Formats
Download as PDF, TXT or read online on Scribd
50% found this document useful (2 votes)
8K views

VIOS Commands

This document provides instructions for managing virtual devices and network configuration on a VIOS. It includes commands for checking virtual devices and mappings, hardware configuration, IP addressing, logical volumes, virtual device creation and removal, storage array emulation configuration, and more. Key steps are to list virtual devices and mappings, check hardware configuration and IP addresses, create logical volumes for virtual disks, establish mappings between logical volumes and virtual devices, and configure network interfaces for storage array emulation.

Uploaded by

selvaraj1950
Copyright
© Attribution Non-Commercial (BY-NC)
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 2

1.

To check all the virtual devices on the VIOS


lsdev –virtual

2. To check the virtual device mapping.


lsmap –all

3. To check the adapters on the VIOS


lsdev –type adapter

4. To Access the root


oem_setup_env

5. To check the ip addr assigned to VIOS


lstcpip –interfaces

6. To check the status of virtual Ethernet adapters.


lsmap –all –net

7. To configure the hardware


cfgdev

8. To check the slot ID of the virtual devices:


lsmap –all command

9. To remove the virtual device


rmdev –dev vhost0 –recursive

10. To see the VPD


lsdev –vpd |more

11. To see the LV in a VG


lsvg –lv <vgname>

12. To mirror ios


extendvg rootvg hdisk1
mirrorios –f hdisk1 ---- f flag will automatically reboot the VIOS.

13.To create VG in VIOS


mkvg –f –vg <vgname> <pvname>
e.g
mkvg –f –vg clientvg hdisk1

14.To create LVs for vitual disks:


mklv –lv <lvname> <vgname> <size>
e.g mklv –lv client1 clientvg 10G ------- 10G is the size of LV
15.To create the virtual device mapping between LVs and vhosts:
mkvdev –vdev <lvname> -vadapter <vhost #> -dev <mapping name>
e.g
mkvdev –vdev client1 –vadapter vhost0 –dev client1disk1

16.To remove the virtual device mapping:


rmvdev –vtd <mapping name>
e.g
rmvdev –vtd client1disk1

17.To configure the SEA:


mkvdev –sea <phy adapter> -vadapter <virtual ent> -default <virtual ent> -defaultid 1
e.g
mkvdev –sea ent0 –vadapter ent1 –default ent1 –defaultid 1

18.To configure tcpip on SEA


mktcpip –hostname <hostname> -inetaddr <ip addr> -interface <en of SEA port> -
netmask <netmask> -gateway <gateway>
e.g
mktcpip –hostname VIO_server –inetaddr 10.1.1.10 –interface en2 –netmask
255.255.255.0 –gateway 10.1.1.100

You might also like