Broadcom Cfe Command Extensions
Broadcom Cfe Command Extensions
1 The Router 3
1.1 Getting started . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
1.1.1 Installation . . . . . . . . . . . . . . . . . . . . . . . . . . 3
1.1.2 Initial configuration . . . . . . . . . . . . . . . . . . . . . 3
1.1.3 Failsafe mode . . . . . . . . . . . . . . . . . . . . . . . . . 3
1.2 Configuring OpenWrt . . . . . . . . . . . . . . . . . . . . . . . . 3
1.2.1 Network . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
1.2.2 Wireless . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
1.3 Advanced configuration . . . . . . . . . . . . . . . . . . . . . . . 15
1.3.1 Hotplug . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
1.3.2 Init scripts . . . . . . . . . . . . . . . . . . . . . . . . . . 16
1.3.3 Network scripts . . . . . . . . . . . . . . . . . . . . . . . . 18
2 Development issues 19
2.1 The build system . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
2.1.1 Building an image . . . . . . . . . . . . . . . . . . . . . . 19
2.1.2 Creating packages . . . . . . . . . . . . . . . . . . . . . . 22
2.1.3 Creating binary packages . . . . . . . . . . . . . . . . . . 27
2.1.4 Creating kernel modules packages . . . . . . . . . . . . . . 28
2.1.5 Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . 29
2.1.6 Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . 29
2.1.7 Using build environments . . . . . . . . . . . . . . . . . . 30
2.2 Extra tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
2.2.1 Image Builder . . . . . . . . . . . . . . . . . . . . . . . . . 31
2.2.2 SDK . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
2.3 Adding platform support . . . . . . . . . . . . . . . . . . . . . . 31
1
2 CONTENTS
The Router
1.1.1 Installation
1.2.1 Network
ifname specifies the Linux interface name. If you want to use bridging on one
or more interfaces, set ifname to a list of interfaces and add:
3
4 CHAPTER 1. THE ROUTER
• username
The PPP username (usually with PAP authentication)
• password
The PPP password
• keepalive
Ping the PPP server (using LCP). The value of this option specifies the
maximum number of failed pings before reconnecting. The ping inter-
val defaults to 5, but can be changed by appending ”,<interval>” to the
keepalive value
• demand
Use Dial on Demand (value specifies the maximum idle time.
• server: (pptp)
The remote pptp server IP
For all protocol types, you can also specify the MTU by using the mtu option.
You can set up static routes for a specific interface that will be brought up after
the interface is configured.
Simply add a config section like this:
The name for the route section is optional, the interface, target and gateway
options are mandatory. Leaving out the netmask option will turn the route into
a host route.
1.2. CONFIGURING OPENWRT 5
On Broadcom hardware the section name needs to be eth0, as the switch driver
does not detect the switch on any other physical device. Every vlan option
needs to have the name vlan<n> where <n> is the VLAN number as used in
the switch driver. As value it takes a list of ports with these optional suffixes:
• ’*’: Set the default VLAN (PVID) of the Port to the current VLAN
• ’u’: Force the port to be untagged
• ’t’: Force the port to be tagged
The CPU port defaults to tagged, all other ports to untagged. On Broadcom
hardware the CPU port is always 5. The other ports may vary with different
hardware.
For instance, if you wish to have 3 vlans, like one 3-port switch, 1 port in a
DMZ, and another one as your WAN interface, use the following configuration :
Three interfaces will be automatically created using this switch layout : eth0.0
(vlan0), eth0.1 (vlan1) and eth0.2 (vlan2). You can then assign those inter-
faces to a custom network configuration name like lan, wan or dmz for instance.
OpenWrt supports IPv6 connectivity using PPP, Tunnel brokers or static as-
signment.
If you use PPP, IPv6 will be setup using IP6CP and there is nothing to configure.
To setup an IPv6 tunnel to a tunnel broker, you can install the 6scripts package
and edit the /etc/config/6tunnel file and change the settings accordingly :
config 6tunnel
option tnlifname ’sixbone’
option remoteip4 ’1.0.0.1’
option localip4 ’1.0.0.2’
option localip6 ’2001::DEAD::BEEF::1’
option prefix ’/64’
6 CHAPTER 1. THE ROUTER
Using the same package you can also setup an IPv6 bridged connection :
config 6bridge
option bridge ’br6’
By default the script bridges the WAN interface with the LAN interface and
uses ebtables to filter anything that is not IPv6 on the bridge.
IPv6 static addressing is also supported using a similar setup as IPv4 but with
the ip6 prefixing (when applicable).
1.2.2 Wireless
The reason for using such architecture, is that it abstracts the driver configura-
tion.
1.2. CONFIGURING OPENWRT 7
config wifi-iface
option device "wl0"
# option network lan
option mode "ap"
option ssid "OpenWrt"
option hidden "0"
option encryption "none"
config wifi-iface
option device "wifi0"
# option network lan
option mode "ap"
option ssid "OpenWrt"
option hidden "0"
option encryption "none"
config wifi-iface
option device "wlan0"
# option network lan
option mode "ap"
option ssid "OpenWrt"
option hidden "0"
option encryption "none"
option channel 1
config wifi-iface
option device wifi0
# option network lan
option mode ap
option ssid OpenWrt_private
option hidden 0
option encryption none
config wifi-iface
option device wifi1
# option network lan
option mode ap
option ssid OpenWrt_public
option hidden 1
option encryption none
There are two types of config sections in this file. The ’wifi-device’ refers to
the physical wifi interface and ’wifi-iface’ configures a virtual interface on top
of that (if supported by the driver).
A full outline of the wireless configuration file with description of each field:
config wifi-iface
option network the interface you want wifi to bridge with
option device wifi0, wifi1, wifi2, wifiN
option mode ap, sta, adhoc, monitor, or wds
option txpower transmission power in dBm
option ssid ssid name
option bssid bssid address
option encryption none, wep, psk, psk2, wpa, wpa2
option key encryption key
option key1 key 1
option key2 key 2
option key3 key 3
1.2. CONFIGURING OPENWRT 9
• type
The driver to use for this interface.
• country
The country code used to determine the regulatory settings.
• channel
The wifi channel (e.g. 1-14, depending on your country setting).
• maxassoc
Optional: Maximum number of associated clients. This feature is sup-
ported only on the broadcom chipset.
• distance
Optional: Distance between the ap and the furthest client in meters. This
feature is supported only on the atheros chipset.
• mode
The frequency band (b, g, bg, a). This feature is only supported on the
atheros chipset.
• diversity
Optional: Enable diversity for the Wi-Fi device. This feature is supported
only on the atheros chipset.
• rxantenna
Optional: Antenna identifier (0, 1 or 2) for reception. This feature is
supported by atheros and some broadcom chipsets.
• txantenna
Optional: Antenna identifier (0, 1 or 2) for emission. This feature is
supported by atheros and some broadcom chipsets.
• network
Selects the interface section from /etc/config/network to be used with
this interface
• device
Set the wifi device name.
• mode
Operating mode:
10 CHAPTER 1. THE ROUTER
– ap
Access point mode
– sta
Client mode
– adhoc
Ad-Hoc mode
– monitor
Monitor mode
– wds
WDS point-to-point link
– none
– wep
– psk, psk2
WPA(2) Pre-shared Key
– wpa, wpa2
WPA(2) RADIUS
config wifi-iface
option device "wl0"
option network lan
option mode "ap"
option ssid "OpenWrt"
option hidden "0"
option encryption "none"
config wifi-iface
option device "wl0"
option network lan
option mode wds
option ssid "OpenWrt WDS"
option bssid "ca:fe:ba:be:00:02"
config wifi-iface
option device "wl0"
option network lan
option mode ap
option ssid "OpenWrt"
option encryption psk2
option key "<key for clients>"
config wifi-iface
option device "wl0"
option network lan
option mode wds
option bssid ca:fe:ba:be:00:02
option ssid "OpenWrt WDS"
option encryption psk2
option key "<psk for WDS>"
12 CHAPTER 1. THE ROUTER
EAP-TLS
config wifi-iface
option device "ath0"
option network lan
option ssid OpenWrt
option eap_type tls
option ca_cert "/etc/config/certs/ca.crt"
option priv_key "/etc/config/certs/priv.crt"
option priv_key_pwd "PKCS#12 passphrase"
EAP-PEAP
config wifi-iface
option device "ath0"
option network lan
option ssid OpenWrt
option eap_type peap
option ca_cert "/etc/config/certs/ca.crt"
option auth MSCHAPV2
option identity username
option password password
Limitations: There are certain limitations when combining modes. Only the
following mode combinations are supported:
• Broadcom:
– 1x sta, 0-3x ap
– 1-4x ap
– 1x adhoc
– 1x monitor
WDS links can only be used in pure AP mode and cannot use WEP
(except when sharing the settings with the master interface, which is done
automatically).
• Atheros:
– 1x sta, 0-Nx ap
– 1-Nx ap
1.2. CONFIGURING OPENWRT 13
– 1x adhoc
Each driver script should append the driver to a global DRIVERS variable :
scan_dummy() {
local device="$1"
enable_<driver> This function will bring up the wifi device and optionally
create application specific configuration files, e.g. for the WPA authenticator or
supplicant.
Example:
14 CHAPTER 1. THE ROUTER
enable_dummy() {
local device="$1"
disable_<driver> This function will bring down the wifi device and all its
virtual interfaces (if supported).
Example:
disable_dummy() {
local device="$1"
detect_<driver> This function looks for interfaces that are usable with the
driver. Template config sections for new devices should be written to stdout.
Must check for already existing config sections belonging to the interfaces before
creating new templates.
Example:
detect_dummy() {
[ wifi-device = "$(config_get dummydev type)" ] && return 0
cat <<EOF
config wifi-device dummydev
option type dummy
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1
config wifi-iface
option device dummydev
option mode ap
option ssid OpenWrt
EOF
}
1.3. ADVANCED CONFIGURATION 15
To be able to load configuration files, you need to include the common functions
with:
. /etc/functions.sh
Then you can use config_load <name> to load config files. The function
first checks for <name> as absolute filename and falls back to loading it from
/etc/config (which is the most common way of using it).
If you want to use special callbacks for sections and/or options, you need to
define the following shell functions before running config_load (after including
/etc/functions.sh):
config_cb() {
local type="$1"
local name="$2"
# commands to be run for every section
}
option_cb() {
# commands to be run for every option
}
You can also alter option_cb from config_cb based on the section type. This
allows you to process every single config section based on its type individually.
config_cb is run every time a new section starts (before options are being pro-
cessed). You can access the last section through the CONFIG_SECTION variable.
16 CHAPTER 1. THE ROUTER
Also an extra call to config_cb (without a new section) is generated after con-
fig_load is done. That allows you to process sections both before and after all
options were processed.
Another way of iterating on config sections is using the config_foreach com-
mand.
Syntax:
This command will run the supplied function for every single config section in
the currently loaded config. The section name will be passed to the function as
argument 1. If the section type is added to the command line, the function will
only be called for sections of the given type.
You can access already processed options with the config_get command Syn-
tax:
In busybox ash the three-option config_get is faster, because it does not result
in an extra fork, so it is the preferred way.
Additionally you can also modify or add options to sections by using the con-
fig_set command.
Syntax:
1.3.1 Hotplug
Because OpenWrt uses its own init script system, all init scripts must be in-
stalled as /etc/init.d/name use /etc/rc.common as a wrapper.
Example: /etc/init.d/httpd
1.3. ADVANCED CONFIGURATION 17
#!/bin/sh /etc/rc.common
# Copyright (C) 2006 OpenWrt.org
START=50
start() {
[ -d /www ] && httpd -p 80 -h /www -r OpenWrt
}
stop() {
killall httpd
}
as you can see, the script does not actually parse the command line arguments
itself. This is done by the wrapper script /etc/rc.common.
start() and stop() are the basic functions, which almost any init script should
provide. start() is called when the user runs /etc/init.d/httpd start or (if
the script is enabled and does not override this behavior) at system boot time.
Enabling and disabling init scripts is done by running /etc/init.d/name en-
able or /etc/init.d/name disable. This creates or removes symbolic links
to the init script in /etc/rc.d, which is processed by /etc/init.d/rcS at boot
time.
The order in which these scripts are run is defined in the variable START in the
init script. Changing it requires running /etc/init.d/name enable again.
You can also override these standard init script functions:
• boot()
Commands to be run at boot time. Defaults to start()
• restart()
Restart your service. Defaults to stop(); start()
• reload()
Reload the configuration files for your service. Defaults to restart()
You can also add custom commands by creating the appropriate functions and
referencing them in the EXTRA_COMMANDS variable. Helptext is added in EX-
TRA_HELP.
Example:
status() {
# print the status info
}
EXTRA_COMMANDS="status"
EXTRA_HELP=" status Print the status of the service"
18 CHAPTER 1. THE ROUTER
To be able to access the network functions, you need to include the necessary
shell scripts by running:
Some protocols, such as PPP might change the configured interface names
at run time (e.g. eth0 => ppp0 for PPPoE). That’s why you have to run
scan_interfaces instead of reading the values from the config directly. Af-
ter running scan_interfaces, the ’ifname’ option will always contain the
effective interface name (which is used for IP traffic) and if the physical device
name differs from it, it will be stored in the ’device’ option. That means that
running config_get lan ifname after scan_interfaces might not return the
same result as running it before.
After running scan_interfaces, the following functions are available:
• find_config interface
looks for a network configuration that includes the specified network in-
terface.
You can add custom protocol handlers by adding shell scripts to /lib/network.
They provide the following two shell functions:
scan_<protocolname>() {
local config="$1"
# change the interface names if necessary
}
setup_interface_<protocolname>() {
local interface="$1"
local config="$2"
# set up the interface
}
Development issues
19
20 CHAPTER 2. DEVELOPMENT ISSUES
produce a new firmware image – there is no work to be done trying to track down
an unmodified copy of the existing kernel to see what changes had been made,
the patches are already provided and the process ends up almost completely
transparent. This does not just apply to the kernel, but to anything included
with OpenWrt – It is this one simple understated concept which is what allows
OpenWrt to stay on the bleeding edge with the latest compilers, latest kernels
and latest applications.
So let’s take a look at OpenWrt and see how this all works.
Download OpenWrt
This article refers to the ”Kamikaze” branch of OpenWrt, which can be down-
loaded via subversion using the following command:
• tools
• toolchain
• package
• target
tools and toolchain refer to common tools which will be used to build the
firmware image, the compiler, and the C library. The result of this is three
new directories, build_dir/host, which is a temporary directory for building
the target independent tools, build_dir/toolchain-<arch> * which is used for
building the toolchain for a specific architecture, and staging_dir/toolchain-
<arch> * where the resulting toolchain is installed. You will not need to do
anything with the toolchain directory unless you intend to add a new version of
one of the components above.
• build_dir/host
• build_dir/toolchain-<arch> *
$ ./scripts/feeds update
Those packages can be used to extend the functionality of the build system and
need to be symlinked into the main trunk. Once you do that, the packages will
show up in the menu for configuration. From kamikaze you would do something
like this:
$ make package/symlinks
target refers to the embedded platform, this contains items which are specific to
a specific embedded platform. Of particular interest here is the ”target/linux”
directory which is broken down by platform <arch> and contains the patches to
the kernel, profile config, for a particular platform. There’s also the ”target/image”
directory which describes how to package a firmware for a specific platform.
Both the target and package steps will use the directory ”build_dir/<arch> ”
as a temporary directory for compiling. Additionally, anything downloaded by
the toolchain, target or package steps will be placed in the ”dl” directory.
• build_dir/<arch>
• dl
Building OpenWrt
While the OpenWrt build environment was intended mostly for developers, it
also has to be simple enough that an inexperienced end user can easily build his
or her own customized firmware.
Running the command ”make menuconfig” will bring up OpenWrt’s configu-
ration menu screen, through this menu you can select which platform you’re
targeting, which versions of the toolchain you want to use to build and what
packages you want to install into the firmware image. Note that it will also
check to make sure you have the basic dependencies for it to run correctly. If
that fails, you will need to install some more tools in your local environment
before you can begin.
Similar to the linux kernel config, almost every option has three choices, y/m/n
which are represented as follows:
• <*> (pressing y)
This will be included in the firmware image
22 CHAPTER 2. DEVELOPMENT ISSUES
• <M> (pressing m)
This will be compiled but not included (for later install)
After you’ve finished with the menu configuration, exit and when prompted,
save your configuration changes.
If you want, you can also modify the kernel config for the selected target sys-
tem. simply run ”make kernel_menuconfig” and the build system will unpack
the kernel sources (if necessary), run menuconfig inside of the kernel tree, and
then copy the kernel config to target/linux/<platform> /config so that it is
preserved over ”make clean” calls.
To begin compiling the firmware, type ”make”. By default OpenWrt will only
display a high level overview of the compile process and not each individual
command.
Example:
make[2] toolchain/install
make[3] -C toolchain install
make[2] target/compile
make[3] -C target compile
make[4] -C target/utils prepare
[...]
This makes it easier to monitor which step it’s actually compiling and reduces
the amount of noise caused by the compile output. To see the full output, run
the command ”make V=99”.
During the build process, buildroot will download all sources to the ”dl” direc-
tory and will start patching and compiling them in the ”build_dir/<arch> ”
directory. When finished, the resulting firmware will be in the ”bin” directory
and packages will be in the ”bin/packages” directory.
One of the things that we’ve attempted to do with OpenWrt’s template system
is make it incredibly easy to port software to OpenWrt. If you look at a typical
package directory in OpenWrt you’ll find two things:
• package/<name> /Makefile
• package/<name> /patches
• package/<name> /files
2.1. THE BUILD SYSTEM 23
The patches directory is optional and typically contains bug fixes or optimiza-
tions to reduce the size of the executable. The package makefile is the important
item, provides the steps actually needed to download and compile the package.
The files directory is also optional and typicall contains package specific startup
scripts or default configuration files that can be used out of the box with Open-
Wrt.
Looking at one of the package makefiles, you’d hardly recognize it as a makefile.
Through what can only be described as blatant disregard and abuse of the tra-
ditional make format, the makefile has been transformed into an object oriented
template which simplifies the entire ordeal.
Here for example, is package/bridge/Makefile:
3 include $(TOPDIR)/rules.mk
4
5 PKG_NAME:=bridge
6 PKG_VERSION:=1.0.6
7 PKG_RELEASE:=1
8
9 PKG_SOURCE:=bridge-utils-$(PKG_VERSION).tar.gz
10 PKG_SOURCE_URL:=@SF/bridge
11 PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
12 PKG_CAT:=zcat
13
14 PKG_BUILD_DIR:=$(BUILD_DIR)/bridge-utils-$(PKG_VERSION)
15
16 include $(INCLUDE_DIR)/package.mk
17
18 define Package/bridge
19 SECTION:=net
20 CATEGORY:=Base system
21 TITLE:=Ethernet bridging configuration utility
22 URL:=http://bridge.sourceforge.net/
23 endef
24
25 define Package/bridge/description
26 Manage ethernet bridging:
27 a way to connect networks together to form a larger network.
28 endef
29
30 define Build/Configure
31 $(call Build/Configure/Default, \
32 --with-linux-headers="$(LINUX_DIR)" \
33 )
34 endef
35
36 define Package/bridge/install
24 CHAPTER 2. DEVELOPMENT ISSUES
37 $(INSTALL_DIR) $(1)/usr/sbin
38 $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin/
39 endef
40
As you can see, there’s not much work to be done; everything is hidden in other
makefiles and abstracted to the point where you only need to specify a few
variables.
• PKG_NAME
The name of the package, as seen via menuconfig and ipkg
• PKG_VERSION
The upstream version number that we are downloading
• PKG_RELEASE
The version of this package Makefile
• PKG_SOURCE
The filename of the original sources
• PKG_SOURCE_URL
Where to download the sources from (no trailing slash), you can add
multiple download sources by separating them with a
and a carriage return.
• PKG_MD5SUM
A checksum to validate the download
• PKG_CAT
How to decompress the sources (zcat, bzcat, unzip)
• PKG_BUILD_DIR
Where to compile the package
The PKG_* variables define where to download the package from; @SF is a special
keyword for downloading packages from sourceforge. There is also another key-
word of @GNU for grabbing GNU source releases. If any of the above mentionned
download source fails, the OpenWrt mirrors will be used as source.
The md5sum (if present) is used to verify the package was downloaded correctly
and PKG_BUILD_DIR defines where to find the package after the sources are
uncompressed into $(BUILD_DIR).
At the bottom of the file is where the real magic happens, ”BuildPackage” is a
macro set up by the earlier include statements. BuildPackage only takes one
argument directly – the name of the package to be built, in this case ”bridge”.
All other information is taken from the define blocks. This is a way of providing
a level of verbosity, it’s inherently clear what the contents of the description
template in Package/bridge is, which wouldn’t be the case if we passed this
information directly as the Nth argument to BuildPackage.
2.1. THE BUILD SYSTEM 25
• SECTION
The type of package (currently unused)
• CATEGORY
Which menu it appears in menuconfig: Network, Sound, Utilities, Multi-
media ...
• TITLE
A short description of the package
• URL
Where to find the original software
• MAINTAINER (optional)
Who to contact concerning the package
• DEPENDS (optional)
Which packages must be built/installed before this package. To reference
a dependency defined in the same Makefile, use <dependency name>. If
defined as an external package, use +<dependency name>. For a kernel
version dependency use: @LINUX 2 <minor version>
Package/<name>/conffiles (optional):
A list of config files installed by this package, one file per line.
Build/Prepare (optional):
A set of commands to unpack and patch the sources. You may safely leave this
undefined.
Build/Configure (optional):
You can leave this undefined if the source doesn’t use configure or has a normal
config script, otherwise you can put your own commands here or use ”$(call
Build/Configure/Default,<first list of arguments, second list> )”as
above to pass in additional arguments for a standard configure script. The first
list of arguments will be passed to the configure script like that: -arg 1 -arg
2. The second list contains arguments that should be defined before running
the configure script such as autoconf or compiler specific variables.
To make it easier to modify the configure command line, you can either extend
or completely override the following variables:
• CONFIGURE_ARGS
Contains all command line arguments (format: -arg 1 -arg 2)
• CONFIGURE_VARS
Contains all environment variables that are passed to ./configure (format:
NAME="value")
26 CHAPTER 2. DEVELOPMENT ISSUES
Build/Compile (optional):
How to compile the source; in most cases you should leave this undefined.
As with Build/Configure there are two variables that allow you to override
the make command line environment variables and flags:
• MAKE_FLAGS
Contains all command line arguments (typically variable overrides like
NAME="value"
• MAKE_VARS
Contains all environment variables that are passed to the make command
Build/InstallDev (optional):
If your package provides a library that needs to be made available to other pack-
ages, you can use the Build/InstallDev template to copy it into the staging
directory which is used to collect all files that other packages might depend on
at build time. When it is called by the build system, two parameters are passed
to it. $(1) points to the regular staging dir, typically staging_dir/ARCH , while
$(2) points to staging_dir/host. The host staging dir is only used for binaries,
which are to be executed or linked against on the host and its bin/ subdirec-
tory is included in the PATH which is passed down to the build system processes.
Please use $(1) and $(2) here instead of the build system variables $(STAG-
ING_DIR) and $(STAGING_DIR_HOST), because the build system behavior when
staging libraries might change in the future to include automatic uninstallation.
Package/<name>/install:
A set of commands to copy files out of the compiled source and into the ipkg
which is represented by the $(1) directory. Note that there are currently 4
defined install macros:
• INSTALL_DIR
install -d -m0755
• INSTALL_BIN
install -m0755
• INSTALL_DATA
install -m0644
• INSTALL_CONF
install -m0600
The reason that some of the defines are prefixed by ”Package/<name> ” and
others are simply ”Build” is because of the possibility of generating multiple
packages from a single source. OpenWrt works under the assumption of one
source per package Makefile, but you can split that source into as many packages
as desired. Since you only need to compile the sources once, there’s one global
set of ”Build” defines, but you can add as many ”Package/<name>” defines as
you want by adding extra calls to BuildPackage – see the dropbear package for
an example.
After you have created your package/<name> /Makefile, the new package will
automatically show in the menu the next time you run ”make menuconfig” and
if selected will be built automatically the next time ”make” is run.
2.1. THE BUILD SYSTEM 27
1 # $Id: $
2
3 include $(TOPDIR)/rules.mk
4
5 PKG_NAME:=binpkg
6 PKG_VERSION:=1.0
7 PKG_RELEASE:=1
8
9 PKG_SOURCE:=binpkg-$(PKG_VERSION).tar.gz
10 PKG_SOURCE_URL:=http://server
11 PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
12 PKG_CAT:=zcat
13
14 include $(INCLUDE_DIR)/package.mk
15
16 define Package/binpkg
17 SECTION:=net
18 CATEGORY:=Network
19 TITLE:=Binary package
20 endef
21
22 define Package/bridge/description
23 Binary package
24 endef
25
26 define Build/Configure
27 endef
28
29 define Build/Compile
30 endef
31
32 define Package/bridge/install
33 $(INSTALL_DIR) $(1)/usr/sbin
34 $(INSTALL_BIN) $(PKG_BUILD_DIR)/* $(1)/usr/sbin/
35 endef
36
Provided that the tarball which contains the binaries reflects the final directory
layout (/usr, /lib ...), it becomes very easy to get your package look like one
build from sources.
Note that using the same technique, you can easily create binary pcakages for
your proprietary kernel modules as well.
28 CHAPTER 2. DEVELOPMENT ISSUES
The OpenWrt distribution makes the distinction between two kind of kernel
modules, those coming along with the mainline kernel, and the others available
as a separate project. We will see later that a common template is used for both
of them.
For kernel modules that are part of the mainline kernel source, the makefiles
are located in package/kernel/modules/*.mk and they appear under the section
”Kernel modules”
For external kernel modules, you can add them to the build system just like if
they were software packages by defining a KernelPackage section in the package
makefile.
Here for instance the Makefile for the I2C subsytem kernel modules :
1 # $Id $
2
3 I2CMENU:=I2C Bus
4
5 define KernelPackage/i2c-core
6 TITLE:=I2C support
7 DESCRIPTION:=Kernel modules for i2c support
8 SUBMENU:=$(I2CMENU)
9 KCONFIG:=CONFIG_I2C_CORE CONFIG_I2C_DEV
10 FILES:=$(MODULES_DIR)/kernel/drivers/i2c/*.$(LINUX_KMOD_SUFFIX)
11 AUTOLOAD:=$(call AutoLoad,50,i2c-core i2c-dev)
12 endef
13 $(eval $(call KernelPackage,i2c-core))
• TITLE
The name of the module as seen via menuconfig
• DESCRIPTION
The description as seen via help in menuconfig
• SUBMENU
The sub menu under which this package will be seen
• KCONFIG
Kernel configuration option dependency. For external modules, remove it.
• FILES
Files you want to inlude to this kernel module package, separate with
spaces.
2.1. THE BUILD SYSTEM 29
• AUTOLOAD
Modules that will be loaded automatically on boot, the order you write
them is the order they would be loaded.
2.1.5 Conventions
There are a couple conventions to follow regarding packages:
• files
1. configuration files follow the convention
<name>.conf
2. init files follow the convention
<name>.init
• patches
1. patches are numerically prefixed and named related to what they do
2.1.6 Troubleshooting
If you find your package doesn’t show up in menuconfig, try the following com-
mand to see if you get the correct description:
If you’re just having trouble getting your package to compile, there’s a few
shortcuts you can take. Instead of waiting for make to get to your package, you
can run one of the following:
\texttt{./scripts/env help}
This will move your .config file and ./files (if it exists) to the env/ subdi-
rectory and create symlinks in the base folder.
After running make menuconfig or changing things in files/, your current state
will differ from what has been saved before. To show these changes, use:
./scripts/env diff
./scripts/env save
If you want to revert your changes to the previously saved copy, run:
./scripts/env revert
If you want, you can now create a second environment using the new command.
It will ask you whether you want to make it a clone of the current environment
(e.g. for minor changes) or if you want to start with a clean version (e.g. for
selecting a new target).
To switch to a different environment (e.g. test1), use:
If you want to get rid of environment switching and keep everything in the base
directory again, use:
./scripts/env clear
2.2. EXTRA TOOLS 31
2.2.2 SDK
There is a lot of methods to ensure your device is running Linux. Some of them
do need your router to be unscrewed and open, some can be done by probing
the device using its external network interfaces.
A large bunch of tools over the Internet exists in order to let you do OS finger-
printing, we will show here an example using nmap:
nmap is able to report whether your device uses a Linux TCP/IP stack, and if
so, will show you which Linux kernel version is probably runs. This report is
quite reliable and it can make the distinction between BSD and Linux TCP/IP
stacks and others.
Using the same tool, you can also do port scanning and service version discovery.
For instance, the following command will report which IP-based services are
running on the device, and which version of the service is being used:
The web server version, if identified, can be determining in knowing the Operat-
ing System. For instance, the BOA web server is typical from devices running
an open-source Unix or Unix-like.
Although this method is not really known and widespread, using a wireless
scanner to discover which OS your router or Access Point run can be used. We
do not have a clear example of how this could be achieved, but you will have to
monitor raw 802.11 frames and compare them to a very similar device running
a Linux based firmware.
The Linksys WRT54G was originally hacked by using a ”ping bug” discovered in
the web interface. This tip has not been fixed for months by Linksys, allowing
people to enable the ”boot wait” helper process via the web interface. Many
web servers used in firmwares are open source web server, thus allowing the
code to be audited to find an exploit. Once you know the web server version
that runs on your device, by using nmap -sV or so, you might be interested in
using exploits to reach shell access on your device.
2.3. ADDING PLATFORM SUPPORT 33
You are very likely to find a firmware binary image on the manufacturer website,
even if your device runs a proprietary operating system. If so, you can download
it and use an hexadecimal editor to find printable words such as vmlinux, linux,
ramdisk, mtd and others.
Some Unix tools like hexdump or strings can be used to analyse the firmware.
Below there is an example with a binary firmware found other the Internet:
Scroll over the firmware to find printable words that can be significant.
Linux can hardly fit in a 2MB flash device, once you have opened the device and
located the flash chip, try to find its characteristics on the Internet. If your flash
chip is a 2MB or less device, your device is most likely to run a proprietary OS
such as WindRiver VxWorks, or a custom manufacturer OS like Zyxel ZynOS.
OpenWrt does not currently run on devices which have 2MB or less of flash
memory. This limitation will probably not be worked around since those devices
are most of the time micro-routers, or Wireless Access Points, which are not the
main OpenWrt target.
By using a serial port and a level shifter, you may reach the console that is
being shown by the device for debugging or flashing purposes. By analysing the
output of this device, you can easily notice if the device uses a Linux kernel or
something different.
34 CHAPTER 2. DEVELOPMENT ISSUES
Once you are sure your device run a Linux based firmware, you will be able to
start hacking on it. If the manufacturer respected the GPL, it will have released
a Sample Development Kit with the device.
GPL violations
Miss, Mister,
I am using a <device name>, and I cannot find neither on your
website nor on the CD-ROM the open source software used to
build or modify the firmware.
In conformance to the GPL license, you have to release the following
sources:
Once the SDK is available, you are most likely not to be able to build a complete
or functional firmware using it, but parts of it, like only the kernel, or only the
root filesystem. Most manufacturers do not really care releasing a tool that do
work every time you uncompress and use it.
You should anyway be able to use the following components:
• kernel sources with more or less functional patches for your hardware
• packages of the toolchain used to compile the whole firmware: gcc, binutils,
libc or uClibc
2.3. ADDING PLATFORM SUPPORT 35
• create a clean patch of the hardware specific part of the linux kernel
• spot potential kernel GPL violations especially on netfilter and USB stack
stuff
• make the binary drivers work, until there are open source drivers
• use standard a GNU toolchain to make working executables
• understand and write open source tools to generate a valid firmware image
Most of the time, the kernel source that comes along with the SDK is not really
clean, and is not a standard Linux version, it also has architecture specific fixes
backported from the CVS or the git repository of the kernel development trees.
Anyway, some parts can be easily isolated and used as a good start to make a
vanilla kernel work your hardware.
Some directories are very likely to have local modifications needed to make your
hardware be recognized and used under Linux. First of all, you need to find
out the linux kernel version that is used by your hardware, this can be found by
editing the linux/Makefile file.
head -5 linux-2.x.x/Makefile
VERSION = 2
PATCHLEVEL = x
SUBLEVEL = y
EXTRAVERSION = z
NAME=A fancy name
So now, you know that you have to download a standard kernel tarball at
kernel.org that matches the version being used by your hardware.
Then you can create a diff file between the two trees, especially for the following
directories:
This will constitute a basic set of three patches that are very likely to contain
any needed modifications that has been made to the stock Linux kernel to run
on your specific device. Of course, the content produced by the diff -urN may
not always be relevant, so that you have to clean up those patches to only let
the ”must have” code into them.
36 CHAPTER 2. DEVELOPMENT ISSUES
The first patch will contain all the code that is needed by the board to be
initialized at startup, as well as processor detection and other boot time specific
fixes.
The second patch will contain all useful definitions for that board: addresses,
kernel granularity, redefinitions, processor family and features ...
The third patch may contain drivers for: serial console, ethernet NIC, wireless
NIC, USB NIC ... Most of the time this patch contains nothing else than ”glue”
code that has been added to make the binary driver work with the Linux kernel.
This code might not be useful if you plan on writing drivers from scratch for
this hardware.
The bootloader is the first program that is started right after your device has
been powered on. This program, can be more or less sophisticated, some do let
you do network booting, USB mass storage booting ... The bootloader is device
and architecture specific, some bootloaders were designed to be universal such
as RedBoot or U-Boot so that you can meet those loaders on totally different
platforms and expect them to behave the same way.
If your device runs a proprietary operating system, you are very likely to deal
with a proprietary boot loader as well. This may not always be a limitation,
some proprietary bootloaders can even have source code available (i.e : Broad-
com CFE).
According to the bootloader features, hacking on the device will be more or
less easier. It is very probable that the bootloader, even exotic and rare, has
a documentation somewhere over the Internet. In order to know what will be
possible with your bootloader and the way you are going to hack the device,
look over the following features :
Net booting is something very convenient, because you will only have to set
up network booting servers on your development station, and keep the original
firmware on the device till you are sure you can replace it. This also prevents
your device from being flashed, and potentially bricked every time you want to
test a modification on the kernel/filesystem.
If your device needs to be flashed every time you load a firmware, the bootlader
might only accept a specific firmware format to be loaded, so that you will have
to understand the firmware format as well.
2.3. ADDING PLATFORM SUPPORT 37
Most of the time, loading binary drivers will fail, and generate a kernel oops.
You can know the last symbol the binary drivers attempted to use, and see in
the kernel headers file, if you do not have to move some structures field before
or after that symbol in order to keep compatibily with both the binary driver
and the stock kernel drivers.
You might want to understand the firmware format, even if you are not yet
capable of running a custom firmware on your device, because this is sometimes
a blocking part of the flashing process.
A firmware format is most of the time composed of the following fields:
Once you have figured out how the firmware format is partitioned, you will have
to write your own tool that produces valid firmware binaries. One thing to
be very careful here is the endianness of either the machine that produces the
binary firmware and the device that will be flashed using this binary firmware.
The flash map driver has an important role in making your custom firmware
work because it is responsible of mapping the correct flash regions and associated
rights to specific parts of the system such as: bootloader, kernel, user filesystem.
Writing your own flash map driver is not really a hard task once you know how
your firmware image and flash is structured. You will find below a commented
example that covers the case of the device where the bootloader can pass to the
kernel its partition plan.
First of all, you need to make your flash map driver be visible in the kernel config-
uration options, this can be done by editing the file linux/drivers/mtd/maps/Kconfig:
config MTD_DEVICE_FLASH
tristate "Device Flash device"
depends on ARCHITECTURE && DEVICE
help
Flash memory access on DEVICE boards. Currently only works with
Bootloader Foo and Bootloader Bar.
obj-\$(CONFIG_MTD_DEVICE_FLASH) += device-flash.o
You can then write the kernel driver itself, by creating a linux/drivers/mtd/maps/device-
flash.c C source file.
// Includes that are required for the flash map driver to know of the prototypes:
#include <asm/io.h>
#include <linux/init.h>
#include <linux/kernel.h>
#include <linux/mtd/map.h>
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
#include <linux/vmalloc.h>
2.3. ADDING PLATFORM SUPPORT 39
if (device_mtd_info) {
device_mtd_info->owner = THIS_MODULE;
int parsed_nr_parts = 0;
// We try here to use the partition schema provided by the bootloader specific code
if (parsed_nr_parts == 0) {
int ret = parse_bootloader_partitions(device_mtd_info, &parsed_p
if (ret > 0) {
part_type = "BootLoader";
parsed_nr_parts = ret;
}
}
40 CHAPTER 2. DEVELOPMENT ISSUES
return 0;
}
iounmap(device_map.virt);
return -ENXIO;
}
// This function will make the driver clean up the MTD device mapping
static void __exit device_mtd_cleanup(void)
{
// If we found a MTD device before
if (device_mtd_info) {
// Delete every partitions
del_mtd_partitions(device_mtd_info);
// Delete the associated map
map_destroy(device_mtd_info);
}
// Macros defining license and author, parameters can be defined here too.
MODULE_LICENSE("GPL");
MODULE_AUTHOR("Me, myself and I <[email protected]");
2.4. DEBUGGING AND DEBRICKING 41
2.4.2 JTAG
Opening a ticket
Regarding the kind of ticket that is open, a patch is welcome in those cases:
• fix for a bug that works for the reporter and has no known side effect
Once the ticket is open, a developer will take care of it, if so, the ticket is marked
as ”accepted” with the developer name. You can add comments at any time to
the ticket, even when it is closed.
42 CHAPTER 2. DEVELOPMENT ISSUES
Closing a ticket
• the problem described is not judged as valid, and comes along with an
explanation why (invalid)
• the developers know that this bug will be fixed upstream (wontfix)
• the problem is very similar to something that has already been reported
(duplicate)
At the same time, the reporter may want to get the ticket closed since he is not
longer able to trigger the bug, or found it invalid by himself.
This section tries to lay out a procedure to enable people to submit patches in
a way that is most effective for all concerned.
• talk explaining what problem you are addressing and your proposed solu-
tion.
• Forum: http://forum.openwrt.org/
It is often best to document what you are doing before you do it. The process of
documentation often exposes possible improvements. Keep your documentation
up to date.
4. Please use your real name and email address in the Signed-off-by line,
following the same guidelines as in the Linux Kernel patch submission
guidelines