]> woffs.de Git - fd/haskell-amqp-utils.git/blob - flake.nix
flake.lock: Update
[fd/haskell-amqp-utils.git] / flake.nix
1 # SPDX-FileCopyrightText: 2023 Frank Doepper
2 #
3 # SPDX-License-Identifier: GPL-3.0-only
4
5 # thank https://magnus.therning.org/2022-03-13-simple-nix-flake-for-haskell-development.html !
6 {
7   inputs = {
8     nixpkgs.url = "nixpkgs/nixos-unstable";
9     flake-utils.url = "flake-utils";
10   };
11
12   outputs = { self, nixpkgs, flake-utils }:
13     flake-utils.lib.eachDefaultSystem (system:
14       let
15         pkgs = nixpkgs.legacyPackages.${system};
16         t = pkgs.lib.trivial;
17         hl = pkgs.haskell.lib;
18         hp = pkgs.haskell.packages.ghc96;
19         project = { withEnv ? false }:
20           hp.developPackage {
21             root = ./.;
22             name = "amqp-utils";
23             returnShellEnv = withEnv;
24             withHoogle = false;
25             overrides = self: super: rec {
26               tls = super.tls_2_0_6;
27               crypton-connection = super.crypton-connection.override { inherit tls; };
28             };
29             modifier = (t.flip t.pipe) [
30               hl.dontHaddock
31               hl.enableStaticLibraries
32               hl.justStaticExecutables
33               hl.disableLibraryProfiling
34               hl.disableExecutableProfiling
35             ];
36           };
37       in {
38         packages.default = project { };
39         devShells.default = project { withEnv = true; };
40         apps = builtins.listToAttrs (builtins.map (x: {
41           name = x;
42           value = {
43             type = "app";
44             program = "${project { }}/bin/${x}";
45           };
46         }) [ "agitprop" "konsum" "plane" "arbeite" ]);
47       });
48 }