]> woffs.de Git - fd/haskell-amqp-utils.git/blob - debian/changelog
release 0.6.6.0
[fd/haskell-amqp-utils.git] / debian / changelog
1 haskell-amqp-utils (0.6.6.0) unstable; urgency=medium
2
3   * LineBuffering
4   * print heartbeat parameter
5   * optionally delay negative acknowledgements (--delaynack/-D)
6
7  -- Frank Doepper <[email protected]>  Fri, 06 Dec 2024 11:39:53 +0100
8
9 haskell-amqp-utils (0.6.5.0) unstable; urgency=medium
10
11   * konsum: new --stream_offset option
12
13  -- Frank Doepper <[email protected]>  Tue, 14 Nov 2023 21:42:24 +0100
14
15 haskell-amqp-utils (0.6.4.0) unstable; urgency=medium
16
17   * fix exception handling and avoid hang
18   * migrate to crypton-connection and crypton-x509-system, adjust deps
19
20  -- Frank Doepper <[email protected]>  Thu, 20 Jul 2023 14:15:43 +0200
21
22 haskell-amqp-utils (0.6.3.2) unstable; urgency=medium
23
24   * update README
25
26  -- Frank Doepper <[email protected]>  Mon, 25 Oct 2021 15:57:27 +0200
27
28 haskell-amqp-utils (0.6.3.1) unstable; urgency=medium
29
30   * avoid setCurrentDirectory which is not thread-safe
31   * start watch before initial scan
32   * put filename without directory into filename header
33
34  -- Frank Doepper <[email protected]>  Wed, 08 Sep 2021 12:06:49 +0200
35
36 haskell-amqp-utils (0.6.3.0) unstable; urgency=medium
37
38   * watch multiple dirs in hotfolder mode
39   * drop hinotify < 0.3.10 compatibility
40   * use RawFilePath for file names
41   * fix handling of non-ascii filenames in agitprop hotfolder
42
43  -- Frank Doepper <[email protected]>  Mon, 06 Sep 2021 16:11:08 +0200
44
45 haskell-amqp-utils (0.6.2.4) unstable; urgency=medium
46
47   * depend on tls >= 1.5.0 (thread safety for writes)
48
49  -- Frank Doepper <[email protected]>  Mon, 30 Aug 2021 16:21:40 +0200
50
51 haskell-amqp-utils (0.6.2.2) unstable; urgency=medium
52
53   * agitprop: option to move sent file to another dir instead of just removing
54
55  -- Frank Doepper <[email protected]>  Wed, 25 Aug 2021 11:53:04 +0200
56
57 haskell-amqp-utils (0.6.1.1) unstable; urgency=medium
58
59   * disable inotify on non-linux
60
61  -- Frank Doepper <[email protected]>  Tue, 11 May 2021 11:17:59 +0200
62
63 haskell-amqp-utils (0.6.1.0) unstable; urgency=medium
64
65   * add remaining message properties as callback environment variables, too
66
67  -- Frank Doepper <[email protected]>  Thu, 11 Mar 2021 11:06:38 +0100
68
69 haskell-amqp-utils (0.6.0.0) unstable; urgency=medium
70
71   * update and amend README
72   * add --arg as alias for --args
73   * konsum: remove default binding to #
74   * plane: use -r (--routingkey) instead of -Q (--qname) (but still accept legacy -Q)
75   * print server properties
76
77  -- Frank Doepper <[email protected]>  Wed, 10 Mar 2021 12:15:37 +0100
78
79 haskell-amqp-utils (0.5.0.0) unstable; urgency=medium
80
81   * add option -f (--prefetch) for arbeite, default 1 (was unset before)
82   * print a line after (not) receiving rpc answer
83   * catch IOException instead of SomeException in callback
84   * remove --enable-tests from cabal in Makefile
85   * reformat with hindent + stylish-haskell
86
87  -- Frank Doepper <[email protected]>  Wed, 03 Mar 2021 16:34:44 +0100
88
89 haskell-amqp-utils (0.4.5.1) unstable; urgency=medium
90
91   * unify threadDelay in mainloop (reduce system load when sleeping)
92
93  -- Frank Doepper <[email protected]>  Fri, 19 Feb 2021 18:40:06 +0100
94
95 haskell-amqp-utils (0.4.5.0) unstable; urgency=medium
96
97   * format with stylish-haskell
98   * agitprop: rename variables in code
99   * new options -d (--dirscan) and -u (--remove) for agitprop hotfolder mode
100   * cwd to hotfolder directory in agitprop hotfolder mode
101   * change logging of boolean parameters
102
103  -- Frank Doepper <[email protected]>  Wed, 10 Feb 2021 22:33:23 +0100
104
105 haskell-amqp-utils (0.4.4.1) unstable; urgency=medium
106
107   * change default connection timeout from 60 to 600s
108   * update description
109
110  -- Frank Doepper <[email protected]>  Wed, 19 Aug 2020 13:18:51 +0200
111
112 haskell-amqp-utils (0.4.4.0) unstable; urgency=medium
113
114   * push callback options into environment variables
115
116  -- Frank Doepper <[email protected]>  Tue, 18 Feb 2020 13:24:36 +0100
117
118 haskell-amqp-utils (0.4.3.0) unstable; urgency=medium
119
120   * specify -R YES option for callback in case of a redelivered message
121
122  -- Frank Doepper <[email protected]>  Mon, 10 Feb 2020 18:28:30 +0100
123
124 haskell-amqp-utils (0.4.2.0) unstable; urgency=medium
125
126   * introduce --cleanup (-j) to remove temp file
127   * change temp file name from konsum-* to amqp-utils-*
128   * handle all numeric types in amqp headers same
129   * update to amqp-0.19
130   * use utf8-string for header string values
131
132  -- Frank Doepper <[email protected]>  Thu, 19 Dec 2019 15:07:19 +0100
133
134 haskell-amqp-utils (0.4.1.0) unstable; urgency=medium
135
136   * printparam -> Flexprint
137   * introduce --simple / -i
138   * review data types
139   * reformat with hindent
140   * update doc
141
142  -- Frank Doepper <[email protected]>  Mon, 09 Dec 2019 16:31:48 +0100
143
144 haskell-amqp-utils (0.4.0.1) unstable; urgency=medium
145
146   * fix exit codes
147
148  -- Frank Doepper <[email protected]>  Wed, 04 Dec 2019 13:49:41 +0100
149
150 haskell-amqp-utils (0.4.0.0) unstable; urgency=medium
151
152   * agitprop: show exchange arg
153   * agitprop does not need -q or -Q
154   * allow RPC with dedicated exchange
155   * add missing hFlush
156   * stdin / stdout handling without using /dev/
157   * cleanup plane answer file handling
158   * duplicate plane body to outfile and stderr
159
160  -- Frank Doepper <[email protected]>  Mon, 11 Nov 2019 17:04:22 +0100
161
162 haskell-amqp-utils (0.3.7.1) unstable; urgency=medium
163
164   * re-add accidentally removed option -n
165
166  -- Frank Doepper <[email protected]>  Tue, 10 Sep 2019 16:13:21 +0200
167
168 haskell-amqp-utils (0.3.7.0) unstable; urgency=medium
169
170   * connect timeout
171
172  -- Frank Doepper <[email protected]>  Tue, 10 Sep 2019 15:26:24 +0200
173
174 haskell-amqp-utils (0.3.6.0) unstable; urgency=medium
175
176   * Bugfix, stderr/stdout and --header for RPC (plane, arbeite)
177
178  -- Frank Doepper <[email protected]>  Mon, 18 Mar 2019 22:55:39 +0100
179
180 haskell-amqp-utils (0.3.4.2) unstable; urgency=medium
181
182   * remove obsolete debian deps
183
184  -- Frank Doepper <[email protected]>  Tue, 22 Jan 2019 18:10:50 +0100
185
186 haskell-amqp-utils (0.3.4.0) unstable; urgency=medium
187
188   * bug fix: re-add exception handler
189   * plane + arbeite: rpc client + server
190
191  -- Frank Doepper <[email protected]>  Sat, 21 Jul 2018 13:26:00 +0200
192
193 haskell-amqp-utils (0.3.3.1) unstable; urgency=medium
194
195   * hinotify 0.3.10 and lts-12.0 compat
196
197  -- Frank Doepper <[email protected]>  Tue, 10 Jul 2018 17:15:15 +0200
198
199 haskell-amqp-utils (0.3.3.0) unstable; urgency=medium
200
201   * konsum: options nack and requeuenack
202
203  -- Frank Doepper <[email protected]>  Tue, 10 Jul 2018 10:52:38 +0200
204
205 haskell-amqp-utils (0.3.2.2) unstable; urgency=medium
206
207   * fix hotfolder mode in other than cwd
208
209  -- Frank Doepper <[email protected]>  Wed, 04 Jul 2018 18:32:39 +0200
210
211 haskell-amqp-utils (0.3.2.1) unstable; urgency=medium
212
213   * fix doc
214
215  -- Frank Doepper <[email protected]>  Wed, 04 Jul 2018 13:50:29 +0200
216
217 haskell-amqp-utils (0.3.2.0) unstable; urgency=medium
218
219   * option cleanup
220
221  -- Frank Doepper <[email protected]>  Wed, 04 Jul 2018 12:05:07 +0200
222
223 haskell-amqp-utils (0.3.1.4) unstable; urgency=medium
224
225   * agitprop: file magic
226
227  -- Frank Doepper <[email protected]>  Wed, 27 Jun 2018 18:06:57 +0200
228
229 haskell-amqp-utils (0.3.1.3) unstable; urgency=medium
230
231   * agitprop: headers
232
233  -- Frank Doepper <[email protected]>  Tue, 26 Jun 2018 21:54:42 +0200
234
235 haskell-amqp-utils (0.3.1.2) unstable; urgency=medium
236
237   * agitprop: hotfolder mode
238
239  -- Frank Doepper <[email protected]>  Tue, 26 Jun 2018 11:22:41 +0200
240
241 haskell-amqp-utils (0.3.1.1) unstable; urgency=medium
242
243   * agitprop: publisher confirms
244
245  -- Frank Doepper <[email protected]>  Mon, 25 Jun 2018 17:24:35 +0200
246
247 haskell-amqp-utils (0.3.1.0) unstable; urgency=medium
248
249   * agitprop, a publisher
250
251  -- Frank Doepper <[email protected]>  Fri, 22 Jun 2018 16:26:41 +0200
252
253 haskell-amqp-utils (0.3.0.2) unstable; urgency=medium
254
255   * use ciphersuite_default
256
257  -- Frank Doepper <[email protected]>  Tue, 24 Apr 2018 17:25:30 +0200
258
259 haskell-amqp-utils (0.3.0.1) unstable; urgency=medium
260
261   * don't sleep too long
262
263  -- Frank Doepper <[email protected]>  Sun, 04 Mar 2018 16:07:06 +0100
264
265 haskell-amqp-utils (0.3.0.0) unstable; urgency=medium
266
267   * remove special options
268   * implement multiple bindings per queue
269
270  -- Frank Doepper <[email protected]>  Tue, 21 Nov 2017 11:56:11 +0100
271
272 haskell-amqp-utils (0.2.2.0) unstable; urgency=medium
273
274   * option -Q
275
276  -- Frank Doepper <[email protected]>  Mon, 20 Nov 2017 17:19:57 +0100
277
278 haskell-amqp-utils (0.2.1.5) unstable; urgency=medium
279
280   * amqp 0.17, coName, reduce load
281
282  -- Frank Doepper <[email protected]>  Mon, 25 Sep 2017 19:25:37 +0200
283
284 haskell-amqp-utils (0.2.1.4+2) unstable; urgency=medium
285
286   * callback: pass-through timestamp, ignore non-existing sha
287
288  -- Frank Doepper <[email protected]>  Thu, 13 Jul 2017 15:57:53 +0200
289
290 haskell-amqp-utils (0.2.1.4+1) jessie-taz-unstable; urgency=medium
291
292   * try to repair jessie
293
294  -- Frank Doepper <[email protected]>  Thu, 01 Jun 2017 19:19:23 +0200
295
296 haskell-amqp-utils (0.2.1.4) unstable; urgency=medium
297
298   * amqp-0.15.0
299   * Cabal: use hvr/multi-ghc-travis, add source-repository and Setup.hs
300
301  -- Frank Doepper <[email protected]>  Thu, 01 Jun 2017 17:57:17 +0200
302
303 haskell-amqp-utils (0.2.1.3) unstable; urgency=medium
304
305   * show all message properties
306
307  -- Frank Doepper <[email protected]>  Fri, 05 May 2017 15:56:51 +0200
308
309 haskell-amqp-utils (0.2.1.2) unstable; urgency=medium
310
311   * remove old cabal tweaks
312
313  -- Frank Doepper <[email protected]>  Thu, 27 Apr 2017 20:05:22 +0200
314
315 haskell-amqp-utils (0.2.1.1) unstable; urgency=medium
316
317   * fix debian package
318
319  -- Frank Doepper <[email protected]>  Wed, 26 Apr 2017 13:05:06 +0200
320
321 haskell-amqp-utils (0.2.1.0) unstable; urgency=medium
322
323   * use $(CURDIR), not $(PWD)
324   * show msgPriority
325
326  -- Frank Doepper <[email protected]>  Tue, 25 Apr 2017 16:17:18 +0200
327
328 haskell-amqp-utils (0.2.0.2) unstable; urgency=medium
329
330   * need base-4.6 for forkFinally
331   * debian build tweaks for wheezy
332
333  -- Frank Doepper <[email protected]>  Fri, 17 Feb 2017 18:23:29 +0100
334
335 haskell-amqp-utils (0.2.0.1) unstable; urgency=medium
336
337   * debian/rules: pseudo home location
338
339  -- Frank Doepper <[email protected]>  Fri, 17 Feb 2017 17:33:26 +0100
340
341 haskell-amqp-utils (0.2.0.0) unstable; urgency=medium
342
343   * Version
344   * indent
345   * english
346   * options --user and --pass
347   * add plain auth and make TLS optional
348   * default guest / guest
349   * remove custom shortcuts
350   * update .gitignore
351   * update examples, make -T toggle TLS
352   * Create README.md
353   * update Makefile with install-cabal
354
355  -- Frank Doepper <[email protected]>  Thu, 16 Feb 2017 19:07:42 +0100
356
357 haskell-amqp-utils (0.1.2.8) unstable; urgency=medium
358
359   * indentation
360   * pass routing key through to callback action
361
362  -- Frank Doepper <[email protected]>  Fri, 03 Feb 2017 18:27:01 +0100
363
364 haskell-amqp-utils (0.1.2.7) unstable; urgency=medium
365
366   * fix .cabal
367   * Makefile: no -O2
368   * konsum.hs: timestamp lesbarer
369   * kommentieren, umsortieren
370   * hindent --style cramer
371   * time to printmsg
372   * more hindent
373   * move comment
374   * timestamp stuff
375   * showtime folks
376   * smarter timestamps and -diff
377   * gitignore .stack*
378   * X.SomeException
379   * don't hang when createProcess fails
380   * stack: ghc 7.10
381
382  -- Frank Doepper <[email protected]>  Tue, 12 Jul 2016 11:54:52 +0200
383
384 haskell-amqp-utils (0.1.2.6) unstable; urgency=medium
385
386   *  callback: don't eat leading whitespace
387   *  include example callback config snippet
388   *  unwords statt show
389   *  callback variable
390   *  less Just more '
391   *  update doc comments
392   *  cleanup
393   *  cleanup saveFile
394   *  delivery tag
395   *  envDeliveryTag statt counter IORef
396   *  fix double reject/ack
397   *  redelivered?
398   *  unify printline / printparam
399   *  printparam printline printbody
400   *  comment
401   *  stack.yaml
402
403  -- Frank Doepper <[email protected]>  Thu, 07 Jul 2016 14:17:48 +0200
404
405 haskell-amqp-utils (0.1.2.5) unstable; urgency=medium
406
407   * callback: set -o pipefail
408
409  -- Frank Doepper <[email protected]>  Thu, 30 Jun 2016 16:49:17 +0200
410
411 haskell-amqp-utils (0.1.2.4) unstable; urgency=medium
412
413   * numstring überall, buffering ok
414
415  -- Frank Doepper <[email protected]>  Thu, 30 Jun 2016 16:36:14 +0200
416
417 haskell-amqp-utils (0.1.2.3) unstable; urgency=medium
418
419   * fix race condition in callback
420
421  -- Frank Doepper <[email protected]>  Wed, 29 Jun 2016 20:04:54 +0200
422
423 haskell-amqp-utils (0.1.2.2) unstable; urgency=medium
424
425   * callback: exit nach action()
426
427  -- Frank Doepper <[email protected]>  Tue, 28 Jun 2016 18:48:34 +0200
428
429 haskell-amqp-utils (0.1.2.1) unstable; urgency=medium
430
431   * konsum.hs: print consumer tag
432   * konsum.hs: openBinaryTempFileWithDefaultPermissions
433   * callback: auch einteilige cp + mv
434
435  -- Frank Doepper <[email protected]>  Tue, 28 Jun 2016 16:13:53 +0200
436
437 haskell-amqp-utils (0.1.2.0) unstable; urgency=medium
438
439   * include generic callback.bash
440
441  -- Frank Doepper <[email protected]>  Mon, 27 Jun 2016 15:21:16 +0200
442
443 haskell-amqp-utils (0.1.1.0) unstable; urgency=medium
444
445   * -X implies -t
446
447  -- Frank Doepper <[email protected]>  Thu, 23 Jun 2016 11:18:24 +0200
448
449 haskell-amqp-utils (0.1.0.0) unstable; urgency=low
450
451   * haskell amqp consumer
452
453  -- Frank Doepper <[email protected]>  Wed, 22 Jun 2016 17:11:45 +0200