]> woffs.de Git - fd/haskell-amqp-utils.git/blob - amqp-utils.nix
release 0.6.6.0
[fd/haskell-amqp-utils.git] / amqp-utils.nix
1 # SPDX-FileCopyrightText: 2022 Frank Doepper
2 #
3 # SPDX-License-Identifier: GPL-3.0-only
4
5 { lib, mkDerivation, amqp, base, bytestring, crypton-connection, containers
6 , data-default-class, process, text, time, tls, crypton-x509-system, unix
7 , hinotify, magic, network, directory, utf8-string, filepath
8 , rawfilepath, filepath-bytestring
9 }:
10
11 mkDerivation {
12   pname = "amqp-utils";
13   version = "0.6.6.0";
14   src = ./.;
15   isLibrary = false;
16   isExecutable = true;
17   enableSharedExecutables = false;
18   executableHaskellDepends = [
19     amqp base bytestring crypton-connection containers data-default-class
20     process text time tls crypton-x509-system unix hinotify magic network
21     directory utf8-string filepath rawfilepath filepath-bytestring
22   ];
23   description = "AMQP toolset for the command line";
24   license = lib.licenses.gpl3Only;
25 }