Up to [cvs.NetBSD.org] / pkgsrc / news / flnews
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
news/flnews: Fix reproducible build
news/flnews: Switch to FLTK 1.4 Part of FLTK 1.4 transition (Step 2). Bump PKGREVISION.
news/flnews: Update to 1.2.1 This is a bugfix release. - Potential crash fixed if an article is selected while article tree/list widget update is still in progress (race condition). - FLTK 1.3 may crash if Fl_Text_Display widget contains very long lines. With FLTK 1.3 articles containing lines beyond 1000 octets are no longer displayed. It's still possible to store the raw data to a file. With FLTK 1.4 the behaviour is unchanged. - Inconsistent permissions of created files fixed. - Conversion from multiple seldom used 8-bit codepages to Unicode fixed. - Unicode database updated to version 15.1.0. - Connector lines in article tree are now solid for better visibility.
*: revebump for new brotli option for freetype2 Addresses PR 57693
*: bump for openssl 3
news/flnews: Update to 1.2.0
1.2.0 2023-06-08 Release
--------------------------
Important notes:
- The experimental option USE_CUSTOM_FONTSIZE has been removed
Since FLTK 1.4 there is a resize feature via keyboard (Ctrl-+/-).
- Doxygen 1.9.4 is now required to build the documentation.
Bug fixes:
- GUI: Callback for "Mark all groups read" fixed to not block any
further operation if confirmation was "No" (reported by Marcel Logen).
- GUI: Callback for "Next unread group" fixed to not always select the
first group with unread articles (reported by Dennis Preiser).
- CONF: Update of configuration data fixed (formerly truncated if
filesystem was full). Return values of flush operations are now
checked before rename() is executed.
- GUI: Group list is now updated to previous group after group selection
error (reported by Michael Uplawski).
- GUI: No longer show busy mouse cursor after group selection if article
tree/list has no drawing area (reported by Michael Uplawski).
- ENC: Memory leak fixed in MIME Content-Disposition decoder.
- TLS: Memory leaks fixed.
- TLS: OpenSSL 3 version number is now printed correctly on terminal.
- GUI: Soft hyphens are now handled consistently with all FLTK backends
(formerly X11 rendered all SHY characters visible, as defined by
ISO 8859-1, while Pango and Cocoa rendered SHY characters invisible).
- FILTER: Documentation of scorefile syntax fixed (type "extended" is no
longer supported).
- CORE: Doxygen documentation of function core_get_msgid() fixed.
New features and improvements:
- GUI: French translation added for NLS support (provided by yamo').
NLS documentation updated for hexadecimal-escape-sequence (not
allowed in translated strings).
- GUI: Option to skip to next group while searching for next unread
article added (can be enabled with a nonzero value for the new
"unread_in_next_group" entry in configfile) (proposed by Thomas
Barghahn).
- GUI: No longer uses Fl_Pack widget because behaviour has changed in
recent FLTK 1.4.0 snapshots (reported by Dennis Preiser).
- CONF: Support for custom colors in displayed article added
(based on patch from Martin Schnitkemper).
- INET: Support for user defined TCP connection timeout (suggested by
yamo'). Option CFG_TCP_CONNECT_TIMEOUT in CONFIG added.
- GUI: With FLTK 1.4 (or FLTK 1.3.3 ABI) the horizontal scrollbar of the
article tree or list respectively is moved to a sensible position.
- CORE: Header field "Newsgroups" can now be extracted from overview, if
present. Scoring rules of type "group" are applied to all groups of an
Xpost in this case.
- NNTP: Support for LIST OVERVIEW.FMT command (RFC 3977) added.
- NNTP: Experimental support for MAXARTNUM extension added.
Intended to be compliant with the RFC draft provided by Julien Élie
in Message-ID <tnqm14$35bas$[email protected]>.
- ENC: Zero-width space (ZWSP) is now used too as line breaking hint for
the format "flowed" decoder.
- GUI: URI delegation: Separate error message for invalid encoding.
- EXT: External URI handler returns a flag to indicate invalid encoding.
- EXT: Examples for postprocessor added in subdirectory "postproc"
(suggested by yamo').
- EXT: Example for external editor added in subdirectory "editor".
- CONF: Documentation of configfile entry "cancelkey" modified (added
note that "fqdn" entry must also be set to create Cancel-Lock/Key
header fields).
- FILTER: Documentation of scorefile modified (added notes that scoring
rules can be shared).
- Build system: The mkconfig script now checks for POSIX.1c-1995
Thread-Safe Functions (TSF) option too. Usage is forced by default via
CFG_FORCE_TSF option in CONFIG.
- Build system: The C++ object files are moved to the beginning of the
list. This can reduce build time with make utilities that support
parallel build.
- Build system: BSD install utility now deletes existing target files
before copying new ones. This solves problems with macOS on machines
with Apple Silicon and signed binaries (patch from Dennis Preiser).
- Unicode database updated to version 15.0.0
Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/. Almost all uses, if not all of them, are wrong, according to the semantics of BUILD_DEPENDS (packages built for target available for use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for host available for use _as_ tools at build-time). No change to BUILD_DEPENDS as used correctly inside buildlink3. As proposed on tech-pkg: https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html
*: Recursive revbup from graphics/freetype2
news/flnews: Update to 1.1.0 1.1.0 2022-05-21 Release -------------------------- Bug fixes: - CORE: Authentication without password is now rejected (reported by Marcel Logen). - MAIN: Potential deadlocks in thread-safe replacement functions fixed. - GUI: State machine modified to avoid race condition when articles are marked read while group is not completely loaded yet. New features and improvements: - GUI: Option to automatically check for new articles added (an interval in minutes can be configured with the new "refresh_interval" entry in configfile). - GUI: Checkbox "Tools->Debug mode" removed. Debug mode must be enabled with command line option "-debug". - NNTP: Protocol logfile is only created if debug mode was enabled (and unlinked otherwise, if present). "Tools->Protocol console" window now requires debug mode. - GUI: Support for estimated article count in subscription window added - GUI: Support for group descriptions in subscription window added - NNTP: Support for LIST NEWSGROUPS command (RFC 3977) added - GUI: Support for subscription proposals from server added (offered to user after server was changed and group list is empty) - CORE: Support for subscription proposals from server added - NNTP: Support for LIST SUBSCRIPTIONS command (RFC 6048) added - TLS: Support for LibreSSL 3.5 API added - GUI: File save operations now suggest a pathname in the file selection window. - GUI: File save operations now ask the user before an existing file is overwritten. - CORE: Function added to suggest a pathname (created from home directory, program name and timestamp). - CORE: Message-IDs are now generated with algorithm A3 (uses a modified Base64 alphabet with "/" replaced by "-"). This allows to generate RFC 5538 conformant "news"-URIs without percent-encoding.
news/flnews: Update to 1.0.1 Bug fixes: - ENC: Off-by-one read from uninitialized data in MIME encoded-word decoder fixed. - GUI: Clickable references are now restored after ROT13 was applied twice. - GUI: Click on "Cancel" button in server configuration window no longer creates an error message in the status bar. - GUI: "Group->Mark subthread read" now redraws the widget and closes the processed subthread (reported by Christian Schumacher) - GUI: Server configuration: Automatically modify service name when TLS is enabled/disabled (suggested by Julien Élie) - References to legacy configuration path "~/.flnews" fixed in man page New features and improvements: - Unicode database updated to version 14.0.0
news/flnews: Update to 1.0.0 1.0.0 2021-05-09 Release -------------------------- Important notes: - The new configuration data format is not compatible with versions 0.x (indicated by the major number bump)! A script is provided to automatically convert existing configuration data to the new format. Read "migration/README" for details. - Because the location of the configuration has changed (see new XDG module below), the configuration for versions 0.x is preserved. - It is still possible to downgrade flnews to 0.x, the preserved old configuration data is used again in this case. - Now the release version contains 3 numbers "x.y.z" Major (x) indicates compatibility with configuration data Minor (y) is incremented for new features Patch (z) is incremented for bug fixes Bug fixes: - CORE: Request for group information is no longer rejected with error if the group list is empty. - GUI: After unsubscribing the last group, the article tree/list was not cleared and the user can click on articles for which the associated data no longer exists. Such operations will crash the program (reported by Martin Schnitkemper). - CORE: Line length limit (998 octets) is now checked before injection. - GUI: On macOS with system menu bar the status updates to menu entry "Group->Sort by article number" work now (patch from Dennis Preiser). The required method update() is not available with old FLTK 1.3 libraries, the option CFG_COCOA_SYS_MENUBAR now requires FLTK 1.4. - ENC: URI percent encoder for scheme <news> fixed: The characters defined as <gen-delims> (RFC 3986 Section 2.2) are now encoded (reported by Marcel Logen). - GUI: The URI parser now accepts empty <host> for scheme <news>. - GUI: The current group selection is now restored after a click into the empty space below the group list (reported by Christian Schumacher). - GUI: The article list/tree is now cleared after selecting an empty group (formerly articles of an unrelated group may still be visible). - GUI: Some FLTK versions accept selection of deactivated items. There is now a workaround implemented to make such selections nonfatal. - GUI: Horizontal scrolling to highlighted result of search fixed. - GUI: Use FLTK default forground color for group subscription window too. This should make the content readable with dark background (reported by Christian Schumacher). - NLS: German translation "Artikel herunterladen fehlgeschlagen" fixed (reported by Marcel Logen). - GUI: If there are multiple signature separators ("-- ") present, now the last one is used according to "Usenet Best Practice" draft 01 (reported by Marcel Logen). New features and improvements: - XDG: Moved default configuration directory to location defined by XDG Base Directory Specification 0.7 ("$XDG_CONFIG_HOME/$CFG_NAME"). Other modules now ask the XDG module for the configuration path. - MAIN: The new command line option "-confprefix" can be used to override the configuration directory (proposed by Helmut Waitzmann). - GUI: It is now possible to mark all articles in all groups as read (menu entry "Group->Mark all groups as read"). - MAIN: New command line option "-debug" to enable debug mode early. - CONF: configfile entry "domain" replaced with "fqdn". Some users saw the hostname field in Message-ID algorithm A1 as privacy problem. A <dot-atom> can be configured for the new entry "fqdn" (should be a fully qualified domain name, but without root domain). It is used as <id-right> element when a Message-ID is created with algorithm A2. - Support for SOURCE_DATE_EPOCH Specification 1.1 added to build system. Reproducible build option CFG_REPRODUCIBLE removed from CONFIG. The SOURCE_DATE_EPOCH variable from the environment now overrides the dates in the GUI, the output of the "-v" command line option and the man pages (original patch from Bernhard M. Wiedemann). - Support for target "install-strip" added to build system. The target "install" no longer strips unnecessary symbols from binaries (proposed by Martin Schnitkemper). - EXT: Support for external inews added. Pathname can be specified with the new "inews" entry in configfile. - TLS: Protocol versions 1.0 and 1.1 are now disabled as required by RFC 8996. Both versions are still available in "weak" encryption mode. - GUI: New menu entry "Group->Mark subthread as read". - GUI: If there is only one entity to display for a MIME multipart message (e.g. the selected one with multipart/alternative), the entity header is now displayed too. - GUI: An initial greeting phrase can now be specified with the new "initial_greeting" entry in configfile. It is inserted into articles that start a new thread (proposed by Wolfgang Bauer). - FUTIL: Function added to create (multiple) missing directories of a path. - FILTER: New scorefile syntax to eliminate the workaround with type "extended". All score rules now have a wildmat in the first field. - FILTER: Simplified default regex for test group detection to "\.test$|^test$", removing the ".*" part at the beginning (proposed by Urs Janßen). - POSIX: Support for POSIX.1-2008 and SUSv4 added. No local replacement functions are used anymore on modern operating systems. snprintf() replacement function now uses SUSv4 semantics. - ENC: MIME encoded-words are now generated with "US-ASCII" charset declaration if there is no 8-bit data to encode in the header field (e.g. to represent words like " =?-?= " in a RFC 2049 conformant way). This follows the "lowest common denominator" principle decribed in RFC 2046 Section 4.1.2. - TLS: Deprecated functions from OpenSSL 3 API are no longer used. - GUI: Modified question popup windows to handle pressing ESC key as "No" or "Reject" respectively. - GUI: Some entries moved from menu "Article" to "Group".
news/flnews: Update to 0.18 - Searching for Unicode string in current article is now supported (case insensitive variant based on Unicode case folding algorithm) - Unicode database updated to version 13.0.0 (CaseFolding.txt added) - The new 'force_unicode' entry in configfile set to a nonzero value sends all outgoing articles in Unicode, if they contain non-ASCII characters - Dark background color is now usable - MIME conformance reached (as defined in RFC 2049 Section 2) - If selected text is present, quote only selected text for followup - XDG desktop entry and icon theme added (option CFG_XDG_DISABLE) - Configuration window in GUI now allows to disable the "User-Agent" header field for outgoing articles - It is now possible to enable AUTHINFO USER/PASS without encrypted connection (option CFG_NNTP_AUTH_UNENCRYPTED) This allows to use stunnel instead of the internal TLS module - TLS module no longer calls deprecated functions HMAC*(), RSA_size() and SSL_get_peer_certificate() for OpenSSL API 3.0.0
*: revbump after fontconfig bl3 changes (libuuid removal)
news/flnews: Remove libXcursor dependency It is a dependency of FLTK library (missing in the bl3 file there).
Needs libXcursor
*: Remove obsolete BUILDLINK_API_DEPENDS.openssl.
*: Recursive revision bump for openssl 1.1.1.
news/flnews: Update to 0.17 Removed pkgsrc patches merged upstream. Changelog ========= 0.17 Bugfix: Configuration test result for inttypes.h presence is used, reintroduce the test removed for 0.16 Bugfix: BSD version of ntohl() for old systems was broken Bugfix: ISO-2022-JP decoder: Mask for unassigned codepoints fixed Bugfix: SHA2 support in OpenSSL 1.0.0 must be explicitly enabled Display article from "news" type URI in separate window (if it's not found in current group) Clickable References added (articles displayed in separate window) Search for Message-ID added to the Tools menu (Keyboard shortcut is Ctrl-s) Previous read article (in current group) menu entry added Keyboard shortcut for "Quit" changed from Ctrl-x to Ctrl-q (Proposed by Marcel Logen) Keyboard shortcut for "View source" changed from Ctrl-v to Ctrl-e (Proposed by Marcel Logen) Menu entry "Article->Mark as unread" (Ctrl-u) changed to toggle between read and unread state (Proposed by Marcel Logen) Command line option "-4" added (force usage of IPv4 network protocol) Flowed format: The 'flowed_insert_crlf' entry in configfile adds an empty line separator after every paragraph that ends with an empty line. Defaults to 0 (former behaviour) Flowed format: The behaviour of 'flowed_insert_crlf' can be requested by the sender of an article with "InsLine=yes" in the Content-Type headerfield. TLS module can now use OpenSSL 3 API (required for FFDHE group negotiation with TLSv1.2 and TLSv1.3 protocols) TLS module can now use LibreSSL 3 (formerly major version 2 was used to identify LibreSSL and distinguish it from OpenSSL) TLS modules compile time option 'CFG_USE_TLS_OWNCERTS' replaced by the new 'tls_owncerts' entry in configfile TLS modules experimental compile time option 'CFG_USE_TLS_CRLS' replaced by normal option 'CFG_TLS_CRLS_DISABLE'. Default is to use no CRLs (former behaviour) because this option increases the system requirements (to POSIX.1-2001 or XSI extension) TLS module now supports new 'crl_check' entry in configfile (ignored if CFG_TLS_CRLS_DISABLE is nonzero) TLS module now prints real LibreSSL version instead of generic 2.0.0 TLS module no longer supports options 'CFG_USE_TLS_DHPARAM_CHECK' and 'CFG_USE_TLS_SETSIGALG'. They were obsoleted by the OpenSSL 1.1 API Unicode database updated to version 12.1.0 GUI module no longer supports experimental FLTK 1.3 option 'USE_X11_GLYPH_SUBSTITUTION'. It was obsoleted by FLTK 1.4 Modified LaTeX documentation to work with recent doxygen
all: replace SUBST_SED with the simpler SUBST_VARS pkglint -Wall -r --only "substitution command" -F With manual review and indentation fixes since pkglint doesn't get that part correct in every case.
flnews: update to 0.16. Provided by Michael Bäuerle in pkgsrc-wip. Backported patches from 0.17 branch: -------------------------------------------------------------------------------- Bugfix: Configuration test result for inttypes.h presence is used, reintroduce the test Bugfix: BSD version of ntohl() for old systems now working again Modified LaTeX documentation to work with recent doxygen -------------------------------------------------------------------------------- Changelog: -------------------------------------------------------------------------------- V0.16 Bugfix: Supersede now preserves Followup-To header field Bugfix: The code that generates the attribute "reply to own article" now checks the Message-IDs too (to avoid errors if the parent article is missing in the hierarchy) Bugfix: Header parser and MIME parser fixed to correctly handle MIME entity delimiters (for boundary strings that contain spaces) Bugfix: Removed Unicode range U+E0020 ... U+E007E from rejected control characters (deprecated since Unicode 5.1, reintroduced for different purpose since Unicode 9.0) (Reported by Marcel Logen) TLS: Protocol version TLSv1.3 according to RFC8446 is now supported (requires at least OpenSSL 1.1.1) CORE module now supports multiple article hierarchies Unicode database updated to version 11.0.0 IBM852 to UTF-8 converter added If the OS doesn't report IPv6 as available, usage can now be forced with the option 'CFG_FORCE_IP6' Support for reproducible builds added (option 'CFG_REPRODUCIBLE') Some checks for system header files removed to speed up configuration (Build fails in any case if they are missing) Documentation updated --------------------------------------------------------------------------------
Recursive bump for perl5-5.28.0
news/flnews: import flnews-0.15 flnews is a client with graphical user interface to read USENET newsgroups. It is intended for POSIX compliant operating systems running the X window system. The main development goals are (in order of importance): - No bloat - Support for old workstations - Standard compliance - Be conservative in what you do, be liberal in what you accept from others - Compatibility with other newsreaders - Usable X display redirection via network (or ssh tunnel) - Warn users about things that are not forbidden but considered "bad practice" Features that are currently not implemented (or not usable yet): - UUCP - Multiple servers - Offline mode (for network connection via dialup line) Packaged for wip by Michael Bäuerle.