ll09
Forum Replies Created
-
We just edit posts inside WP Admin.
(Simply) Guest Author Name
Auto Affiliate Links
Contact Form 7
Drag and Drop Multiple File Upload PRO – Contact Form 7
Jetpack
JReviews | JReviews Deploy | s2framework
Simple Local Avatars
Sucuri Security – Auditing, Malware Scanner and Hardening
tagDiv Composer | tagDiv Speed Booster | tagDiv Standard Pack
WP Rocket
WPCode Lite
XPoster – Share to Bluesky and Mastodon
Yoast SEOIt doesn’t look like the new version has helped much unfortunately 🙁
Version 5.1.0
Forum: Plugins
In reply to: [Broken Link Checker] BLC version 2.4.9 causing issues serverwideOur server admin said:
“Hello,
The issue is it runs alter table statements to update from version 17 to 18 and sets a md5 on url_hash() but it has no locking so it fires on every request and never completes. Really poor code not designed or tested against scale (and this isn’t even a very big install) and upgrade_database() fails before writing the updated version so it fires again . This is the function that keeps doing the alters on every request make_schema_current()
Writing a transient lock so it only fires this on one request is the correct behaviour for these type of updates otherwise you simply flood the database when it deals with larger data. Then this is basically this what I gathered from looking is the root bug
It runs
ALTER TABLE wp_blc_links ADD UNIQUE KEY url_hash (url_hash)
Gets an error
ERROR 1062 Duplicate entry ” (10,271 collisions)
The delta() function records the failure, have_errors = true, make_schema_current() returns false, version stays 17, next request repeats so it never completes the upgrade and just floods the database on every request with the same attempt to upgrade.”
We has to disable the plugin too.
Alright, is it ready?
I checked several where the meta value said yes or no, and they’re all set to Don’t Post.
Yea sure once it doesn’t have any breaking changes that’ll affect anything outside of X Poster.
From all of the old published posts that I’m checking, it’s all set to “Don’t Post”. The only ones I’m seeing set to “Post” are the drafts and the pending posts.
Is this value saved in the database so I can run a search?
Under XPoster it says “Don’t Post” inside the post that was posted to Twitter/X.
Okay done can you check it out please? – https://wordpress.org/support/topic/update-when-posts-are-edited-ignored-2/
@joedolson can you reopen this thread please or mention when/if it’ll be patched or if it’s even possible? – https://wordpress.org/support/topic/update-when-posts-are-edited-ignored/
It’d be great if this is fixed to cut down on the spam/clutter people see when we edit old WP Posts to clean up dead 404 links etc.
Any chance that filter can be turned into an option in the admin panel?
Forum: Plugins
In reply to: [WooCommerce] 10.8.0 Update ErrorI received the same error while updating 2 different Woo sites. I don’t think reinstalling is going to fix it. But nothing visible appears broken in the frontend.
I’ll leave OP to send the pastebin since it’s their thread.
See this to get back your settings – https://wordpress.org/support/topic/7-02-upgrade-problem/#post-18888938
Forum: Plugins
In reply to: [Print Invoice & Delivery Notes for WooCommerce] Downgraded back to V6@clambton29 did you lose the plugin settings after downgrading?
Everything from wp-admin/admin.php?page=wc-settings&tab=wcdn-settings is missing. I also no longer see the Order Printing button inside product pages via WP Admin.
Edit:
I just saw this post by the plugin owner and it fixed it for me – https://wordpress.org/support/topic/7-02-upgrade-problem/#post-18888938
- This reply was modified 5 months, 2 weeks ago by ll09.
@tempesttech563 on invoices, do you still see the store name, logo, address etc or are those gone and it’s just the settings page from the admin panel it’s not showing up?
Forum: Plugins
In reply to: [Print Invoice & Delivery Notes for WooCommerce] New UpdateI think updating to anything in 7.x lost all of our settings and entering them back just gets cleared again. I’ll wait for 7.0.3 before upgrading so just subbing to this thread for now.