Browse free open source Java System Software and projects below. Use the toggles on the left to filter open source Java System Software by OS, license, language, programming language, and project status.

  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 1
    Java SIP softphone
    Peers is a very simple softphone. It's a SIP User-Agent, written in java, it works on windows, linux and mac. It can be used with SIP servers like opensips or asterisk IPBX. It supports G711 codec (PCMU and PCMA) and telephone-events (DTMF).
    Downloads: 6 This Week
    Last Update:
    See Project
  • 2
    Revival/2k is a modular BBS/suite of internet servers and a web-site management system. It consists of multiple web applications (forums, mail, login, etc), internet servers (NNTP, POP3, etc) and a Telegard/Renegade styled telnet server all interacting
    Downloads: 13 This Week
    Last Update:
    See Project
  • 3
    properJavaRDP is an open source Java RDP client for Windows Terminal Server. It is based on rdesktop, a SourceForge project. properJavaRDP runs on Java 1.1 up (optimised for 1.4), and works on Linux, Windows and Mac. It also includes log4j-java1.1.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 4

    Linpac

    Amateur Radio AX.25 chat and PBBS program using Linux's AX.25 stack

    A modular console-oriented amateur radio AX.25 keyboard to keyboard chat and PBBS program using Linux's AX.25 stack. Includes support for multiple concurrent connected sessions, a unconnected (UI) message screen, and an automated packet message client
    Downloads: 6 This Week
    Last Update:
    See Project
  • MongoDB Atlas runs apps anywhere Icon
    MongoDB Atlas runs apps anywhere

    Deploy in 115+ regions with the modern database for every enterprise.

    MongoDB Atlas gives you the freedom to build and run modern applications anywhere—across AWS, Azure, and Google Cloud. With global availability in over 115 regions, Atlas lets you deploy close to your users, meet compliance needs, and scale with confidence across any geography.
    Start Free
  • 5
    Netsim is a mobile ad hoc network simulator targeted at large heterogeneous node configurations. It is written in Java and is easily extensible through its modular concept.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 6
    A VNC Client for J2ME (Java 2 Mobile Edition). This includes a side project, an easy to use, clean java API for the RFB protocall. This project is now dead. Please see: https://sourceforge.net/projects/j2mevncclient/
    Downloads: 5 This Week
    Last Update:
    See Project
  • 7
    Enables access to SSH Shell and File Transfer services using a web browser. Java Servlet application uses pure HTML to provide access to SSH services.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 8
    iplist is a list based packet handler which uses the netfilter netlink-queue library (kernel 2.6.14 or later). It filters by IP-address and is optimized for thousands of IP-address ranges.
    Leader badge
    Downloads: 1 This Week
    Last Update:
    See Project
  • 9
    pj-ntp-server

    pj-ntp-server

    Pure Java NTP server.

    Pure Java NTP server. Run as root/admin in cmd-mode without cmd argument, for example: java -jar pj-ntp-server.jar (server start on standart UDP/123-port) or run as root/admin in cmd-mode with UDP-port cmd argument, for example: java -jar pj-ntp-server.jar 1111 where 1111=udp-port of server listen. Need JRE-1.8. Source = https://github.com/harp077/pj-ntp-server If you like this - put a star on https://github.com/harp077/pj-ntp-server/ for support project please.
    Downloads: 3 This Week
    Last Update:
    See Project
  • Fully Managed MySQL, PostgreSQL, and SQL Server Icon
    Fully Managed MySQL, PostgreSQL, and SQL Server

    Automatic backups, patching, replication, and failover. Focus on your app, not your database.

    Cloud SQL handles your database ops end to end, so you can focus on your app.
    Start Free
  • 10
    This java, platform-independent application allows users to share files across the internet.
    Downloads: 2 This Week
    Last Update:
    See Project
  • 11
    jSLP is a pure Java implementation of RFC 2608 (SLP, Service Location Protocol, Version 2) with a RFC 2614 style API. It can be both SLP UserAgent (UA) and ServiceAgent (SA).
    Leader badge
    Downloads: 2 This Week
    Last Update:
    See Project
  • 12
    Java Download Manager

    Java Download Manager

    A Download Manager in Java for Desktop

    A Download Manager in Java for Desktop
    Downloads: 1 This Week
    Last Update:
    See Project
  • 13
    SimpleXDCC is an intuitive xdcc download manager. It lets you simply join a desired server/channel and begin making xdcc bot requests. Ideal for people who wish to download multiple files without having to type a lot of xdcc send commands.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 14
    Bluetooth Instant Messenger Valhallachat
    Valhalla Chat is a Bluetooth Instant Messenger (IM), that provides a common messaging platform for mobile phones, desktop computers and pdas.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 15
    Open Sourced Bluetooth tools.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 16
    Process flow designer that creates applications (Saflets) for us in the SafiServer engine. SafiWorkshop is used for the design, real time debugging and deployment of advanced flow based applications. Currently tailored for use with Asterisk PBX.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 17
    pj-tftp-server

    pj-tftp-server

    Pure Java TFTP server.

    Pure Java TFTP server. Free, portable, cross-platform. Fully multi-threaded. Implements RFC 1350. Run as root/admin in cmd-mode with cmd argument = path to folder, for example: java -jar pj-tftp-server.jar /tmp .Need JRE-1.8. Source - https://github.com/harp077/pj-tftp-server If you like this - put a star on https://github.com/harp077/pj-tftp-server/ for support project please.
    Downloads: 1 This Week
    Last Update:
    See Project
  • 18
    Downloads: 0 This Week
    Last Update:
    See Project
  • 19
    Backup P2P is a peer to peer application doing automated and secured backups inside a community (Jabber, XMPP). Each user shares some available space on his disk with others, to be able in return to remotely backup some of his own data.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 20
    BioCluster is a peer-to-peer clustering platform for Asterisk, the Open Source PBX, which allows utilising Asterisk as a full carrier-grade telephony solution.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 21
    Bitcoop is a Peer to Peer backup system enabling the storage of files on remote computers. The size of files depends on the quantity you wish to share with the other peers. This software is intended for server farms that wish to backup data among themsel
    Downloads: 0 This Week
    Last Update:
    See Project
  • 22
    BTLib package is a J2ME Bluetooth library usefull when developing applications for Java, Bluetooth enabled mobile devices. The other packages are individual applications utilizing BTLib. You can download any of them and run it in your mobile device.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 23
    BonAHA allows devices in a local network to discover each others' services easily with central servers. Built on Apple's Bonjour technology, BonAHA offers an easy programming API to develop mobile ad-hoc applications like iChat and iTunes sharing.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 24
    A C++ framework utilizing Design Patterns for creating Linux and Windows communications applications that contain Dialogic® products. Includes media and network classes (analog, digital, SIP, H323), multithreaded event handling, distributed app support.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 25
    Catalog and browse files on CD and HD, also searchs on edonkey / emule network and saves the search. Indicates if an edonkey / ed2k file is on some CD and helps locating similar content.
    Downloads: 0 This Week
    Last Update:
    See Project