Descrizione
Un backend di cache ad oggetti persistente powered by Redis®¹. Supporta Predis, PhpRedis (PECL), Relay, la replica, i sentinel, il clustering e WP-CLI.
Per modificare i parametri di connessione, aggiungere prefissi alle chiavi della cache o configurare la replica e/o il clustering, dai un’occhiata alle opzioni di configurazione.
Object Cache Pro
Un backend per la cache degli oggetti di Redis®¹ di classe business. Veramente molto affidabile, altamente ottimizzato, completamente personalizzabile, facile da usare e con un ingegnere dedicato proprio quando ne avrai più bisogno.
- Riscritto per garantire le massime prestazioni
- Compatibile al 100% con l’API di WordPress
- Serializzazione e compressione più veloci
- Debug e registrazione dei registri di log semplificati
- Precaricamento della cache ed analisi dei dati
- Testato integralmente a livello d’unità (copertura del codice al 100%)
- Connessioni sicure con TLS
- Controlli d’integrità tramite WordPress e WP CLI
- Ottimizzato per WooCommerce, Jetpack e Yoast SEO
Approfondisci e scopri di più su Object Cache Pro.
¹ Redis è un marchio registrato di Redis Ltd. Tutti i diritti relativi a tale marchio sono riservati a Redis Ltd. Qualsiasi utilizzo da parte di Redis Object Cache è solo a scopo di riferimento e non implica alcuna sponsorizzazione, approvazione e/o affiliazione tra Redis e Redis Object Cache.
Guida alla risoluzione dei problemi
Le risposte alle domande più frequenti e le soluzioni agli errori più comuni le trovi nelle Domande frequenti (FAQ). Leggerle è sempre più veloce che aspettare una risposta nei forum d’assistenza.
Configurazione
Il plugin offre una vasta gamma d’opzioni di configurazione ed esempi di connessione. Gli utenti più esperti possono consultare anche questi documenti sulla scalabilità e replica
Comandi WP CLI
Redis Object Cache offre diversi comandi WP CLI; per approfondire e per saperne di più, dopo aver installato il plugin, esegui wp help redis.
Screenshot




Installazione
Per avere tutte le istruzioni dettagliate sull’installazione, leggi le esaurienti e più che complete istruzioni d’installazione.
Recensioni
Contributi e sviluppo
“Redis Object Cache” è un software open source. Le persone che hanno contribuito allo sviluppo di questo plugin sono indicate di seguito.
Collaboratori“Redis Object Cache” è stato tradotto in 20 lingue. Grazie a chi traduce per il contributo.
Traduci “Redis Object Cache” nella tua lingua.
Ti interessa lo sviluppo?
Esplora il codice segui il repository SVN, segui il log delle modifiche tramite RSS.
Changelog
3.0.0
- Consenti Predis v3.0 come dipendenza di Composer
- Ho aggiornato la libreria Predis inclusa nel pacchetto alla versione 2.4.1
- Ho aggiornato ApexCharts alla versione 4.7.0
- Indica quando la cache è disabilitata tramite la costante
WP_REDIS_DISABLED - Aggiunta la costante
WP_REDIS_CHART_COLOR - Aggiunta la costante
WP_REDIS_LOAD_APEXCHARTS - È stato corretto il problema in cui
wp_cache_replace()scriveva chiavi inesistenti e riportava un risultato errato - Corretti i metodi di cache di massa che bloccavano la connessione in modalità pipeline
- Corretto il problema per cui
WP_REDIS_USERNAMEveniva ignorato dalle connessioni PhpRedis/Relay - Corretto il problema per cui
WP_REDIS_USERNAMEveniva ignorato quando non era configurata alcuna password - Corretto il problema relativo alla gestione dei valori vuoti
WP_REDIS_PASSWORD - Corretto l’errore delle connessioni shard quando si usa
WP_REDIS_USERNAMEcon PhpRedis precedente alla versione 5.3.0 - È stato corretto il problema della mancanza del nome utente nella diagnostica delle connessioni in cluster
2.8.0
- Elimina i dati dei transient quando la cache è abilitata
- Stile migliorato per la versione di WordPress 7.x
- Tieni presente
WP_REDIS_SSL_CONTEXTquando usi Predis e le connessioni in cluster - Aggiunti gli hook mancanti
redis_object_cache_(disable|update_dropin)ad i comandi di WP CLI - Corretto il parametro del risultato dell’azione
redis_object_cache_enable
2.7.0
- Mantieni la chiave TTL quando chiami i metodi (in|de)crement
- Ho aggiornato le firme delle funzioni
wp_cache_*()per allinearle e farle corrispondere con il codice di base - È stato rimosso il supporto per HHVM, ormai deprecato
- Rimosso il valore deprecato della costante
WP_REDIS_SERIALIZER
2.6.5
- È stato corretto un problema relativo all’incremento (o decremento) dei valori della cache quando si utilizza igbinary
2.6.4
- Evita alcuni avvisi d’obsolescenza
- È stato corretto un problema relativo all’incremento ed alla decrementazione dei valori della cache
2.6.3
- Nel drop-in passa a
E_USER_DEPRECATEDinvece che a_doing_it_wrong() - È stato corretto l’errore che si verificava quando s’utilizzava Credis (ormai deprecato) come client
2.6.2
- Sono stati corretti altri errori d’analisi degli heredoc nella versione di PHP 7.2
2.6.1
- È stato corretto l’errore d’analisi dell’heredoc nelle versione di PHP 7.2
- È stato corretto il richiamo ad una funzione non definita
wp_rand()
2.6.0
- È stato aggiunto l’header
Primary Branch - Ho aggiunto
idad i tag script e style - Ho aggiornato Predis alla versione 2.4.0
- Ho aggiornato Credis alla versione 1.17.0
- Contrassegnato come testato fino alla versione 6.8
- Ora rispetta le linee guida di Plugin Check (PCP)
- È stato risolto il problema dell’incremento (o decremento) che non funzionava con il serializzatore
- È stato risolto un problema raro relativo alla modalità di replica
- Risolto un raro errore irreversibile nella diagnostica
2.5.4
- Tieni presente
WP_REDIS_SCHEMEper le connessioni al cluster - È stato corretto il problema con Predis e con la connessione
SentinelReplication - È stato corretto il doppio slash nell’indirizzo URL
admin.css
2.5.3
- Aggiunta la costante
WP_REDIS_DISABLE_GROUP_FLUSH - Aggiunti il filtro
redis_cache_manager_capabilitye la costanteWP_REDIS_MANAGER_CAPABILITY - Aggiunto il supporto
WP_REDIS_SSL_CONTEXTper le connessioni al cluster di PhpRedis - Sono stati corretti diversi problemi relativi a Predis ed alle connessioni in cluster o replicate
- È stato corretto un’altro raro errore irreversibile in
show_error_and_die()
2.5.2
- Ora rispetta
WP_REDIS_FLUSH_TIMEOUTnegli script di flush in Lua - È stato migliorato il supporto per
DISALLOW_FILE_MODS - È stato ripristinato il cambiamento del comportamento in
sanitize_key_part() - È stato corretto nuovamente un raro errore irreversibile in
show_error_and_die()
2.5.1
- Aggiunti i timeout alla diagnostica
- Ora supporta l’installazioni di PHP non comuni prive dell’estensione
sockets - È stato corretto un raro errore irreversibile in
show_error_and_die() - È stato corretto l’avviso di deprecazione in
sanitize_key_part()
2.5.0
- È necessaria la versione di WordPress 4.6 o versioni successive
- Carica il dominio “text” solo quando serve
- Aggiunta la costante
WP_REDIS_DISABLE_DROPIN_CHECK - Rispetta il filtro
file_mod_allowede la costanteDISALLOW_FILE_MODS - È stato rinominato il file di prova
.redis-write-test.tmpinobject-cache.tmp - Chiama l’azione
redis_object_cache_errorprima diwp_die() - Consenti che
WP_REDIS_PLUGIN_PATHsia definito altrove - Aggiunto un timeout sperimentale per il flush (il valore predefinito è di
5secondi) - Ho eliminato i gruppi predefiniti superflui ed ignorati
2.4.4
- Miglioramento della gestione dei risultati imprevisti delle transazioni
2.4.3
- È stato corretto l’errore della sintassi della versione di PHP
<=7.2 - Sono state corrette le traduzioni della pagina d’errore del caricamento
2.4.2
- Ho reso lo script della barra d’amministrazione più affidabile
- Sono state migliorate le istruzioni di ripristino su
redis-error.php - È stato migliorato il rilevamento di CloudLinux
- Miglioramenti alla localizzazione
- Abbiamo impedito al plugin W3 Total Cache ed al plugin LiteSpeed Cache di sovrascrivere il file “drop-in”
- È stato corretto il problema relativo al supporto dei nomi utente ACL quando si usa Predis e la sintassi degli array
2.4.1
- È stato corretto l’errore della sintassi della versione di PHP
<=7.2
2.4.0
- Svuota la cache quando attivi/disattivi la cache degli oggetti
- Mostra un messaggio d’errore personalizzato quando Redis non è raggiungibile
- Non consentire l’abilitazione della cache degli oggetti quando Redis non è raggiungibile
- La costante di configurazione
WP_REDIS_SERIALIZERè deprecata e comporta rischi; usa inveceWP_REDIS_IGBINARY - Supporta
WP_REDIS_USERNAMEquando usi Predis - Mostra i decimali della percentuale di hit della cache nel nodo della barra d’amministrazione
- Il codice segreto viene nascosto quando visualizzi
WP_REDIS_SERVERS - È stata migliorata la compatibilità di Accelerate WP con CloudLinux
- Lo svuotamento della cache della barra d’amministrazione ora utilizza AJAX
2.3.0
- Mostra il widget della bacheca solo agli amministratori
- Aggiunto un nodo nella barra d’amministrazione (puoi disattivarlo usando
WP_REDIS_DISABLE_ADMINBAR) - Aggiunta la costante della configurazione
WP_REDIS_SSL_CONTEXT - Genera un errore quando si verifica un errore di connessione
- Aggiunto il supporto per i nomi utente quando si usa Predis
- È stato aggiunto il supporto per caricare Predis da
WP_REDIS_PLUGIN_PATH - Sono state rese più rigorose le connessioni tramite socket Unix in Predis
- È stato corretto un raro bug che causava il ricaricamento del gruppo
- È stato corretto il problema del ping del cluster quando si usa Predis
- Ho aggiornato Predis alla versione 2.1.2
- La documentazione è stata migliorata
2.2.4
- Registra il comando
wp redisdella CLI in ritardo - Non entrare in conflitto con Object Cache Pro per il comando
wp redis - Impedisci a Perflab di sovrascrivere il file di cache degli oggetti “drop-in”
- Ho aggiornato Predis alla versione 2.1.1
- Evita errori di battitura e/o digitazione quando la transazione fallisce
- Controlla se ci sono header di tipo di contenuto incompatibili
2.2.3
- Aggiunto il supporto per
wp_cache_flush_group() - Ho aggiornato Credis alla versione 1.14.0
- Elimina il parametro
$delaydalla funzionewp_cache_flush() - Prevenire un’errore raro nella diagnostica durante la lettura degli errori di connessione
2.2.2
- Usa
QM_Data_Cacheal posto diQM_Data - È stato corretto l’avviso relativo all’istruzione “use” con nome non composto in
WP_Error
2.2.1
- Aggiunta la funzione
wp_cache_supports()della versione di WordPress 6.1 - Ho aggiornato Predis alla versione 2.0.3
- Evita le chiamate anticipate a
microtime()all’interno diWP_Object_Cache::get() - Supporta la nuova classe
QM_Datadi Query Monitor - Lancia un’eccezione se la pipeline restituisce risultati inaspettati
2.2.0
- Aggiunto il filtro
redis_cache_add_non_persistent_groups - Sono stati corretti i parametri
wp_add_dashboard_widget - È stato corretto il problema della replica
WP_REDIS_SERVERScon Predis v2.0 - È stato corretto il supporto per la stringa
WP_REDIS_CLUSTER - È stato corretto il problema per cui
MGETfalliva nella chiamata aget_multiple() - Sono stati corretti diversi avvisi che comparivano in caso d’errori nella pipeline
2.1.6
- Sono state corrette tutte le discrepanze SVN
2.1.5
- È stato corretta la chiamata a
is_predis()
2.1.4
- Aggiunto l’helper
is_predis()
2.1.3
- È stato corretto un bug in
wp_cache_add_multiple()ewp_cache_set_multiple()
2.1.2
- È stato corretta e migliorata la logica di
wp_cache_*_multiple() - Chiama l’azione
redis_object_cache_setinwp_cache_set_multiple() - Chiama l’azione
redis_object_cache_deleteinwp_cache_delete_multiple() - Controlla se viene ignorato il nome del gruppo non elaborato, non quello pulito
- È stato rimosso il tracciamento
2.1.1
- Abbiamo aggiornato i requisiti minimi di PHP alla versione di PHP 7.2
- Ho rinominato
WP_REDIS_DIRinWP_REDIS_PLUGIN_DIR - È stato corretto un raro errore irreversibile nella diagnostica
- Consenti l’installazione di Predis v1.1 tramite Composer
- Supporta l’uso della stringa
WP_REDIS_CLUSTER
2.1.0
- Abbiamo aggiornato i requisiti minimi di PHP alla versione di PHP 7.0
- I client di Credis e di HHVM sono ormai obsoleti e deprecati
- Ho aggiornato Predis alla versione 2.0.0
- Ho aggiornato Credis alla versione 1.13.1
- Migliore leggibilità dei cluster nella diagnostica
- Miglioramento della connessione ad i cluster
- È stato corretto il problema dei cluster di ping dopo la connessione
- Sono stati corretti diversi bug in
connect_using_credis()
2.0.26
- È stato corretto un bug in
wp_cache_delete_multiple()quando si usa Predis - È stato corretto un bug in
wp_cache_add_multiple()quando l’aggiunta alla cache è sospesa
2.0.25
- Rimosso il codice non funzionante
wp_cache_add_multiple()
2.0.24
- È stato migliorata la formattazione dell’etichette e dei tooltip delle metriche
- È stato corretto il problema del grafico delle metriche che non veniva visualizzato
- Ho aggiornato Predis alla versione 1.1.10
- Ho aggiornato Credis alla versione 1.13.0
- Supporta
composer/installersv1 e v2 - Collegamento alla pagina delle impostazioni quando viene rilevato un drop-in esterno
- Aggiunta la funzione
wp_cache_flush_runtime() - Aggiunta la funzione
wp_cache_add_multiple() - Aggiunta la funzione
wp_cache_delete_multiple()
2.0.23
- Aggiunto il supporto per Relay
- Piccole correzioni e miglioramenti all’esperienza utente
- È stato corretto il messaggio di deprecazione nella versione di PHP 8.1
- Ho aggiornato ApexCharts alla versione 3.31.0
2.0.22
- Correzioni di compatibilità con la versione di PHP 8.1
- Aggiornato a Predis v1.1.9
- Aggiunto il link alle impostazioni nel widget
- Il pannello della diagnostica è stato completamente rinnovato
- Ho aggiornato ApexCharts alla versione 3.30.0
- Reindirizza alle impostazioni del plugin dopo l’attivazione
- Ho corretto il percorso errato del file
diagnostics.php - È stato corretto il problema d’overflow del grafico nella scheda delle impostazioni
- È stato corretto il problema del ping del cluster Predis
- Evita di mostrare l’avviso quando la cartella dei contenuti non è scrivibile
2.0.21
- Aggiunta la diagnostica delle metriche
- Aggiunto l’alias
WP_Object_Cache::decr() - Ho spostato il file
diagnostics.php
2.0.20
- È stato corretta la versione su wp.org
2.0.19
- Rendi unico l’identificatore metrico
- Imposta un prefisso unico per i siti web ospitati su Cloudways
- Non stampare i commenti di debug HTML quando
WP_CLIè impostato sul valoretrue
2.0.18
- Aggiunta l’azione
redis_object_cache_tracee la costanteWP_REDIS_TRACE - Ho aggiornato ApexCharts alla versione 3.26.0
- È stato corretto un problema con
WP_REDIS_DISABLE_METRICS
2.0.17
- Pulizia del codice.
- È stato corretto il problema delle metriche mancanti
- È stato corretto il test del filesystem
2.0.16
- Ho aggiornato Credis alla versione 1.11.4
- È stato corretto lo stile degli avvisi “drop-in”
- Ho spostato le metriche in una classe dedicata
- Aggiunto il filtro
redis_cache_validate_dropin - Usa la costante
WP_DEBUG_DISPLAY(al posto diWP_DEBUG) per visualizzare le informazioni di debug - È stato corretto un’errore raro in
wp_cache_get_multiple() - È stato rimosso l’uso di
intval()
2.0.15
- Sono state annullate le modifiche apportate a
build_key()a causa di problemi negli ambienti che utilizzano la versione multisito di WordPress
2.0.14
- La scheda “Made Object Cache Pro” ora è traducibile
- Aggiunto
WP_REDIS_SERIALIZERalla sezione “Diagnostica” - È stato migliorata la velocità di
build_key() - Supporta le impostazioni
WP_REDIS_PREFIXeWP_REDIS_SELECTIVE_FLUSHtramite le variabili d’ambiente - Aggiunto
WP_REDIS_METRICS_MAX_TIMEper regolare l’intervallo di tempo delle metriche memorizzate - Ritarda il caricamento del dominio di testo e della programmazione fino all’hook
init - Abbiamo aggiornato la libreria Predis inclusa nel pacchetto alla versione 1.1.6
- Viene prevenuto il problema di riferimento alle variabili in
connect_using_credis()
2.0.13
- Ho aggiornato la libreria Predis inclusa al pacchetto alla versione 1.1.4
- Ho creato
redis-cachecome gruppo globale per migliorare le metriche sui siti web che utilizzano la versione multisito di WordPress - Sono passato alla sintassi con array breve
- Ho aggiunto i tag
@sincea tutti gli hook - Usa
parse_url()al posto diwp_parse_url()nel drop-in - Ho corretto il nome della variabile dell’istanza del plugin in
wp redis status
2.0.12
- È stato corretto il calcolo delle metriche a byte fissi
- È stato corretto un problema con le configurazioni non standard di Predis
- Sono stati migliorati gli standard della codifica di WordPress
2.0.11
- È stato corretto un problema in
wp_cache_get_multiple()quando si usa Predis - Evita l’avviso d’indice non definito nella diagnostica
2.0.10
- È stato corretto il problema della deserializzazione dei valori in
wp_cache_get_multiple()
2.0.9
- Evidenzia il tipo di metrica corrente con un colore
- Mostra la scheda “Metriche” quando le metriche sono disabilitate
- Riorganizzazione della logica di connessione e di gestione dello stato di Redis
- Ho aggiornato Predis alla versione 1.1.2
- Rimuovi l’avviso di deprecazione di Predis
- È stato corretto il problema relativo al recupero delle chiavi derivate in
wp_cache_get_multiple()
2.0.8
- È stato corretto il problema delle schede fisse che non funzionavano nelle versioni 2.0.6 e 2.0.7 a causa di un problema con l’SVN di wordpress.org
2.0.7
- È stato corretto il problema con
wp_cache_get_multiple()
2.0.6
- Aggiunto un test sperimentale del filesystem nella sezione “Diagnostica”
- Ho riorganizzato la logica della scheda delle impostazioni (ho corretto anche il problema del salto)
- Sono stati corretti i problemi relativi a
wp_cache_get_multiple() - Restituisce un valore booleano da
wp_cache_delete() - Usa
redis-cachecome namespace per gli eventi JS - Nascondi la riga “Pro” nel widget quando i banner sono disabilitati
- Ho rinominato l’azione
redis_object_cache_get_multiinredis_object_cache_get_multiple
2.0.5
La versione 2.0 rappresenta una revisione sostanziale del plugin. T’invitiamo a leggere le note di rilascio della v2.0.0.
- È stato corretto il problema dei pulsanti d’azione che usano la versione multisito di WordPress e che non funzionavano
- È stato rimosso l’avviso obsoleto relativo alla versione di PHP 5.4
- Aggiunto il supporto per
read_timeouta Credis - Visualizza i parametri di connessione quando usi Credis
- Ho aggiunto il link al wiki con l’avviso sull’aggiornamento di Predis
2.0.4
- Cerca d’aggiornare in modo affidabile il file dropin quando questo è ormai obsoleto e deprecato
- Mostra il nome utente ACL nella schermata delle impostazioni
- Visualizza la diagnostica completa con
wp redis status - Imposta sempre
FS_CHMOD_FILEquando copi il fileobject-cache.php - Non inserire elenchi puntati nella diagnostica delle password
- Chiama
redis_object_cache_update_dropindurante l’aggiornamento in modalità dropin
2.0.3
- Nascondi la scheda “Metriche” quando le metriche sono disabilitate
- È stato corretto il problema del mancato caricamento di
admin.jsnegli ambienti che utilizzano la versione multisito di WordPress - Evita un errore irreversibile quando interagisci con le metriche, ma Redis non è più disponibile
- Aggiunto
WP_Object_Cache::__get()per garantire la retrocompatibilità
2.0.2
- File POT aggiornato e commenti per i traduttori
2.0.1
- Supporta le versioni precedenti di Query Monitor
- Abbiamo reso lo stato “Dropin” più utile
- Nascondi la versione di Redis nelle impostazioni quando non è disponibile
- Percorsi delle dipendenze compressi utilizzando il pacchetto
composer-custom-directory-installer - Prevenire i conflitti tra
QM_Collectored altri plugin - Prevenire problemi con le metriche quando la cache non è disponibile
- È stato corretto il problema del link “Impostazioni” nell’elenco dei plugin
- È stata corretta la logica
WP_REDIS_DISABLED
2.0.0
La versione 2.0 è stata completamente riscritta. Il plugin ora richiede come minimo la versione di PHP 5.6, proprio come WordPress 5.2.
Il repository su GitHub e Composer è stato spostato da tillkruss/redis-cache a rhubarbgroup/redis-cache.
Nelle reti che utilizzano la versione multisito di WordPress, assicurati di “attivare il plugin in rete” dopo l’aggiornamento alla versione 2.x.
- È necessaria la versione di PHP 5.6
- Il plugin ora funziona solo nel network e/o nella rete
- Passa a WPCS per gli standard di codifica
- Abbiamo completamente rinnovato la schermata delle impostazioni
- Aggiunte le metriche relative alla cache degli oggetti (nel widget della bacheca e nelle impostazioni)
- Aggiunto il supporto per Query Monitor
- Ho aggiunto il namespace
Rhubarb\RedisCachea tutti i file - È stato aggiunto il supporto per la nuova funzione
wp_cache_get_multi()presente nella versione di WordPress 5.5 - È stata aggiunta la funzione
redis_object_cache()per recuperare l’istanza del plugin - Aggiunti avvisi relativi ai drop-in alla bacheca del network e/o rete
- È stato aggiunto il supporto per l’impostazione dei numeri del database Sentinel
- Supporta l’autenticazione tramite nome utente e password con ACL di Redis 6
- Supporta la sovrascrittura del file “dropin” esistente nella schermata delle impostazioni
- Usa il pattern singleton per creare un’istanza del plugin
- Usa Composer per installare e caricare Predis
- Aggiorna il file di cache degli oggetti durante l’aggiornamento del plugin
- Usa metodi diversi per collegarti a tutti i client
- Ho risolto il problema con
CUSTOM_USER_TABLEeCUSTOM_USER_META_TABLE - Ho aggiunto
themescome gruppo da ignorare - Ho impostato il timeout predefinito per la connessione e la lettura ad 1 secondo
- Prevenire una condizione di competizione in
add_or_replace() - Per maggiore chiarezza, ho rinominato
WP_CACHE_KEY_SALTinWP_REDIS_PREFIX - Ho sostituito il termine “schiavo” con “replica”
- Seleziona il database
SELECTsolo se non è0
1.6.1
- È stato corretto il problema che causava la visualizzazione del commento nel footer della pagina durante le richieste AJAX
1.6.0
- Miglioramento della sanificazione dei nomi dei gruppi (grazie @naxvog)
- Prevenire un errore irreversibile durante la sostituzione di un dropin esterno
- Aggiunto un commento nel footer HTML con informazioni di debug opzionali e facoltative
- Suggerimenti dei prefissi rimossi
Il commento nel footer HTML mostra le informazioni di debug solo quando WP_DEBUG è abilitato. Per disabilitare completamente il commento, imposta la costante WP_REDIS_DISABLE_COMMENT sul seguente valore: true.
1.5.9
- È stato corretto il problema della mancata assegnazione della variabile
$infonel costruttore - È stata corretta la condizione d’avviso relativa a MaxTTL
- Sono passato ad usare gli stili predefiniti dei pulsanti
1.5.8
- Aggiunto un messaggio d’avviso relativo ad un valore MaxTTL non valido
- Aggiunto un avviso sulla libreria Predis non più supportata
- Aggiunto un suggerimento sui prefissi più brevi e di più facile comprensione
- Aggiunta la compatibilità con la versione professionale di Redis Cache Pro nelle impostazioni
- È stato corretto il problema dello svuotamento della cache quando il prefisso conteneva caratteri speciali
- È stato corretto il problema che causava la visualizzazione di “Redis
INFO” durante l’uso dei cluster - Ho sistemato un po’ le impostazioni
1.5.7
- Aggiunto il supporto per le connessioni TLS di PhpRedis
- Aggiunto il supporto per il timeout, il timeout di lettura e la password quando s’utilizza il cluster PhpRedis
- È stato corretto il problema con il comando
INFO - È stato corretto il problema della clonazione degli oggetti durante l’impostazione delle chiavi della cache
1.5.6
- Aggiunta la clonazione degli oggetti nella cache in memoria
- È stato corretto il messaggio di avviso di PHP relativo al parametro
read_timeout
1.5.5
Devi svuotare la cache degli oggetti dopo aver aggiornato il drop alla versione 1.5.5, per evitare che le chiavi inattive riempiano la memoria di Redis.
- Ho tolto i tasti per mettere in minuscolo
- Rimuovi l’evento di monitoraggio programmato
- È stato corretto il problema relativo alla versione di Redis quando s’utilizza la replica
1.5.4
- Metriche rimosse
1.5.3
- Correzione: chiamata ad una funzione non definita
get_plugin_data() - Correzione: chiamata ad un metodo non definito
WP_Object_Cache::redis_version()
1.5.2
- Aggiunta la versione di Redis alla sezione “Diagnostica”
- Aggiunta la costante
WP_REDIS_DISABLE_BANNERSper disattivare le promozioni - È stato corretto un problema con
redis.replicate_commands()
1.5.1
Oggi (14 novembre) questo plugin compie 5 anni ed è proprio il momento giusto per lanciare anche la versione business e professionale Pro.
Object Cache Pro è una versione rivisitata di questo plugin, davvero affidabile, altamente ottimizzata e facile da debuggare, pensata appositamente per le PMI.
- Aggiunti i tempi d’esecuzione alle azioni
- Aggiunta la costante
WP_REDIS_VERSION - È stata corretta la compatibilità con PhpRedis v3
- È stato corretto un problema relativo allo svuotamento selettivo
- È stato corretto un problema relativo all’assenza delle funzioni
mb_* - Ho sostituito la scheda codificatore degl’indirizzi email con la scheda Redis Cache Pro
- Raccogli i dati sulle prestazioni per prendere le decisioni più efficaci
1.5.0
Dato che Predis non viene più aggiornato, ti consiglio vivamente di passare a PhpRedis (l’estensione PECL di Redis).
- Improved Redis key name builder
- Added support for PhpRedis serializers
- Added
redis_object_cache_erroraction - Added timeout, read-timeout and retry configuration
- Aggiunti gruppi non cancellabili (impostazione predefinita:
['userlogins']) - È stato corretto il problema delle password che non venivano visualizzate nell’elenco dei server
1.4.3
- Require PHP 5.4 or newer
- Use pretty print in diagnostics
- Throw exception if Redis library is missing
- Fixed cache not flushing for some users
- Fixed admin issues when
WP_REDIS_DISABLEDisfalse
1.4.2
- Added graceful Redis failures and
WP_REDIS_GRACEFULconstant - Improved cluster support
- Added
redis_cache_expirationfilter - Renamed
redis_object_cache_getfilter toredis_object_cache_get_value
1.4.1
- Fixed potential fatal error related to
wp_suspend_cache_addition()
1.4.0
- Added support for igbinary
- Added support for
wp_suspend_cache_addition()
1.3.9
- Fixed
WP_REDIS_SHARDSnot showing up in server list - Fixed
WP_REDIS_SHARDSnot working when using PECL extension - Removed
WP_REDIS_SCHEMEandWP_REDIS_PATHleftovers
1.3.8
- Switched from single file Predis version to full library
1.3.7
- Revert back to single file Predis version
1.3.6
- Added support for Redis Sentinel
- Added support for sharing
- Switched to PHAR version of Predis
- Improved diagnostics
- Added
WP_REDIS_SELECTIVE_FLUSH - Added
$fail_gracefullyparameter toWP_Object_Cache::__construct() - Always enforce
WP_REDIS_MAXTTL - Pass
$selectiveand$salttoredis_object_cache_flushaction - Don’t set
WP_CACHE_KEY_SALTconstant
1.3.5
- Added basic diagnostics to admin interface
- Added
WP_REDIS_DISABLEDconstant to disable cache at runtime - Prevent “Invalid plugin header” error
- Return integer from
increment()anddecrement()methods - Prevent object cache from being instantiated more than once
- Always separate cache key
prefixandgroupby semicolon - Improved performance of
build_key() - Only apply
redis_object_cache_getfilter if callbacks have been registered - Fixed
add_or_replace()to only set cache key if it doesn’t exist - Added
redis_object_cache_flushaction - Added
redis_object_cache_enableaction - Added
redis_object_cache_disableaction - Added
redis_object_cache_update_dropinaction
1.3.4
- Added WP-CLI support
- Show host and port unless scheme is unix
- Updated default global and ignored groups
- Do a cache flush when activating, deactivating and uninstalling
1.3.3
- Updated Predis to
v1.1.1 - Added
redis_instance()method - Added
incr()method alias for Batcache compatibility - Added
WP_REDIS_GLOBAL_GROUPSandWP_REDIS_IGNORED_GROUPSconstant - Added
redis_object_cache_deleteaction - Use
WP_PLUGIN_DIRwithWP_CONTENT_DIRas fallback - Set password when using a cluster or replication
- Show Redis client in
stats() - Change visibility of
$cacheto public - Use old array syntax, just in case
1.3.2
- Make sure
$resultis notfalseinWP_Object_Cache::get()
1.3.1
- Fixed connection issue
1.3
- New admin interface
- Added support for
wp_cache_get()‘s$forceand$foundparameter - Added support for clustering and replication with Predis
1.2.3
- UI improvements
1.2.2
- Added
redis_object_cache_setaction - Added
redis_object_cache_getaction and filter - Prevented duplicated admin status messages
- Load bundled Predis library only if necessary
- Load bundled Predis library using
WP_CONTENT_DIRconstant - Updated
stats()method output to be uniform with WordPress
1.2.1
- Aggiunto
composer.json - Aggiunti gli hook di disattivazione e disinstallazione per eliminare il file
object-cache.php - Sono state aggiunte funzioni di serializzazione locali per un miglior supporto del file
advanced-cache.php - Ho aggiornato la versione di Predis inclusa nel pacchetto alla versione
1.0.3 - Ho aggiornato la struttura degli header per renderla semantica
1.2
- È stato aggiunto il supporto per chi utilizza la versione multisito di WordPress
- Ho spostato il menu d’amministrazione nel menu Impostazioni
- È stato corretto il messaggio d’avviso di PHP in
get_redis_client_name()
1.1.1
- Chiama
select()e, se vuoi,auth()se usi l’estensione HHVM
1.1
- Aggiunto il supporto per l’estensione di Redis di HHVM
- Aggiunto il supporto per l’estensione PECL Redis
- Aggiunta la costante
WP_REDIS_CLIENT, per impostare il client di Redis preferito - Aggiunta la costante
WP_REDIS_MAXTTL, per forzare la scadenza delle chiavi della cache - Miglioramento dei metodi
add_or_replace(),get(),set()edelete() - Stili migliorati per le schermate d’amministrazione
- Ho rimosso tutte le parti relative all’internazionalizzazione ed alla localizzazione dal drop-in
1.0.2
- Aggiunto il pulsante “Svuota la cache”
- Aggiunto il supporto per i socket di dominio UNIX
- Le prestazioni nel recupero degli oggetti dalla cache sono migliorate in modo significativo
- Updated bundled Predis library to version
1.0.1
1.0.1
- Load plugin translations
- Hide global admin notices from non-admin users
- Prevent direct file access to
redis-cache.phpandadmin-page.php - Colorize “Disable Object Cache” button
- Call
Predis\Client->connect()to avoid potential uncaughtPredis\Connection\ConnectionException
1.0
- Versione iniziale
