Title: Redis Object Cache
Author: Till Krüss
Published: <strong>14 de noviembre de 2014</strong>
Last modified: 18 de septiembre de 2026

---

Buscar plugins

![](https://ps.w.org/redis-cache/assets/banner-772x250.png?rev=2315420)

![](https://ps.w.org/redis-cache/assets/icon-256x256.gif?rev=2568513)

# Redis Object Cache

 Por [Till Krüss](https://profiles.wordpress.org/tillkruess/)

[Descargar](https://downloads.wordpress.org/plugin/redis-cache.3.0.0.zip)

 * [Detalles](https://es.wordpress.org/plugins/redis-cache/#description)
 * [Valoraciones](https://es.wordpress.org/plugins/redis-cache/#reviews)
 *  [Instalación](https://es.wordpress.org/plugins/redis-cache/#installation)
 * [Desarrollo](https://es.wordpress.org/plugins/redis-cache/#developers)

 [Soporte](https://wordpress.org/support/plugin/redis-cache/)

## Descripción

Un backend de caché de objetos persistente basado en Redis®¹. Compatible con [Predis](https://github.com/predis/predis/),
[PhpRedis (PECL)](https://github.com/phpredis/phpredis), [Relay](https://relaycache.com),
la replicación, los centinelas, la agrupación en clústeres y [WP-CLI](https://wp-cli.org/).

Para ajustar los parámetros de conexión, añadir prefijos a las claves de caché o
configurar la replicación o la agrupación en clústeres, consulta las [opciones de configuración](https://github.com/rhubarbgroup/redis-cache/#configuration).

#### Object Cache Pro

Un backend de caché de objetos Redis®¹ de **clase empresarial**. Totalmente fiable,
altamente optimizado, totalmente personalizable y con un ingeniero dedicado a tu
disposición cuando más lo necesites.

 * Reescrito para ofrecer un rendimiento óptimo
 * 100 % compatible con la API de WordPress
 * Serialización y compresión más rápidas
 * Fácil depuración y registro
 * Precarga de caché y análisis
 * Totalmente probado por unidades (cobertura del código del 100 %)
 * Conexiones seguras con TLS
 * Comprobaciones de estado mediante WordPress y WP CLI
 * Optimizado para WooCommerce, Jetpack y Yoast SEO

Más información sobre [Object Cache Pro](https://objectcache.pro/?ref=oss&utm_source=wp-plugin&utm_medium=readme).

¹ Redis es una marca registrada de Redis Ltd. Todos los derechos sobre la misma 
están reservados a Redis Ltd. Cualquier uso que haga Redis Object Cache de la misma
tiene únicamente fines de referencia y no implica ningún patrocinio, respaldo o 
afiliación entre Redis y Redis Object Cache.

### Solución de problemas

En la sección de preguntas frecuentes (FAQ) de [](https://github.com/rhubarbgroup/redis-cache/blob/develop/FAQ.md)
encontrarás respuestas a las dudas más habituales y soluciones a los errores más
comunes. Consultarlas siempre es más rápido que esperar una respuesta en los foros
de asistencia.

### Configuración

El plugin incluye un amplio conjunto de [opciones de configuración](https://github.com/rhubarbgroup/redis-cache/#configuration)
y [ejemplos de conexión](https://github.com/rhubarbgroup/redis-cache/#connections).
Los usuarios avanzados pueden consultar [Escalabilidad y replicación](https://github.com/rhubarbgroup/redis-cache/blob/develop/README.md#scaling)

### Comandos de WP CLI

Redis Object Cache dispone de varios comandos de WP CLI; para obtener más información,
ejecuta `wp help redis` tras instalar el plugin.

## Capturas

[⌊Configuración del plugin, conectada a un único servidor Redis.⌉⌊Configuración 
del plugin, conectada a un único servidor Redis.⌉[

Configuración del plugin, conectada a un único servidor Redis.

[⌊Configuración del plugin, que muestra métricas recientes sobre el tiempo de respuesta.⌉⌊
Configuración del plugin, que muestra métricas recientes sobre el tiempo de respuesta
.⌉[

Configuración del plugin, que muestra métricas recientes sobre el tiempo de respuesta.

[⌊Configuración del plugin, que muestra información de diagnóstico.⌉⌊Configuración
del plugin, que muestra información de diagnóstico.⌉[

Configuración del plugin, que muestra información de diagnóstico.

[⌊Widget del panel de control que muestra métricas recientes sobre los tiempos de
respuesta.⌉⌊Widget del panel de control que muestra métricas recientes sobre los
tiempos de respuesta.⌉[

Widget del panel de control que muestra métricas recientes sobre los tiempos de 
respuesta.

## Instalación

Para obtener instrucciones detalladas de instalación, lea las completas [instrucciones de instalación](https://github.com/rhubarbgroup/redis-cache/blob/develop/INSTALL.md).

## Reseñas

![](https://secure.gravatar.com/avatar/86c46ccacac2166f2bfb52a3f2b8a1f61731fa4a4d54c4788a38ad508e890741?
s=60&d=retro&r=g)

### 󠀁[Works great with minimal setup and provides easy configuration for advanced use](https://wordpress.org/support/topic/works-great-with-minimal-setup-and-provides-easy-configuration-for-advanced-use/)󠁿

 [Jason LeMahieu (MadtownLems)](https://profiles.wordpress.org/madtownlems/) 28 
de septiembre de 2026

I had Redis on my "todo" list for quite a while, but was always a bit nervous about
it, as it felt like a big undertaking. This plugin made it very easy to use! With
minimal setup, it made a massive improvement in page generation times. And I appreciate
the advanced configuration options via wp-config to let me customize things without
having to bother with filters or hacky workarounds.It has great support as well.
Highly recommend giving it a shot!

![](https://secure.gravatar.com/avatar/d74a8b420bd5361d4db4504ef26b0ef830d9405c04bbada58a1be619f64f6cc9?
s=60&d=retro&r=g)

### 󠀁[Outstanding performance for heavy data](https://wordpress.org/support/topic/outstanding-performance-for-heavy-data/)󠁿

 [cocatips](https://profiles.wordpress.org/cocatips/) 23 de septiembre de 2026

Excellent caching solution! I work extensively with Nuxt.js and Node.js to process
real-time data for over 80,000 football clubs on my platform. Managing that level
of data requires serious optimization, and seeing how well this plugin handles object
caching is truly impressive. It makes a massive difference in server response times.
Highly recommended for any data-heavy project!

![](https://secure.gravatar.com/avatar/74cb9868751280139359e8ca02502f4e10e5a12a7f399a874c45fdf4f4d83e34?
s=60&d=retro&r=g)

### 󠀁[Will crash your site on caching error](https://wordpress.org/support/topic/will-crash-your-site-on-caching-error/)󠁿

 [eir3apps](https://profiles.wordpress.org/eir3apps/) 19 de septiembre de 2026 1
respuesta

The plugin is fine, as long as no errors occur. When a caching error occurs, the
plugin will crash your site, and the only way to restore it is to delete a certain
file from the WP Plugin directory. Make sure to comment out the die() and wp_die()
calls, as the developer is too stubborn to change this ridiculous behaviour.

![](https://secure.gravatar.com/avatar/684cc2693f559bdcb81a858b26de2a99218b5e8137011a52e854824950e17ee6?
s=60&d=retro&r=g)

### 󠀁[SIMPLY THE BEST](https://wordpress.org/support/topic/simply-the-best-747/)󠁿

 [The Godfather](https://profiles.wordpress.org/geologynebula/) 18 de agosto de 
2026

IT JUST WORKS! So refreshing and our metal is smoking fast now. Thank you and props
to the Redis team for making this so easy for a caveman like me. Simply the best!
Better than all the rest, better than anyone, anyone I ever met. SIMPLY THE BEST
🎶 🎶

![](https://secure.gravatar.com/avatar/7e070140a620097525e4443f97652ded8138d63d9e41757b9f1581f4550c7dda?
s=60&d=retro&r=g)

### 󠀁[Good cache](https://wordpress.org/support/topic/good-cache/)󠁿

 [j0nny5](https://profiles.wordpress.org/j0nny5/) 5 de junio de 2026 1 respuesta

Truly, I would recommend this plug-in. Fast, efficient, and once you make the normal
modifications to your WordPress installation, it works like a charm.The only concern
is, if you flush your cache, it flushes the whole DB number the WordPress Site is
using in Redis, and whatever else was in that DB number is gone too. This means 
that if you want to have to-site accurate cache flushes, you will need to setup 
a DB number per WordPress site you are hosting.Author, please see this and make 
the flush scoped to the site's cache match, not the whole Redis DB number. Yes this
isn't a world ending detail… but could be a chance for a good optimization. Thank
you again for this plug-in!!

![](https://secure.gravatar.com/avatar/fbb7a94de6ebaed7aa5e75eac95c83fb011df41bb30f9a762cfe3e61a23a7628?
s=60&d=retro&r=g)

### 󠀁[Just works and does what it states on the tin.](https://wordpress.org/support/topic/just-works-and-does-what-it-states-on-the-tin/)󠁿

 [reecejames](https://profiles.wordpress.org/reecejames/) 5 de mayo de 2026 1 respuesta

Easy to use and just does the job!!!!

 [ Leer todas las 179 reseñas ](https://wordpress.org/support/plugin/redis-cache/reviews/)

## Colaboradores y desarrolladores

«Redis Object Cache» es un software de código abierto. Las siguientes personas han
colaborado con este plugin.

Colaboradores

 *   [ Till Krüss ](https://profiles.wordpress.org/tillkruess/)

«Redis Object Cache» está traducido en 20 idiomas. Gracias a [los traductores](https://translate.wordpress.org/projects/wp-plugins/redis-cache/contributors)
por sus contribuciones.

[Traduce «Redis Object Cache» a tu idioma.](https://translate.wordpress.org/projects/wp-plugins/redis-cache)

### ¿Interesado en el desarrollo?

[Revisa el código](https://plugins.trac.wordpress.org/browser/redis-cache/) , echa
un vistazo al [repositorio SVN](https://plugins.svn.wordpress.org/redis-cache/) 
o suscríbete al [registro de desarrollo](https://plugins.trac.wordpress.org/log/redis-cache/)
por [RSS](https://plugins.trac.wordpress.org/log/redis-cache/?limit=100&mode=stop_on_copy&format=rss).

## Registro de cambios

#### 3.0.0

 * Allow Predis v3.0 as a Composer dependency
 * Upgraded bundled Predis library to v2.4.1
 * Upgraded ApexCharts to v4.7.0
 * Indicate when the cache is disabled via the `WP_REDIS_DISABLED` constant
 * Added `WP_REDIS_CHART_COLOR` constant
 * Added `WP_REDIS_LOAD_APEXCHARTS` constant
 * Fixed `wp_cache_replace()` writing keys that don’t exist and misreporting its
   result
 * Fixed bulk cache methods leaving the connection stuck in pipeline mode
 * Fixed `WP_REDIS_USERNAME` being ignored by PhpRedis/Relay connections
 * Fixed `WP_REDIS_USERNAME` being ignored when no password is configured
 * Fixed handling empty `WP_REDIS_PASSWORD` values
 * Fixed sharded connections erroring when `WP_REDIS_USERNAME` is used with PhpRedis
   older than v5.3.0
 * Fixed the username missing from the diagnostics of clustered connections

#### 2.8.0

 * Eliminar transitorios cuando la caché esté habilitada
 * Estilo mejorado para WordPress 7.x
 * Se ha respetado `WP_REDIS_SSL_CONTEXT` al usar Predis y conexiones en clúster.
 * Se agregaron los ganchos `redis_object_cache_(disable|update_dropin)` que faltaban
   a los comandos de WP CLI.
 * Se ha corregido el parámetro de resultado de la acción `redis_object_cache_enable`

#### 2.7.0

 * Conservar el TTL de la clave al llamar a los métodos de incremento/decremento.
 * Se actualizaron las firmas de la función `wp_cache_*()` para que coincidan con
   el núcleo.
 * Se eliminó la compatibilidad obsoleta con HHVM.
 * Se eliminó la constante obsoleta `WP_REDIS_SERIALIZER`.

#### 2.6.5

 * Se solucionó un problema con el incremento/decremento de los valores de caché
   al usar igbinary.

#### 2.6.4

 * Evitar algunos avisos de desuso
 * Se solucionó un problema con los valores de caché de incremento/decremento.

#### 2.6.3

 * Cambie a `E_USER_DEPRECATED` en lugar de `_doing_it_wrong()` en drop-in
 * Se corrigió un error al usar Credis (obsoleto) como cliente.

#### 2.6.2

 * Se corrigieron más errores de análisis de heredoc en PHP 7.2.

#### 2.6.1

 * Se corrigió un error de análisis de heredoc en PHP 7.2.
 * Se corrigió la llamada a la función indefinida `wp_rand()`

#### 2.6.0

 * Se agregó el encabezado `Primary Branch`
 * Se agregó `id` a las etiquetas script/style
 * Predis se actualizó a la versión 2.4.0.
 * Credis se ha actualizado a la versión 1.17.0.
 * Marcar como probado hasta 6.8
 * Cumple con Plugin Check (PCP)
 * El incremento fijo (in/de) no funciona con el serializador
 * Se solucionó un problema poco frecuente del modo de replicación.
 * Se corrigió un error fatal poco frecuente en el diagnóstico.

#### 2.5.4

 * Se ha respetado `WP_REDIS_SCHEME` para las conexiones de clúster.
 * Se solucionó un problema con la conexión Predis y `SentinelReplication`.
 * Se corrigió la doble barra en la URL `admin.css`

#### 2.5.3

 * Se agregó la constante `WP_REDIS_DISABLE_GROUP_FLUSH`
 * Se agregó el filtro `redis_cache_manager_capability` y la constante `WP_REDIS_MANAGER_CAPABILITY`.
 * Se agregó compatibilidad con `WP_REDIS_SSL_CONTEXT` para conexiones de clúster
   PhpRedis.
 * Se corrigieron varios problemas con Predis y la conexión de clúster/replicada.
 * Se corrigió otro error fatal poco frecuente en `show_error_and_die()`

#### 2.5.2

 * Se ha respetado `WP_REDIS_FLUSH_TIMEOUT` en los scripts de vaciado de Lua
 * Mejorar la compatibilidad con `DISALLOW_FILE_MODS`
 * Se revirtió el cambio de comportamiento a `sanitize_key_part()`
 * Se corrigió un error fatal poco frecuente en `show_error_and_die()` (de nuevo).

#### 2.5.1

 * Se agregaron tiempos de espera a los diagnósticos.
 * Compatibilidad con instalaciones PHP poco comunes sin la extensión `sockets`
 * Se corrigió un error fatal poco frecuente en `show_error_and_die()`
 * Se corrigió la advertencia de obsolescencia en `sanitize_key_part()`

#### 2.5.0

 * Requiere WordPress 4.6 o posterior.
 * Cargar el dominio de texto solo cuando sea necesario.
 * Se agregó la constante `WP_REDIS_DISABLE_DROPIN_CHECK`
 * Se ha respetado el filtro `file_mod_allowed` y la constante `DISALLOW_FILE_MODS`.
 * Se cambió el nombre del archivo de prueba `.redis-write-test.tmp` a `object-cache.
   tmp`.
 * Llama a la acción `redis_object_cache_error` antes de `wp_die()`
 * Permite que `WP_REDIS_PLUGIN_PATH` se defina en otro lugar
 * Se agregó un tiempo de espera experimental para el vaciado (por defecto es de`
   5` segundos).
 * Se eliminaron los grupos ignorados predeterminados innecesarios.

#### 2.4.4

 * Mejor manejo de resultados de transacciones inesperados

#### 2.4.3

 * Se corrigió el error de sintaxis de PHP `<=7.2`
 * Se corrigió el error de carga de las traducciones de la página.

#### 2.4.2

 * Se ha mejorado la robustez del script de la barra de administración.
 * Instrucciones de recuperación mejoradas en `redis-error.php`
 * Detección mejorada de CloudLinux
 * Mejoras de localización
 * Evitar que W3 Total Cache y LiteSpeed ​​Cache sobrescriban los archivos de configuración
   adicionales.
 * Se corrigió la compatibilidad con nombres de usuario de ACL al usar Predis y 
   sintaxis de matriz.

#### 2.4.1

 * Corregir error de sintaxis de PHP `<=7.2`

#### 2.4.0

 * Vaciar la caché al activar o desactivar la caché de objetos
 * Mostrar un mensaje de error personalizado cuando Redis no está accesible
 * No permitir activar la caché de objetos cuando Redis no está accesible
 * La constante de configuración `WP_REDIS_SERIALIZER` queda obsoleta por ser arriesgada;
   usa `WP_REDIS_IGBINARY` en su lugar
 * Compatibilidad con `WP_REDIS_USERNAME` al usar Predis
 * Mostrar decimales de la tasa de aciertos de caché en el nodo de la barra de administración
 * Ocultar secretos al mostrar `WP_REDIS_SERVERS`
 * Mejorada la compatibilidad con Accelerate WP de CloudLinux
 * El vaciado de la caché de la barra de administración ahora utiliza AJAX.

#### 2.3.0

 * Mostrar el widget del escritorio solo a los administradores
 * Añadido nodo en la barra de administración (desactivar con `WP_REDIS_DISABLE_ADMINBAR`)
 * Añadida la constante de configuración `WP_REDIS_SSL_CONTEXT`
 * Lanzar errores cuando se produzca un error de conexión
 * Añadida compatibilidad con nombres de usuario al usar Predis
 * Añadida compatibilidad para cargar Predis desde `WP_REDIS_PLUGIN_PATH`
 * Endurecidas las conexiones mediante socket Unix de Predis
 * Corregido un error poco frecuente al vaciar grupos
 * Corregido el ping de clúster al usar Predis
 * Actualizado Predis a la versión 2.1.2
 * Documentación mejorada

#### 2.2.4

 * Registrar el comando `wp redis` de CLI más tarde
 * No competir con Object Cache Pro por el comando `wp redis`
 * Evitar que Perflab sobrescriba el dependiente de caché de objetos
 * Actualizado Predis a la versión 2.1.1
 * Evitar errores de tipo cuando falla una transacción
 * Comprobar cabeceras de tipo de contenido incompatibles

#### 2.2.3

 * Añadida compatibilidad con `wp_cache_flush_group()`
 * Actualizado Credis a la versión 1.14.0
 * Eliminar el parámetro `$delay` de `wp_cache_flush()`
 * Prevenir un error poco frecuente en el diagnóstico al leer errores de conexión

#### 2.2.2

 * Usar `QM_Data_Cache` en lugar de `QM_Data`
 * Corregido el aviso de nombre no compuesto en la declaración de uso de `WP_Error`

#### 2.2.1

 * Añadida la función `wp_cache_supports()` de WordPress 6.1
 * Actualizado Predis a la versión 2.0.3
 * Evitar llamadas tempranas a `microtime()` en `WP_Object_Cache::get()`
 * Compatibilidad con la nueva clase `QM_Data` de Query Monitor
 * Lanzar una excepción si el pipeline devuelve resultados inesperados

#### 2.2.0

 * Añadido el filtro `redis_cache_add_non_persistent_groups`
 * Corregidos los parámetros de `wp_add_dashboard_widget`
 * Corregido el problema de replicación de `WP_REDIS_SERVERS` con Predis v2.0
 * Corregida la compatibilidad con cadenas en `WP_REDIS_CLUSTER`
 * Corregido el problema cuando `MGET` falla en la llamada a `get_multiple()`
 * Corregidos varios avisos en caso de fallos en el pipeline

#### 2.1.6

 * Corregidas discrepancias de SVN

#### 2.1.5

 * Corregida la llamada a `is_predis()`

#### 2.1.4

 * Añadida la función auxiliar `is_predis()`

#### 2.1.3

 * Corregido un error en `wp_cache_add_multiple()` y `wp_cache_set_multiple()`

#### 2.1.2

 * Corregida y mejorada la lógica de `wp_cache_*_multiple()`
 * Llamar a la acción `redis_object_cache_set` en `wp_cache_set_multiple()`
 * Llamar a la acción `redis_object_cache_delete` en `wp_cache_delete_multiple()`
 * Comprobar si se ignora el nombre de grupo original, no el nombre saneado
 * Eliminado el rastreo

#### 2.1.1

 * Requisito de PHP elevado a 7.2
 * Renombrada `WP_REDIS_DIR` a `WP_REDIS_PLUGIN_DIR`
 * Corregido un error fatal poco frecuente en el diagnóstico
 * Permitir instalaciones de Composer para Predis v1.1
 * Compatibilidad con el uso de cadenas en `WP_REDIS_CLUSTER`

#### 2.1.0

 * Requisito de PHP elevado a 7.0
 * Los clientes Credis y HHVM quedan obsoletos
 * Actualizado Predis a la versión 2.0.0
 * Actualizado Credis a la versión 1.13.1
 * Mejorada la legibilidad de los clústeres en el diagnóstico
 * Mejorada la conexión a clústeres
 * Corregido el ping a clústeres después de conectar
 * Corregidos varios errores en `connect_using_credis()`

#### 2.0.26

 * Corregido un error en `wp_cache_delete_multiple()` al usar Predis
 * Corregido un error en `wp_cache_add_multiple()` cuando la adición de caché está
   suspendida

#### 2.0.25

 * Eliminada la función `wp_cache_add_multiple()` que no funcionaba

#### 2.0.24

 * Mejorar el formato de las etiquetas y la información emergente de las métricas
 * Corregido el error que impedía mostrar el gráfico de métricas
 * Actualizado Predis a la versión 1.1.10
 * Actualizado Credis a la versión 1.13.0
 * Compatibilidad con `composer/installers` v1 y v2
 * Enlace a la página de ajustes cuando se ha encontrado un dependiente externo
 * Añadida la función `wp_cache_flush_runtime()`
 * Añadida la función `wp_cache_add_multiple()`
 * Añadida la función `wp_cache_delete_multiple()`

#### 2.0.23

 * Añadida compatibilidad con [Relay](https://relaycache.com)
 * Pequeñas correcciones y mejoras en la experiencia de usuario
 * Corregido el aviso de obsolescencia de PHP 8.1
 * Actualizado ApexCharts a la versión 3.31.0

#### 2.0.22

 * Correcciones de compatibilidad con PHP 8.1
 * Actualizado a Predis v1.1.9
 * Añadido un enlace a los ajustes en el widget
 * Reformado el panel de diagnóstico
 * Actualizado ApexCharts a la versión 3.30.0
 * Redirigir a los ajustes del plugin después de la activación
 * Corregida la ruta incorrecta al archivo `diagnostics.php`
 * Corregido el desbordamiento del gráfico en la pestaña de ajustes
 * Corregido el ping de clúster de Predis
 * Evitar avisos cuando la carpeta de contenido no se puede escribir

#### 2.0.21

 * Añadido el diagnóstico de métricas
 * Añadido el alias `WP_Object_Cache::decr()`
 * Movido el archivo `diagnostics.php`

#### 2.0.20

 * Corregir la publicación en wp.org

#### 2.0.19

 * Hacer que el identificador de métricas sea único
 * Establecer un prefijo único para los sitios alojados en Cloudways
 * No imprimir el comentario de depuración HTML cuando `WP_CLI` es `true`

#### 2.0.18

 * Añadida la acción `redis_object_cache_trace` y la constante `WP_REDIS_TRACE`
 * Actualizado ApexCharts a la versión 3.26.0
 * Corregido un problema con `WP_REDIS_DISABLE_METRICS`

#### 2.0.17

 * Limpieza de código
 * Corregidas las métricas que faltaban
 * Corregida la prueba del sistema de archivos

#### 2.0.16

 * Actualizado Credis a la versión 1.11.4
 * Corregido el estilo del aviso del dependiente
 * Movidas las métricas a una clase dedicada
 * Añadido el filtro `redis_cache_validate_dropin`
 * Usar la constante `WP_DEBUG_DISPLAY` (en lugar de `WP_DEBUG`) para mostrar información
   de depuración
 * Corregido un error poco frecuente en `wp_cache_get_multiple()`
 * Eliminado el uso de `intval()`

#### 2.0.15

 * Revertidos los cambios en `build_key()` debido a problemas en entornos multisitio

#### 2.0.14

 * Hecha traducible la tarjeta de Object Cache Pro
 * Añadido `WP_REDIS_SERIALIZER` al diagnóstico
 * Mejorada la velocidad de `build_key()`
 * Compatibilidad con los ajustes `WP_REDIS_PREFIX` y `WP_REDIS_SELECTIVE_FLUSH`
   mediante variables de entorno
 * Añadido `WP_REDIS_METRICS_MAX_TIME` para ajustar el período de almacenamiento
   de las métricas
 * Retrasar la carga del dominio de texto y la programación hasta el hook `init`
 * Actualizada la biblioteca Predis incluida a la versión 1.1.6
 * Prevenir problemas de referencia de variables en `connect_using_credis()`

#### 2.0.13

 * Actualizada la biblioteca Predis incluida a la versión 1.1.4
 * Convertido `redis-cache` en un grupo global para mejorar las métricas en multisitio
 * Cambiado a la sintaxis abreviada de arrays
 * Añadidas etiquetas `@since` a todos los hooks
 * Usar `parse_url()` en lugar de `wp_parse_url()` en el dependiente
 * Corregido el nombre de la variable de la instancia del plugin en `wp redis status`

#### 2.0.12

 * Corregido el cálculo de las métricas de bytes
 * Corregido un problema con configuraciones no estándar de Predis
 * Mejorar los estándares de código de WordPress

#### 2.0.11

 * Corregido un problema en `wp_cache_get_multiple()` al usar Predis
 * Prevenir el aviso de índice indefinido en el diagnóstico

#### 2.0.10

 * Corregida la deserialización de valores en `wp_cache_get_multiple()`

#### 2.0.9

 * Resaltar el tipo de métrica actual con color
 * Mostrar la pestaña «Métricas» cuando las métricas están desactivadas
 * Reestructurada la lógica de conexión y estado de Redis
 * Actualizado Predis a la versión 1.1.2
 * Eliminar el aviso de obsolescencia de Predis
 * Corregida la obtención de claves derivadas en `wp_cache_get_multiple()`

#### 2.0.8

 * Corregido el problema de las pestañas en las versiones 2.0.6 y 2.0.7 debido a
   un problema de SVN en WP.org

#### 2.0.7

 * Corregido un problema con `wp_cache_get_multiple()`

#### 2.0.6

 * Añadida una prueba experimental del sistema de archivos al diagnóstico
 * Reestructurada la lógica de las pestañas de ajustes (también se ha corregido 
   el salto)
 * Corregidos problemas con `wp_cache_get_multiple()`
 * Devolver un booleano desde `wp_cache_delete()`
 * Usar `redis-cache` como espacio de nombres para eventos JS
 * Ocultar la línea Pro en el widget cuando los banners están desactivados
 * Renombrada la acción `redis_object_cache_get_multi` a `redis_object_cache_get_multiple`

#### 2.0.5

La versión 2.0 es una reescritura importante del plugin. Lee las notas de la versión
2.0.0.

 * Corregido el problema de los botones de acción en multisitio
 * Eliminado el aviso obsoleto de PHP 5.4
 * Añadida compatibilidad con `read_timeout` a Credis
 * Mostrar los parámetros de conexión al usar Credis
 * Añadido un enlace a la wiki en el aviso de actualización de Predis

#### 2.0.4

 * Intentar actualizar de forma fiable el dependiente cuando está obsoleto
 * Mostrar el nombre de usuario ACL en la pantalla de ajustes
 * Mostrar el diagnóstico completo con `wp redis status`
 * Establecer siempre `FS_CHMOD_FILE` al copiar `object-cache.php`
 * No codificar los puntos en el diagnóstico de la contraseña
 * Llamar a `redis_object_cache_update_dropin` durante la actualización del dependiente

#### 2.0.3

 * Ocultar la pestaña «Métricas» cuando las métricas están desactivadas
 * Corregido el problema de que `admin.js` no se cargaba en entornos multisitio
 * Evitar errores fatales al interactuar con las métricas cuando Redis ha desaparecido
 * Añadido `WP_Object_Cache::__get()` para compatibilidad hacia atrás

#### 2.0.2

 * Actualizado el archivo POT y los comentarios para los traductores

#### 2.0.1

 * Compatibilidad con versiones anteriores de Query Monitor
 * Hacer más útil el estado del «Dependiente»
 * Ocultar la versión de Redis en los ajustes cuando no está disponible
 * Rutas de dependencias contraídas usando el paquete `composer-custom-directory-
   installer`
 * Prevenir conflictos de `QM_Collector` con otros plugins
 * Prevenir problemas de métricas cuando la caché no está disponible
 * Corregido el enlace «Ajustes» en la lista de plugins
 * Corregida la lógica de `WP_REDIS_DISABLED`

#### 2.0.0

La versión 2.0 es una reescritura importante. El plugin ahora requiere PHP 5.6, 
al igual que WordPress 5.2.

El repositorio de GitHub y Composer se ha movido de `tillkruss/redis-cache` a `rhubarbgroup/
redis-cache`.

En redes multisitio, asegúrate de «Activar en red» el plugin después de actualizar
a la versión 2.x.

 * Requerir PHP 5.6
 * El plugin ahora es «solo para redes»
 * Cambio a WPCS para los estándares de código
 * Reformada la pantalla de ajustes
 * Añadidas métricas de la caché de objetos (en el widget del escritorio y en los
   ajustes)
 * Añadida compatibilidad con Query Monitor
 * Añadido el espacio de nombres `Rhubarb\RedisCache` a todos los archivos
 * Añadida compatibilidad con la nueva función `wp_cache_get_multi()` de WP 5.5
 * Añadida la función `redis_object_cache()` para recuperar la instancia del plugin
 * Añadidos avisos sobre el dependiente en el escritorio de la red
 * Añadida compatibilidad para establecer números de base de datos Sentinel
 * Compatibilidad con la autenticación por nombre de usuario y contraseña ACL de
   Redis 6
 * Compatibilidad para sobrescribir el dependiente existente en la pantalla de ajustes
 * Usar el patrón singleton para instanciar el plugin
 * Usar Composer para instalar y cargar Predis
 * Actualizar el dependiente de la caché de objetos durante la actualización del
   plugin
 * Usar métodos separados para conectar con todos los clientes
 * Eliminadas las rarezas de `CUSTOM_USER_TABLE` y `CUSTOM_USER_META_TABLE`
 * Añadido `themes` como grupo ignorado
 * Cambiado el tiempo de espera de conexión y lectura por defecto a 1 segundo
 * Prevenir condiciones de carrera en `add_or_replace()`
 * Renombrado `WP_CACHE_KEY_SALT` a `WP_REDIS_PREFIX` para mayor claridad
 * Sustituida la terminología «esclavo» por «réplica»
 * Hacer un `SELECT` a la base de datos solo cuando no sea `0`

#### 1.6.1

 * Corregido el problema del comentario en el pie de página durante las peticiones
   AJAX

#### 1.6.0

 * Mejorada la saneación del nombre de grupo (gracias a @naxvog)
 * Prevenir errores fatales al reemplazar un dependiente externo
 * Añadido un comentario HTML en el pie de página con información de depuración 
   opcional
 * Eliminadas las sugerencias de prefijo

_El comentario HTML en el pie de página solo muestra información de depuración cuando`
WP\_DEBUG` está activado. Para desactivar el comentario por completo, establece 
la constante `WP\_REDIS\_DISABLE\_COMMENT` a `true`._

#### 1.5.9

 * Corregida la asignación de la variable `$info` que faltaba en el constructor
 * Corregida la condición del aviso de MaxTTL
 * Cambiado a usar los estilos de botón por defecto

#### 1.5.8

 * Añadido un mensaje de aviso sobre MaxTTL no válido
 * Añadido un aviso sobre la biblioteca Predis no mantenida
 * Añadida una sugerencia sobre prefijos más cortos y legibles
 * Añadida compatibilidad con Redis Cache Pro en los ajustes
 * Corregido el vaciado de la caché cuando el prefijo contiene caracteres especiales
 * Corregida la llamada a `INFO` de Redis al usar clústeres
 * Limpieza menor de los ajustes

#### 1.5.7

 * Añadida compatibilidad con conexiones TLS de PhpRedis
 * Añadida compatibilidad con tiempo de espera, tiempo de lectura y contraseña al
   usar el clúster de PhpRedis
 * Corregido un problema con el comando `INFO`
 * Corregida la clonación de objetos al establecer claves de caché

#### 1.5.6

 * Añadida la clonación de objetos a la caché en memoria
 * Corregido el aviso de PHP relacionado con el parámetro `read_timeout`

#### 1.5.5

Por favor, vacía la caché de objetos después de actualizar el dependiente a la versión
1.5.5 para evitar que las claves muertas llenen la memoria de Redis.

 * Eliminada la conversión a minúsculas de las claves
 * Eliminar el evento programado de métricas
 * Corregida la llamada a la versión de Redis al usar replicación

#### 1.5.4

 * Eliminadas las métricas

#### 1.5.3

 * Corregido: llamada a la función indefinida `get_plugin_data()`
 * Corregido: llamada al método indefinido `WP_Object_Cache::redis_version()`

#### 1.5.2

 * Añadida la versión de Redis al diagnóstico
 * Añadida la constante `WP_REDIS_DISABLE_BANNERS` para desactivar promociones
 * Corregido un problema con `redis.replicate_commands()`

#### 1.5.1

Hoy (14 de noviembre) este plugin cumple 5 años, y es justo que también lancemos
hoy la edición empresarial.
 [Object Cache Pro](https://objectcache.pro/) es una
reescritura de este plugin realmente fiable, muy optimizada y fácil de depurar para
pymes.

 * Añadidos tiempos de ejecución a las acciones
 * Añadida la constante `WP_REDIS_VERSION`
 * Corregida la compatibilidad con PhpRedis v3
 * Corregido un problema con el vaciado selectivo
 * Corregido un problema con las funciones `mb_*` que no existían
 * Sustituida la tarjeta de Email Address Encoder por la de Redis Cache Pro
 * Recopilar métricas de versiones para una mejor toma de decisiones

#### 1.5.0

Como Predis ya no se mantiene, es muy recomendable cambiar a PhpRedis (la extensión
PECL de Redis).

 * Mejorado el constructor de nombres de clave de Redis
 * Añadida compatibilidad con serializadores de PhpRedis
 * Añadida la acción `redis_object_cache_error`
 * Añadida configuración de tiempo de espera, tiempo de lectura y reintentos
 * Añadidos grupos no vaciables (por defecto `['userlogins']`)
 * Corregido el problema de que las contraseñas no se mostraban en la lista de servidores

#### 1.4.3

 * Requerir PHP 5.4 o superior
 * Usar formato legible en el diagnóstico
 * Lanzar una excepción si falta la biblioteca de Redis
 * Corregido el problema de que la caché no se vaciaba para algunos usuarios
 * Corregidos problemas de administración cuando `WP_REDIS_DISABLED` es `false`

#### 1.4.2

 * Añadidos fallos controlados de Redis y la constante `WP_REDIS_GRACEFUL`
 * Mejorada la compatibilidad con clústeres
 * Añadido el filtro `redis_cache_expiration`
 * Renombrado el filtro `redis_object_cache_get` a `redis_object_cache_get_value`

#### 1.4.1

 * Corregido un posible error fatal relacionado con `wp_suspend_cache_addition()`

#### 1.4.0

 * Añadida compatibilidad con igbinary
 * Añadida compatibilidad con `wp_suspend_cache_addition()`

#### 1.3.9

 * Corregido el problema de que `WP_REDIS_SHARDS` no aparecía en la lista de servidores
 * Corregido el problema de que `WP_REDIS_SHARDS` no funcionaba con la extensión
   PECL
 * Eliminados los restos de `WP_REDIS_SCHEME` y `WP_REDIS_PATH`

#### 1.3.8

 * Cambiado de la versión de Predis de un solo archivo a la biblioteca completa

#### 1.3.7

 * Volver a la versión de Predis de un solo archivo

#### 1.3.6

 * Añadida compatibilidad con Redis Sentinel
 * Añadida compatibilidad con uso compartido
 * Cambiado a la versión PHAR de Predis
 * Diagnóstico mejorado
 * Añadido `WP_REDIS_SELECTIVE_FLUSH`
 * Añadido el parámetro `$fail_gracefully` a `WP_Object_Cache::__construct()`
 * Aplicar siempre `WP_REDIS_MAXTTL`
 * Pasar `$selective` y `$salt` a la acción `redis_object_cache_flush`
 * No establecer la constante `WP_CACHE_KEY_SALT`

#### 1.3.5

 * Añadido diagnóstico básico a la interfaz de administración
 * Añadida la constante `WP_REDIS_DISABLED` para desactivar la caché en tiempo de
   ejecución
 * Prevenir el error «Cabecera de plugin no válida»
 * Devolver un entero de los métodos `increment()` y `decrement()`
 * Prevenir que la caché de objetos se instancie más de una vez
 * Separar siempre el `prefijo` y el `grupo` de la clave de caché con punto y coma
 * Mejorado el rendimiento de `build_key()`
 * Aplicar el filtro `redis_object_cache_get` solo si se han registrado callbacks
 * Corregido `add_or_replace()` para que solo establezca la clave de caché si no
   existe
 * Añadida la acción `redis_object_cache_flush`
 * Añadida la acción `redis_object_cache_enable`
 * Añadida la acción `redis_object_cache_disable`
 * Añadida la acción `redis_object_cache_update_dropin`

#### 1.3.4

 * Añadida compatibilidad con WP-CLI
 * Mostrar el host y el puerto a menos que el esquema sea unix
 * Actualizados los grupos globales e ignorados por defecto
 * Vaciar la caché al activar, desactivar y desinstalar

#### 1.3.3

 * Actualizado Predis a la versión `v1.1.1`
 * Añadido el método `redis_instance()`
 * Añadido el alias `incr()` para compatibilidad con Batcache
 * Añadidas las constantes `WP_REDIS_GLOBAL_GROUPS` y `WP_REDIS_IGNORED_GROUPS`
 * Añadida la acción `redis_object_cache_delete`
 * Usar `WP_PLUGIN_DIR` con `WP_CONTENT_DIR` como alternativa
 * Establecer la contraseña al usar un clúster o replicación
 * Mostrar el cliente de Redis en `stats()`
 * Cambiar la visibilidad de `$cache` a pública
 * Usar la sintaxis antigua de arrays, por si acaso

#### 1.3.2

 * Asegurarse de que `$result` no sea `false` en `WP_Object_Cache::get()`

#### 1.3.1

 * Corregido un problema de conexión

#### 1.3

 * Nueva interfaz de administración
 * Añadida compatibilidad con los parámetros `$force` y `$found` de `wp_cache_get()`
 * Añadida compatibilidad con clústeres y replicación con Predis

#### 1.2.3

 * Mejoras en la interfaz de usuario

#### 1.2.2

 * Añadida la acción `redis_object_cache_set`
 * Añadida la acción y el filtro `redis_object_cache_get`
 * Prevenidos los mensajes de estado duplicados en la administración
 * Cargar la biblioteca Predis incluida solo si es necesario
 * Cargar la biblioteca Predis incluida usando la constante `WP_CONTENT_DIR`
 * Actualizada la salida del método `stats()` para que sea uniforme con WordPress

#### 1.2.1

 * Se agregó `composer.json`
 * Se agregaron ganchos de desactivación y desinstalación para eliminar `object-
   cache.php`
 * Se agregaron funciones de serialización local para una mejor compatibilidad con`
   advanced-cache.php`.
 * Se actualizó la versión de Predis incluida a `1.0.3`
 * Estructura de encabezados actualizada para que sea semántica.

#### 1.2

 * Añadida compatibilidad con multisitio
 * Movido el menú de administración bajo el menú _Ajustes_
 * Corregido el aviso de PHP en `get_redis_client_name()`

#### 1.1.1

 * Llamar a `select()` y opcionalmente a `auth()` si se usa la extensión HHVM

#### 1.1

 * Añadida compatibilidad con la extensión Redis de HHVM
 * Añadida compatibilidad con la extensión PECL Redis
 * Añadida la constante `WP_REDIS_CLIENT` para establecer el cliente de Redis preferido
 * Añadida la constante `WP_REDIS_MAXTTL` para forzar la caducidad de las claves
   de caché
 * Mejorados los métodos `add_or_replace()`, `get()`, `set()` y `delete()`
 * Mejorados los estilos de la pantalla de administración
 * Eliminada toda internacionalización/localización del dependiente

#### 1.0.2

 * Añadido el botón «Vaciar caché»
 * Añadida compatibilidad con sockets de dominio UNIX
 * Mejorado significativamente el rendimiento de recuperación de objetos de caché
 * Actualizada la biblioteca Predis incluida a la versión `1.0.1`

#### 1.0.1

 * Cargar las traducciones del plugin
 * Ocultar los avisos globales de administración a los usuarios que no son administradores
 * Prevenir el acceso directo a los archivos `redis-cache.php` y `admin-page.php`
 * Colorear el botón «Desactivar caché de objetos»
 * Llamar a `Predis\Client->connect()` para evitar una posible `Predis\Connection\
   ConnectionException` no capturada

#### 1.0

 * Versión inicial

## Plugin comercial

Este plugin es gratuito pero ofrece actualizaciones o soporte comercial de pago.
[Ver soporte](https://github.com/rhubarbgroup/redis-cache/issues)

## Meta

 *  Versión **3.0.0**
 *  Última actualización **hace 3 semanas**
 *  Instalaciones activas **500.000+**
 *  Versión de WordPress ** 4.6 o superior **
 *  Probado hasta **7.1.3**
 *  Versión de PHP ** 7.2 o superior **
 *  Idiomas
 * [Chinese (China)](https://cn.wordpress.org/plugins/redis-cache/), [Chinese (Taiwan)](https://tw.wordpress.org/plugins/redis-cache/),
   [Czech](https://cs.wordpress.org/plugins/redis-cache/), [Dutch](https://nl.wordpress.org/plugins/redis-cache/),
   [English (UK)](https://en-gb.wordpress.org/plugins/redis-cache/), [English (US)](https://wordpress.org/plugins/redis-cache/),
   [French (France)](https://fr.wordpress.org/plugins/redis-cache/), [Galician](https://gl.wordpress.org/plugins/redis-cache/),
   [German](https://de.wordpress.org/plugins/redis-cache/), [Hindi](https://hi.wordpress.org/plugins/redis-cache/),
   [Italian](https://it.wordpress.org/plugins/redis-cache/), [Korean](https://ko.wordpress.org/plugins/redis-cache/),
   [Norwegian (Bokmål)](https://nb.wordpress.org/plugins/redis-cache/), [Polish](https://pl.wordpress.org/plugins/redis-cache/),
   [Portuguese (Brazil)](https://br.wordpress.org/plugins/redis-cache/), [Portuguese (Portugal)](https://pt.wordpress.org/plugins/redis-cache/),
   [Russian](https://ru.wordpress.org/plugins/redis-cache/), [Serbian](https://sr.wordpress.org/plugins/redis-cache/),
   [Spanish (Chile)](https://cl.wordpress.org/plugins/redis-cache/), [Spanish (Spain)](https://es.wordpress.org/plugins/redis-cache/)
   y [Swedish](https://sv.wordpress.org/plugins/redis-cache/).
 *  [Traducir a tu idioma](https://translate.wordpress.org/projects/wp-plugins/redis-cache)
 * Etiquetas:
 * [caching](https://es.wordpress.org/plugins/tags/caching/)[object cache](https://es.wordpress.org/plugins/tags/object-cache/)
   [performance](https://es.wordpress.org/plugins/tags/performance/)[redis](https://es.wordpress.org/plugins/tags/redis/)
   [relay](https://es.wordpress.org/plugins/tags/relay/)
 *  [Vista avanzada](https://es.wordpress.org/plugins/redis-cache/advanced/)

## Valoraciones

 4.5 de 5 estrellas.

 *  [  149 valoraciones de 5 estrellas     ](https://wordpress.org/support/plugin/redis-cache/reviews/?filter=5)
 *  [  4 valoraciones de 4 estrellas     ](https://wordpress.org/support/plugin/redis-cache/reviews/?filter=4)
 *  [  4 valoraciones de 3 estrellas     ](https://wordpress.org/support/plugin/redis-cache/reviews/?filter=3)
 *  [  2 valoraciones de 2 estrellas     ](https://wordpress.org/support/plugin/redis-cache/reviews/?filter=2)
 *  [  20 valoraciones de 1 estrellas     ](https://wordpress.org/support/plugin/redis-cache/reviews/?filter=1)

[Tu valoración](https://wordpress.org/support/plugin/redis-cache/reviews/#new-post)

[Ver todas las reseñas](https://wordpress.org/support/plugin/redis-cache/reviews/)

## Colaboradores

 *   [ Till Krüss ](https://profiles.wordpress.org/tillkruess/)

## Soporte

Problemas resueltos en los últimos dos meses:

     3 de 4

 [Ver el foro de soporte](https://wordpress.org/support/plugin/redis-cache/)

## Donar

¿Te gustaría apoyar el progreso de este plugin?

 [ Dona a este plugin ](https://github.com/sponsors/tillkruss)