メインコンテンツまでスキップ

CONNECT_SESSION_MIGRATION error condition

SQLSTATE: 56K00

Generic Session Migration error (userId: <userId>, sessionId: <sessionId>, serverSessionId: <serverSessionId>).

EXECUTION_ERROR_CLIENT_LAST_SEEN_SESSION_VERSION_AHEAD_OF_SERVER_SESSION_VERSION​

Cannot proceed with the request as the client session's version is ahead of the corresponding server session's version. Please recreate the session to avoid inconsistent results.(lastSeenServerSessionVersion: <lastSeenServerSessionVersion>, serverSessionVersion: <serverSessionVersion>).

INCREMENTAL_PERSISTENCE_ERROR_UNEXPECTED_OPERATOR_IN_PLAN​

Cannot restore the session because the unexpected operator <actualOperatorName> is found in the plan, expected operator is <expectedOperatorName>.

RESTORATION_ERROR_CANNOT_RESTORE_SESSION​

Cannot restore the session because an error encountered while replaying the session state (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_INVALID_SNAPSHOT​

Cannot restore the session because its snapshot is in invalid format (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_MIGRATION_DISABLED​

Cannot restore the session because Session migration is disabled (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_OUTDATED_SNAPSHOT​

Cannot restore the session because the snapshot is outdated (lastSeenVersion: <lastSeenVersion>, snapshotVersion: <snapshotVersion>).

RESTORATION_ERROR_PERMISSION_DENIED​

Cannot restore the session because the user does not have permission to access the session state (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_SESSION_ALREADY_EXISTS​

Cannot restore the session because it would duplicate the state of an existing session (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_SNAPSHOT_NOT_FOUND​

Cannot restore the session because its snapshot is not found (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_UNKNOWN​

Cannot restore the session due to an unknown error (lastSeenVersion: <lastSeenVersion>).

RESTORATION_ERROR_UNRECOVERABLE​

Cannot restore the session because it is unrecoverable due to internal limits (lastSeenVersion: <lastSeenVersion>).